FORUMS
Remove All Ads from XDA

Galaxy Watch + Samsung Galaxy A50 BT connection problems

670 posts
Thanks Meter: 205
 
By pabgar, Senior Member on 29th March 2019, 04:03 PM
Post Reply Email Thread
Hello.
Been using Galaxy Watch with Lenovo P2 without problems. Time came to get new phone. So i got the idea ( my bad ! ) that Galaxy A50 would be good move. Phone itself is OK.
Also I was counting ( naive ) that cooperation with 2 Galaxy devices will be brillant. I couln't be more mistaken.
BT connection between phone and watch is a nightmare. For first 10 hours it was OK. Next is going wrong. Every few minutes watch vibrates and beeps as BT connection is broken. It established back almost immediately.
This drives me crazy.
Any ideas ? I guess that Galaxy A50 ROM is young and has bugs
The Following User Says Thank You to pabgar For This Useful Post: [ View ] Gift pabgar Ad-Free
 
 
22nd April 2019, 09:57 PM |#2  
Junior Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by pabgar

Hello.
Been using Galaxy Watch with Lenovo P2 without problems. Time came to get new phone. So i got the idea ( my bad ! ) that Galaxy A50 would be good move. Phone itself is OK.
Also I was counting ( naive ) that cooperation with 2 Galaxy devices will be brillant. I couln't be more mistaken.
BT connection between phone and watch is a nightmare. For first 10 hours it was OK. Next is going wrong. Every few minutes watch vibrates and beeps as BT connection is broken. It established back almost immediately.
This drives me crazy.
Any ideas ? I guess that Galaxy A50 ROM is young and has bugs

Have you found any solution? I have this issue also...
The Following User Says Thank You to mostlystupid For This Useful Post: [ View ] Gift mostlystupid Ad-Free
23rd April 2019, 07:07 AM |#3  
OP Senior Member
Flag Warsaw
Thanks Meter: 205
 
More
Quote:
Originally Posted by mostlystupid

Have you found any solution? I have this issue also...

No, I have not. I think this is issue of Galaxy Wearable App. Seems to me BT connection is OK but the app does not sync with watch.
Can you confirm ?
The Following User Says Thank You to pabgar For This Useful Post: [ View ] Gift pabgar Ad-Free
28th April 2019, 05:22 AM |#4  
khaisttj92's Avatar
Senior Member
Flag seremban
Thanks Meter: 122
 
More
Quote:
Originally Posted by pabgar

No, I have not. I think this is issue of Galaxy Wearable App. Seems to me BT connection is OK but the app does not sync with watch.
Can you confirm ?

I'm doesnt have any issue about that. I am also using A50. Try toogle off battery optimisation for bluetooth and galaxy wearable. Hope it will help you.

Sent from my Galaxy A50 using XDA Labs
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190428-122034_Settings.jpg
Views:	102
Size:	230.3 KB
ID:	4750020   Click image for larger version

Name:	Screenshot_20190428-122029_Settings.jpg
Views:	100
Size:	118.3 KB
ID:	4750021  
28th April 2019, 12:23 PM |#5  
Junior Member
Thanks Meter: 0
 
More
Also I was counting ( naive ) that cooperation with 2 Galaxy devices will be brillant. I couln't be more mistaken.
As a former Iphone user,i ve changed my phone only for tfhis reason to switch S10 PLUS.Now they together working brilliant.It s seems like firmware problem about A50.
28th April 2019, 04:35 PM |#6  
galaxys's Avatar
Senior Member
Flag Cosmos
Thanks Meter: 1,944
 
More
I also use the S10 Plus with my watch! Works a treat! Cheers
29th April 2019, 07:47 AM |#7  
OP Senior Member
Flag Warsaw
Thanks Meter: 205
 
More
Quote:
Originally Posted by khaisttj92

Try toogle off battery optimisation for bluetooth and galaxy wearable. Hope it will help you.

Thank you for this hint. I had: Galaxy app and Watch plugin on this list but not Bluetooth. I will try
13th May 2019, 07:40 AM |#8  
OP Senior Member
Flag Warsaw
Thanks Meter: 205
 
More
For those who have problems like me. I think I found the reason of disconnections. Please make experiment: switch off wifi in your phones permanently and check if disconnections occurs during that time.
20th May 2019, 05:16 PM |#9  
OP Senior Member
Flag Warsaw
Thanks Meter: 205
 
More
What I observed: when I switch off 2.4 wifi ( or "forget" all known networks so the phone does not connect ) then BT connection with watch works perfectly.
Strangely enough when I am connected to 5 GHz wifi BT seems to work OK.
So in my case: BT and 2.4 GHz wifi running together causes problems
30th May 2019, 09:35 AM |#10  
bbali81's Avatar
Junior Member
Flag Budapest
Thanks Meter: 0
 
More
Quote:
Originally Posted by pabgar

What I observed: when I switch off 2.4 wifi ( or "forget" all known networks so the phone does not connect ) then BT connection with watch works perfectly.
Strangely enough when I am connected to 5 GHz wifi BT seems to work OK.
So in my case: BT and 2.4 GHz wifi running together causes problems

I have the same problem with A50 & Watch. BT connection drop in every minute.
Tomorrow I will try your idea, what happen if I use only 5 ghz wifi.

Do you have any solution?

Thanks
30th May 2019, 10:36 AM |#11  
OP Senior Member
Flag Warsaw
Thanks Meter: 205
 
More
2 days ago I flashed May firmware update for Galaxy A50. All problems are gone. Connection with watch works perfectly now.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes