FORUMS

[TIP] Solve SW2's constant conecctions-disconnections [ROOT].

24 posts
Thanks Meter: 3
 
By skrlet13, Junior Member on 1st August 2015, 08:20 PM
Post Reply Email Thread
Well guys, I have a short tip to solve that common problem on the SW2 (as far as I read). I have only tried it on my smartphone, but it worked and you could try just in case. You´ll need root for this. Don't worry, if it doesn't work for you, you can go back to normal easily.

In my case, my phone killed the smartwatch service and then it "revived". So I put the Low Memory Killer (LKM) (not sure if is that the English name, in Spanish it's called "Prefijos de Limpieza de Memoria") into a lower value that it had (depends of the phone). After that, my disconnections problems disappeared
To change it, I recommend use Kernel Adiutor, an awesome kernel tweaker.

I hope this works for you. Tell me your results. Peace
2nd August 2015, 08:26 PM |#2  
Senior Member
Flag Nancy, Lorraine
Thanks Meter: 286
 
More
I think this do not happen on modern phone with 1 Go or 2 Go memory.
20th August 2015, 07:35 PM |#3  
Senior Member
Thanks Meter: 52
 
More
Quote:
Originally Posted by skrlet13

Well guys, I have a short tip to solve that common problem on the SW2 (as far as I read). I have only tried it on my smartphone, but it worked and you could try just in case. You´ll need root for this. Don't worry, if it doesn't work for you, you can go back to normal easily.

In my case, my phone killed the smartwatch service and then it "revived". So I put the Low Memory Killer (LKM) (not sure if is that the English name, in Spanish it's called "Prefijos de Limpieza de Memoria") into a lower value that it had (depends of the phone). After that, my disconnections problems disappeared
To change it, I recommend use Kernel Adiutor, an awesome kernel tweaker.

I hope this works for you. Tell me your results. Peace

This is interesting and I would like to try it. Which low memory killer value did you change? I assume you changed 'hidden applications' but I thought I would check.

Thanks,
Fred
20th August 2015, 10:17 PM |#4  
OP Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by ffarber

This is interesting and I would like to try it. Which low memory killer value did you change? I assume you changed 'hidden applications' but I thought I would check.

Thanks,
Fred

I actually changed to one of the "pre-set profiles" of kernel audiutor because I'm lazy .


But yeah, the smartwatch service is just that, a hidden app, so if you just want to change hidden applications it should be enough.

I would change empty apps a little too because when the smartwatch isn't doing anything, my phone thought the service was one. (?)

Enviado desde mi XT1040 mediante Tapatalk
21st August 2015, 03:05 PM |#5  
Senior Member
Thanks Meter: 52
 
More
Thanks, I have Kernel Audiutor as part of my ROM anyway so it is easy to do. I was thinking of playing around with the LMK after reading your post, which preset profile did you finally choose? I actually use two Smartwatches:
  • An SW2 is attached to the handle bars of my motorcycle for a variety of reasons
  • I sometimes wear a Cogito Classic
I have many more problems with random disconnects with the Cogito than the SW2 but I will play around.

I also have the canonical problem of the phone randomly disconnecting from my car's Bluetooth and this could be the cure for that ill as well. Of course, it is very difficult to prove the absence of a problem like that.

Thanks again,
Fred
21st October 2015, 08:01 PM |#6  
OP Junior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by ffarber

Thanks, I have Kernel Audiutor as part of my ROM anyway so it is easy to do. I was thinking of playing around with the LMK after reading your post, which preset profile did you finally choose? I actually use two Smartwatches:

  • An SW2 is attached to the handle bars of my motorcycle for a variety of reasons
  • I sometimes wear a Cogito Classic
I have many more problems with random disconnects with the Cogito than the SW2 but I will play around.

I also have the canonical problem of the phone randomly disconnecting from my car's Bluetooth and this could be the cure for that ill as well. Of course, it is very difficult to prove the absence of a problem like that.

Thanks again,
Fred

I chose light. Sorry for the late answer!
Too much work in school...
23rd October 2015, 10:19 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Does 'Aplicar al inicio' have to be enabled? Thanks

Enviado desde mi Elephone G6 mediante Tapatalk
24th October 2015, 08:10 PM |#8  
sfemat's Avatar
Junior Member
Flag Camposanto
Thanks Meter: 0
 
More
Quote:
Originally Posted by Rojo10000

Does 'Aplicar al inicio' have to be enabled? Thanks

Enviado desde mi Elephone G6 mediante Tapatalk

Sure
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes