FORUMS
Remove All Ads from XDA

[TUT] how to fix swr50 with working fastboot

73 posts
Thanks Meter: 14
 
By alex_SW, Member on 28th November 2015, 09:44 AM
Post Reply Email Thread
hi people,i wanna share a fix solution for any smartwatch 3 with working fastboot mode...
so,presuming u already have adb drivers installed lets proceed

https://drive.google.com/open?id=0B1...DBjRnliUDVXU1k is link to a shared folder with all needed files,inside folder are :

repacked rom 5.0.1 - swr50.zip
stock recovery image - swr50.img
twrp recovery image for old rom version - twrp.img
twrp recovery image for new rom version - twrpnew.img
update packages that can also be sideloaded if watch dosent update itself after first flash

updatep-k.zip -its from verison lwx48p tp lwx48k
then k to d and d to lca43(5.1.1)

so,boot into fastboot and fastboot boot twrp.img (that will boot twrp image on watch).then,adb push swr50.zip /sdcard/swr50.zip
in twrp push install and select the newly copied swr50.zip flashable rom...flash it,then adb reboot
let watch reboot,presuming all went fine,ull watch will boot in 5.0.1 rom,let it connect to phone.inside settings,open options/about,and push built version until u get dev mode...in dev mode enable usb debug,confirm also on phone

so right now u have watch connected to pc with usb debug on....write adb reboot bootloader ,so watch goes in fastboot again
now,flash stock recovery...fastboot flash recovery swr50.img (watch will get the stock recovery),after u can fastboot continue
right now u can update watch,connected to phone,via own update ota service,settings/about/system update,it will download and install next version,the update again and again.if u dont wanna wait thatu can adb sideload files i provided,its actualy stock ota update

so....
adb reboot recovery,select adb sideload,and adb sideload updatep-k.zip,reboot watch and let update,then sideload again updatek-d.zip,reboot and let it update,then again last update
AFTER THIS UPDATE TWRP.IMG NO LONGER WORK,DONT BOOT IT,WATCH WILL ENTER BOOT LOOP,WE WILL BOOT TWRPNEW.IMG.....becouse 5.1.1 updated also boot image,so fastboot twrpnew.img if u wanna use twrp in some way.....

i hope its was helpfull,any questions fell free to leave,im no developer,i just like to play with things

BIG thanx to those who packed,repacked flashes and recovery images!!!!




l
The Following 7 Users Say Thank You to alex_SW For This Useful Post: [ View ] Gift alex_SW Ad-Free
 
 
27th July 2016, 12:05 PM |#2  
Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by alex_SW

hi people,i wanna share a fix solution for any smartwatch 3 with working fastboot mode...
so,presuming u already have adb drivers installed lets proceed

https://drive.google.com/open?id=0B1...DBjRnliUDVXU1k is link to a shared folder with all needed files,inside folder are :

repacked rom 5.0.1 - swr50.zip
stock recovery image - swr50.img
twrp recovery image for old rom version - twrp.img
twrp recovery image for new rom version - twrpnew.img
update packages that can also be sideloaded if watch dosent update itself after first flash

updatep-k.zip -its from verison lwx48p tp lwx48k
then k to d and d to lca43(5.1.1)

so,boot into fastboot and fastboot boot twrp.img (that will boot twrp image on watch).then,adb push swr50.zip /sdcard/swr50.zip
in twrp push install and select the newly copied swr50.zip flashable rom...flash it,then adb reboot
let watch reboot,presuming all went fine,ull watch will boot in 5.0.1 rom,let it connect to phone.inside settings,open options/about,and push built version until u get dev mode...in dev mode enable usb debug,confirm also on phone

so right now u have watch connected to pc with usb debug on....write adb reboot bootloader ,so watch goes in fastboot again
now,flash stock recovery...fastboot flash recovery swr50.img (watch will get the stock recovery),after u can fastboot continue
right now u can update watch,connected to phone,via own update ota service,settings/about/system update,it will download and install next version,the update again and again.if u dont wanna wait thatu can adb sideload files i provided,its actualy stock ota update

so....
adb reboot recovery,select adb sideload,and adb sideload updatep-k.zip,reboot watch and let update,then sideload again updatek-d.zip,reboot and let it update,then again last update
AFTER THIS UPDATE TWRP.IMG NO LONGER WORK,DONT BOOT IT,WATCH WILL ENTER BOOT LOOP,WE WILL BOOT TWRPNEW.IMG.....becouse 5.1.1 updated also boot image,so fastboot twrpnew.img if u wanna use twrp in some way.....

i hope its was helpfull,any questions fell free to leave,im no developer,i just like to play with things

BIG thanx to those who packed,repacked flashes and recovery images!!!!




l

Thanks for putting this together. My sw3 has been stuck on the MM dots / symbols for some time. After several attempts of running various roms, img, simg, XC, etc, I could get no further than the original software issue. With your post, I was able to get it to the LCA43 update. Although, for some reason I could not use the twrp.img in your file list (I found another one) and I could not adb the recovery file (I had to flash it), nevertheless, it provided a way for me to update the sw3. I did not flash the updates, but just let the watch do it. While that was a slow process, it was working so I continued...until.

I could not get the MM update to work though. It downloaded and installed on the sw3. But when booting up, I got the dreaded 4 dots / symbols again. If you are still around and have any ideas of updating this procedure to include the MM updates, it would be much appreciated. Again, the XC does not work for me even though both the repair and update options in the software said they were successfully installed.
7th October 2016, 04:10 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Hi!
I really need to do this for activate the NFC and use to check glicemia on the watch.
But i'm stuck almost at the first point.
I already activate the adb on the watch and put him "runnig fastboot".
On the pc I write on command prompt "adb reboot bootloader" and returns: "error: device '(null)' not found"
Anyone can helps?
Regards,
22nd October 2016, 09:25 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Same position as Moitas
Realy would appreciate if somebody could help me and at the same time moitas. I run windows10 and have the same problem. The device is called Tetra when it shows up in fastboot and I canĀ“t get any driver to work with it. Have tried several differet ones but none seem to fit. Any clever one with a solution I would salute you
15th November 2016, 10:21 PM |#5  
Member
Thanks Meter: 3
 
More
@moitas @tobas70 you need to install the correct drivers - http://forum.xda-developers.com/atta...mentid=2480396
16th November 2016, 09:43 AM |#6  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ajolly

@moitas @tobas70 you need to install the correct drivers - http://forum.xda-developers.com/atta...mentid=2480396

Thanks Ajolly! I finally managed to get it done. As new to this rooting buisness there were a lot of steps that where more complicated than the manual I followed applied
25th November 2016, 12:30 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Hi! i have problem after downgrade...
After I push SWR50.zip and reboot, my devices is unauthorized. When i enter in fastboot manually there's any devices (null). I install drivers like You said, and form adb, google. If somebody can help me this i will be very grateful
2nd January 2017, 02:17 AM |#8  
Junior Member
Thanks Meter: 0
 
More
any one can help me. After failed up SW3 by sideload, they ignored PC conncetion. Try "adb devices", fastboot mode, recovery mode, MTP, - anything happend in device manager.
10th February 2017, 03:07 AM |#9  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ajolly

@moitas @tobas70 you need to install the correct drivers - http://forum.xda-developers.com/atta...mentid=2480396

I just got a new SWR50 for the sole purpose of using NFC (with FreeStyle Libre).

On the Win10 PC I don't have "Android Device" as a hardware type. -- I'm not sure if this is causing the problem that in Fastboot (white background) I cannot communicate with the watch from the PC anymore.

Also, when turned on for the first time watch automatically upgrades to M1D64T and I don't seem to be able to stop that and don't seem to be able to downgrade to be able to use this package.

Any suggestions? Thanks
22nd October 2017, 02:24 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Restore to the latest firmware
After downgrading to LCA43, what would be the easiest way to restore the watch to the latest firmware, is there a real factory reset?
22nd October 2017, 08:07 PM |#11  
Junior Member
Thanks Meter: 0
 
More
Not pair after downgrade
I have downgraded from version M1D64T to LWX48P and now my phone do not see the watch in bluetooth devices. I tried few things to start BT working like:

- remove Android Wear from phone
- clear Google Play Services
- send few intent through adb like bluetooth.REQUEST_DISCOVERABLE
- return to M1D64T by Sony PC Companion

Bluetooth still not works and I cannot connect to any phone.
Maybe somebody have an idea how to repair my watch?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes