FORUMS
Remove All Ads from XDA

How can I enable ADB Debugging when my watch is stuck on the LG boot screen?

13 posts
Thanks Meter: 0
 
By chipmcd, Junior Member on 13th June 2019, 10:59 PM
Post Reply Email Thread
I have ADB and Fastboot installed on my computer. Nothing lists/shows up when the watch is connected and I run "adb devices" in terminal (as I thought would happened) .

In the recovery, there's a choice for "apply update from sd card". How does that work or does it even work, on this watch?

I haven't used the watch in some time (silver 1st gen); I guess I gave up on it a while ago. It used to be stuck on the 4 spinning circles but not anymore. When I put it on the charger, it's just stuck on the LG boot screen. I think it showed the empty battery icon and thunderbolt but can't remember seeing it today. Search for some threads on being stuck on the LG screen, not charging and stock image recovery.

So trying to troubeshoot it, I tried to charge it (w/stock charger) and all I got was stuck on the LG screen and it got warm to the touch after about 20 mins. I worried about screen burns so, I shut it down. I'm able to get into the fastboot and recovery menus. In the recovery menu, I tried a reset but nothing changed after a reboot.

In thinking it may need a restoring with the stock image, I've read that ADB Debugging on the device must be enabled (or am I incorrect about that?) Question: How can I do that if I can't get into the settings of the watch?

I'm on Linux Mint. I have SDKManager on it but not quite sure how to use it. Not a power user by any means. A little help is greatly appreciated. The only other device I've used XDA before was on a Galaxy Note (1). That was a long time ago (what we're on Note 9 now!)
 
 
16th June 2019, 12:53 AM |#2  
OP Junior Member
So Cal
Thanks Meter: 0
 
More
Well after thinking about it, I figured I'd try the option "apply update from ADB" in the recovery mode on the watch. The watch prompted for the package I wanted to apply to the device. I opened a terminal window on my computer and ran "adb devices" and lo and behold, it came up with the watch's serial number and the text "sideload" next to it. So does this mean I could sideload a stock (or custom) ROM back on to it?

here's some specifics of the watch:

Fastboot menu

Product name - bass
Variant - bass 4GB
HW version - rev_10
Bootloader version - BASSZ12b
Singing - Production
Secured Boot - enabled
Lock State - locked

Android Recovery menu

lge/bass/bass
7.1.1/NWS2.170620.003/4125898


Any help would be appreciated for this noob.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes