FORUMS
Remove All Ads from XDA

 View Poll Results: Do you like Aandroid Wear 2.0?

YES
 
13 Vote(s)
27.08%
NO
 
35 Vote(s)
72.92%

[GUIDE] How to revert back to Android Wear 1.5

697 posts
Thanks Meter: 524
 
Post Reply Email Thread
16th December 2017, 01:19 PM |#71  
Senior Member
Thanks Meter: 125
 
More
Quote:
Originally Posted by TurboFool

Notification returned yesterday, so I ran the process again, successfully. It's back again today. Sounds like this isn't going to be a viable long-term solution, sadly.

Try this. @TurboFool @irmatt

Turn off notification on your phone for Google Play Services. Set it to level 0.
Then clear again on your watch and reboot both phone and the watch. See if that helps.
 
 
17th December 2017, 06:52 PM |#72  
Senior Member
Thanks Meter: 125
 
More
Status report.

It's been a month since I've downgraded to V 1.5 custom ROM.
I did get one OTA notification when the Google Play Services was updated on the watch but since then, I have pm disabled both again and cleared data and cache. In addition, I have disabled notification for Google Play Services on the phone.

So at the end of the month, no downloads on the watch (both fota and cache folders are clear) and no OTA notifications. Just enjoying the version 1.5.
22nd December 2017, 09:30 PM |#73  
Senior Member
Flag Oxford
Thanks Meter: 178
 
More
Quote:
Originally Posted by csrow

I have been going back and forth between V 2.0 to V 1.5 few times. Every time I downgrade to 1.5, OTA will push the watch back up to 2.0.

So, finally I used the method @nmdang suggested to disable the Update Service and that seems have worked. So I am documenting the steps I took to downgrade to 1.5 and lock down the OTA.

This guide assumes you have a working knowledge of ADB, Fastboot, and TWRP and your computer is set up properly to communicate with the watch and the watch has the ADB debug enabled.
If you are not comfortable with ADB, Fastboot, TWRP, or rooting, do not try these steps.
Your warranty will be voided and you may brick your watch.

By the way, all the data and apps will be lost during this procedure so make sure you have a way to recover.

Here are the files you need;
1) grab the boot.img from inside stock MWG68 ROM from this page. System and recovery image is not needed.
2) Latest TWRP recovery image from this page
3) V 1.5 custom ROM from this page


Steps;
- Make sure you have a working communication link in ADB and Fastboot by running the devices command to check each time as you change the mode.

1) adb reboot bootloader
2) fastboot oem unlock
(at this point you need to push the side button for a couple of seconds to accept the unlock)(this step will erase all the data)(wait for the watch to get back into bootloader mode)
3) fastboot flash boot boot.img
(flash the v1.5 stock boot image since the v 2.0 boot image will not work with a V 1.5 ROM)
4) fastboot boot twrp_whatever_you_have_named_it.img
(this will start the TWRP recovery and you'll be back in the ADB mode)
5) adb push -p custom_rom_whatever_you_named_it.zip /sdcard/

- now work from your watch in TWRP mode but leave the watch still in the stand. At the start of TWRP, allow for system modification.
6) mount system
7) wipe - system, data, dalvik cache, cache
8) install zip custom_rom_whatever_you_named_it.zip
9)reboot system (do not allow TWRP to be installed)

- the watch will reboot with a warning message about the unlock bootloader. Do not push the button and just wait for it to start. It will take some time.
- You should see the large ANDROID boot screen graphics instead of the google version if the ROM has been installed correctly. The first boot will take long one.
- As soon as watch goes past the link with the phone process, watch will ask the permission to debug. Select [Always allow]

- as the watch starts syncing, the ADB should be enabled.
10) adb shell
11) su
12) pm disable com.google.android.gms/.update.SystemUpdateService
13) pm disable com.google.android.gsf/.update.SystemUpdateService
14) exit
15) exit

That's it. Now you should have a custom V1.5 ROM on your watch with OTA blocked.
Once you are happy everything is working, optionally, you can go back and lock the bootloader to remove the warning message and speed up the boot up process.

EDIT:
I'm adding one more step in order to block notifications coming from the phone.
16) On your phone go to settings / notifications and find Google Play Services. Turn off all notifications (set it to level 0) for Google Play Services.
End of EDIT:

What's the negatives to turning off Google play services?
23rd December 2017, 03:26 AM |#74  
Senior Member
Thanks Meter: 125
 
More
Quote:
Originally Posted by worldsoutro

What's the negatives to turning off Google play services?

It's not turning off Google Play Services. You are turning off the notifications from Google Play Services.
The result is that you will not get any notifications. Everything else will function normally.
27th December 2017, 10:39 PM |#75  
Junior Member
Flag Manchester
Thanks Meter: 4
 
More
Has anyone that did this experienced connection issues? I followed the steps successfully last week and it worked great. Now today I noticed my watch will not stay connected to the phone. It seems to connect when the screen of the phone is on, however once it goes black the watch disconnects. no new apps installed in either. I tried disconnecting watch and reinstalling wear app. they connected and synced afterwards, then problem started immediately. I have Nexus6P with Oreo and Asus Zenwatch 2
14th January 2018, 11:02 PM |#76  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by ingbrzy

How to revert back to Android Wear 1.5

Flashing stock AW1.5 build:
- Unlock your bootloader
- Reboot into FASTBOOT MODE
- Download STOCK ROM MWG68 images
- via adb type commands:

Code:
fastboot flash system system.img
fastboot flash boot boot.img
fastboot flash recovery recovery.img
fastboot erase userdata
fastboot reboot
How to block OTA to AW 2.0
- adb shell
- pm disable com.google.android.gms/.update.SystemUpdateService
- pm disable com.google.android.gsf/.update.SystemUpdateService
- exit

I was able to revert to AW 1.5 but I want to undo everything...some apps aren't working like I want. Is there a way to undo everything I did?
7th March 2018, 04:55 PM |#77  
arys64's Avatar
Senior Member
Flag Santiago
Thanks Meter: 49
 
More
Quote:
Originally Posted by jbennett3112

I was able to revert to AW 1.5 but I want to undo everything...some apps aren't working like I want. Is there a way to undo everything I did?

If you want Stock AW 1.5 or AW 2.0 I recommend following this guide [AS ALWAYS, WE ARE NOT RESPONSIBLE FOR WHAT YOU DO TO YOUR DEVICE]
https://forum.xda-developers.com/zen...-boot-t3535589

Hope it works.
7th May 2018, 07:10 AM |#78  
Senior Member
Thanks Meter: 17
 
More
Might want to edit the part where it says fastboot erase userdata; You should change it to fastboot format userdata because a lot of times it errors out that it can't mount and you'll be unable to flash back to stock or any custom rom.
28th January 2019, 08:57 AM |#79  
Junior Member
Thanks Meter: 0
 
More
I did the downgrade to 1.5 as described, but now the watch always starts to recovery showing a dead android, does not start into the OS. If I boot with TWRP and do a factory reset, I am stuck in a boot loop.
I had the watch repaired as the screen did not work, but there was no hardware error, they just reset the system. But like it often happens with Android wear 2.0, I could not connect to my mobile any more. That is why I decided to do this downgrade (did that already half a year ago and it worked, but upgraded to 2.0 a few months later and was quite satisfied). Maybe the reset procedure done by the repair company did some changes
that now prevent the watch from starting after the downgrade ? Any ideas ?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes