FORUMS
Remove All Ads from XDA

SM-G930P Root - Updated 10/25/2016

412 posts
Thanks Meter: 272
 
By colormedroid, Senior Member on 4th July 2016, 06:50 AM
Post Reply Email Thread
Below, not only will you find step by step instructions on how to root your device but also a FAQ section in post #2 that will guide you through the problems most of us encountered in the beginning. It is highly recommended that you read through all of it. Basic knowledge of ADB is required and if you don't have it then you should definitely read the FAQ section for ADB set up. Make sure you have all the files downloaded.

Update 10/25/2016: Attached at the end of this thread is a modified debloat script for knox removal and a few other apps. This will make your root experience a heck of a lot smoother than before. Just flash the zip using FlashFire without changing any settings. You may notice a reboot or two. There are few bloatware apps that will still be there (amazon shopping, amazon videos, amazon photos, etc) that you'll have to remove manually. Happy flashing and don't forget to hit that Thanks button down below!

Disclaimer:
  • This root method is NOT for beginners. It is NOT easy. If you don't get it then DON'T do it. Especially if you're worried about voiding the warranty and blah blah blah. Simply put, don't do it if you don't have the slightest idea of what you're doing. I'm tired of complaints. This guide is not for the faint of heart. Do this at your own risk!
  • Package Disabler Pro is required to get this rooting method working. Yes, it costs money ($.99) but it's the way I acheived this work around at the moment.
  • Be prepared to lose data (LTE) connection but don't be scared as it's an easy fix.
  • Make sure you don't have Secure startup set up before you start the process. Having this set up causes issues.
  • Must have ADB set up and installed system-wide.
  • This root method should be used with PE1 firmware for both the GS7 and the GS7 Edge. Although this root method might work with the latest firmware, users have been reporting issues dealing with APN's on the newest update. Look at post 2 FAQ's returning to stock for flashing PE1 firmware through Odin.
  • Do not update to PJ2 if you want to keep service with your root. Phone calls and text messages won't come through after rooting on PJ2.

Files you will need:Click on the BLUE "download" links. Extract everything into a folder easy to locate.


Here we go:
  1. After downloading and getting set up Package Disabler Pro, you'll need to disable the following three packages:

    • samsung dm phone interface
    • samsung dm service
    • securityLogAgent.

    Use the search box to easily find these packages.

  2. Power off your device and boot into download/bootloader mode by pressing and holding the volume down, home, and the power button. Press volume up to get into bootloader.
  3. Open PrinceComsy odin and flash the engineer boot.img by clicking AP and navigating to the file for your model. Click start and your device should reboot by itself.
  4. Enable developer options by going to Settings>About Device and tapping Build Number till it shows Developer mode has been turned on. You will now have Developer options under the settings menu.
  5. Enable USB debugging in the Developer options settings.
  6. Extract the SuperSU zip and run the root.bat file. Your phone will reboot if the script is successfully ran.
  7. Next, we'll get LTE data back:

    • Method A: BuildProp Editor (easiest method)

      Open Build.Prop with BuildProp Editor and change the following settings:

      ro.cdma.default_numeric=310000 to 310120
      ro.cdma.default_alpha=Chameleon to Sprint
      ro.build.characteristics=Chameleon to Sprint

      Make sure you grant root permissions when it asks. You may have to try this twice. Reboot and LTE should stick.

    • Method B: Manual activation (also if you're not able to make any calls)

      Enable the three packages disabled in step 1. Go into the phone dialer and type in ##72786# and your phone should reboot and begin the activation process. After the 5th retry, it will manually activate itself. It should say "writing to device". Don't click done yet. Press the home button and disable the three packages once again. Reboot.

      Alternatively, after renabling the three packages and dialing ##72786#, you can go into Settings>Activate this device and manually try to activate it yourself. It still must say "writing to device". Don't click done. Disable the packages once again. Reboot. Voice and LTE should stick.


  8. Download S7_or_S7Edge_Fixes_V15.zip to your internal or external storage and install install FlashFire from the playstore.
  9. Open FlashFire and let it acquire root access. Click the + button at the bottom right corner then click on Flash ZIP or OTA. Navigate and select the S7_or_S7Edge_Fixes_V15.zip. file. Leave the options alone and click the check in the top right. Scroll down to the bottom and click flash. Your phone will reboot and flash the zip. This can take a while.
  10. Go to Settings>Lock screen and security>Other security settings>Security policy updates and turn off "Automatic updates" and "Wi-Fi only". Reboot. This seems to be the culprit of the 7 day soft brick.
  11. Open back up Package Disabler Pro and search for "software update". Disable both packages (com.sec.android.soagent and com.wssyncmldm)
  12. Enjoy your rooted device with minimal to almost no lag.
  13. ???
  14. Profit.


As always, be sure to donate to the people who actually helped achieved root: @Princecosmy, @br3w3r, and @Chainfire
For the bounty donate to elsa3id.3agwa@gmail.com PayPal

Shout out to @psouza4, @izzibew26, @mhill1986, @LeftyGR, @Soooperstar, and to all of you who are contributing in making this root method easier everyday. Thanks for the feedback.

Originally, it started getting interesting at post #185:
http://forum.xda-developers.com/att-...t3341274/page4

I'm also keeping track of the Sprint Galaxy S7 Edge (SM-G935P) version:
http://forum.xda-developers.com/spri.../root-t3410424
Attached Files
File Type: zip S7_or_S7Edge_Fixes_Debloater_V15_SPRINT2.zip - [Click for QR Code] (701.5 KB, 4262 views)
The Following 34 Users Say Thank You to colormedroid For This Useful Post: [ View ] Gift colormedroid Ad-Free
 
 
4th July 2016, 06:50 AM |#2  
colormedroid's Avatar
OP Senior Member
Houston
Thanks Meter: 272
 
More
FAQ's:
  1. My WiFi credentials keep on getting erased after a reboot. What gives?
    A: This seems to be an issue across all the QC S7 variants. Here's what I did to fix it. Download BuildProp Editor and change: ro.securestorage.support=true to ro.securestorage.support=false

    Credit goes out to: @guaneet for this fix

  2. Can I install Xposed?
    A: Yep. Here's how to do it:
    Quote:
    Originally Posted by fnztakedown

    Alright. Here is a DB link of the two files I had installed to get xposed working. To flash this you will need flashfire.
    Process is simple. Download both files and install the apk.

    Open flashfire> select flash new file> find the xposed zip, flash. Give it a solid 5-7 minutes during boot up.

    Ensure you do not have any major packages disabled and ensure you have BACKED UP YOUR ROM VIA FLASHFIRE. Please be aware, this was successful for me on the 935T and I do have random reboots at time. I cannot confirm this is the cause yet. I would also suggest finding the uninstall zip in the event you have issues you can flashfire back.



    https://www.dropbox.com/sh/0yabdfx6a...uG1Nq5jba?dl=0

    Credit goes out to: @fnztakedown for these instructions

  3. I'm having issues with ADB. Any help?
    A: Easiest way to install ADB and its subsequent drivers would be to get it from here:
    http://forum.xda-developers.com/show....php?t=2588979
    It's SO easy to install and it takes most if not all of the hassle out of it.
    Credit to @Snoop05 for this easy ADB installer.

  4. How do I enable USB debugging?
    A: Go to Settings>About device and tap Build number until it shows Developer options has been enabled.

  5. I'm stuck on the LTE splash screen. What do I do?
    A: Press and hold the Volume Down + Power button down until your phone restarts. If you keep on getting stuck at the LTE splash screen you may have to factory reset your device. As soon as your phone restart quickly press the volume up + home + power button and let it boot into recovery. Wipe data/factory reset and cache partition.

  6. I'd like to unroot and return to factory stock. How would I go about this?
    A: Head on over to @psouza4's post HERE and follow his steps in the return to stock section. The steps are easy and he's posted mostly all the firmware.

  7. Does this method trip Knox?
    A: No, it doesn't. And flashing back to stock will allow Knox to work again, as long as you didn't flash files from other sources (there are some that will trip Knox, so be careful).

  8. Does Samsung Pay work?
    A: No, sorry. They can detect the rooted boot environment through a driver, so you can't even hide root from the app using RootCloak.

  9. Does Android Pay work?
    A: It does, but you have to make a change that disables root and then reboot your phone. You can toggle this back/forth without flashing, but you either get root or Android Pay at any one time.

  10. What happens if I brick my phone?
    A: As long as there are stock images to flash back to, it's almost impossible to do this no matter how badly the process goes. Check that we have stock images; if we do, then we can always flash them over the device using the unroot method in this guide. That practically guarantees a return-to-stock experience for a phone as long as it doesn't have any serious physical damage preventing it from powering on.

  11. I installed the ADB system-wide on my Windows computer/laptop, but I see "'adb' is not recognized as an internal or external command, operable program or batch file".
    A: Your user profile path can't contain a space. That means if your Windows user is 'Somebody Nice' and thus your Windows user path is 'C:\Users\Somebody Nice', the install will fail. You can create another user on your computer (if prompted for a Microsoft login, choose to make only a local account) and enter a short, single-word name for your user. Sign into and use that user profile instead. Also, the path where you extract the SuperSU package can't contain a space, so try extracting them to somewhere simple like perhaps C:\S7Root.

More answers to FAQ's to come.
The Following 14 Users Say Thank You to colormedroid For This Useful Post: [ View ] Gift colormedroid Ad-Free
4th July 2016, 05:08 PM |#3  
slickdealers's Avatar
Senior Member
Thanks Meter: 41
 
More
Quote:
Originally Posted by colormedroid

Just got home to test this out. Currently on PC5 since I've been waiting for this day to come. Will post back once I have results.

Just flashed the engineering boot.img. Make sure you boot into BOOTLOADER mode when using odin to flash this because the instructions don't show this. Also, make sure to back up all your stuff because most likely this will involve a factory reset.

Update #3: So, seems like our variant seems to have issues with the activation process. Here's what I did to fix it. It's a temporary fix until it gets figured out completely but it's a fix none the less.
1. Flash engineer boot.img through odin.
2. Factory reset/wipe
3. Go through the setup process without actually activating (once it gets to the activation screen press and hold the back button).
4. I signed into my google account through wifi and I downloaded Package Disable Pro+ Samsung (https://play.google.com/store/apps/d...isablerpremium). Yes it costs money but it's the way I achieved this work around at the moment.
5. I went into settings>Acitvate this device.
Don't click "done" after it gets activated.
6. Press the home button to get to the main screen and open up Package Disabler Pro+ Samsung
7. After Package Disabler Pro is set up... I searched for Samsung DM Service and I disabled it.

Voila! No more rebooting. Like I said, this is hopefully temporary until it gets figured out.

Now on to installing SU. I will post back with pictures of Root Checker.

Update #4: Installed SU through the root.bat file in the instructions. Took a screenshot of root checker. Here it is in all it's glory.
http://imgur.com/FHvak9Z
Almost forgot to mention that it seems that the engineer boot.img does lag the system a little bit so again, try it at your own risk. I for one will be trying this out like I have with all my older devices. Next step is Adaway =D.


I can't believe it! Have you tried to install adaway and xposed yet? You said the system lags a bit, is it laggy enough that it would become frustrating after using for a few minutes? I'm still on my Galaxy S5 and just deciding whether I should head to the Sprint store today or not.
4th July 2016, 05:13 PM |#4  
colormedroid's Avatar
OP Senior Member
Houston
Thanks Meter: 272
 
More
Quote:
Originally Posted by slickdealers

I can't believe it! Have you tried to install adaway and xposed yet? You said the system lags a bit, is it laggy enough that it would become frustrating after using for a few minutes? I'm still on my Galaxy S5 and just deciding whether I should head to the Sprint store today or not.

Adaway installed successfully. Haven't installed xposed but someone said that you could do it through flashfire. That might have to wait for tomorrow as today is the 4th. M'urica!

*whoops, forgot to quote you my bad.

Sent from my SM-G935P using Tapatalk
The Following User Says Thank You to colormedroid For This Useful Post: [ View ] Gift colormedroid Ad-Free
4th July 2016, 10:39 PM |#5  
Junior Member
Thanks Meter: 2
 
More
It works
I tried it and it works also have adaway installed through f Droid
The Following User Says Thank You to vahalaru For This Useful Post: [ View ] Gift vahalaru Ad-Free
5th July 2016, 12:43 AM |#6  
eurominican's Avatar
Senior Member
Thanks Meter: 216
 
More
Can i install this update?



Sent from my SM-G930P using Tapatalk
5th July 2016, 01:26 AM |#7  
Junior Member
Thanks Meter: 10
 
More
You should NEVER install an over the air update if you want to keep root. Always get your updates from xda.
The Following 2 Users Say Thank You to skribe For This Useful Post: [ View ] Gift skribe Ad-Free
5th July 2016, 04:19 AM |#8  
Senior Member
Flag Kansas City,Missouri
Thanks Meter: 144
 
More
Click image for larger version

Name:	1467688773072.jpg
Views:	2846
Size:	36.2 KB
ID:	3803555

Sent from my SM-G930P using XDA-Developers mobile app
The Following User Says Thank You to sml2004 For This Useful Post: [ View ] Gift sml2004 Ad-Free
5th July 2016, 04:25 AM |#9  
colormedroid's Avatar
OP Senior Member
Houston
Thanks Meter: 272
 
More
Quote:
Originally Posted by sml2004

Attachment 3803555

Sent from my SM-G930P using XDA-Developers mobile app

Good job getting it working!

Sent from my SM-G935P using Tapatalk
5th July 2016, 04:29 AM |#10  
Senior Member
Flag Kansas City,Missouri
Thanks Meter: 144
 
More
Quote:
Originally Posted by colormedroid

Good job getting it working!

Sent from my SM-G935P using Tapatalk

Now I guess we need Hotspot mod. And a damn sd card fix. Lol

Sent from my SM-G930P using XDA-Developers mobile app
The Following User Says Thank You to sml2004 For This Useful Post: [ View ] Gift sml2004 Ad-Free
5th July 2016, 05:45 AM |#11  
Member
Thanks Meter: 1
 
More
Has anyone tried this on PF2? I honestly had to update and have been taking updates, because this is one ****ty sluggish phone. It seems to get worse the longer I have the S7. This is much like what happened with the S6, so root would be appreciated to alleviate it.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes