[10.0][OFFICIAL] Resurrection Remix v8.x [HDK][GAPPS]

Search This thread

Top Liked Posts

  • There are no posts matching your filters.
  • 4

    Resurrection Remix Q

     * Your warranty is now void.
     * I am not responsible for bricked devices, dead SD cards,
     * thermonuclear war, or you getting fired because the alarm app failed. Please
     * do some research if you have any concerns about features included in this ROM
     * before flashing it! YOU are choosing to make these modifications, and if
     * you point the finger at me for messing up your device, I will laugh at you.


    Resurrection Remix the ROM has been based on LineageOS, SlimRoms, Omni and original Remix ROM builds, this creates an awesome
    combination of performance, customization, power and the most new features, brought directly to your Device.

    Many things that in previous versions were tweaked with mods, are now included by default in the ROM so, please enjoy!
    Special thanks to the LineageOS team, Omni team, SlimRoms and of course to all the supporters.


    Make sure you have a custom recovery installed(TWRP is the preferred recovery)
    Download the latest Resurrection Remix Rom & the latest GApps package
    Boot into recovery
    Perform a FULL factory wipe and wipe/system and dalvik cache as a precaution
    Flash ResurrectionRemix Rom
    Flash Google Apps package(Optional)
    Flash Magisk Root(Optional)
    First boot may take up to 10 minutes.

    Your device needs to be wiped, period, theres no way around it, if you find a way around it I dont want to hear about it, you shouldnt dirty flash things

    You must be running Android 10 (QD4A.200805.003) before installing this.

    From a PC, Download ROM zip and boot.img
    Reboot to bootloader (`adb reboot-bootloader`)
    `fastboot flash --slot all boot path/to/boot.img`
    Reboot to Recovery
    Factory Reset
    Apply Update -> ADB then from PC `adb sideload path/to/rom.zip`
    When finished, and it shows complete with status 0, go back and reboot system
    You should be presented with Android Setup Wizard

    ROM now comes with HolyDragon Kernel included, Special shoutouts and thanks to HolyAngel for allowing us to include his awesome kernel!


    ROM Download


    Resurrection Remix Source
    Device Source
    Kernel Source
    Vendor Source


    XDA Developers
    The Kangarooster Meadows
    LineageOs Team
    Dirty Unicorns
    Evolution X
    Omni Team
    And Of Course To All The Supporters, Donators And Users

    Join our Telegram channel : https://t.me/resurrectionremixchat


    If you have a major bug to report that has not been reported already, please take the following steps to report it to us. It will save you, Team Resurrection Remix and me quite some time.

    Download the MatLog app from the Play Store.
    After downloading the MatLog app, go to the app settings, and change the log level to Debug.
    Clear all previous logs and take the exact steps to produce the error you are receiving. As soon as you receive the error (probably a force close), go straight into MatLog and stop the log recording.
    Copy and paste the entire log either to Hastebin or Pastebin
    Save the log, and copy and paste the link into the thread with a brief description of the error.

    XDA:DevDB Information
    ResurrectionRemix, ROM for the Google Pixel 4a

    xstefen, varund7726
    Source Code: https://github.com/ResurrectionRemix

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    ROM Firmware Required: QD4A.200805.003
    Based On: AOSP, LineageOS, etc

    Version Information
    Status: Official

    Created 2020-09-06
    Last Updated 2020-10-04
    I dont know who you think your talking to and you might want to slow your roll brother, I was only mentioning DU as a rom that the dev might ask for help with for volte since it is working on that rom and as a reference for the screenshot I attached. This dev did post something on this thread asking us to let him know if there were possible fixes out there so he can make this rom better.


    As you can see, the DU dev is already graciously providing assistance to this dev which is the way XDA is supposed to be. I have been around android for a minute and know how things work and in NO way was I being disrespectful so you can take that accusation elsewhere! I am the first person to help others and the last to be disrespectful. Now, I DO NOT want to take up anymore of this thread with this nonsense, if you wish to talk to me in private and discuss things PM me! If the OP ever thought I was being disrespectful I am sure he would have let me know. Cluttering up this thread is wrong.

    If your using Dirty Unicorns why are you here? Mentioning another devs rom in another devs thread is considered disrespectful. These people put in a lot of time and effort to bring this to us and they don't have to. They have other full time jobs and can't focus on rom development full time. I appreciate what we have and I'm sure it will only get better. Patience is key.
    I'm on latest rr, RROS-Q-8.6.1-20201007-sunfish-Official. So my boot.img should be fine.
    Please keep the stock rr boot.img by the hand, if something goes wrong and your OS does not boot!
    Patched boot.img which is working for me is here: https://www.androidfilehost.com/?fid=10763459528675570623
    THANK YOU all for the tips, support and effort on this ROM. It's amazing.

    I've never installed a custom ROM on any device before. That said, this has been an equally frustrating and enlightening experience for me. I read through the whole thread and see a handful of problems that others have ran into that I've also experienced. Maybe I can lend a little input that might be helpful. Some of the processes in making this work are still a little confusing for me. Please bear with me and any experienced users, please feel free to clarify some things that may not make sense. This is all coming from a super newb, I definitely don't know everything, but I have learned a lot over the past week.

    I bought my Pixel 4a about a week ago and it came with 11 stock. I went to the Google page and downloaded the 'stock ROM' from there. (Which I believe is 11(?) or 10, I'mnot 100% sure, BUT, it did allow me to root and install RROS with minimal issues once I figured out how to do it all correctly.)

    There are two of the newest version available, Verizon and Unlocked. I used the Unlocked version.

    Download the zip and extract it to your desktop or somewhere it can be found easily.
    -Do this just to get the boot.img out of it, as you'll need this to flash the stock Rom to your device.

    It's a good idea to keep the boot.img for each ROM next to the .zip file (on your desktop or somewhere easy to find) for that ROM to change them in and out of your platform-tools directory, which I've conveniently placed directly into the C:/ directory. (C:/platform-tools)

    Don't continue from here if your bootloader isn't unlocked and you don't have Root.
    If you have the bootloader unlocked and you have Root, then continue...

    Please keep in mind that I don't remember the EXACT process I used to do all this, but xstefen's instructions on the original post are what I kept coming back to in order to do this correctly, no matter which ROM I was flashing.

    Follow the instructions on the very first post for flashing RROS, but do it for this Stock ROM instead. (Sunfish-q4da.200805.003) Use the boot.img file you took from the Sunfish .zip file.

    It is really convenient and seems to eliminate some or most errors by putting these files directly into your C:/platform-tools directory. (or wherever your platform-tools folder is located)

    Here are xstefen's original instructions, copy/pasted:

    You must be running Android 10 (QD4A.200805.003) before installing this.

    From a PC, Download ROM zip and boot.img
    Reboot to bootloader (`adb reboot-bootloader`)
    `fastboot flash --slot all boot path/to/boot.img`
    Reboot to Recovery
    Factory Reset
    Apply Update -> ADB then from PC `adb sideload path/to/rom.zip`
    When finished, and it shows complete with status 0, go back and reboot system
    You should be presented with Android Setup Wizard

    Click in the search bar of your platform-tools directory and type cmd, hit enter. You need to be using cmd.exe in the directory the files you're trying to flash are located in. For some reason I ran into hurdle after hurdle trying to target the files while they were in Downloads or on the Desktop. (for instance, I could get the RROS.zip to install up to 56%, then it would suddenly quit for no apparent reason.)

    If the file you're trying to flash are in the same directory as platform-tools, then designating:
    fastboot flash boot C:/platform-tools/boot.img

    Was unnecessary and you can simply use the command:
    fastboot flash boot boot.img

    Remember, you're using the boot.img from the sunfish stock ROM downloaded from the link above.

    Go through the process of installing the Stock ROM.

    Once you have the Stock ROM installed, THEN remove the boot.img and sunfish-q4da.200805.003 files from your platform-tools directory.

    Now, replace those with the boot.img and RROS.zip files provided by xstefen, which I'll re-link here:

    Again, make sure you move or copy/paste these files to the platform-tools directory, where you're running cmd from, via the search bar.

    Now, scroll back up to xstefen's instructions for installing RROS and it should go through okay.

    I hope this works for everyone having some of the same issues I had with the installation stopping part of the way through with command errors(or the wonderful error: no error) message I was getting.


    Okay, this ROM is really great. I spent probably three days, a total of 12-16 hours digging through all of the settings and testing them pretty extensively. I can tell that you guys have put a LOT of time and effort into this.

    Seriously, thank you so much for making me appreciate Android again.

    The only two things I had issues with were:

    1. The SafetyNet ctsprofile fail. (Which I think is a false flag since I was able to update the Play store, download banking apps and use them)

    I went through the process of getting the MagiskHide module, forcing basic attestation by changing the profile to a Pixel 3a for instance that utilizes software based attestation instead of hardware based. I still can't get the ctsprofile to pass, but it doesn't seem to matter either way.

    Here are a couple articles I found talking about how to pass the SafetyNet ctsprofile check. I couldn't get it to work, but maybe someone here can:

    2. I can't seem to change the color of the date on the lockscreen, but I can change the color of the clock. I also can't seem to change the style in which they display, which is pretty minor in the larger scope of what this ROM provides as far as other features. Regardless, I'm beyond satisfied with how my clock and date display on the lockscreen, no real complaints there.

    I understand that xstefen may or may not be ditching further development of RROS based on Android 10. Very special shoutout to xstefen and his team for putting all of this together, you guys did a fantastic job.

    One thing I'm curious about is: How the hell do I get rid of the G search bar on my home screen? I'll never use it and would love to see it disappear. :)

    For OTA Updates:

    It looks like topjohnwu wrote an article with a process to install OTA updates without losing Magisk or Root access.

    Full disclosure, I have not tried this. I'm not brave enough for this. But it's nice knowing that when I DO encounter this issue, I've got this resource from the developer of Magisk himself to walk me through it. I believe this is the process you would go through without having TWRP installed, which is our case, for now.

    If anyone is brave enough to verify that this method works without causing harm to the RROS install or integrity, that would be great.

    Aside from that, I don't even see an option to disable automatic OTA updates in the developer menu. Was this disabled by default in the RROS ROM? (We may not have to worry about this at all)

    I took some screenshots of my current configurations, here's the link if you'd like to check them out:

    Thanks again for the ROM and all the help!
    At least by changing your launcher to one that allows you to do that. Nova Launcher, in my case 😉

    My guy. I will look into this, thank you!

    I figured out the issue with not being able to change the date color on the lock screen as well. I had the Divided Lines clock selected, which I guess will force the date color to white and still allow you to change the time color. After changing the clock type in theme settings, it let me change the date display and color settings.