• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[10.0] Project Treble for Xperia XZs [2020.03.18]

Search This thread

Sjll

Recognized Developer
Jun 4, 2017
510
590
Chongqing
Project Treble 10.0 For XZs​
Based on Sony Open Devices​
I am not responsible for bricked devices, dead SD cards.​
Special Thanks: @local__hero
请中文用户遵守XDA规则,使用双语留言

Download Link

How to flash: See the guidance in Treble-10.0-keyaki-4.9-sjll-V2.10.zip.

You need to choose the GSI type:
Android 10.0.
A/B or B, don't choose A-only!
ARM64.

XDA:DevDB Information
Treble, ROM for the Sony Xperia XZs

Source Codes
Link
Contributors
Sjll
ROM OS Version: 10.0
ROM Kernel: Linux 4.x

Paypal
I am very happy to receive your donation.

Version Information
Status: Testing

Created 2019-10-02
Last Updated 2020-03-18
 

Attachments

  • Screenshot_20191001-232613.png
    Screenshot_20191001-232613.png
    130.2 KB · Views: 4,188
Last edited:

fengwang233

New member
Oct 2, 2019
2
0
The device is always inexplicably restarted for unknown reasons.

The device is always inexplicably restarted for unknown reasons.Looks like all the three-party rom of xzs has this problem (from google translation, my English is really bad XD)
 

DAANDAV

Member
Feb 15, 2012
9
0
You should flash a gapps suit for Android 10.0.

Thanks. I was not sure since OEM is still 9 and Gapps 10 was not yet available for download on official website. Tried from Cyanogen website Gapps 10 (full, pico) but 'Android Setup keeps stopping'. Tried from XDA BiTGApps, does not have Android Setup and works.

Will keep you posted here on how ROM behaves.
 

Sjll

Recognized Developer
Jun 4, 2017
510
590
Chongqing

DAANDAV

Member
Feb 15, 2012
9
0
Seems to work

So I tested the rom for some time now.

It indeed restarts at some random moments just idling laying on the desk. Do not yet have an understanding why this is. However it is not that often that it is annoying.

Magisk works perfectly.

BitGApps does also work.

A lot of notifications saying app versions are not made for Android 10, try to update while having latest installed. Guess this is a Android 10 issue?

Netflix does not seem to work keeps giving connection error (9).

At startup the notification always pops up saying there is a problem with the android system.

Sometimes text in apps or launcher vanishes until restart.

Thanks for all the work!
 
Last edited:

DAANDAV

Member
Feb 15, 2012
9
0
Are there any near future plans for updates to make this ROM more stable? Or can I provide error logs to contribute?

The rebooting is getting worse and more annoying. I'm in doubt to get back to old ROM.

Thanks in advance.
 

sam595

Member
Mar 20, 2020
5
5
low battery protection

hay , i just notice , if my power level is under 5%
the phone will extreme laggy , and the core is offline
how can i fix it ?
 

fhcwcsy

Member
Aug 21, 2017
21
3
Hi. I want to try this project but I'm not sure how to do this. I tried once but I failed. Can someone tell me what's wrong? Thanks. Here's what I tried (bootloader is already unlocked):

1. flash "41.3.A.2.247. Customization : Customized US" using flashtool.
2. fastboot flash oem vendor.img
3. fastboot flash boot boot.img
4. fastboot flash system <GSI Image>
where <GSI Image> is downloaded from [here](https://forum.xda-developers.com/pr...evice-development/lineage-phh-treble-t3767690) following [this](https://www.xda-developers.com/flash-generic-system-image-project-treble-device/) tutorial. The download link in [phh-Treble AOSP Thread](https://forum.xda-developers.com/pr...-development/experimental-phh-treble-t3709659) is dead.
5. Bootloop. Doesn't even get pass the sony logo.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    Project Treble 10.0 For XZs​
    Based on Sony Open Devices​
    I am not responsible for bricked devices, dead SD cards.​
    Special Thanks: @local__hero
    请中文用户遵守XDA规则,使用双语留言

    Download Link

    How to flash: See the guidance in Treble-10.0-keyaki-4.9-sjll-V2.10.zip.

    You need to choose the GSI type:
    Android 10.0.
    A/B or B, don't choose A-only!
    ARM64.

    XDA:DevDB Information
    Treble, ROM for the Sony Xperia XZs

    Source Codes
    Link
    Contributors
    Sjll
    ROM OS Version: 10.0
    ROM Kernel: Linux 4.x

    Paypal
    I am very happy to receive your donation.

    Version Information
    Status: Testing

    Created 2019-10-02
    Last Updated 2020-03-18
    2
    hay , i just notice , if my power level is under 5%
    the phone will extreme laggy , and the core is offline
    how can i fix it ?

    It normal to enter powersave mode in low battery.

    Hi. I want to try this project but I'm not sure how to do this. I tried once but I failed. Can someone tell me what's wrong? Thanks. Here's what I tried (bootloader is already unlocked):

    1. flash "41.3.A.2.247. Customization : Customized US" using flashtool.
    2. fastboot flash oem vendor.img
    3. fastboot flash boot boot.img
    4. fastboot flash system <GSI Image>
    where <GSI Image> is downloaded from [here](https://forum.xda-developers.com/pr...evice-development/lineage-phh-treble-t3767690) following [this](https://www.xda-developers.com/flash-generic-system-image-project-treble-device/) tutorial. The download link in [phh-Treble AOSP Thread](https://forum.xda-developers.com/pr...-development/experimental-phh-treble-t3709659) is dead.
    5. Bootloop. Doesn't even get pass the sony logo.

    You need to choose the GSI type:
    Android 10.0.
    A/B or B, don't choose A-only!
    ARM64.
    1
    It normal to enter powersave mode in low battery.



    You need to choose the GSI type:
    Android 10.0.
    A/B or B, don't choose A-only!
    ARM64.

    Oh, I didn't notice that I downloading the wrong version. Thank you for pointing out. I'm going try system-quack-arm64-ab-gapps.img.xz from here (this is correct right?) I guess this will work, right?
    Another question, does the lineage OS version work? (lineage-17.1-20200309-UNOFFICIAL-treble_arm64_bvN.img.xz from here)

    Edit:
    I tried both of them and neither of them worked :( . I flashed the official firmware, then vendor.img, boot.img, and finally the system mentioned above. What's wrong here?

    Edit 2:
    I figured it out myself. I wiped userdata, cache and system then the device actually boots. Sim card can be detected so far. Looking forward to test out more features. Thank you for the brilliant work.
    1
    Oh, I didn't notice that I downloading the wrong version. Thank you for pointing out. I'm going try system-quack-arm64-ab-gapps.img.xz from here (this is correct right?) I guess this will work, right?
    Another question, does the lineage OS version work? (lineage-17.1-20200309-UNOFFICIAL-treble_arm64_bvN.img.xz from here)

    Edit:
    I tried both of them and neither of them worked :( . I flashed the official firmware, then vendor.img, boot.img, and finally the system mentioned above. What's wrong here?

    Edit 2:
    I figured it out myself. I wiped userdata, cache and system then the device actually boots. Sim card can be detected so far. Looking forward to test out more features. Thank you for the brilliant work.

    You're welcome.
    Fot GSI, just try and see more threads.
    1
    I just installed yesterday and no major problems so far. The rom is certainly usable. But a problem still annoys me. I installed XZ version of twrp but it cannot mount data partition. It shows
    Code:
    failed to mount /data (Invalid argument)
    . I followed a thread to format it into ext2 and back to ext4, wiped cache, but the phone can no longer boot. Also the phone heat up quite easily. The other features are great. Any idea on how to solve the mounting problem?

    This problem is normal, you need to format data partition.