100% working guide for VoLTE+VoWiFi on mi9 miui 11 no root needed !!

Search This thread

Almog Hilel

Member
Mar 25, 2020
8
2
Hello guys,
Well this was a hell of a month for me.
I learned so much about this 2 options and now I finally got them to work !
I live in Israel, my cell supp is Partner (former Orange , but this will work for every carrier)
This is my guide, works on all Stable ROMs with NO root needed !!!
No pc, no root, no flashes.
Have a good one!

tzBTqb1.jpg


Little update:
You have to ask the service from you carrier before !
They need to approve your SIM for that.
Just search "(your carrier name) WiFi calling"
Enable it and then do this trick.
So first,
1. disable the carrier check for this 2 options:
VoLTE:
Dialer
*#*#86583#*#*
VoWifi:
Dialer
*#*#869434#*#*

2. Now go to settting>sim and cellular>'your sim' (example: Partner IL) > scroll down and enable Volte and calles over wi-fi (or Wlan)
In the calles over wi-fi - choose WiFi preferred.

A3aXrHx.jpg


3. Go to Play store and Download this app: (like the picture) shortcut maker
Open the app

7IISSSs.jpg


4. Select the "activities" tab
oujMyry.jpg


5. Scroll down and search "modem config"
Press on it.

JbemzOs.jpg


6. Open the selected "MBNLoader" by pressing "try this shortcut"
GANdIdf.jpg


7. Now you will see the toggle on the first one, ignore it and scroll down till you see: MBNLoader /vendor/................. (The path doesn't matter) /Vodafone/volte/Greece/mcfg_sw.mbn
Select it !
SjnaLsK.jpg


Now go back, Exit the app, And restart your phone !

Viola !!! Vowifi and volte are working !!!!
Pictures attached as you can see for yourself.
Enjoy !!


p.s: if this didnt work for your try choosing other carrier from that (huge) list. one of them will work like a chram.
 
Last edited:
  • Like
Reactions: xuxu1

mrnannu

Senior Member
Jul 2, 2014
50
6
Dhaka
Xiaomi 12X
Hello guys,

Well this was a hell of a month for me.

I learned so much about this 2 options and now I finally got them to work !

I live in Israel, my cell supp is Partner (former Orange , but this will work for every carrier)

This is my guide, works on all Stable ROMs with NO root needed !!!

No pc, no root, no flashes.

Have a good one!


tzBTqb1.jpg




So first,

1. disable the carrier check for this 2 options:

VoLTE:

Dialer

*#*#86583#*#*

VoWifi:

Dialer

*#*#869434#*#*



2. Now go to settting>sim and cellular>'your sim' (example: Partner IL) > scroll down and enable Volte and calles over wi-fi (or Wlan)

In the calles over wi-fi - choose WiFi preferred.


A3aXrHx.jpg




3. Go to Play store and Download this app: (like the picture) shortcut maker

Open the app


7IISSSs.jpg




4. Select the "activities" tab

oujMyry.jpg




5. Scroll down and search "modem config"

Press on it.


JbemzOs.jpg




6. Open the selected "MBNLoader" by pressing "try this shortcut"

GANdIdf.jpg




7. Now you will see the toggle on the first one, ignore it and scroll down till you see: MBNLoader /vendor/................. (The path doesn't matter) /Vodafone/volte/Greece/mcfg_sw.mbn

Select it !

SjnaLsK.jpg




Now go back, Exit the app, And restart your phone !



Viola !!! Vowifi and volte are working !!!!

Pictures attached as you can see for yourself.

Enjoy !!




p.s: if this didnt work for your try choosing other carrier from that (huge) list. one of them will work like a chram.
Thanks, stil not success trying one by one.
Which country are you from?

Sent from my MI 9 using Tapatalk
 

mrnannu

Senior Member
Jul 2, 2014
50
6
Dhaka
Xiaomi 12X
From Israel.

Which carrier are you using ?

Ofc, before doing this you need to apply the service via your carrier, this method is after the carrier enabled you in their system.
I am from Bangladesh, using Grameenphone sim which is known as telenor in other country. I have already tested with volte + all the country but its not working [emoji22].

Yes, I have already Volte + WiFi enabled as per your requirements. IMG_20200325_222720.jpg

Sent from my MI 9 using Tapatalk
 

Almog Hilel

Member
Mar 25, 2020
8
2
I am from Bangladesh, using Grameenphone sim which is known as telenor in other country. I have already tested with volte + all the country but its not working [emoji22].

Yes, I have already Volte + WiFi enabled as per your requirements. View attachment 4978773

Sent from my MI 9 using Tapatalk

Did you went to your carrier website and apply this service ? This has to work after all the steps.
But you have to register in your carrier website for this service.
 

mrnannu

Senior Member
Jul 2, 2014
50
6
Dhaka
Xiaomi 12X
Did you went to your carrier website and apply this service ? This has to work after all the steps.

But you have to register in your carrier website for this service.
I have nothing found on their website?
How it looks like?

Sent from my MI 9 using Tapatalk

---------- Post added at 10:34 PM ---------- Previous post was at 10:31 PM ----------

A few years ago I have seen HD in calling screen which could be for Volte but never seen Volte Wifi. Now nothing of these are working.

Sent from my MI 9 using Tapatalk
 

Almog Hilel

Member
Mar 25, 2020
8
2
I have nothing found on their website?
How it looks like?

Sent from my MI 9 using Tapatalk

---------- Post added at 10:34 PM ---------- Previous post was at 10:31 PM ----------

A few years ago I have seen HD in calling screen which could be for Volte but never seen Volte Wifi. Now nothing of these are working.

Sent from my MI 9 using Tapatalk
For the carrier - If you have an app search there for WiFi calling (or Vowifi) inside the the app.

Try switching to Indian config in the list.
Joi maybe or Airtel will work for you.
 
  • Like
Reactions: mrnannu

zgfg

Senior Member
Oct 10, 2016
7,801
5,208
Mi 9T stock QFJEUXM 11.0.4.0, I don't see anything like Modem (config) in Activities, trying with Shortcut Maker and Package Manager

Phone is rooted, any other way to choose MBNLoader?

Thanks
 

Attachments

  • Screenshot_2020-04-09-13-24-31-359_rk.android.app.shortcutmaker.jpg
    Screenshot_2020-04-09-13-24-31-359_rk.android.app.shortcutmaker.jpg
    241.3 KB · Views: 596
Last edited:

zgfg

Senior Member
Oct 10, 2016
7,801
5,208
@zgfg
Yes, there is another method

https://forum.xda-developers.com/poco-f1/how-to/guide-activate-vowifi-wlan-call-t3871263
https://telegra.ph/Trying-out-diffe...-SoCmodem-to-make-VoLTEViLTEVoWIFI-work-07-03

You need a PC and root. (for some redmi devices it works without root)

Please Backup EFS and MODEM in TWRP before trying this
Ok thanks, I will study but I first have to get VoLTE activated for my subscription (cannot arrange now these days)
 

zgfg

Senior Member
Oct 10, 2016
7,801
5,208
For VoLTE its easier, just go to dialer and enter
*#*#86583#*#*
then there should be a popup where it says "Carrier Check disabled". Then go to your settings and enable volte. :)
I saw, I am talking about getting VoLTE subcribtion with my carrier
 

leobahlis

Senior Member
Nov 14, 2018
63
5
Hello guys,
Well this was a hell of a month for me.
I learned so much about this 2 options and now I finally got them to work !
I live in Israel, my cell supp is Partner (former Orange , but this will work for every carrier)
This is my guide, works on all Stable ROMs with NO root needed !!!
No pc, no root, no flashes.
Have a good one!

tzBTqb1.jpg


Little update:
You have to ask the service from you carrier before !
They need to approve your SIM for that.
Just search "(your carrier name) WiFi calling"
Enable it and then do this trick.
So first,
1. disable the carrier check for this 2 options:
VoLTE:
Dialer
*#*#86583#*#*
VoWifi:
Dialer
*#*#869434#*#*

2. Now go to settting>sim and cellular>'your sim' (example: Partner IL) > scroll down and enable Volte and calles over wi-fi (or Wlan)
In the calles over wi-fi - choose WiFi preferred.

A3aXrHx.jpg


3. Go to Play store and Download this app: (like the picture) shortcut maker
Open the app

7IISSSs.jpg


4. Select the "activities" tab
oujMyry.jpg


5. Scroll down and search "modem config"
Press on it.

JbemzOs.jpg


6. Open the selected "MBNLoader" by pressing "try this shortcut"
GANdIdf.jpg


7. Now you will see the toggle on the first one, ignore it and scroll down till you see: MBNLoader /vendor/................. (The path doesn't matter) /Vodafone/volte/Greece/mcfg_sw.mbn
Select it !
SjnaLsK.jpg


Now go back, Exit the app, And restart your phone !

Viola !!! Vowifi and volte are working !!!!
Pictures attached as you can see for yourself.
Enjoy !!


p.s: if this didnt work for your try choosing other carrier from that (huge) list. one of them will work like a chram.

here my list is empty...don't know why, can somebody help?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello guys,
    Well this was a hell of a month for me.
    I learned so much about this 2 options and now I finally got them to work !
    I live in Israel, my cell supp is Partner (former Orange , but this will work for every carrier)
    This is my guide, works on all Stable ROMs with NO root needed !!!
    No pc, no root, no flashes.
    Have a good one!

    tzBTqb1.jpg


    Little update:
    You have to ask the service from you carrier before !
    They need to approve your SIM for that.
    Just search "(your carrier name) WiFi calling"
    Enable it and then do this trick.
    So first,
    1. disable the carrier check for this 2 options:
    VoLTE:
    Dialer
    *#*#86583#*#*
    VoWifi:
    Dialer
    *#*#869434#*#*

    2. Now go to settting>sim and cellular>'your sim' (example: Partner IL) > scroll down and enable Volte and calles over wi-fi (or Wlan)
    In the calles over wi-fi - choose WiFi preferred.

    A3aXrHx.jpg


    3. Go to Play store and Download this app: (like the picture) shortcut maker
    Open the app

    7IISSSs.jpg


    4. Select the "activities" tab
    oujMyry.jpg


    5. Scroll down and search "modem config"
    Press on it.

    JbemzOs.jpg


    6. Open the selected "MBNLoader" by pressing "try this shortcut"
    GANdIdf.jpg


    7. Now you will see the toggle on the first one, ignore it and scroll down till you see: MBNLoader /vendor/................. (The path doesn't matter) /Vodafone/volte/Greece/mcfg_sw.mbn
    Select it !
    SjnaLsK.jpg


    Now go back, Exit the app, And restart your phone !

    Viola !!! Vowifi and volte are working !!!!
    Pictures attached as you can see for yourself.
    Enjoy !!


    p.s: if this didnt work for your try choosing other carrier from that (huge) list. one of them will work like a chram.
    1
    I have nothing found on their website?
    How it looks like?

    Sent from my MI 9 using Tapatalk

    ---------- Post added at 10:34 PM ---------- Previous post was at 10:31 PM ----------

    A few years ago I have seen HD in calling screen which could be for Volte but never seen Volte Wifi. Now nothing of these are working.

    Sent from my MI 9 using Tapatalk
    For the carrier - If you have an app search there for WiFi calling (or Vowifi) inside the the app.

    Try switching to Indian config in the list.
    Joi maybe or Airtel will work for you.
    1
    @zgfg
    Yes, there is another method

    https://forum.xda-developers.com/poco-f1/how-to/guide-activate-vowifi-wlan-call-t3871263
    https://telegra.ph/Trying-out-diffe...-SoCmodem-to-make-VoLTEViLTEVoWIFI-work-07-03

    You need a PC and root. (for some redmi devices it works without root)

    Please Backup EFS and MODEM in TWRP before trying this
    1
    Ok thanks, I will study but I first have to get VoLTE activated for my subscription (cannot arrange now these days)
    For VoLTE its easier, just go to dialer and enter
    *#*#86583#*#*
    then there should be a popup where it says "Carrier Check disabled". Then go to your settings and enable volte. :)