[11.0][OFFICIAL] LineageOS 18.1 for Oneplus 5 & 5T

Search This thread

frov

Senior Member
Dec 31, 2014
428
188
Tilburg
In general this ROM works really well. Many thanks to the developers!

I observed 2 issues (OnePlus 5T):
1) Random phone freezes (like once within 1-2 weeks) - hard shut off and reboot helps (I got no data restrictions)
2) Call-Issues
Looking back, I started having crashes in 5T/17.1 recently after some OTA updates and messing around with Magisk: that made me move to total clean install with this 18.1. That fixed those reboots: I could easily trigger these 17.1 crashes by toggling Wifi & 4G_Data: it would crash imm. and start the lineageos boot logo&sequence. After few secs it would be back again. So it did not go via the bootloader at all. Strange. I disliked this trigger happy situation and totally wiped the phone, updated TWRP and installed 18.1. That fixed it. So, also in this/your case, I would go for a fresh and clean install (incl format data). Takes me 1 hour, using SwiftBackup to get it all back up&running (incl registering with banking apps and such). But this is just me, what I would do.
 

hemanthDroids

Member
Jun 26, 2016
24
3
Call issues on OP5. The caller is able to hear dial sound but my phone doesn't ring.

@T1mb3
Trautamaki on telegram group was trying to fix this issue. I am not sure if you are same person. He tried to use Mi A2 IMS stack blobs but still the same issue persist. The logcat wasn't useful as there were no exceptions and it was as though call just came in.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Next update fixes the call audio issue, where volume would be stuck at max.
    If someone is interested in the fix: https://review.lineageos.org/c/LineageOS/android_device_oneplus_msm8998-common/+/309144.
    2
    Hi, I am on the latest LOS 18.1 dumpling.

    I would like to update the baseband and/or radio+modem component of the latest OnePlus 5T firmware contained in OnePlus5TOxygen_43_OTA_069_all_2010292144_76910d123e3940e5.zip

    My device has the firmware from OnePlus5TOxygen_43_OTA_054_all_2002242025_81ae0ff9d1c34a3f.zip.

    I cannot flash then entire OS (because I am unable to perform proper nandroid backup and restore in TWRP due to a bug in TWRP related to multiple users [work profile]), so need to do only the components radio+modem, using "fastboot flash".

    I have extracted the folders" "firmware-update" and "RADIO" from the most recent version OS zip but want to check which files need to be flashed and to what blocks, IOW:

    "fastboot flash modem NON-HLOS.bin"
    "fastboot flash bluetooth BTFM.bin"

    and

    "flashboot flash oem_stanvbk RADIO/static_nvbk.bin"

    Are these 3 correct? And can I safely just flash those 2 to update the baseband? Or is something else required?
    Why on earth will you not just follow the install instructions?
    1
    In general this ROM works really well. Many thanks to the developers!

    I observed 2 issues (OnePlus 5T):
    1) Random phone freezes (like once within 1-2 weeks) - hard shut off and reboot helps (I got no data restrictions)
    2) Call-Issues

    The second one (Call-Issues) is a real problem for me. I've activated VoLTE and VoWifi, my carrier supports both and the phone displays both from time to time as I receive or make calls. Especially when the HDVoice Icon is shown (within the caller app) I, as well as the other side, got sound problems: Sound stops randomly or only background sounds are audible, but no voice. It's not possible to chat properly this way and the issue is repeatable when it happens (e.g. hang up and call again -> same problem).
    Switching to e.g. a WhatsApp voice call works as it should. So I guess there is a problem somewhere within the HD-Voice or VoLTE/VoWifi code. I think (!) that the problem isn't there when not using HDVoice (e.g. because of low signal and thus switching to GSM-Calls (or so)).
    I've deactivated VoWifi and will test whether it helps/fixes the problem or not.
    1
    hi

    what are the known bugs?
    I read something in the second post, but it is from October 2020.

    thanks
    1
    Hi all,

    It looks like after each update, the SIM card used for data is reset to SIM1. Currently my SIM1 has no data plan whereas my SIM2 has an unlimited data plan. So SIM1 has data disabled and SIM2 has data enabled. After an update, it switches back to SIM1 data enabled and SIM2 data disabled.

    Obfix would be to physically switch cards, but thought I'll mention it here anyway.

    Thanks!
  • 13
    LineageOS 18.1 is now released for officially supported devices:
    Upgrade guide from official to official: https://wiki.lineageos.org/devices/cheeseburger/upgrade
    Upgrade guide from unofficial to official:
    - Wipe data
    - Install LineageOS & GAPPS

    Unsupported method:
    Migration tools by Codeworkx: https://androidfilehost.com/?w=files&flid=254680 (Unofficial->Official, Official->Unofficial)
    - Flash before updating
    - Read more: https://wiki.lineageos.org/signing_builds.html#test-keys-to-official-or-vice-versa

    NOTE: If you previously had any Google Apps add-on package installed on your device, you must install an updated package before the first boot of Android! If you did not have Google Apps installed, you must wipe the Data partition (or perform a factory reset) to install them.
    12
    2okPze5.png

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.

    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */

    HOW TO INSTALL LINEAGEOS:
    - Official instructions
    - In short: sideload in Lineage recovery (suggested) / flash in TWRP

    HOW TO UPDATE LINEAGEOS:
    - Download update from Updater app
    - Install update

    DOWNLOADS:
    LineageOS 17.1: Official Oneplus 5, Official Oneplus 5T
    Google Apps: MindTheGapps
    Recovery: Suggested: Lineage recovery for Oneplus 5, Oneplus 5T | Alternative: TWRP

    DEVELOPER RESOURCES
    LineageOS source code:
    - https://github.com/LineageOS
    Device tree:
    - android_device_oneplus_cheeseburger
    - android_device_oneplus_dumpling
    - android_device_oneplus_msm8998-common
    Kernel:
    - android_kernel_oneplus_msm8998

    Android version: Android 11
    Kernel version: Linux 4.4.y
    Required firmware: OxygenOS 10.0.1 (shipped with ROM, no need to install manually)

    Telegram group: https://t.me/los_op5
    12
    UPDATE:
    * Synced LineageOS sources
    * EAS is here to stay
    * Upstreamed kernel to 4.4.258
    * More detailed changelog

    Download for Oneplus 5 or Oneplus 5T.
    10
    UPDATE:
    * Synced LineageOS sources
    * Fix USB file transfer
    * Kernel: Merge tag 'LA.UM.9.2.r1-02500-SDMxx0.0' of https://source.codeaurora.org/quic/la/kernel/msm-4.4 into HEAD
    * Removed some 30 mb of unused camera blobs
    * Detailed changelog

    Download for Oneplus 5 or Oneplus 5T.
    9
    Today after my cheeseburger was connected to the charger for hours and did not charge at all I discovered this message "Plugged in, can't charge at the moment":View attachment 5278115

    I'm on 18.1 for a few days now. Never saw such a message before. I rebooted the phone whithout disconnecting the charger and now it Dash-charged nicely. That is why I think the cause of this strange behaviour is in the OS.
    Anyone else?

    Same here. Happened three times since I'm on 18.1. In all three occurences I plugged in the charger directly after I had a usb audio dac connected while using the usb audio player pro app. I use this dac and app regularly and normally the phone charges fine afterwards, so not sure if there is any relation.

    For the rest very happy with 18.1!
    Issue was caused by CAF change in kernel a while back.
    It should be fixed in next weekly.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone