[12.1][OFFICIAL] LineageOS 19 for Oneplus 5 & 5T

Search This thread

phosky0

New member
Mar 4, 2012
4
0
Hi everyone,

Updated my OP5T from LOS16.0 to LOS19.1 and now I cannot see fingerprint sensor settings in Settings > Security. If I touch the fingerprint sensor does nothing, and apps dont show me the fingerprint option to login. Is like the LOS is not recognizing my fingerprint sensor. Like my phone doesnt have one. It was working correctly in LOS 16.0 until I updated.

To do the update from 16.0 to 19.1, I first fastbooted the "lineage-19.1-20221025-recovery-dumpling" and then sideloaded from that recovery the "lineage-19.1-20221025-nightly-dumpling-signed" and the "MindTheGapps-12.1.0-arm64-20220605_112439". Before sideloded I do a factory reset, wiping data, cache and system (all 3 options in LOS recovery).

I also tried with the recovery "twrp-3.7.0_12-0-cheeseburger_dumpling" doing factory reset wipe and sideload same LOS19.1 and MindTheGapps files.

I also tried only the LOS19.1 and not MindTheGapps.

Everything else in LOS19.1 seems to work perfectly, so I feel I'm missing something, like something to activate or to install. Even Google Wallet allows me to add a card.

I also tried rooting it with "Magisk-v25.2", provide the LOS19.1 boot.img to the apk and then flash the patched boot.img with fastboot. And then activate Zygote so I can hide the financial apps to work properly.

Only thing missing is fingerprint sensor working. I use a lot the fingerprint, so in case I cant make it work I should go back to 16.0 as I can't find how to download LOS18.1 firmware from an official site to try. I found LOS18.1 from another site, but I'm not confident using them Is dont know how I can check they are valid (as not having the sha256) or check the signature. Is there any way to do that?

Thanks in advance.
 
Is it just me, or the option for button backlight control is gone ?
I usually turn the backlight off.
Here on my OnePlus 5 running 19.1 :
1667323978047.png


Here is my Samsung Galaxy a3 2017 running 17.1 (Rétroéclairage is french for backlight):
1667323996209.png


I wonder if it's related to the fact that I did a screen replacement...
 

mepherion

New member
Sep 11, 2016
3
1
Nexus 7 (2013)
Google Nexus 5
Is it just me, or the option for button backlight control is gone ?
I usually turn the backlight off.
Here on my OnePlus 5 running 19.1 :
View attachment 5749641

Here is my Samsung Galaxy a3 2017 running 17.1 (Rétroéclairage is french for backlight):
View attachment 5749643

I wonder if it's related to the fact that I did a screen replacement...

I never had the ability to turn off the button backlight on the OnePlus 5 LineageOS. I don't think it was ever added into LineageOS from stock OxygenOS
 
  • Like
Reactions: olimar7184

phosky0

New member
Mar 4, 2012
4
0
i used twrp to upgrade from 18 to 19, as per the thread, upgrading to the twrp suggested for that step (3.6.??) and my fingerprint sensor is normal

maybe reflash twrp (earlier version to 3.7) and simply flash again
Thanks @scruffy1 for the advice, as recommended I tried with the TWRP v3.6.2 and not working neither... I tried LOS17, LOS18 and LOS19, and fingerprint only working with LOS17, so I will stay in that version then. Don't know what have changed from LOS17 to LOS18 that my fingerprint stops appearing in Settings > Security section.

Happy to hear any other advice.
 

tobby88

Senior Member
Jul 4, 2012
244
64
Hanover
OnePlus 5
I bought my OP5 on the day it was released and I am using LOS since it's first official for the OP5. But I never experienced a missing fingerprint sensor after an update. But my recommendation would be: start from scratch. Try wiping all data, use a "fresh and clean" LOS. If that doesn't help either: start with the latest official Oxygen OS and then go over to LOS 19.
 

flurky

New member
Nov 4, 2022
1
0
OnePlus 5
Hey guys !

I just downloaded a newer version of twrp (3.6.2) to update mine (was 3.5.0), worked fine by installing it from twrp.
Then i upgraded my lineage from 18.1 to 19.1 (with mindthegapps) everything went well ! It booted and seems to work as excepted.

So i wanted to make a backup from twrp and i can't decrypt my pattern anymore ! (It was working when i upgraded to 3.6.2)

The good thing is the system is still working but i can't access my data in twrp it says "failed to decrypt user 0"

Do you know how i can fix this ? (i read a bit and it seems to be an issue between android 12 and twrp pattern thingy)

Thanks a lot ! :)

EDIT :

Nevermind, after more tests and researchs i found the issue, twrp 3.6.2 wans't allowing gesture pattern for android 12 to encrypt/decrypt data.

So i downloaded the 3.7 version (latest) and just fasboot flashed it (I disabled the security screenlock from my system before just to make sure)
 
Last edited:

djimel

New member
Nov 5, 2022
2
0
Bonjour
j'ai installé lineageos 19 sur mon oneplus 5T avec succès (lineage-19.1-20221025-nightly-dumpling-signed)

Quand je fais une mise à jour depuis le gestionnaire sur mon tel (lineage-19.1-20221115-nightly-dumpling-signed), il redémarre avec le logo en boucle !
Obligation de tout réinstaller

--------------------------------------------------------------------
Hello

i installed lineageos 19 on my oneplus 5T successfully (lineage-19.1-20221025-nightly-dumpling-signed)

When I do an update from the manager on my phone, (lineage-19.1-20221115-nightly-dumpling-signed), it restarts with the logo in a loop!
Obligation to reinstall everything

Thank's a lot
 

SirRGB

Senior Member
Jun 29, 2019
477
171
Google Nexus 5
Samsung Galaxy S5 Mini
Hi everyone,

Updated my OP5T from LOS16.0 to LOS19.1 and now I cannot see fingerprint sensor settings in Settings > Security. If I touch the fingerprint sensor does nothing, and apps dont show me the fingerprint option to login. Is like the LOS is not recognizing my fingerprint sensor. Like my phone doesnt have one. It was working correctly in LOS 16.0 until I updated.

To do the update from 16.0 to 19.1, I first fastbooted the "lineage-19.1-20221025-recovery-dumpling" and then sideloaded from that recovery the "lineage-19.1-20221025-nightly-dumpling-signed" and the "MindTheGapps-12.1.0-arm64-20220605_112439". Before sideloded I do a factory reset, wiping data, cache and system (all 3 options in LOS recovery).

I also tried with the recovery "twrp-3.7.0_12-0-cheeseburger_dumpling" doing factory reset wipe and sideload same LOS19.1 and MindTheGapps files.

I also tried only the LOS19.1 and not MindTheGapps.

Everything else in LOS19.1 seems to work perfectly, so I feel I'm missing something, like something to activate or to install. Even Google Wallet allows me to add a card.

I also tried rooting it with "Magisk-v25.2", provide the LOS19.1 boot.img to the apk and then flash the patched boot.img with fastboot. And then activate Zygote so I can hide the financial apps to work properly.

Only thing missing is fingerprint sensor working. I use a lot the fingerprint, so in case I cant make it work I should go back to 16.0 as I can't find how to download LOS18.1 firmware from an official site to try. I found LOS18.1 from another site, but I'm not confident using them Is dont know how I can check they are valid (as not having the sha256) or check the signature. Is there any way to do that?

Thanks in advance.
Did you flash the required oos 10 firmware?
 

js-xda

Senior Member
Aug 20, 2018
362
157
Samsung Galaxy S4
i9100
[...]

Nevermind, after more tests and researchs i found the issue, twrp 3.6.2 wans't allowing gesture pattern for android 12 to encrypt/decrypt data.

So i downloaded the 3.7 version (latest) and just fasboot flashed it (I disabled the security screenlock from my system before just to make sure)

Well, the inability of TRWP <3.7.0 to decrypt Android 12 encryption is not specific to pattern. Just in case someone wonders. And also, dependent on how it is implemented, not in all cases TWRP 3.7.0 solves it (e.g. LOS 19.1 for SM-T580/P580). Glad to hear nevertheless that it works for OP5(T)! :)
 
Last edited:

Chris576

Senior Member
May 2, 2015
87
8
Hello,

I have Wifi micro outages one or two times in a day and I think it is Lineage OS (wifi on my wife's phone is fine). Someone else have this problem ?
 

indiandragon

Senior Member
Mar 13, 2012
84
15
Greetings folks.

After updating to latest LineageOS 19-20221212 on my OnePlus 5, I couldn't get Magisk to work. After patching the boot.img and installation it still shows Installed N/A, Apps which dependent upon Magisk/Root are now telling neither is available.

I didn't happen before during any of the updates. I've tried uninstalling/installing Magisk several times now.

Is anyone else facing this?
 

Top Liked Posts