[13][UNOFFICIAL] Evolution X [23-12-2022]

Search This thread
proxy.png

Evolution X for the Sony Xperia XZ1 (Poplar)

DON'T FORGET TO JOIN OUR AWESOME TELEGRAM XZ1 GROUP! ;D (Extra modules, help, laughts)


512a7f06-d404-4653-9981-ae3e6166e939.png
Code:
*
* Your warranty is void. Or valid, probably?
*
* I am not responsible for bricked devices, dead SD cards, Ebolation X,
* thermonuclear war, or the current economic crisis caused by you following
* these directions. YOU are choosing to make these modifications, and if
* you point your finger at me for messing up your device, I will LMAO at you.
*/

Reach us on Twitter! @EvolutionXROM

SRQCjQJ.png



Just flash and check "The Evolver". We have tons of features combined together from different ROMs.​

CIrL2gb.png


* You tell me

DO NOT FLASH GAPPS, ALREADY INCLUDED

o2G52Ve.png



CLEAN FLASH :

Download the latest build

Reboot to recovery

Wipe System, Data, Cache, Dalvik

Format Data

Reboot to recovery again

Flash the latest build

Done!


DIRTY FLASH :

Download the latest build

Reboot to recovery

Flash the latest build

Wipe Cache/Dalvik Cache

Done!

proxy (1).png




XDA: DevDB Information
Evolution X, ROM for the Sony Xperia XZ1 (Poplar)

Contributors
derf elot, modpunk, Rooted_Ansh,
javiwz
Thanks to hsheemi for testing!

ROM OS Version:
Android 13
Based On: AOSP

Version Information
Status:
Stable
 

Attachments

  • 512a7f06-d404-4653-9981-ae3e6166e939.png
    512a7f06-d404-4653-9981-ae3e6166e939.png
    4.3 KB · Views: 184
Last edited:
NOTE: Some TWRP versions can't decrypt ROM YET. So you need a microSD to flash the ROM! Put the ROM on microSD, then flash it from there.


Download

TWRP (able to decrypt!)
: https://sourceforge.net/projects/yoshino/files/poplar/twrp/

28/11/2022
changelog:
  • First Release
  • Tons of love
  • Let's hope future releases will come
SINGLE SIM (G8341): https://mega.nz/file/gDERCaSZ#LwOCM7kAPozpdm1QiJJSjsYSUoXOHQDI3zWWqbB6wAY
DUAL SIM (G8342): https://mega.nz/file/gKVSlLZC#2SgRtMiwr4S2SrBeuEc1HPY3mo-ZePpSUVV5Q7T1hq0
SOV36 (JAPAN, KDDI etc): https://mega.nz/file/xHsmGRqS#7g_V7FZ-n3dbKwo3wMca7VjwT0psi4LINffeo4Awwk0

23/12/2022
changelog:
  • New Android version (13 R16)
  • EvoX 7.4
  • New security Patch
  • TONS of fixes on SystemUI, Keyguard, Smart Pixels etc
  • Tons of other things you can check on Evox Github
SINGLE SIM (G8341): https://mega.nz/file/wPsCRIIR#P_q9A1x1cpOPUJkHxcFJ19g61Xu1dHSvFyX3bImiZ2A
DUAL SIM (G8342): https://mega.nz/file/dClzma5Y#pEHoTk6BOMyNbhwCTL-I7GnsKh_spQl_AbyOyp1N_nw
SOV36 (JAPAN, KDDI etc): https://mega.nz/file/gLkSgRiT#AJ3MxvR3DTySdmtuZGQSn6fYyorZK6wyskzvTHOfqek

NOTES OF THIS SPECIFIC RELEASE: if you have weird freezes, go in system/build.prop, remove the line "debug.hwui.use_buffer_age", save, reboot, solved.
 
Last edited:

Lexх

Member
Nov 5, 2021
14
2
Dual sim version. Clean installed but there are some serious problems with network. Celuar keeps telling there is no service and wi-fi is like keep reconnecting all the time. It started during initial setup when I connected to wi-fi and it wouldn't proceed further because it probably kept losing connection. Then - entered email - error. Then proceeded to password - error, than on second try it proceeded further. If I open network setting it keeps reconnecting from celluar to wi-fi and again to celluar.

Wiped everything again and started all over again. On first try it wouldn't even see my sim even when I repluged it again. Then somehow I finished instalation and even celluar would work at some point. But then I rebooted and got same deal again with not working sim card. Had none of these problems on A13 PE (installing it back now and celluar just get working instantly during instalation).

You can see on screenshots that smth is definetly not right.
 

Attachments

  • Screenshot_20221128-203634_Pixel_Launcher.png
    Screenshot_20221128-203634_Pixel_Launcher.png
    1 MB · Views: 204
  • Screenshot_20221128-203642_Pixel_Launcher.png
    Screenshot_20221128-203642_Pixel_Launcher.png
    56.4 KB · Views: 209
Last edited:

perosmc

Member
Nov 24, 2016
42
20
Rom is great works super.

Two issues though. Only with camera. Scan doesn't work it has no option to capture anything. There other one is, resolution is only 8mp back camera instead of 19mp. It's even lesser than front camera has 13mp ready. Thanks!
 
  • Like
Reactions: Tux111

Victor7657

New member
Nov 28, 2022
2
1
Dual sim version. Clean installed but there are some serious problems with network. Celuar keeps telling there is no service and wi-fi is like keep reconnecting all the time. It started during initial setup when I connected to wi-fi and it wouldn't proceed further because it probably kept losing connection. Then - entered email - error. Then proceeded to password - error, than on second try it proceeded further. If I open network setting it keeps reconnecting from celluar to wi-fi and again to celluar.

Wiped everything again and started all over again. On first try it wouldn't even see my sim even when I repluged it again. Then somehow I finished instalation and even celluar would work at some point. But then I rebooted and got same deal again with not working sim card. Had none of these problems on A13 PE (installing it back now and celluar just get working instantly during instalation).

You can see on screenshots that smth is definetly not right.
I had the same issue. Now she's gone.
Flashed over the latest official firmware, using twrp 3.6.2 and wipe everything except internal storage, micro sd, otg. Wi-fi and sim cards work as they should.
 
  • Love
Reactions: Tux111
Dual sim version. Clean installed but there are some serious problems with network. Celuar keeps telling there is no service and wi-fi is like keep reconnecting all the time. It started during initial setup when I connected to wi-fi and it wouldn't proceed further because it probably kept losing connection. Then - entered email - error. Then proceeded to password - error, than on second try it proceeded further. If I open network setting it keeps reconnecting from celluar to wi-fi and again to celluar.

Wiped everything again and started all over again. On first try it wouldn't even see my sim even when I repluged it again. Then somehow I finished instalation and even celluar would work at some point. But then I rebooted and got same deal again with not working sim card. Had none of these problems on A13 PE (installing it back now and celluar just get working instantly during instalation).

You can see on screenshots that smth is definetly not right.
Clearly not a rom problem, more like a problem related to some stock files missing during flashing/switching roms.

Do as Victor suggested, reflash latest official firmware and retry. ROM working great.
 

Lexх

Member
Nov 5, 2021
14
2
I had the same issue. Now she's gone.
Flashed over the latest official firmware, using twrp 3.6.2 and wipe everything except internal storage, micro sd, otg. Wi-fi and sim cards work as they should.
Did as suggested and yup, now it works. I think my mistake was that I wiped internal storage (it does store some needed modem files I guess).
One weird thing though. On stock ROM latest TWRP actualy could decrypt internal storage, but after flashing it looks like it's not just unable to ask a password to decrypt, but it also doesn't see any encrypted files on internal storage, like there are no files at all. Before this flashin, it did see encrypted files. It's not really a problem, just my observation.

UPD: Turned out this installation broke Internal storage partition for TWRP and when I tried to wipe the system to get back to A12 (because for instance there in no Night Light option now, and no option to add buttons to quick settings, broken player notification behaviour. These options were in A12 EvoX. So, turns out even EvoX unable to make A13 any better) - I couldn't. So I had to Repair File System first (format Data to EXT2 first, and then format back to EXT4). Tho when booted in System there were no problems at all. That's why I didn't see any encrypted files in Internal storage.
 
Last edited:
  • Like
Reactions: Tux111

x2sJwETTXL

Senior Member
What a nice Christmas 🎁 thank you!!

After a clean flash from the SD card with latest TWRP and 24 hrs of running, I can confirm that this is another great ROM!
The battery doesn't fast charge and there is still ~10% difference between offline and online charge. But it last enough while in standby or for videocalls. Which is great for a daily use 4 yrs old phone.
Basic Lineage camera is okay for apps looking for default camera but Open Camera or other camera apps can also be used for better results.
WiFi and cellular signals are ok. Voice calls (only VoIP, as I'm not a phone service subscriber) ok both directions.
The Google's account backup emails saw
1671997857145.png

when enrolled. Don't kinda like it but don't really care 😁

Happy holidays and a new year full of joy and fullfilments for all of you involved!! and updates for ours XZ1 😍
 
What a nice Christmas 🎁 thank you!!

After a clean flash from the SD card with latest TWRP and 24 hrs of running, I can confirm that this is another great ROM!
The battery doesn't fast charge and there is still ~10% difference between offline and online charge. But it last enough while in standby or for videocalls. Which is great for a daily use 4 yrs old phone.
Basic Lineage camera is okay for apps looking for default camera but Open Camera or other camera apps can also be used for better results.
WiFi and cellular signals are ok. Voice calls (only VoIP, as I'm not a phone service subscriber) ok both directions.
The Google's account backup emails saw
View attachment 5793653
when enrolled. Don't kinda like it but don't really care 😁

Happy holidays and a new year full of joy and fullfilments for all of you involved!! and updates for ours XZ1 😍
Are you saying 2A charge doesnt work? (that is the max supproted by xz1 afaik)?

That signin name is a must if you want to use google photo infinite backup etc.

Happy holidays to you and to all ;)
 

x2sJwETTXL

Senior Member
Are you saying 2A charge doesnt work? (that is the max supproted by xz1 afaik)?

That signin name is a must if you want to use google photo infinite backup etc.

Happy holidays to you and to all ;)
Actually it's smart charge: will rapidly charge when the battery level is low ☺️
After authenticate in Samsung SmartThings app, received a confirmation email about my new Google Pixel 7 Pro ;)

Sometimes I have the impression the user interface lags, does not responding promptly. Anyone else observed this too?
 

raffyei8ht

Member
Jun 29, 2010
46
19
Actually it's smart charge: will rapidly charge when the battery level is low ☺️
After authenticate in Samsung SmartThings app, received a confirmation email about my new Google Pixel 7 Pro ;)

Sometimes I have the impression the user interface lags, does not responding promptly. Anyone else observed this too?
I have that lag too. That's why i return to pixel experience android 13.
 

x2sJwETTXL

Senior Member
Cannot rely on Google Wallet: no successful NFC payment to date, all tries failed due to a "fast movement" error. I had this problem on EvoX A12 too but was random, now at every attempt. By the contrary, on A11's PixelExperience the payments completed successfully from ~ 5cm of the reader 😄 so I don't think is a device issue.
 
I use to keep NFC off and turning on right before paying... Yesterday I've turned on when entering stores and 3 successful payments from 3 attempts with 3 different cards ;)
Oh nice.

Btw guys, right now evox team has some weird issues on some devices with pixel launcher, theyre infact temporarily switching to launcher3 (for freezing, touch issues etc). So, if youre experiencing problems, switch launcher or wait next release.
 

Top Liked Posts