[2013.04.11][2.3.1+] USB Host Diagnostics v1.3

Search This thread

jontp2

Senior Member
Feb 3, 2010
87
2
Quick question and apologies if I missed it but has anyone tried a galaxy s3 i9300 with stock rom?
Couldn't see it listed on the web site.
Thanks all.
 

Diazz72

Senior Member
Mar 11, 2012
488
630
Pula ( Croatia )
Hi guys i am having one little problem, i am having two tablets, one is some 7" prestigio and 2nd is AQPROX Cheesecake 10.1" XL, whit prestigio USB Disk and DLSR Camera are working, but on aqprox DSLR is not working but usb storage is working, any idea why?


Tnx ;)
 

mai77

Senior Member
Nov 16, 2011
1,430
580
nexus 7 flo 2013 works with dual plug thumbdrive but not with otg cable in CM10.:good:

in kk4.4.2 mice , kbd etc. work via otg cable.:good:
 

zxhwk

Senior Member
Mar 22, 2008
90
19
Fortlaurdale Florida
Sprint HtcOne running Viper Rom 5.7 works with most all OTG cables and thumb drives (EXCEPT one 16 GIG PNY NOT WORK )

M7-WLS PVT SHIP S-ON RH
HBOOT-1.56.0000
RADIO-1.0020.1108
OpenDSP-v32.120.274.0909
OS-4.06.651.4
eMMC-boot 2048
Jan 23 2014
 

dark_phoenix

Senior Member
Feb 6, 2013
300
42
developer bro, here is my device's screenshot. is my device capable of running usb otg mode ??? my phone is karbonn A15, 4.0.4 rooted + busybox installed...
 

Attachments

  • 1395848395982.jpg
    1395848395982.jpg
    48 KB · Views: 1,719
Last edited:

Ouzo

Senior Member
Nov 30, 2007
1,048
191
http://www.amazon.co.uk/CSL-Receive...tphone/dp/B00DZR3OKS/ref=cm_cr_pr_product_top

I just wanted to add my thanks to chainfire for this app :)

I have a Jiayu G4S which supports USB OTG but I encountered a problem when I tried to use a CSL Mini DVB-T dongle. It just didn't work like it does on my other devices. After running USB diagnostics, allowing it to attempt the fix and rebooting my phone, the TV dongle now works perfectly. Awesome! There's a link above if anybody wants to see what the dongle can do :)
 
Last edited:

DeanGibson

Senior Member
Apr 30, 2011
530
364
Seattle, WA
What did you do when you offered to "fix" the firmware?

On a rooted stock Nook HD+, I ran the app, and it offered to "fix" the problem in firmware. I said yes, and rebooted as recommended. When the Nook OS (Android 4.0.4) finds something it doesn't like (eg, a detected modification to /system or its children) when it boots, it reboots again. After eight reboots, it will reinstall the original factory image and do a total data wipe as well.

BEFORE IT GOT TO 8 REBOOTS, I stopped it and inserted a bootable microSD card (yes, most Nooks will boot from an SD card!!!) with CM11 on it, so I have access to the internal flash from CM11. Now, if I were to know what you did as part of your "fix", and can undo it via the booted CM11, that would be nice, and I can avoid the forced factory reset of the internal flash.

FYI: I use SuperSU as well in the rooted/stock Nook OS, and I have to do a little "dance" in /system/xbin anytime SuperSU updates the SU binary: I move the SU binary to a "hidden" folder and symbolic link to it. The Nook's modification test of /system and its children, ignores symbolic links and "hidden" folders (those with names beginning with a period). This is not a problem; it's just info for you.

Edit: OK, from looking at the timestamps of directories and files, it appears that you added the file /system/etc/permissions/android.hardware.usb.host.xml, especially since that filename is not in the factory load. It contains:
Code:
<permissions><feature name="android.hardware.usb.host" /></permissions>

I moved that file to my "hidden" folder, and symbolic linked to it. That fixes the native Nook OS booting/rebooting problem, and causes an app that previously complained about the lack of USB host mode, to not complain any more. USB host mode still does not work, but that's not your problem ....
 
Last edited:
  • Like
Reactions: winningbon8

findinghomer

Senior Member
Aug 13, 2013
242
13
USB Host Diagnostics determines your device's USB host capabilities. 92)

Hey chainfire, i have an lg g2 verizon model, the usb on the go recently stopped working. I used your app to help diagnose my problem. It seems to be detecting a device but it doesnt work (meenova card reader) My phone will also no longer connect to pc via usb, but does charge. I replaced the usb motherboard, thinking it's hardware, it wasn't. Result code from your app is .508334. Please let me know if you got any ideas of whats going on with my usb... i'm afraid of a possible brick in the future with no adb. Thanks !
 

Cindypooh

New member
Mar 20, 2018
1
1
No its my phone I was hacked on Jan. 23 and been fighting this ever since it has cost me over 20,000..00. An a lot more any information you can give me or devices I need to buy. I would appreciate it this is the 4th cell and they have wiped 4 computer's I am trying to fix.
Thank you
 
  • Like
Reactions: gerlad ssemaganda

agwal1991

New member
Dec 4, 2020
1
0
لدي مشكله في جوال جالكسي نوت 20 الترا محول رأس السماعه لا يدعم ماهو الحل
 

Top Liked Posts

  • There are no posts matching your filters.
  • 54
    USB Host Diagnostics determines your device's USB host capabilities.

    USB host is a very powerful feature of recent Android based smartphones and tablets, but on many firmwares (both stock and custom) the feature is somewhat broken.

    For example, at launch the Galaxy Nexus told all the apps and the Market that it supported USB host, but USB host did not actually work (this was fixed in the Android 4.0.2 update). This broke several apps.

    That is just one example of many. There are even cases where OEMs advertise USB host support, but the device does not support it at all. It appears as if USB host support isn't tested by Google or the OEMs when they push out new firmwares and devices at all.

    As we cannot depend on Google or the OEMs to correctly provide information regarding USB host support, and the Android framework will regularly lie about it to both the Market as well as Android apps, this application was created so you can test your device's USB host capabilities for yourself.

    If you allow it, the app will also submit your results to my website, so together we can create a complete database of devices and firmwares and their USB host support.

    This tool may also come in handy for those porting firmwares.

    Requirements:
    - Android 2.3.1 or newer
    - (Optional) Root
    - USB OTG cable (unless your device has a fullsize USB port)
    - USB memory stick, or another USB device to test the connection with

    The result database is available here:
    http://usbhost.chainfire.eu/

    The download can be found on Market here:
    http://pkg.to/eu.chainfire.usbhostdiagnostics

    It is also attached: DO NOT REDISTRIBUTE

    (v1.2: 9284)
    5
    Changelog for v1.3:

    - Detects some common issues with firmwares that can cause apps to be unable to use USB host, and if you are rooted, offers to (try to) fix the problem
    - Gives you a unique code that can be used to locate your result, if uploaded to server
    - Added option to follow me
    - Fixed some more crashes
    - Disabled rooted API for Jelly Bean and newer
    - API 14 and higher get Holo look now
    5
    What about Galaxy S5 Mini G800F with Lollipop 5.1.1?

    Testet my S5 mini with your app and an android endoscope camera.
    Despite Kernel and API claims "yes" the camera isn't recognized. See following screenshots. Is the OS the Problem?

    3a4d189b109fcbba0eeda4c12e9f4101.jpg


    9ff4eefdfa8757b4a50f997b4203c827.jpg


    Gesendet von meinem SM-G800F mit Tapatalk
    3
    galaxys2 GT-I9100 IML74K samsung/GT-I9100/GT-I9100:4.0.3/IML74K/XXLPB:user/release-keys Custom 2 Yes Yes Yes Yes Yes Yes Yes Yes Full

    USB Sticks fail to detect the only thing I can get working is your DSLR application.

    Try my StickMount app from the Market, it's actually for the G.Nexus. Your build just doesn't have automounting and such enabled... doesn't mean USB host isn't working :)
    2
    Try my StickMount app from the Market, it's actually for the G.Nexus. Your build just doesn't have automounting and such enabled... doesn't mean USB host isn't working :)

    Sweet that works!! Detects FAT32 SD cards but didnt detect NTFS USB stick.

    Is that something the CM9 devs can change to enable it by default?