• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[2019.5.1][Magisk] Systemless Xposed v89.3/v90.2-beta3 (SDK 21-27)

Search This thread

Aerosolx

Member
Nov 9, 2018
12
2
Does anything exist to unlink system volume from ring volume on Android 10? Running on a pixel 2xl. I've searched for hours. Hope this is the right place to ask. Thanks in advance.
 

mrjuniork

Forum Moderator
Staff member
Aug 29, 2015
1,171
1,930
OnePlus 5
OnePlus 6
  • Like
Reactions: b1k3rdude

xianonandroid

New member
Nov 5, 2015
2
0
Mine got stuck on bootloop its samsung galaxy note-4 with android 6.0 and i have twrp installed what should i do to revert it....???
Clearing cahe and dalvik\ART cache will help or not?
 
G

GuestD2581

Guest
In SM-G531F after flashing xposed framework (rovo89) magisk module it get stuck on boot is there any way to came out of it (other than flashing firmware again via odin)
 
Last edited:

junaidali15

Member
Jun 29, 2012
42
2
i have LG G5 830 20A .. stocked android and magisk installed.. whenever i am trying xposed its going into bootloop.. i tried installing from xposed app, twrp recovery, and also tried to install this version but still bootloop as soon as i uninstall it .. it works fine please help
 

januario-hh

New member
Feb 26, 2016
3
0
xprivacy

Xposed is a must have for me as I would never use my phone without XPrivacy, it has almost all of my privacy data and that of friends.
Same here! xprivacy is an absolute prerequisite for me; otherwise I would rather do without an android phone in my pocket.
I've spent hours searching for a way to have xprivacy on my Galaxy S5 DUOS (touchwiz!), which I eventually have upgraded to MM 6.01 (the latest stock ROM). I've managed to get root over Magisk (CF autoroot failed) but when it comes to XPOSED/xprivacy, I am stuck. Standard xposed installer 3.15 didn't do the trick and XposedInstaller_3.1.5-Magisk.apk either. Is it possible to get xposed (and then xprivacy!) via magisk at all? Is there a reliable way to get xposed onto stock Marshmallow without Magisk? Or is there a custom ROM supporting xposed for Samsung touchwiz devices?
 

januario-hh

New member
Feb 26, 2016
3
0
I have only 87.3 for SDK23 which means Marshmallow and it won't work for you.
Maybe someone else can share the Systemless Xposed for Samsung TouchWiz ROM 87.1/87.3 for SDK 22 or you might ask Topjohnwu if he still has the files.


Note: Even if you get the necessary files, installation is only compatible with Magisk v15.3 not later! This means you have to:

  1. Uninstall newest Magisk and flash v15.3 then install Magisk Manager v6.x (v7.x is not compatible) if not included.
  2. Choose Systemless Xposed for Samsung TouchWiz ROM 87.1/87.3 for SDK 22 inside of Magisk Manager in Modules to install.
  3. Reboot, will take some time as ART/Dalvik Cache need to be deleted and regenerated.
  4. Now you can flash latest version of Magisk, it will update everything and you will keep Xposed.


I just tested it on my S5 (G900F) and it seems it is possible to skip the steps before and just replace the files of the 87.3 version with the files of latest Module installer.

Hello MysteryIII, I have flashed Stock Marshmallow to my S5 (SM-G900FD) yesterday and have run into the same trouble. I'd like to follow your example and ask you politely if you could make available your copies of 87.3 for SDK23 and Magisk Manager v6.x?
 

MysteryIII

Senior Member
Nov 7, 2012
521
259
Hello MysteryIII, I have flashed Stock Marshmallow to my S5 (SM-G900FD) yesterday and have run into the same trouble. I'd like to follow your example and ask you politely if you could make available your copies of 87.3 for SDK23 and Magisk Manager v6.x?
Sorry for the late response. The last weeks I only looked into XDA for some stuff I wanted to check and didn't take time for anything else.



You can get older versions of Magisk here, straight from the source. I attached the 87.3 Xposed file here, the rest is up to you.


I gave up on the camera quality and went to AOSP/LOS based ROM and use Android Pie right now. In exchange for losing camera quality (especially in bad conditions) I got newer Android, smoother phone and rarely compatibility issues with Magisk or other features made for newer Android (excluding Camera API 2, that's impossible to get).
If you have any other device to make good pictures, I would recommend you to do the same and go for Android 10 as it has become stable and smooth on our phone.


Of course, you can ask me if you run into any problems, but all support I can give you now will be just what I remember and not really "active" support.

Good luck!
 

Attachments

  • xposed-v87.3-sdk23-topjohnwu.zip
    16.7 MB · Views: 177
Last edited:

januario-hh

New member
Feb 26, 2016
3
0
I gave up on the camera quality and went to AOSP/LOS based ROM and use Android Pie right now.

Thanks MysteryIII, in the meantime I've found out a suitable solution for my phone: Resurrection Remix, Magisk and edXposed - and most important! - xprivacyLUA running!

As to the camera, I haven't found out yet whether it's really worse than on Stock. But I'm happy to have dared the leap onto a CustomRom. Coming from KitKat it's amazing to have all the enhancements of Android Pie.
 

obamaforever

Member
May 26, 2014
46
3
Which files should I use to intall magisk and xposed on decent ultralite 5.0?

Have tested maybe all versions of ARM,SDK and dont know what to do anymore. I only get stucked in boot logo.

---------- Post added at 01:13 PM ---------- Previous post was at 01:13 PM ----------

Which files should I use to intall magisk and xposed on decent ultralite 5.0?

Have tested maybe all versions of ARM,SDK and dont know what to do anymore. I only get stucked in boot logo.

---------- Post added at 01:58 PM ---------- Previous post was at 01:13 PM ----------

Anybody have answer? Which files do I need, please when I update magisk with the new zip it gets stuck in logo.
Have S5 930f with decent ultra rom 5.0
 
Last edited:

obamaforever

Member
May 26, 2014
46
3
Hahah have been testing all of your solutions, nothing works.

S7 decent ultralite 5.0 android v. 6.0.1

I give up this **** with xposed

---------- Post added at 11:01 AM ---------- Previous post was at 11:01 AM ----------

Hahah have been testing all of your solutions, nothing works.

S7 decent ultralite 5.0 android v. 6.0.1

I give up this **** with xposed
 

Keule-Tm

Senior Member
Oct 3, 2016
383
146
Berlin
Samsung Galaxy S10
Hahah have been testing all of your solutions, nothing works.

S7 decent ultralite 5.0 android v. 6.0.1

I give up this **** with xposed
Maybe you should not use such an outdated ROM to begin with. You could easily go for eg Android Pie.
And if you do that, go for EdXposed. Xposed is heavily outdated as well, and there will be no more releases (not even for maintenance).
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1145
    Prerequisite
    Magisk is required to be installed on your device!

    Support Devices
    All Magisk compatible devices

    Downloads
    My Xposed zip is universal across all architectures and Android versions.
    https://androidfilehost.com/?fid=1395089523397956629

    Install Guide
    • Install the XposedInstaller in the attachments
    • Follow the instructions in the Magisk release thread to install Magisk on to your device
    • Install Xposed within Magisk Manager's Download Section, or download the zip and flash in custom recovery
    • For uninstallation, remove the Xposed Magisk Module within Magisk Manager

    Systemless Xposed does not pass SafetyNet!!!

    Credits
    @rovo89 for creating Xposed

    Source
    All binaries are downloaded and repacked from either places:
    Official build from rovo89
    I did not recompile/change anything how Xposed works, the behavior should be 100% identical to original sources, if you experience any Xposed issues, please directly report to the original threads.
    221
    Changelog

    • v87.0
      - Include fix from rovo89 to prevent bootloops in the latest security patch
      - Android 5.1 (SDK 22) was broken after one Magisk upgrade, it's now Magisk version independent
    • v86.6 (Downloaded 126324 times)
      - Update to support the new repo system of Magisk
      - Fixed incompatibility of suhide
    • v86.5 (Downloaded 174328 times)
      - Update for the new API of Magisk v4
      - NOTE: In order to update to Magisk v4, you are required to uninstall Magisk completely before upgrading. Please look at the main Magisk thread for more info
    • v86.4 (Downloaded 16246 times)
      - Revert the disable to not mount method for Android Pay
      - Fixed alt version script typo
    • v86.3
      - Use Magisk as dependancy
      - Support all the way back to Android 5.0
      - Android Pay :)
    • v86.2 (Downloaded 30608 times)
      - Script updates, more info here
    • v86.1 (Downloaded 10185 times)
      - Minor fixes, release notes here
    • v86.0
      - Massive update, see release notes here
    • v85.7 (Downloaded 15774 times)
      - Hot fix for some devices which breaks proper init commands
    • v85.6
      - Add SELinux label when executing script, should fix the few devices that aren't working
      - Massively improve the script to handle /cache to /data migration (the rare case when /data isn't available in TWRP)
      - Add Pixel C support (not-tested)
      - Combine all architecture into an All-In-One flash zip, users will only need to be aware of their own Android version
    • v85.5
      - Combine image mount and bind mount into one single script, should be more reliable and cleaner, hopefully it will fix ALL previous issues ;)
      - Add more logs to boot for debugging
      - Add SDK 22 support (un-tested!!)
    • v85.4
      - The mounting method should now support all devices :)
      - The installer will now merge Xposed Image if possible, so feel free to place your own files under /xposed
    • v85.3
      - Improved compatibility for some recoveries with incorrect libraries
      - Changed the method to mount xposed.img, hopefully will fix issues on some devices
    • v85.2
      - Separate Systemless Xposed from SuperSU. It now uses it's own image in data (/data/xposed.img)
      - Won't effect SuperSU anymore. Both are now working independently
      - Massively updated flash script, should be more reliable (e.g. Prefer sukernel in su.img over bundled binary)
      - (Derived from Wanam's update) Add Huawei theming engine support (details); Ensure the recompilation on Huawei EMUI Roms (details).
    • v85.1
      - Fixed flash script not installing files issue
    • v85.0
      - Initial release
    64
    Updates!
    I slightly updated the scripts to work with the changes in Magisk v16.4.
    As you know currently I have very limited free time, I can't test everything before I went back to the military camp, that's why the latest Magisk releases are always dubbed "beta", and fixes will always take a week before I can finally touch my computer.
    Hope you can understand :)
    63
    Systemless Xposed Update!!
    Here comes the long awaited Oreo Xposed thanks to rovo89. I'm glad to see Xposed running on my Pixel XL on the latest version of Android :)
    All previous versions are also updated to use the newer templates for better support on Magisk v15+.

    BTW, the fact that the source code for v90 are not out yet I can still release systemless versions again proven that I do not recompile the binaries, all binaries are repackaged from the original sources.
    So if you face any issues, do not complain here :)
    59
    Update!
    Update Oreo builds with official v90-beta3. Hey this time I'm super fast :)