[4.3+] [Root] App Ops for Root (Version 1.1)

Search This thread

djhuzi

Member
Aug 29, 2012
18
1
On my Huawei Honor 6 rooted, when i swipe till DEVICE, the app load 2 second and after crash. Why?

Inviato dal mio H60-L04 utilizzando Tapatalk
 

williamworlde

Member
Dec 9, 2012
5
0
This is a VERY GOOD app, but...

...it's almost powerless against the apps themselves. (Many apps crash as you take away certain privileges – that you would never imagine those apps would ever need!)

I've got a banking app on my Canadian D852 LG G3 (reverted to KK 4.4.2). So, I'm thinking – logically – why the heck would such an app "need" access to my contacts or camera or a slew of other seemingly non-relevant privileges?! Strip it of those accesses and it's useless!

I can't wait for Android M, which is supposed to allow you more control over apps' access rights.
Currently, it's either very sloppy, lazy coding by the devs, or their blatant intrusion into one's privacy!
 

supahaga

New member
Aug 21, 2015
2
0
suggestions

Great app. Installed v.2. From googleplay
These things would be good
-side movement category changed to: all, core, system, apps
Reason for this is that it's annoying to see same app listed again and again in different page

-search function to search from million apps, system stuff, etc

-blocking permissions to return false info, blank camera photo... contact, mic would "return" void, etc so it wouldn't cause app crash
 
Last edited:

hooliganx

Senior Member
May 22, 2008
2,685
2,483
Brasília
Oi @safet.me
like your app. and wanna know if have options to autostart and wake up.
or just keep awake option?
thanks.

n5twisted.08.18layeredslim.gapps.08.20
blu_spark.r14rd.2.26v4a.2.3.4twrp2.8.7.1
-----------------------------------------
 

aldra

New member
Dec 13, 2016
1
0
Hey guys,

I've installed it on my device (Xperia X Performance running Marshmallow), skimmed over this thread and didn't see anyone else with the same issue - the actual installer application requests root privileges and installs the AppOps application, but after rebooting the AppOps application does not request root access on run and hence cannot retrieve the privilege lists - it just sits there loading on each tab.

In short - the installer runs as root but the actual permission manager does not.

I'm using SuperSu and tried enabling root access to system applications by default, but it doesn't appear to have made a difference. As per another problem in the thread I also tried installing Busybox and then reinstalling AppOps, no luck.

I'll be checking out how it's been installed using the Busybox shell, but do you have any tips or have you heard of this issue before?

Thanks.
 

AndroidDeveloperLB

Senior Member
Mar 30, 2014
1,932
456
I have a few questions:
1. Is it still possible to install and run App Ops on new Android versions?
2. For those that the official (of Google) App Ops exist on their devices, I wonder: how is it called in other languages? Does it translate to something else? Or just stays "App Ops" ?
 
  • Like
Reactions: Bigdaddy123456

rfurb

Member
Mar 14, 2017
21
0
Excellent app. Running on Android 5.1.1 stock rooted with SuperSU in a Samsung SM-N910F phone. It would be even better if it had a search function and app names weren't repeated across tabs. Also, it is strange to see so little activity in this thread.
 

basile

Senior Member
Dec 8, 2003
70
5
is there an alternative app that allows to access ALL permissions in android 10 ?
 

WarriorMax

Senior Member
Jun 10, 2011
501
173
Is there any alternative app like this monitor the apps that keep device awake in Android 10 pls.?? Any lead would help.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 48
    As you may know, Google has remove App Ops on Android 4.4.2. This app helps you to bring it back

    Root device only for now

    What is App Ops
    App Ops is an activity, within the Settings app, that allows users to enable or disable operations on a per-app basis. These operations cover many common scenarios identified by permissions (e.g., read contacts, write contacts, access location), though it is not a pure one-to-one mapping.

    Operations blocked by App Ops are inaccessible by the affected app, though that may vary by device.

    Toggle-able permissions
    - Access notifications
    - Alarm volume
    - Audio focus
    - Bluetooth volume
    - Call phone
    - Camera
    - Draw on top
    - Keep awake
    - Location
    - Master volume
    - Media buttons
    - Media volume
    - Modify calendar
    - Modify call log
    - Modify clipboard
    - Modify contacts
    - Modify settings
    - Notification volume
    - Play audio
    - Post notification
    - Read calendar
    - Read call log
    - Read clipboard
    - Read contacts
    - Read SMS/MMS
    - Receive SMS/MMS
    - Record audio
    - Ring volume
    - Send SMS/MMS
    - Vibrate
    - Voice volume
    - Write SMS/MMS

    Download
    Google Play:
    Free: https://play.google.com/store/apps/details?id=droidmate.appopsinstaller
    Pro: https://play.google.com/store/apps/details?id=droidmate.appopsinstallerpro


    Any feedback, report, please leave your comment.

    Change logs
    Ver 1.1
    - Add uninstall AppOps
    - Add update AppOps
    - Fixed minor bugs
    - Refine permission list

    Ver 1.0
    - Initial release
    4
    That's how Google implemented App Ops. It was never meant to control all permissions.
    Just a small subset, unfortunately.
    Even CM's Privacy Guard doesn't control everything.

    To control more permissions, such as Internet access or storage access, I highly recommend the Advanced Permission Manager app: https://play.google.com/store/apps/details?id=com.gmail.heagoo.pmaster

    What it does is edit the apk itself and reinstall (non-system) apps with reduced permissions. You can see and remove any permission. There are 2 caveats:
    1. Certain apps crash if you remove certain permissions from them. So try and remove one or two permissions only first.
    2. You will no longer be prompted for updates in an app that you removed permissions since the app signature is changed.

    These caveats are not a fault of Advanced Permission Manager (just like the reduced permissions is not a fault of the various App Ops apps).

    Anyway I have had great success with both these apps, I even got the Pro version of Advanced Permission Manager.
    2
    As this changes this system files can we uninstall if we want? I have not installed it yet

    It only installs one apk in /system/priv-app/

    If you are rooted and have titanium backup or other toolbox you can easily uninstall it (titanium can uninstall system apps); second easiest option is to use ES File Explorer or other root file manager; other ways include adb shell commands (mount / rm), and finally another method that actually doesn't require root is via custom recovery that has a builtin file manager like twrp does... you would mount /system and delete the apk from /system/priv-app
    2
    How does this compare to the likes of XPrivacy. It appears this completely denies the permission which would cause certain apps to crash vs providing random false data.

    XPrivacy is way more powerful and allows you to revoke many more permissions, but App Ops although limited, works quite well. You cannot remove network access with it, but I removed location, contacts, vibrate, camera, from some apps, and none crashed so far. I've been using App Ops since it was introduced in Jelly Bean, and still do in KitKat.
    2
    for all people where the install option does not work:

    this is the app that is copied to /system/priv-app. dont know if its the same as the playtore apk.
    got this when playing around with "setenforce 0" and remount /system. but cant reproduce it.

    anyway, this works:
    https www dot dropbox dot com/s/tcw7vdvij84m2m7/AppOpsApp.apk?dl=0

    # copy apk:
    adb push AppOpsApp.apk /sdcard/.
    # get into adb shell
    adb shell
    # get root permissions
    su (confirm su on android)
    # remount /system
    busybox mount /system -o rw,remount
    # copy app
    cp /sdcard/AppOpsApp.apk /system/priv-app/AppOpsApp.apk
    # fix permissions
    chmod 777 /system/priv-app/AppOpsApp.apk
    # notify package manager for new app
    am broadcast -a android.intent.action.BOOT_COMPLETED

    if not, put a few "setenforce 0" between the commands ^^

    edit: i did a "setenforce 1" when finished, dont know if this is needed.
    and completely shut down and start the phone, because otherwise supersu may not work.
    hope the dev can use this infos for fixing the app.