Question 4G+ not showing / working

Search This thread

n70shan

Senior Member
Jan 10, 2012
643
115
Lahore
Hi all, sorry if its not relevant to post here but i need help. I am using poco m4 pro 4G (g96) version which is 4G+ supported phone but it doesn't show 4g+ when mobile data turned on. While my 3 years old redmi note 8 pro showing 4g+ in exact same place exact same network sim card etc. I have tried messing with Apns and engineering mode settings but everything seems fine. Any idea what's going on?
 
  • Like
Reactions: MezzaLuna

sBinnala

Member
Aug 6, 2020
37
10
Hi all, sorry if its not relevant to post here but i need help. I am using poco m4 pro 4G (g96) version which is 4G+ supported phone but it doesn't show 4g+ when mobile data turned on. While my 3 years old redmi note 8 pro showing 4g+ in exact same place exact same network sim card etc. I have tried messing with Apns and engineering mode settings but everything seems fine. Any idea what's going on?
Probably because
1. Both phones support different 4g+ bands, and your carrier might not support the bands which is compatible with the Poco M4 Pro.
2. Xiaomi probably forgot your carrier exists and maybe the phone's firmware lacks the necessary configurations required to support 4g+ with your carrier.
 

MezzaLuna

Senior Member
Feb 20, 2017
93
17
Hi. Happens the same to me.
Moto g52 uses 4g+ meanwhile poco m4 pro 4g doesn't. Same operator(ho mobile, Italian virtual of Vodafone) , some place. Nothing we can do but changing phone. By the way even without 4g+ it works fine so we have to live with that since there is no way to enable it.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi all, sorry if its not relevant to post here but i need help. I am using poco m4 pro 4G (g96) version which is 4G+ supported phone but it doesn't show 4g+ when mobile data turned on. While my 3 years old redmi note 8 pro showing 4g+ in exact same place exact same network sim card etc. I have tried messing with Apns and engineering mode settings but everything seems fine. Any idea what's going on?
    Probably because
    1. Both phones support different 4g+ bands, and your carrier might not support the bands which is compatible with the Poco M4 Pro.
    2. Xiaomi probably forgot your carrier exists and maybe the phone's firmware lacks the necessary configurations required to support 4g+ with your carrier.
    1
    Hi all, sorry if its not relevant to post here but i need help. I am using poco m4 pro 4G (g96) version which is 4G+ supported phone but it doesn't show 4g+ when mobile data turned on. While my 3 years old redmi note 8 pro showing 4g+ in exact same place exact same network sim card etc. I have tried messing with Apns and engineering mode settings but everything seems fine. Any idea what's going on?