(5.0.2+5.1) (UPDATED 08/27/2016) How to: Use Verizon Moto E (2015) on ANY GSM network

Did this method work for you?


  • Total voters
    172
Search This thread

arshull

Senior Member
Mar 26, 2009
200
287
Raleigh
The Sprint, Boost, and Virgin varients do not work on domestic GSM networks, don't ask me why, I don't know, something to do with Sprint being an awful company I'd presume! You can try to call them and get them to unlock domestic GSM but they probably won't do it for you...

OK, will try to exchange it then. I would like to spend the same amount, so I assume the Verizon variant would be the best choice? The at&t version can't be bootloader unlocked and the unlocked version is twice the price.
 

TheDerekHarper

Senior Member
Jun 21, 2015
137
33
OK, will try to exchange it then. I would like to spend the same amount, so I assume the Verizon variant would be the best choice? The at&t version can't be bootloader unlocked and the unlocked version is twice the price.

Yeah, the Verizon one is your best bet for now. Just don't expect much quality of service from at&t

Sent from my XT1528 using XDA Free mobile app
 

etronz

Member
Aug 3, 2015
7
0
Verizon's LTE phones are supposed to be unlocked by legal statute on the 700MHZ Upper C block (i.e. Band 13). How are they able to get away with this nonsense?
 

unmesh59

Senior Member
Nov 21, 2010
68
5
I'm beginning to lose connection with the AT&T network on occasion, both here in the San Jose area and on a recent trip to Los Angeles.

I wonder if it is because of the lack of band 17; if so, I might have to get the AT&T version of the phone even though I am beyond the return period for the Verizon one.

Update: I have a 3G microcell at home which my Samsung tells me is broadcasting on Band 5 which is supported by the Verizon Moto E but I lose connection at home too
 
Last edited:

juanjacinto

Member
Jun 5, 2012
35
1
The Sprint, Boost, and Virgin varients do not work on domestic GSM networks, don't ask me why, I don't know, something to do with Sprint being an awful company I'd presume! You can try to call them and get them to unlock domestic GSM but they probably won't do it for you...

But this variants should work outside USA on GSM network's? I am right?
 

Ace42

Senior Member
Jul 20, 2009
11,327
2,037
New York
Moto G Power
Motorola Edge
Verizon's LTE phones are supposed to be unlocked by legal statute on the 700MHZ Upper C block (i.e. Band 13). How are they able to get away with this nonsense?

Companies get away with a lot of things, this is nothing. I doubt anyone will punish Red for finding a loophole around the law on a random prepaid device.

I'm beginning to lose connection with the AT&T network on occasion, both here in the San Jose area and on a recent trip to Los Angeles.

Update: I have a 3G microcell at home which my Samsung tells me is broadcasting on Band 5 which is supported by the Verizon Moto E but I lose connection at home too
Same thing happens on T-Mobile even if LTE signal is strong. Switching to HSPA+ at least reduces the frequency it drops the signal.


Sent from my XT1528
 

razielpr

Senior Member
May 30, 2011
1,102
354
maunabo
im having problems with calls my moto e gets signal and 4glte but when i try to make a call it gives me a error saying no sim or sim error and sometimes it just says call ended any help?
 

etronz

Member
Aug 3, 2015
7
0
im having problems with calls my moto e gets signal and 4glte but when i try to make a call it gives me a error saying no sim or sim error and sometimes it just says call ended any help?

Sounds like your still in CDMA/LTE mode. At least, that's what happens on my XT1042 Moto G that's stuck in CDMA/LTE mode.
 

mrbears

Member
Jun 30, 2010
35
1
Woohoo! So like a few of you..I sim swap and got locked out again to the LTE/CDMA mode after swapping my sim. Setting the preferred mode again in adb, rebooting etc. did nothing. I also tried what someone else mentioned and setting them to stock values (8, null, null), which also didn't work.

Just figured out a different method of doing it without having to factory reset! One moment. I need to confirm it as I issued a few string of commands and now have to isolate which one did it, so someone else can replicate it.

EDIT: CONFIRMED! If you sim swapped and are now stuck on LTE/CDMA mode again simply issue the following command in adb shell

Code:
 pm clear com.android.providers.telephony

It should say "Success" after you issued the command.

Then reboot. This will essentially reset the values back to stock. After reboot issue the same commands found in OP to set the global preferred_network_mode back to 9 and reboot once more and you're back in service!

No need to factory reset.

Thank you so much for the above post. I was about to give up, but this method revived my phone and it is working perfectly on T-Mobile 4G LTE now. (Before, it would not take T-Mobile sim and keeps on go on to Emergency call only mode even after following OP's instruction) For the editors and OP, this info should be added to the first post for everyone to benefit in my opinion. I am glad I kept on looking. Thank you again dzap
 
  • Like
Reactions: hamplanet

razielpr

Senior Member
May 30, 2011
1,102
354
maunabo
Now my problem is worse I have the same issue even with LTE/CDMA I have 4GLTE but can't make calls I get no network available when I try to make calls the same with GSM I have 4GLTE but no calls anybody else has this issue or anyone can help me here any suggestions????


Sent from my iPhone using Tapatalk
 

dzap

Senior Member
Jan 6, 2008
166
34
Thank you so much for the above post. I was about to give up, but this method revived my phone and it is working perfectly on T-Mobile 4G LTE now. (Before, it would not take T-Mobile sim and keeps on go on to Emergency call only mode even after following OP's instruction) For the editors and OP, this info should be added to the first post for everyone to benefit in my opinion. I am glad I kept on looking. Thank you again dzap

You're very welcome. I know a lot of users like to sim swap, like me, and hate having to factory reset, so this works perfectly to avoid doing that. I do wish this would be added to the OP, but I don't think he's been around for a while. I'm sure would help a lot of users.

Anyway, glad to help!

---------- Post added at 07:57 PM ---------- Previous post was at 07:56 PM ----------

Now my problem is worse I have the same issue even with LTE/CDMA I have 4GLTE but can't make calls I get no network available when I try to make calls the same with GSM I have 4GLTE but no calls anybody else has this issue or anyone can help me here any suggestions????


Sent from my iPhone using Tapatalk
Who is your carrier?
 

razielpr

Senior Member
May 30, 2011
1,102
354
maunabo
You're very welcome. I know a lot of users like to sim swap, like me, and hate having to factory reset, so this works perfectly to avoid doing that. I do wish this would be added to the OP, but I don't think he's been around for a while. I'm sure would help a lot of users.



Anyway, glad to help!

---------- Post added at 07:57 PM ---------- Previous post was at 07:56 PM ----------



Who is your carrier?

Its a Verizon Moto E second gen since I did the unlock it only works now the 4GLTE with all carriers including Verizon but no calls and in status it says voice out of service and data in service I have followed the instructions closely.


Sent from my iPhone using Tapatalk
 

infinitycane

Member
Apr 23, 2013
23
0
I Can't get 3G , stuck on Edge. Even when I change the network settings to 3G it will give me edge. My carrier is MTN in Nigeria. somebody help me with solution or explanation please
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 82
    Please follow the updated directions provided by Bendrexl below before attempting any other methods.
    Here's a roundup of essential steps from this thread that worked for me...
    :good: HUGE THANKS to: Whoareyou, docna, caspar347, Dishe

    Prepare for battle:
    1. Ensure your Verizon Moto E 2015 is configured for USB debugging.
    2. Ensure your Verizon Moto E 2015 has airplane mode enabled.
    3. Ensure your PC/Mac has the Android SDK Platform Tools installed & accessible via your terminal / command line (added to $PATH var).
    4. Download 5.0.2 factory image: http://forum.xda-developers.com/moto-e-2015/general/stocks-firmwares-moto-e-t3113235/page2?nocache=1 (Thanks to caspar347!)
    5. Unzip / expand this .zip archive.
    6. Open a terminal session in the directory you just unzipped (containing NON-HLOS.bin & fsg.mbn)

    Execute!
    In your terminal with phone plugged in:
    1. $ adb reboot bootloader (your phone should now reboot into bootloader, wait for this)
    2. $ fastboot flash modem NON-HLOS.bin
    3. $ fastboot erase modemst1
    4. $ fastboot erase modemst2
    5. $ fastboot flash fsg fsg.mbn
    6. $ fastboot reboot (WAIT for phone to fully boot before continuing)
    7. $ adb shell (your command prompt will change to something like [email protected]_cdma:/ $. If you get kicked out of the session while entering the next commands, just type adb shell again and pick up where you left off)
    8. [email protected]_cdma:/ $ pm clear com.android.providers.telephony
    9. [email protected]_cdma:/ $ settings put global preferred_network_mode 9
    10. [email protected]_cdma:/ $ settings put global preferred_network_mode1 9
    11. [email protected]_cdma:/ $ settings put global preferred_network_mode2 9
    12. [email protected]_cdma:/ $ pm hide com.motorola.setupwizard.phoneservice (optional)
    13. [email protected]_cdma:/ $ exit (or just unplug & reboot phone)
    14. $ adb reboot (or just unplug & reboot phone)

    On the phone:
    1. Turn off Airplane mode
    2. Open Settings app > More > Cellular Networks
    3. Ensure Preferred network type selected is "4G (recommended)"
    4. Under Access Point Names, add the appropriate APNs for your specific carrier. (for Fi data, I only needed "h2g2").
    5. Disable all Verizon apps through settings or Titanium Backup. (Optional)

    CREDITS: Whoareyou, docna, caspar347, Dishe




    IF YOUR DEVICE IS RUNNING 5.1, FOLLOW THE GREEN INSTRUCTIONS!
    In order to attempt to get Verizon/Motorola to push out a new update with a fix for the removal of the option to switch to GSM, please sign this petition on Change.org and share it to anyone who you know will sign it! https://www.change.org/p/verizon-daniel-s-mead-stop-carrier-locking-motorola-moto-e-lte-xt1528
    Background Info: I work at Walmart in the Connection Center, and today I had a customer wanting to switch to Family Mobile from AT&T, so I showed them our Family Mobile devices and T-Mobile Devices, they didnt seem interested in them and said they wanted somthing that had Android 5.0 Lollipop, I thought about it for a minute and remembered that the Moto E (2015) shipped with Lollipop installed, I also knew that Verizon phones come unlocked, so I showed them the device and they decided to go with it, they bought the Family Mobile Micro SIM starter kit, and the Moto E, but once I powered it on, I couldn't get it to connect to Family Mobile, so I tried to access the advanced radio menu (*#*#4636#*#*) to no avail, but I eventually got it working, with full LTE support, heres how:

    POSSIBLE SIM SWAP WORKAROUND (Reported by wogeboy):
    Disable vzwAPNpermissions.apk and vzwAPNservice.apk using this program: http://bit.ly/1HHyVao
    I have not tested this as I dont have a VZW Moto E to test it on.


    5.1 Updated Instrcutions:
    With the SIM you want to use the the phone :
    1. Put the phone into Airplane mode (I'm not sure this is needed, but it doesn't hurt)
    2. Go to Settings -> About Phone and tap on "Build Number" until it says you are in Developer Mode (~10 times)
    3. Go back one menu, and right above About Phone there should now be an option for Developer Options, go into that.
    4. Turn on USB Debugging
    5. Connect the phone to your computer and type "adb shell" in your CMD window
    6. Run the following commands in adb shell :
    pm clear com.android.providers.telephony

    settings put global preferred_network_mode 9

    settings put global preferred_network_mode1 9

    settings put global preferred_network_mode2 9

    7. Turn off Airplane mode

    8. Power off and Restart the phone

    9. Open up the settings app, go to the mobile networks panel, select "Prefered Network Mode" and change it to "4G"

    10. Input the appropriate APNs for your specific carrier

    11. (Optional). Disable all Verizon apps through settings or Titanium Backup.
    CREDIT: docna
    .


    5.0.2 Instructions:
    1. Power on the device with the GSM SIM card in the SIM card slot
    2. Connect to WiFi and complete Google Sign-In
    3. Go to the Play Store and search "Network" download the first app (A white circle with a black phone in it) (This will allow us access to the advance radio options)
    4. Open the "Network" shortcut
    5. Change the radio mode from "CDMA/LTE PRL" to "GSM/LTE Auto"
    6. Open up the settings app, go to the mobile networks panel, select "Prefered Network Mode" and change it to "4G"
    7. Input the appropriate APNs for your specific carrier
    8 (Optional). Disable all Verizon apps through settings or Titanium Backup.
    The only thing I couldnt solve was how to remove the "SIM Card is not from Verizon Wireless" error in the status bar permanently, but thats just an annoyance, and causes no usability decrease.
    28
    Enabling GSM with 5.1!

    So I've managed to get GSM working on a factory reset 5.1!

    It's basically in the same state as after the 5.1 upgrade - it works fine with GSM, but swapping the SIM or doing a new factory reset stops it from working - but you can always just follow the same process again to get it going.

    You'll need "adb" and the Moto USB drivers installed on your computer. If you don't know what that is, Google is your friend.

    With the SIM you want to use the the phone :
    1. Put the phone into Airplane mode (I'm not sure this is needed, but it doesn't hurt)
    2. Go to Settings -> About Phone and tap on "Build Number" until it says you are in Developer Mode (~10 times)
    3. Go back one menu, and right above About Phone there should now be an option for Developer Options, go into that.
    4. Turn on USB Debugging
    5. Connect the phone to your computer and fire up "adb"
    6. Run the following commands in adb :
    settings put global preferred_network_mode 9
    settings put global preferred_network_mode1 9
    settings put global preferred_network_mode2 9
    7. Turn off Airplane mode
    8. Power off and Restart the phone

    After the restart, go to Settings -> More -> Cellular Networks and you should find the 4G/3G/2G options, with 4G selected (if not, select it).

    After doing this I'm successfully running with an AT&T SIM with no problems. According to the status bar, I'm getting '4G LTE', with about 6Mbps down and 10Mbps up according to Speedtest. Rebooting the phone works fine. Removing the SIM and putting in a different one resets it back to CDMA, but following the steps above again gets back to 4G.
    7
    For Android 5.1 (havent tried on 5.0.2)

    I hope this makes everyones life a little easier.
    Run the script and it will do the same as the steps in the OP. works like a charm.
    FYI... Changing sim cards or doing factory reset will change phone back to CDMA and will not pick up GSM anymore, you'll have to run the script again (see link below):
    https://drive.google.com/file/d/0B1zhN8KFcCjqYWl6UDR6clNWa2s/view?usp=sharing
    7
    Obviously can't use TIBU to disable apps because we don't have root... HOWEVER, I found that the debloater.exe works wonders for disabling apps (disable com.motorola.setupwizard.xxxxx to get rid of SIM NOT FROM VERIZON warning)

    UPDATE!!!

    DISABLED vzwAPNpermissions.apk & vzwAPNservice.apk and was able to change sims without having to redo the settings in ADB!! :D

    Also, the phone automatically found my APN settings on different SIM cards after doing this!!
    6
    Hey everyone. I just went through a lot of digging last night to get this phone working on Cricket and I wanted to share my findings since OP hasn't been updated with new info and it looks like a lot of y'all are trying to figure this out. I'm a longtime lurker but this is important enough for me to actually sign in and post.

    It's possible to get GSM working on the latest update (23.201.2 and probably any before or after as well). You just have to downgrade the modem. Instructions here:
    http://forum.xda-developers.com/showpost.php?p=62239017&postcount=486

    The link is dead and none of the indexed firmware dumps anywhere have the 5.0 files. Some searching revealed someone (probably in our situation since they're asking for the modem) asked if anyone had the files and someone dropped a link that still works:
    http://forum.xda-developers.com/moto-e-2015/general/stocks-firmwares-moto-e-t3113235/page2?nocache=1
    You only need the "NON-HLOS.bin" and "fsg.mbn" files but I recommend downloading the whole thing if you have space. You never know when you're gonna need a copy of your phone's stock firmware.

    Once you use the files from my second link and follow the instructions in the post on my first link, go back to the first post of this thread and follow the green instructions. Worked for me.

    And if you're gonna thank me, go thank the posts I linked too. I couldn't have done it without 'em.

    Edit for noob-proofing: The instructions on the first link are written for a weird version of fastboot. If you're using Google's SDK fastboot, just type "fastboot" instead of "mfastboot" where written in the instructions. If you have no idea what I'm talking about, go here: http://forum.xda-developers.com/showthread.php?t=2277112 - I personally recommend just using the "command line tools only" version at the bottom of the download page from Google unless you're gonna start developing android apps.

    And I didn't have to install any Moto drivers (the Google Nexus drivers worked fine) but YMMV.

    Edit 2: one more thing: to get rid of the "not a Verizon SIM" notification, while in normal booted state do
    adb shell
    pm hide com.motorola.setupwizard.phoneservice
    To re-enable just replace "hide" with "unhide" in the above instructions. A factory reset will probably restore this stuff too.
    And I found that here:
    http://forum.xda-developers.com/mot...sm-network-t3098953/post64209858#post64209858
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone