5.8.014s DEVELOPER ROM Release for LETV MAX 2 x820

Search This thread

UNDR8D83

Senior Member
Sep 19, 2010
125
20
Hi guys posting this forward from the Letv.re forum if anyone wants to have a play with some of the new features, its very very snappy and also seem to have sped up the fingerprint scanner along with some new stock apps

im not the creator of this so hold no liability if your phone burns your house down :laugh::laugh:

this will also install the latest TWRP but will be in chinese, all you need to do is go into SETTINGS, click on the GLOBE IMAGE and select ENGLISH

as always backup your current rom

INSTRUCTIONS

FLASH THROUGH TWRP!!

original link:

http://bbs.ydss.cn/thread-643193-1-1.html

Google drive link thanks to 'z953rr' from the letv.re forum:

https://drive.google.com/file/d/0B9vZ7uqCP8s7Q3RJaFZQT1FuMzQ/view?usp=sharing

GAPPS:

after installing the v2 installer run the app and follow prompts till finish, afterwards goto APKMirror.com and download the latest framwork and play store and install n everything work again

http://xiaomitips.com/download/google-installer-app/

Root(it claimed to install SuperSU but i had to install manually):

flash through TWRP https://www.androidfilehost.com/?fid=24545065934258533

Download latest xposed from the official xposed thread:

http://dl-xda.xposed.info/framework/sdk23/arm64/

AGAIN...this is not my work only posting if some keen people want to have a play with the 5.8 before its official release
 
Last edited:

jim262

Senior Member
Jul 17, 2015
1,182
254
Hi guys posting this forward from the Letv.re forum if anyone wants to have a play with some of the new features, its very very snappy and also seem to have sped up the fingerprint scanner along with some new stock apps

im not the creator of this so hold no liability if your phone burns your house down :laugh::laugh:

this will also install the latest TWRP but will be in chinese, all you need to do is go into SETTINGS, click on the GLOBE IMAGE and select ENGLISH

as always backup your current rom

INSTRUCTIONS

FLASH THROUGH TWRP!!

original link:

http://bbs.ydss.cn/thread-643193-1-1.html

Google drive link thanks to 'z953rr' from the letv.re forum:

https://drive.google.com/file/d/0B9vZ7uqCP8s7Q3RJaFZQT1FuMzQ/view?usp=sharing

GAPPS:

http://weigu.org/wp-content/uploads/2015/11/Letv-google-new.zip

Root(it claimed to install SuperSU but i had to install manually):

flash through TWRP https://www.androidfilehost.com/?fid=24545065934258533

Download latest xposed from the official xposed thread:

http://dl-xda.xposed.info/framework/sdk23/arm64/

AGAIN...this is not my work only posting if some keen people want to have a play with the 5.8 before its official release
Has anyone gotten google play to work? I like what I see. It does seem quicker, It recognizes 4G LTE for my carrier, and it supports wifi calling, but I can't get Google play to work.
 

UNDR8D83

Senior Member
Sep 19, 2010
125
20
that link i provided was the hassle free way of getting it to work instead of manually installing it with google installer apk

also check ur data connection management n make sure play store has permission to connect to data
 

Monk3y

Senior Member
Jan 6, 2011
975
215
London
I tried yesterday with clean install, with and without gapps, with and without Google installer nothing worked... Play store still not working
 

UNDR8D83

Senior Member
Sep 19, 2010
125
20
it worked for me on my first install, but in saying that since u mentioned it i did a full wipe and re-installed and now its not working for me either...very strange

try this for now http://xiaomitips.com/download/google-installer-app/

im charging my phone atm cos i full drained it playing around too much haha but i'll try too n come back with results
 

UNDR8D83

Senior Member
Sep 19, 2010
125
20
ok dont know how i managed it the first time but seems the link i provided is no go so i'll be ammending my first post but here is how i got gapps working now

install the google installer v2 apk n install as instructed, but this will still not get it working 100%

then goto the APKMirror.com and download the lastest framwork and play store apk's and install

BOOM! everything works again
 

jim262

Senior Member
Jul 17, 2015
1,182
254
Well I have finally got this firmware working. The gapps are working and I rooted it and deleted all the Chinese bloat. It runs real smooth and fast. Since it was a Chinese firmware/ROM and is technically not meant for US, but does support band 12, it has Wi Fi calling. If it was released here, T-MOBILE would probably have stopped that. Nice feature on an awesome phone. The only thing lacking is sd card support.
 
Last edited:

EverPing

Senior Member
Jul 9, 2011
62
31
Tokyo
Question regarding Playstore issue:

These are the packages that Xiaomi installer V2 installer provides:

 Xiaomitips: package version list
Google Services Framework 6.0-2302772
Google Account Manager 6.0-2302772
Google Play Services 8.3.01 (2385995-440)
Google Calendar Sync ** 5.2.3-99827563-release
Google Contacts Sync 6.0-2302772
Google Play Store 5.10.30

Which package versions (and dpi) are working for you ?

Thanks for the reply.
 
Last edited:

jim262

Senior Member
Jul 17, 2015
1,182
254
Question regarding Playstore issue:

These are the packages that Xiaomi installer V2 installer provides:

 Xiaomitips: package version list
Google Services Framework 6.0-2302772
Google Account Manager 6.0-2302772
Google Play Services 8.3.01 (2385995-440)
Google Calendar Sync ** 5.2.3-99827563-release
Google Contacts Sync 6.0-2302772
Google Play Store 5.10.30

Which package versions (and dpi) are working for you ?

Thanks for the reply.
It's very easy. First install your firmware, then through fastboot, install twrp recovery and flash SuperSU to root. After you reboot, go back into twrp recovery and flash the google apps file. Here's a link to a YouTube video on how to do it. They also do root in the video, but you do not need to do their way. https://youtu.be/OuIjlX5vSXs
 

EverPing

Senior Member
Jul 9, 2011
62
31
Tokyo
It's very easy. First install your firmware, then through fastboot, install twrp recovery and flash SuperSU to root. After you reboot, go back into twrp recovery and flash the google apps file. Here's a link to a YouTube video on how to do it. They also do root in the video, but you do not need to do their way. https://youtu.be/OuIjlX5vSXs
Thanks, looks like I just bricked it ;-(. I keep you posted.

Edit: (30 minutes later): Its back !! Wow thats scary !! No LED light nothing. Battery was at 90% when this happened.
 
Last edited:

jim262

Senior Member
Jul 17, 2015
1,182
254
Thanks, looks like I just bricked it ;-(. I keep you posted.
How did you brick it? Did you do clean install? This method should not cause brick, bootloop at the very worst, but not brick. Place it on the charger and see if it will accept a charge. If the LED lights up, it is taking on a charge, let it take on charge and try restarting it in a couple hours.
 

EverPing

Senior Member
Jul 9, 2011
62
31
Tokyo
How did you brick it? Did you do clean install? This method should not cause brick, bootloop at the very worst, but not brick. Place it on the charger and see if it will accept a charge. If the LED lights up, it is taking on a charge, let it take on charge and try restarting it in a couple hours.
After replacing recovery rom I got screen as shown in other thread
http://forum.xda-developers.com/le-max-2/development/twrp-twrp-3-0-2-0-testing-help-gemini-t3396582

Left side of screen shows o.k, other half shows strange.
Than not going into recovery or fastboot anymore (bootloop).
Turning it off.

Power light is not coming on also during "charging".
No LED light. Nothing. Battery was at 90% when this happened. Recovery rom is gone.
 
Last edited:

MadMicro

Senior Member
Feb 28, 2015
82
19
After replacing recovery rom I got screen as shown in other thread
http://forum.xda-developers.com/le-max-2/development/twrp-twrp-3-0-2-0-testing-help-gemini-t3396582

Left side of screen shows o.k, other half shows strange.
Than not going into recovery or fastboot anymore (bootloop).
Turning it off.

Power light is not coming on also during "charging".
I guess this one is gone. ;-(

Edit (30 min later): Its back !! Wow thats scary !! No LED light nothing. Battery was at 90% when this happened. Recovery rom is gone.
i had a similar expeience. I didnt like way it was behaving with the new ROM so I decided to apply my most recent TWRP backup. After reboot its bricked. No led then blue led etc. I can still enter fastboot and commands complete but it will not boot TWRP and go to blue led. I have asked for help on another thread but no replies yet.
All help and suggestions please
 
  • Like
Reactions: EverPing

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Hi guys posting this forward from the Letv.re forum if anyone wants to have a play with some of the new features, its very very snappy and also seem to have sped up the fingerprint scanner along with some new stock apps

    im not the creator of this so hold no liability if your phone burns your house down :laugh::laugh:

    this will also install the latest TWRP but will be in chinese, all you need to do is go into SETTINGS, click on the GLOBE IMAGE and select ENGLISH

    as always backup your current rom

    INSTRUCTIONS

    FLASH THROUGH TWRP!!

    original link:

    http://bbs.ydss.cn/thread-643193-1-1.html

    Google drive link thanks to 'z953rr' from the letv.re forum:

    https://drive.google.com/file/d/0B9vZ7uqCP8s7Q3RJaFZQT1FuMzQ/view?usp=sharing

    GAPPS:

    after installing the v2 installer run the app and follow prompts till finish, afterwards goto APKMirror.com and download the latest framwork and play store and install n everything work again

    http://xiaomitips.com/download/google-installer-app/

    Root(it claimed to install SuperSU but i had to install manually):

    flash through TWRP https://www.androidfilehost.com/?fid=24545065934258533

    Download latest xposed from the official xposed thread:

    http://dl-xda.xposed.info/framework/sdk23/arm64/

    AGAIN...this is not my work only posting if some keen people want to have a play with the 5.8 before its official release
    2
    I am not an expert and don't know how to dump a ROM.
    The easiest way to do it is download twrp for your device onto a PC. Download ADB as well and install it on your PC. Place twrp in the ADB directory. Also download drivers for your device and install these also on your PC. These will help insure your device is visible to the PC. Attach the USB cable to your PC and open command prompt on PC. At the prompt navigate to your ADB directory. At the prompt, type ADB devices. It will then return information if your device is discovered. Now reboot your phone into fast boot mode. Once in fast boot mode, go to PC with the DOS prompt window still open, and type at the c://ADB prompt, Fastboot boot twrp.img , or whatever name twrp.img file is. This will bring up twrp recovery, but not install it. You can then make a backup of your device by selecting backup option.
    1
    After replacing recovery rom I got screen as shown in other thread
    http://forum.xda-developers.com/le-max-2/development/twrp-twrp-3-0-2-0-testing-help-gemini-t3396582

    Left side of screen shows o.k, other half shows strange.
    Than not going into recovery or fastboot anymore (bootloop).
    Turning it off.

    Power light is not coming on also during "charging".
    I guess this one is gone. ;-(

    Edit (30 min later): Its back !! Wow thats scary !! No LED light nothing. Battery was at 90% when this happened. Recovery rom is gone.
    i had a similar expeience. I didnt like way it was behaving with the new ROM so I decided to apply my most recent TWRP backup. After reboot its bricked. No led then blue led etc. I can still enter fastboot and commands complete but it will not boot TWRP and go to blue led. I have asked for help on another thread but no replies yet.
    All help and suggestions please
    1
    Thanks Madmicro , that's exactly same here. The rom itself still boots up now.
    FYI, I am on the EUI 5.8 developers rom
    1
    ok, mine is back !!

    I extracted rec.img from ydss.cn 's rom and flashed it back via adb.