[6.0-12.0][Magisk]Dolby Digital Plus[upd.20211005]

Search This thread


Feb 16, 2021

App is crashing everytime, what kind of problem is it? A11 crdroid


Senior Member
Jul 9, 2016
Guwahati Assam
Any special steps for installation?, I've seen Dolby modules that work only with Magisk Delta on A13, but besides that nothing.
Which rom you are using bro. I am using ancient os mi11 x. And installation is simple you just install the module and reboot and don't use any other sound module. Like audio modification sony sound. And if it's still not working. Then after instll. Go to app info setting and clear cache then don't allow nearby and file permissions. After that add a Dolby widget in home screen to home screen and click on power icon (if it says remote service stopped).

Still not working try changing the selenux in terminal or termux

Use this line- su setenforce 0

Hit thanks 👍 if it's working


  • Screenshot_20230407-063057_Ancient_Home.png
    394.9 KB · Views: 83
Last edited:
  • Like
Reactions: SirRhor


Senior Member
Feb 19, 2015
FCs with Magisk 26.1, here is the log
Generated by AppErrorsTracking
Project Url: https://github.com/KitsunePie/AppErrorsTracking
[Device Brand]: samsung
[Device Model]: SM-N950F
[Android Version]: 9
[Android API Level]: 28
[Process ID]: 15457
[CPU ABI]: none
[Package Name]: com.dolby.ds1appUI
[Version Name]: 1.0
[Version Code]: 0
[Error Type]: JVM
[Stack Trace]:
java.lang.NullPointerException: Attempt to invoke virtual method 'void android.dolby.ds.Ds.saveDsStateAndSettings()' on a null object reference
at android.os.Parcel.createException(Parcel.java:1972)
at android.os.Parcel.readException(Parcel.java:1934)
at android.os.Parcel.readException(Parcel.java:1884)
at android.dolby.IDs$Stub$Proxy.unregisterCallback(IDs.java:1114)
at android.dolby.DsClient.unBindDsService(DsClient.java:1854)
at com.dolby.ds1appUI.MainActivity.unbindFromDsApi(MainActivity.java:356)
at com.dolby.ds1appUI.MainActivity.onDsApiError(MainActivity.java:777)
at com.dolby.ds1appUI.MainActivity.onClientConnected(MainActivity.java:870)
at android.dolby.DsClient$1.onServiceConnected(DsClient.java:1899)
at android.app.LoadedApk$ServiceDispatcher.doConnected(LoadedApk.java:1839)
at android.app.LoadedApk$ServiceDispatcher$RunConnection.run(LoadedApk.java:1871)
at android.os.Handler.handleCallback(Handler.java:873)
at android.os.Handler.dispatchMessage(Handler.java:99)
at android.os.Looper.loop(Looper.java:214)
at android.app.ActivityThread.main(ActivityThread.java:7073)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:494)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:965)
Feb 27, 2021
Xiaomi Redmi 4 Prime
Here is letest one work with android 13 😍👍
Generated by AppErrorsTrackin
[Device Brand]: Xiaomi
[Device Model]: Redmi K20 Pro
[Display]: lineage_raphael-userdebug 13 TQ2A.230405.003.E1 eng.pengle.20230423.112534 release-keys
[Android Version]: 13
[Android API Level]: 33
[System Locale]: zh_CN_#Hans
[Process ID]: 13260
[CPU ABI]: none
[Package Name]: com.dolby
[Version Name]: 4.4.2-1
[Version Code]: 19
[Error Type]: JVM
[Crash Time]: 2023-05-07T12:34:32.706
[Stack Trace]:
java.lang.RuntimeException: Unable to stop service com.dolby.DsService@81957b4: java.lang.NullPointerException: Attempt to invoke virtual method 'void android.dolby.ds.Ds.saveDsStateAndSettings()' on a null object reference
at android.app.ActivityThread.handleStopService(ActivityThread.java:4702)
at android.app.ActivityThread.-$$Nest$mhandleStopService(Unknown Source:0)
at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2181)
at android.os.Handler.dispatchMessage(Handler.java:106)
at android.os.Looper.loopOnce(Looper.java:201)
at android.os.Looper.loop(Looper.java:288)
at android.app.ActivityThread.main(ActivityThread.java:7884)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:548)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:936)
Caused by: java.lang.NullPointerException: Attempt to invoke virtual method 'void android.dolby.ds.Ds.saveDsStateAndSettings()' on a null object reference
at com.dolby.DsService.onDestroy(DsService.java:775)
at android.app.ActivityThread.handleStopService(ActivityThread.java:4682)
... 9 more

Top Liked Posts