[6.0] Factory Image Now Live

Search This thread

maortrol

Senior Member
Aug 16, 2008
247
130
Málaga
I tried ... after all (Android M, TWRP Recovery), I installed SuperSU from ZIP (in TWRP) ... and system didn't boot any more ...
Any idea how to get root?

You need a root-compatible kernel... stock kernel doesn't support root, so flashing SuperSU.zip over stock kernel causes bootloops.

You should flash first a custom kernel (for example ElementalX), then flash SuperSu.zip, and you are done.

;)
 
  • Like
Reactions: tuncan

Molitro

Senior Member
Oct 19, 2010
741
165
Enable Developer options in Settings, then in Developer options scroll down to Select USB Configuration, and choose MTP (even if it's already selected). That fixed it for me.
Nice.
Thank you.

I guess even with it coming in mtp by default, it actually is in charge only or some other mode.

Swiftkey'd from my Nexus 5
 

eberaldo

Member
Nov 11, 2011
24
5
Does anyone of you have the newest camera app with the interface that was shown in the nexus event? i still have the old camera app. also, it's a bummer, that now on tap only works with english set as system language.
 

thesebastian

Senior Member
Sep 25, 2012
1,874
444
Barcelona
I'm happy with this new update. So far it seems to be an improvement over 5.1.1 (not like the update from 4.4.4 to 5.X).

Performance overall is a bit better.

Sent from my Nexus 5
 
Last edited:

xengon

New member
Nov 22, 2014
3
0
coming from a fresh install, having two problems, first, while i am connected to the internet through WiFi or 3g the OS doesn't recognize it and the exclamation mark is up there, and it prevent from auto connecting to WiFi.
second, when fast typing the keyboard doesn't sound on every single tap, i mean when i tap a letter on keyboard twice immediately the second tap doesn't sound, is there anyone with these weird problems??

Sent from my Nexus 5 using Tapatalk
 

Top Liked Posts

  • There are no posts matching your filters.
  • 16
    This is how to ROOT : (Tried same for two devices. it works perfect for me)

    1) use flash-all.bat file (do the thing).
    (you are gonna lose your files etc.)

    2) wait till it reboots itself to the welcome screen. (may take 5 or 20 minutes)
    3) power off and go to the fastboot screen again (power + volume down)
    4) flash StephanMc_Kernel (it's basicly the rootable version of stock kernel. no tweaks, no custom stuff.)
    (command: fastboot flash boot boot.img )
    link to the zip(extract it): http://www.mediafire.com/download/b69gq3wnanmmd4g/StephanMc_Kernel-hammerhead-20150904.zip

    5)flash twrp
    (command: fastboot flash recovery twrp.img )
    link: https://dl.twrp.me/hammerhead

    6) use volume down button in fastboot to browse, and use power button to switch to the recovery.

    7)push beta supersu to your phone (usb cable is enough tho.)
    supersu link: https://download.chainfire.eu/740/SuperSU/BETA-SuperSU-v2.49.zip

    8) flash supersu (Install button on twrp)

    9) profit
    8
    Just an FYI... The factory images are now live!
    xctyzr.png

    Download Link
    https://dl.google.com/dl/android/aosp/hammerhead-mra58k-factory-52364034.tgz
    It should be noted that there is some permission related issues if you remove the -w flag from the flashall.bat file. For now you are better off running the upgrade without modification.

    Rooting Notes:
    See this post
    7
    I wrote a guide for those who wanna manually flash Android 6.0 Marshmallow to their Nexus 5 if they cannot wait for the OTA
    - https://app.box.com/s/503xightidtkcj8i0a4hht4t0k7zm0nk
    5
    Kinda smells like lazy noob in here. Huh, strange.

    Sent from my Nexus 5 using Tapatalk
    4
    Getting some errors when trying to flash it from a stock 5.1.1 LMY48M

    SCR001.jpg


    Anyone can assist? :c

    Guys, my personal belief regarding this issue is that it's RAM related (on your PC, not the Nexus 5). Since Lollipop 5.0, the system.img size increased significantly. I've seen this issue rear its ugly head on nearly every fastboot flash I've had since 5.0 hit a year ago. The easiest solution is to unpack all the .img files from image-hammerhead-mra58k.zip flash manually instead of using flashall.bat:
    fastboot flash bootloader bootloader-hammerhead-hhz12k.img
    fastboot reboot-bootloader
    fastboot flash radio radio-hammerhead-m8974a-2.0.50.2.27.img
    fastboot reboot-bootloader
    fastboot erase cache
    fastboot erase userdata
    fastboot erase system
    fastboot flash recovery recovery.img
    fastboot flash boot boot.img
    fastboot -S 512M flash system system.img
    fastboot flash userdata userdata.img
    fastboot reboot-bootloader
    go into stock recovery, perform factory reset, reboot

    In regards to updating the fastboot.exe utility, here's how I do it, download the sdk zip file from here:
    https://developer.android.com/sdk/index.html#top
    go to "other download options" then download the .zip file. Unpack the .zip file, then run SDK Manager.exe and uncheck ALL packages except for "platform-tools". Go into the platform-tools folder, and there will be the latest fastboot.exe.

    Hopefully this helps
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone