• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

8227L YT9213AJ head unit Radio app won't start

Search This thread

spins49

New member
Oct 25, 2021
3
0
Hi guys, I'd love to know why my Radio app for this head unit can no longer open. I tried force stopping the app, I tried hard reset via factory settings, I tried pulling it out and putting it back in for a power reset (doesn't seem to do anything), tried cleaning cache and data, tried clean up apps, but the stock radio app just keeps saying "Could not open Radio"

I've looked for other fm radio app APKs to install with no luck, they are either incompatible or just streaming online radio apps which doesn't help, nor can I find the replacement radio apk in order to uninstall and reinstall to see if that helps solve the problem.

Anyone else run into this issue? Can I somehow pull the APK of the existing radio app to save, and then uninstall and reinstall it? Any and all help is appreciated - googling is not providing me with anything for this unit thus far which means I'm stuck with a very decent deck for the price, that no longer has a functioning radio (which was working great before it suddenly stopped opening after I was showing off and literally saying how great the radio works!).

Head unit details, for reference, are:

Android: YT9213AJ_00011_V001_20200613
Android OS: Android 9.1 XY AUTO: 3.4 (8227L)
CAN Pro: 3.1 (8227L)
DDR: 1G FLASH: 16G
CPU: A7 1.3GHz x 4
display: 1024x600
MCU: 3.1 (8227L)
Kernel Version: 3.18.22
Build number: android-trunk-m0.AC8227L-V1.0
Custom build version: android-trunk-m0.AC8227L-V1.0
 

spins49

New member
Oct 25, 2021
3
0
Ok, so took a shot after posting this, and funny enough it worked to just do a factory reset via the android settings, and Radio app worked finally! Had to reinstall apps and accounts, but who cares, radio works again!

Now, anyone have any useful info on how to upgrade this unit now? The Android Upgrade and MCU Upgrade buttons are greyed out on this unit, and the various mods and updates I've found here won't do anything (zip files say unrecognized in the file folder and the system is not recognizing an upgrade file was loaded like I've seen others very easily be able to accomplish.