A Temp root solution for Nokia 5.1 Plus

Search This thread

~R1

Member
Mar 17, 2017
12
1
La Plata
If you (by chance) are able to write a single byte to system or boot partition on this dm-Verity enabled device, it won't boot and will need service center.

That changes if bootloader can be unlocked of course.

What happen then if you disable Dm-Verity and patch boot.img and then proceeded to flash it?
 

nachin_007

New member
Dec 26, 2019
1
1
Hi over here. Greetings and good New Year's Eve wishes from Argentina.

It turns up that someone has bothered to make a tutorial video on YouTube of the process and, as he mentioned the source, that's how I found this thread.

I've performed the steps and while it seems to have worked (the Root Checker app says the device has root access and the FontChanger app, which didn't work before the procedure, now works), some other apps such Substratum or better font-changing apps like iFont or HiFont, doesn't work. And yes: I did installed the Magisk module for each of them.

Is this due to the root is not at system partitions level? Or am I doing something wrong?
 
  • Like
Reactions: Ilgazc

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    2019fee24111-d4bd-42ac-80c5-11b877bfdf03.png

    This method is based on Amazing Temp Root for MediaTek ARMv8 by diplomatic

    Clever work that give MTK-soc devices a bootless root ( Root remains until reboot ). And lucky enough it works on our Nokia 5.1 Plus

    So to begin :
    -Grab diplomatic lastest mtk-su.zip in Amazing Temp Root for MediaTek ARMv8

    - Follow instructions from Bootless root with Magisk and MTK-SU
    #You can install Magisk Manager from the magisk 18.1 package, or any version below 7.1.2. Lastest version of MM doesn't work.

    And your device should have root permission.
    3
    Will not work after March security update

    Google had patched the fix for this and will not work after March security update.
    2
    Hi stizzir,

    Great post I've tried it and it works.
    The only problem I had is that you can't use the latest version of Magisk Manager you
    need to use the 7.0.0 version if not Magisk manager won't open after running the suboot.sh script.

    I was wondering if with this we may be able to get full root and also turn the notch on and
    off on devices that don't have the Full Bezel option in Display Settings or Developer Options.

    Best regards,
    voidRunner
    1
    I tried it as well and it works. Thanks for letting us know I've been checking these forums every week waiting for something like this. I also used Magisk 7.0.0 inside the 18.1 Magisk zip. Latest version didn't work.
    1
    I got OTA update today while this thing was running so no OTA issues.

    Just 2 warnings:
    1) Don't write even a single byte to system partition or boot partition.
    2) Don't expect Netflix etc to work since it breaks CTS profile and basic integrity. Banking apps etc will whine for rightful reasons too.