• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[A2017U][RECOVERY][UNOFFICIAL] TWRP 3.0.2-2 touch recovery for ZTE Axon 7

Status
Not open for further replies.
Search This thread

kgptzac

Senior Member
Aug 13, 2010
212
27
I'm having issue with touch screen not working while in the recovery... only way to get touch screen to work is to do power off then power on then to the recovery directly.
 

gpz1100

Senior Member
Nov 28, 2009
3,053
581
A2017U, bootloader unlocked, twrp 3.0.2-2.

Strange behavior with twrp. If I select to back up boot/system/data, upon restore, it just sits at the zte logo indefinitely.

If I select to back up system image (rather than system), then it boots properly.

What am i missing here? Past phones (even on MM) required just /system to be backed up for a successful restore/boot.
 

Loader009

Senior Member
Jul 6, 2012
711
198
Does anyone have issues with an encrypted Backup?

I am not able to make an encrypted Backup.
After setting the encryption password two times, I start the backup.
2 1/2 minutes later it stops, with the following message:
createTarFork() process ended with ERROR: 255

It stops after about 1700MB.
After it stopped, I go back, set the encryption password again and start the backup... still stops with that error.
 
Last edited:

xtermmin

Senior Member
Mar 27, 2011
1,327
543
I have no issue backing up and restoring system/data/boot/cache in TWRP. I'm able to switch between my B29 backup (not the hueg system image) and CM13. I don't do straight Restore though, I do the Advanced Wipe first, and then restore my TWRP backup.

A2017U, bootloader unlocked, using UnjustifiedDev's TWRP.
 
  • Like
Reactions: ruthlessJay

amphi66

Senior Member
Dec 17, 2010
1,056
323
PacNW
... ... snip... .... .
Question is, why doesn't just backing up "system" work?

There are user-defined settings stored under Data that help control system parameters. Dependent upon how different the System and Data levels vary, restoring a backup of just one (or the other) may cause a failure to boot or even with boot may cause FCs in any of several System apps.
Good luck.
 

tasar

Senior Member
Mar 17, 2007
702
123
@xtermmin, the problem is not an normal backup/restore, the problem is when you want to decrypt yout TWRP backup, that doenst work. Backup breaks at Data with error 255.

And dont forget, to disable pin/pattern before backup. When you restore a backup where pin/pattern was set, pin/pattern is break after restore and you must manualy delete some files in system/data:
password.key
pattern.key
locksettings.db
locksettings.db-shm
locksettings.db-wal
password.key
pattern.key

not all of them are present on every device, the last time for me it was enough to delete the locksettings.xxx files and i have full acess again and can make new pin/pattern entry.
 

gpz1100

Senior Member
Nov 28, 2009
3,053
581
There are user-defined settings stored under Data that help control system parameters. Dependent upon how different the System and Data levels vary, restoring a backup of just one (or the other) may cause a failure to boot or even with boot may cause FCs in any of several System apps.
Good luck.

Don't think this plays much of a role. After wiping data, I tried restoring just boot/system with similar results.

Being stuck at the zte logo is some indicator of where the failure is occurring. It's not even getting to the point where the axon logo/boot animation is being displayed.
 
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 38
    Team Win Recovery Project 3.x, or twrp3 for short, is a custom recovery built with ease of use and customization in mind. Its a fully touch driven user interface no more volume rocker or power buttons to mash. The GUI is also fully XML driven and completely theme-able. You can change just about every aspect of the look and feel.



    CHANGELOG for 3.0.2-2:

    -Fix subpartition restore bug (ex: EFS)

    CHANGELOG for 3.0.2-0:

    -Fix a bug with the input box that affected masked inputs (passwords). This fixes decrypt of full device encryption on devices that support decrypt. This bug also impacts encrypted backups. Users are highly encouraged to stop using 3.0.1 if you use encrypted backups or if you need decrypt of data in TWRP.
    -Add Greek translation to some builds.

    CHANGELOG for 3.0.1-0:

    -support new CM 13.0 pattern encryption (sultanqasim)
    -fix slow flashing issue due to modprobe (present on only some devices) (#twrp)
    -libtar updated to latest upstream and fixes (jcadduono)
    -fixes for loading custom themes (_that)
    -TWRP will now detect and install TWRP themes automatically through the normal zip install process (Dees_Troy)
    -translation updates - added Italian, Czech and Polish and significant updates to Dutch
    -progress bar improvements - progress bar updates during image flashing and better tracks progress during file system backups (tar) (Dees_Troy)
    -fix input box text display (Dees_Troy)
    -reboot option after zip install complete (bigbiff)
    -other mostly invisible bug fixes and improvements

    CHANGELOG for 3.0.0-0:

    -Completely new theme - Much more modern and much nicer looking (by z31s1g)
    -True Terminal Emulator - Includes arrow keys, tab and tab completion, etc. (by _that)
    -Language translation - It won’t be perfect and especially some languages that require large font files like Chinese & Japanese won’t be availble on most devices. Also some languages may only be partially translated at this time. Feel free to submit more translations to OmniROM’s Gerrit. (mostly by Dees_Troy)
    -Flashing of sparse images - On select devices you will be able to flash some parts of factory images via the TWRP GUI (by HashBang173)
    -Adopted storage support for select devices - TWRP can now decrypt adopted storage partitions from Marshmallow
    -Reworked graphics to bring us more up to date with AOSP - includes support for adf and drm graphics (by Dees_Troy)
    -SuperSU prompt will no longer display if a Marshmallow ROM is installed
    -Update exfat, exfat fuse, dosfstools (by mdmower)
    -Update AOSP base to 6.0
    -A huge laundry list of other minor fixes and tweaks

    WARNING: This is our first release in a long time. We have a lot of new and somewhat aggressive changes in this new release. The changes to the graphics back-end may cause some devices to not boot up properly or have other display-related issues. If you are not in a position to reflash an older build of TWRP, then wait until you are or at least wait until others have tried the new version for your specific device. You don’t want to end up with a non-working recovery and have to wait several hours or days to get to a computer to be able to fix it.

    Notes for themers: In addition to the udpated theme, we have introduced a theme version variable to the TWRP theme system. If the theme version does not match the version that TWRP expects, TWRP will reject the custom theme and load its stock theme. This change will ensure that people who update TWRP without updating their theme will still have a workable recovery. We have removed libjpeg support. The stock theme was only using a jpeg image for the splash / curtain. This change means that any custom themes will no longer be able to use jpeg images. It also means that tools used to repack recovery images with a different curtain / splash will need to be updated to use the new method.

    Version number notes: For a while we’ve been using a 4 digit version number and reserved the 4th digit for device-specific updates. For instance, we find and fix a device-specific issue like decryption of data on Nexus 5, we would release that as a 2.8.7.1. After a while, some people would start asking where 2.8.7.1 was for other devices. So, going forward we have decided to change the numbering scheme to 3.0.0-2, etc. Our hope is that this version numbering scheme will more clearly identify that the 4th digit does not indicate a version change for the code base.

    We need your help! The bulk of TWRP work is done by 3 people on a volunteer basis. We have pushed most of our device files to our github and we have a gerrit instance. If you have the ability, please help us maintain our official devices and/or add your device to our official device list. Thanks in advance!

    CHANGELOG for 2.8.7.0:

    -Initial ground work for software drawn keyboard (_that)
    -Fix handling of wiping internal storage on datamedia devices (xuefer)
    -Allow DataManager to set and read values from the system properties (xuefer)
    -Fix crash when taking screenshots on arm64 devices (xuefer)
    -Fix error message after an ORS script completes (Dees_Troy)
    -Fix crashes / error when creating encrypted backups (_that, Dees_Troy)
    -Add system read only option – more details below (Dees_Troy)
    -Add resize2fs and GUI option to run resize2fs (Dees_Troy)
    -Fix crash loop caused by empty lines in AOSP recovery command file (_that)
    -Prevent duplicate page overlays such as multiple lock screens (mdmower)

    Note: As always, be sure your custom theme is up to date (or remove your custom theme) before updating TWRP.

    System read only option: Devices that ship with 5.0 and higher as their initial OS are using block level OTA updates. With this style of OTA update, the update script checks to see if the system partition has ever been mounted read/write. Further, the script also usually runs an SHA sum of the entire system partition to detect if any changes have been made. If any changes have been made, the OTA update will refuse to install. Since not all OEMs and devices have factory images available, we have created a new feature in TWRP that detects if the system partition has ever been mounted read/write. If not, you will be prompted asking if you want TWRP to mount system as read/write. If you choose not to allow TWRP to mount as read/write, TWRP won’t prompt to install SuperSU and TWRP won’t try to patch the stock ROM to prevent TWRP from being replaced by stock recovery. The goal of this option is to hopefully allow the user to make a raw system image backup that they can use to get back to a state where they can take OTA updates again.

    resize2fs feature: On some devices like the Nexus 6, the factory images include a userdata image that is the proper size only for the 32GB units. If you flash the factory image to a 64GB Nexus 6, the data partition will appear as if it only has the free space of a 32GB device. Using the resize2fs option, TWRP can resize your data partition to take up the full space available. The resize2fs may also be useful to resize system partitions on devices where custom ROM system images don’t take up the full partition space. Lastly, resize2fs may be useful in some cases to reserve the proper space at the end of a data partition for a full disk encryption key, should your partition be formatted incorrectly for some reason.

    This new version also marks our first set of full builds using our new jenkins build server. You can track the progress of builds at https://jenkins.twrp.me and we have taken additional steps to make it easier for device maintainers to step up and submit patches to our gerrit server at https://gerrit.twrp.me to help us keep devices up to date and working.

    DOWNLOAD:
    TWRP 3.0.2-2

    Can be updated quickly and easily within TWRP if TWRP is already installed
    1) Download the latest version from the above link
    2) Reboot to TWRP
    3) Hit Install and tap the "Images..." button in the lower right
    4) Browse to the location of the TWRP image on your device and select it
    5) Select recovery from the partition list and swipe to flash

    BUGS:
    If you have found a bug, please consider posting it to our github issues log. It's pretty much impossible for us to keep up with the more than 40 threads that we have for the devices that we "directly" support. If you have a significant problem that cannot be answered in this thread, your best bet is to PM me directly, contact us via our website, or find us in our IRC channel below. If you see someone that's struggling, feel free to point it out to us. We need your help to help us keep track of all of our devices! Thanks!

    SUPPORT:
    Live support is available via #twrp on Freenode with your IRC client or just click this link.

    SOURCE/THANKS:
    Device tree: https://github.com/TeamRegular/android_device_zte_ailsa_ii
    @DrakenFX for testing and requesting my help
    @Unjustified Dev for being....ME of course
    20
    Prerequisites:
    * Unlocked bootloader Guide Here

    Installation:
    Code:
    adb reboot bootloader
    fastboot flash recovery twrp-3.0.2-2-a2017u.img
    fastboot reboot

    To enter recovery:
    * Power + volume up

    Code:
    adb reboot recovery

    Installing Mods:
    If you plan on modifying the system, please follow this post here or you'll result in a bootloop.
    10
    New build uploaded the image name is the name

    Download

    Changelog:
    Add support for installing fastboot images (Install -> Install image)
    Add support for backing up and restoring fastboot images
    Add support for double tap to wake (when the screen goes black one tap doesn't work like other devices)
    7
    New build has been uploaded TWRP 3.0.2-2

    I've backported the following fixes for the subpartition restore bug (Tested by @DrakenFX)

    https://gerrit.omnirom.org/18939

    https://gerrit.omnirom.org/18973

    Download:
    https://www.androidfilehost.com/?fid=24686680535467611