• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
Search This thread

TheAirBlow

Member
May 7, 2021
14
0
Explanation and my thoughts:
There is official TWRP for Samsung Galaxy A20s, but it is not flasheable because doesn't allow it - hash mismatch.
Tried everything: empty vbmeta, google disable-verify vbmeta, some other vbmeta, nothing seems to stop it from mismatch error.
Are there any workaround for recovery partition? I know that you can flash null binaries to break binary checking but afaik it works only for system and vendor. Just some common sense - recovery gets overriden automatically and booting into the recovery on boot won't get anything because it is empty. Booting = overriden.

So there's my questions:
1) Is it possible to bypass that broken hash check?
2) Does Android 9 aboot + vaultkeeper bypass work?
 

th4gu11

Member
Sep 21, 2018
5
0
I hope you gets an answer, bc i've gone trought the same issue :( i've tried every online method possible even before the official release of twrp for this device and after that too, and i still wasn't able to root or instal a custom rom