A20e Root,Kernel, TWRP and custom ROM

Search This thread

MikkyX3

Member
Jul 11, 2013
25
32
Prague
Thanks for that.
I've been waiting for someone to tell me about it
I'll try to fix it.
Did you go back to v1.56 ok?
I tried to flash v1.56 but it didn't boot. In the end I flashed stock OS via Odin as it was impossible to make the phone to boot again. Now I flashed the Z Rom again and will flash the 1.56 version, this combination was working well for me.
Hope you'll fix it soon, I like the kernel very much. Thank You for your work!
 

physwizz

Senior Member
Sep 16, 2013
3,484
755
Sydney
I tried to flash v1.56 but it didn't boot. In the end I flashed stock OS via Odin as it was impossible to make the phone to boot again. Now I flashed the Z Rom again and will flash the 1.56 version, this combination was working well for me.
Hope you'll fix it soon, I like the kernel very much. Thank You for your work!
You still had the 1.60 dtbo.img on the phone.
That was causing the issue.
If you now flash 1.56 all should be ok
 

physwizz

Senior Member
Sep 16, 2013
3,484
755
Sydney
physwizz-a20e 1.70
@physwizz
Zip installer from @Topser

-Most securities disabled
-CPU Governors: conservative, ondemand, userspace, powersave, interactive, performance.
-Interactive is default governor
-CPU overclocked and underclocked
-Big: 208 - 2184
-Little: 208 - 1690
-GPU: 343 - 1300
-Extended battery life
-Works with Magisk
-Spectrum support enabled
 
Last edited:
  • Like
Reactions: gtezprado

physwizz

Senior Member
Sep 16, 2013
3,484
755
Sydney
physwizz-a20e 1.70 GSI
@physwizz
Zip installer from @Topser

-Most securities disabled
-CPU Governors: conservative, ondemand, userspace, powersave, interactive, performance.
-Interactive is default governor
-CPU overclocked and underclocked
-Big: 208 - 2184
-Little: 208 - 1690
-GPU: 343 - 1300
-Extended battery life
-Works with Magisk
-Spectrum support enabled
-mtp enabled
 
Last edited:

handycup

Member
Mar 7, 2021
25
4
TWRP 3.5.0 from @Topser99 works fine on a20e, I have successfully flashed:
AOSP v11 vndklite
LineageOS 18.1 normal and vndklite

Magisk works fine, but can't pass safetynet check
On AOSP I was expecting to see @physwizz kernel, then I flashed v1.70 (not the GSI one) on TWRP, and now it's showing on software info, but I didn't run any test yet, maybe I need to flash the other GSI version

When I try to flash some ROMs without using the vndklite version, after flashing, I can't mount system. Happens with AOSP also, and I can't flash anything after flashed ROM

What I'm doing is:
wipes and then format, flash multidisabler-samsung, flash Rom, flash Magisk fix, and Magisk 22
don't know when to flash kernel, could be last step?
 

physwizz

Senior Member
Sep 16, 2013
3,484
755
Sydney
TWRP 3.5.0 from @Topser99 works fine on a20e, I have successfully flashed:
AOSP v11 vndklite
LineageOS 18.1 normal and vndklite

Magisk works fine, but can't pass safetynet check
On AOSP I was expecting to see @physwizz kernel, then I flashed v1.70 (not the GSI one) on TWRP, and now it's showing on software info, but I didn't run any test yet, maybe I need to flash the other GSI version

When I try to flash some ROMs without using the vndklite version, after flashing, I can't mount system. Happens with AOSP also, and I can't flash anything after flashed ROM

What I'm doing is:
wipes and then format, flash multidisabler-samsung, flash Rom, flash Magisk fix, and Magisk 22
don't know when to flash kernel, could be last step?
Some GSIs are difficult.
Yes flash kernel last
 
  • Like
Reactions: handycup

handycup

Member
Mar 7, 2021
25
4
Some GSIs are difficult.
Yes flash kernel last
Haven't flashed the gsi version yet, here's how it looks now
Screenshot_20210316-222256.png
 

physwizz

Senior Member
Sep 16, 2013
3,484
755
Sydney
Can't find the right one to download, the github page won't open. I see a new TWRP in the mega folder, can I update that too?
You don't go to GitHub. Just go to post#1

 

Top Liked Posts