• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

A3 2017(A320FL) Android 8.0 Root

Search This thread

Nils088

Member
Dec 5, 2017
5
1
Hi, i recently updated my A3 2017 to Android 8. It was a bad Idea because I want to root it now. I found a couple of Threads about this topic, but i want something that explains it to 100%(easy). Please Help
 
  • Like
Reactions: carpet55

nekos95

Senior Member
Dec 18, 2015
80
23
download android latest 8 firmware
put magisk on the sd
flash the firmware with odin but uncheck auto reboot
once the flashing is complete disconnect the usb and press power+home+vol down buttons until the screen is black
once is black press them again until the phone reenters download mode
then flash twrp as ap
then boot into twrp but dont let the device boot in to os
go mount check if data is mountable if not wipe and check again
then flash magisk and you are good to go
 

Nils088

Member
Dec 5, 2017
5
1
download android latest 8 firmware
put magisk on the sd
flash the firmware with odin but uncheck auto reboot
once the flashing is complete disconnect the usb and press power+home+vol down buttons until the screen is black
once is black press them again until the phone reenters download mode
then flash twrp as ap
then boot into twrp but dont let the device boot in to os
go mount check if data is mountable if not wipe and check again
then flash magisk and you are good to go

Could you please Post the Download Links to Magisk and Twrp?
 

nekos95

Senior Member
Dec 18, 2015
80
23
Could you please Post the Download Links to Magisk and Twrp?
twrp https://dl.twrp.me/a3y17lte/
magisk https://github.com/topjohnwu/Magisk/releases/download/v17.1/Magisk-v17.1.zip
odin https://forum.xda-developers.com/attachment.php?attachmentid=4431749&d=1519672710

edit: also better follow this guide incase i forgot something but replace everything with its newer versions, especially odin
https://forum.xda-developers.com/sa...-to/sm-a320-fl-android-7-root-xposed-t3696517
 
Last edited:
  • Like
Reactions: Baronmic

friscoboi

Senior Member
Oct 1, 2016
497
118
download android latest 8 firmware
put magisk on the sd
flash the firmware with odin but uncheck auto reboot
once the flashing is complete disconnect the usb and press power+home+vol down buttons until the screen is black
once is black press them again until the phone reenters download mode
then flash twrp as ap
then boot into twrp but dont let the device boot in to os
go mount check if data is mountable if not wipe and check again
then flash magisk and you are good to go

I tried all that. Won't work. Every time I start to system and go back to TWRP later, Data is not mounted anymore. I tried al lot. Always went back to TWRP right after, without bootin to system. At first, Data is mounted. But when I start to System, it seems to unmount Data again.

I flashed stock rom, went to TWRP right after, allowed modifications, flashed magisk, then rebooted, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied modifications, rebooted to TWRP, then installed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went back to TWRP right after, allowed modifications, rebooted to TWRP, then flashed magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied modifications, flashed DM-verity, rebooted to TWRP flashed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, allowed modifications, flashed Magisk, rebooted to TWRP, flashed DM-Verity, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied madifications, flashed DM-Verity, rebooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, allowed modifications, flashed DM-verity, reooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I used different DM-verities. Unmountable Data comes back in any case.

It helps to format Data or change file system and the change back. BUt after bootin to system, Data is unable to be mounted again.
 
  • Like
Reactions: Snowgay

aVapxia

New member
May 30, 2019
1
0
Marpla
I tried all that. Won't work. Every time I start to system and go back to TWRP later, Data is not mounted anymore. I tried al lot. Always went back to TWRP right after, without bootin to system. At first, Data is mounted. But when I start to System, it seems to unmount Data again.

I flashed stock rom, went to TWRP right after, allowed modifications, flashed magisk, then rebooted, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied modifications, rebooted to TWRP, then installed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went back to TWRP right after, allowed modifications, rebooted to TWRP, then flashed magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied modifications, flashed DM-verity, rebooted to TWRP flashed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, allowed modifications, flashed Magisk, rebooted to TWRP, flashed DM-Verity, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied madifications, flashed DM-Verity, rebooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, allowed modifications, flashed DM-verity, reooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I used different DM-verities. Unmountable Data comes back in any case.

It helps to format Data or change file system and the change back. BUt after bootin to system, Data is unable to be mounted again.

Hi, did you renamed "DM.verity" file adding somewhere "quota" in the name ? I read it in another thread.

thx,
 

redalert3d

New member
Apr 1, 2019
2
0
A3 2017 - a320y

I root using supersu 2.82 2017 ---- success.
Data encryptable you must edit boot file maybe need edit fota --- success
After Remove Bloatware --- free space >10gb

App in Phone Screen
Samsung App
Calculator
Calendar
Camera
Clock
Contact
Email
Gallery
Internet
MyFiles
Galaxy App
Phone
Messages

Google App
Drive
Map
Drive
Chrome
 

pienis1

New member
Jan 20, 2020
1
0
Hello there. Im trying to find a working firmware for this but are having trouble to find one. Anyone that can point me in the right direction?
 

Snowgay

Senior Member
Jul 30, 2007
70
6
I tried all that. Won't work. Every time I start to system and go back to TWRP later, Data is not mounted anymore. I tried al lot. Always went back to TWRP right after, without bootin to system. At first, Data is mounted. But when I start to System, it seems to unmount Data again.

I flashed stock rom, went to TWRP right after, allowed modifications, flashed magisk, then rebooted, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied modifications, rebooted to TWRP, then installed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went back to TWRP right after, allowed modifications, rebooted to TWRP, then flashed magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied modifications, flashed DM-verity, rebooted to TWRP flashed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, allowed modifications, flashed Magisk, rebooted to TWRP, flashed DM-Verity, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, denied madifications, flashed DM-Verity, rebooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I flashed stock, went to TWRP right after, allowed modifications, flashed DM-verity, reooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

I used different DM-verities. Unmountable Data comes back in any case.

It helps to format Data or change file system and the change back. BUt after bootin to system, Data is unable to be mounted again.

Hi, did you find a working solution to have moutned data in twarp und magisk installed?
 

7adm

Member
Aug 15, 2011
49
11
To all the people with the problem of TWRP losing /data mount after reboot:
I've had the exact same issue, didn't matter which version of TWRP I've been using or how often I've been trying to reformat/repair /data.. The solution was to use an modified recovery. One of these will do:

Orangefox: works well, the only thing that bugs me with R11.0 is that it won't remember the current time setting (it always boots with the time set to around 9 am)

Pitch Black Recovery: will mount data, nice styling, however it's still not perfectly adjusted to the a3 (first release). Progress bars & counters might overlap with other displayed items, flashlight won't work.

Skyhawk: The one that I'm currently using. Doesn't seem to have any apparent bugs and can be styled to ones liking.

All of these gave me access to the /data partition, hope they will work for y'all as well.
 

newbie_or_not_newbie

Senior Member
Sep 28, 2013
389
75
Bretagne
Google Pixel 4a
To all the people with the problem of TWRP losing /data mount after reboot:
I've had the exact same issue, didn't matter which version of TWRP I've been using or how often I've been trying to reformat/repair /data.. The solution was to use an modified recovery. One of these will do:

Orangefox: works well, the only thing that bugs me with R11.0 is that it won't remember the current time setting (it always boots with the time set to around 9 am)

Pitch Black Recovery: will mount data, nice styling, however it's still not perfectly adjusted to the a3 (first release). Progress bars & counters might overlap with other displayed items, flashlight won't work.

Skyhawk: The one that I'm currently using. Doesn't seem to have any apparent bugs and can be styled to ones liking.

All of these gave me access to the /data partition, hope they will work for y'all as well.

Thanks a lot.
Do these recoveries need all repartition for vendor support before flash them ?
 

airali

Member
Dec 14, 2012
15
5
I successfully rooted my Samsung Galaxy A320FL using the procedure linked below. I also managed to fix fingerprint feature and banking apps and to move whatsapp media folder to SD card.

Here is how I did:

Hope this helps, it took a lot of time to me to retrieve all the information, so I hope that the linked guide will be useful for someone!
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi, i recently updated my A3 2017 to Android 8. It was a bad Idea because I want to root it now. I found a couple of Threads about this topic, but i want something that explains it to 100%(easy). Please Help
    1
    download android latest 8 firmware
    put magisk on the sd
    flash the firmware with odin but uncheck auto reboot
    once the flashing is complete disconnect the usb and press power+home+vol down buttons until the screen is black
    once is black press them again until the phone reenters download mode
    then flash twrp as ap
    then boot into twrp but dont let the device boot in to os
    go mount check if data is mountable if not wipe and check again
    then flash magisk and you are good to go

    I tried all that. Won't work. Every time I start to system and go back to TWRP later, Data is not mounted anymore. I tried al lot. Always went back to TWRP right after, without bootin to system. At first, Data is mounted. But when I start to System, it seems to unmount Data again.

    I flashed stock rom, went to TWRP right after, allowed modifications, flashed magisk, then rebooted, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

    I flashed stock, went to TWRP right after, denied modifications, rebooted to TWRP, then installed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

    I flashed stock, went back to TWRP right after, allowed modifications, rebooted to TWRP, then flashed magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

    I flashed stock, went to TWRP right after, denied modifications, flashed DM-verity, rebooted to TWRP flashed Magisk, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

    I flashed stock, went to TWRP right after, allowed modifications, flashed Magisk, rebooted to TWRP, flashed DM-Verity, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

    I flashed stock, went to TWRP right after, denied madifications, flashed DM-Verity, rebooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

    I flashed stock, went to TWRP right after, allowed modifications, flashed DM-verity, reooted to TWRP, Data is mounted, booted to stock, reooted to TWRP, Mount is gone.

    I used different DM-verities. Unmountable Data comes back in any case.

    It helps to format Data or change file system and the change back. BUt after bootin to system, Data is unable to be mounted again.