AAWireless - General discussion and support

Search This thread

HofaTheRipper

Senior Member
Apr 26, 2014
237
215
38
St. Veit an der Glan
Yup, bumping the question:) As I've wrote earlier on this thread - on my S20 and S9 I am getting my AAW restarting after connecting to my VW's dash. Checked in two VW cars with the same result. Works just fine in Mazda tho (or at least does not crash right away - did not make any long run on this car).

cheers
y666
Had similar problems with my Seat.... Random reconnects... solved it by downgrading my AAW device to V1.5
 

sibesaver

Senior Member
Sep 30, 2010
126
45
Moore, OK
I successfully disabled everything using BlueTask a Tasker task that springs into action whenever I connect to my car.
Can you try disabling everything using BlueTask and see if it's any better ?
Thanks for the idea. I couldn't get Blue Task to control my Huawei watch 2, kept getting an error in Tasker. I did however use Autowesr successfully to disconnect and reconnect my watch from my phone. That seems to have solved the problem with playing the call through my speakers.
 
  • Like
Reactions: EViollet

EGOiST1991

Senior Member
Jul 3, 2015
527
114
Cologne
I am having the same issues (random disconnects). I have an Audi A7, Samsung S21 and this is my 2nd device. Upgrading to 1.8 which has not made any difference as well.

As far as the wifi control, mine shows the history of devices, but I do not see any history related to the last time I used my car and connected with AA wireless so don't know if that really makes a difference at least in my situation.
can you check with an other phone?
 

whatsek

Senior Member
Nov 5, 2009
280
81
After upgrading to 1.8.0 one of my phones wont start Android auto anymore. It connects with bluetooth but it seems that wifi wont connect, the phone is not looking for android auto. (Mi 10T Pro, with Lineage OS 18.1) worked fine with the previous firmware (I guess 1.7.1) But my other phone, Mi 11T Pro with Xiaomi.EU rom, works fine. So I assumed there was something with the other phone. After 2 weeks of reinstalling, clearing data, deleteting bluetooth pairings, it still does not work anymore. No problems using a cable, but that feels so 2020 ;-)

Can my device please be downgraded to 1.7.1 so I can check if that fixes the problem?
My device is GkTTQ55f

Edit: I see a comming 1.9 firmware, I can try that first if it will be availble soon)
 

1qazwsx4

Senior Member
Sep 19, 2011
595
343
New Zealand
After upgrading to 1.8.0 one of my phones wont start Android auto anymore. It connects with bluetooth but it seems that wifi wont connect, the phone is not looking for android auto. (Mi 10T Pro, with Lineage OS 18.1) worked fine with the previous firmware (I guess 1.7.1) But my other phone, Mi 11T Pro with Xiaomi.EU rom, works fine. So I assumed there was something with the other phone. After 2 weeks of reinstalling, clearing data, deleteting bluetooth pairings, it still does not work anymore. No problems using a cable, but that feels so 2020 ;-)

Can my device please be downgraded to 1.7.1 so I can check if that fixes the problem?
My device is GkTTQ55f

Edit: I see a comming 1.9 firmware, I can try that first if it will be availble soon)
I've never had any luck using lineage 18.1 and Android wireless on Xiaomi devices - always have random disconnections or errors connecting.
 

Dr.Klemphoff

New member
Feb 25, 2021
4
0
I've been having a lot of issues with AAwireless on both my oneplus 6t and my pixel 6 pro. 5ghz simply does not work at all. When on 2.4ghz it will often seem to buffer for about 1-2 seconds randomly, the issue is noticeably increased by switching songs or using other areas in android auto like asking maps to navigate, once the navigation command starts to load. My connection speed is over 300mbps, and normally I'd think using 5ghz would be a solution to this, if it could be used, because I have to assume 2.4 is too slow or something?

Also the AAWireless device has to be removed from bluetooth on the phone and readded about twice a week, or else when getting in the car it will connect and disconnect repeatedly, never loading the entire ride. I tried the troubleshooting steps in the FAQ, I think it was something like, remove contacts from either the car or the aa device's bluetooth. Also have whitelisted aawireless in all areas of the phone like battery optimization.

If there's a more extensive guide for either of these issues than what's in the app faq I can start there if someone has a link, but I couldn't find anything yet.
 

12340987

Member
Mar 10, 2007
30
0
After upgrading to 1.8.0 one of my phones wont start Android auto anymore. It connects with bluetooth but it seems that wifi wont connect, the phone is not looking for android auto. (Mi 10T Pro, with Lineage OS 18.1) worked fine with the previous firmware (I guess 1.7.1) But my other phone, Mi 11T Pro with Xiaomi.EU rom, works fine. So I assumed there was something with the other phone. After 2 weeks of reinstalling, clearing data, deleteting bluetooth pairings, it still does not work anymore. No problems using a cable, but that feels so 2020 ;-)

Can my device please be downgraded to 1.7.1 so I can check if that fixes the problem?
My device is GkTTQ55f

Edit: I see a comming 1.9 firmware, I can try that first if it will be availble soon)


I'm having a similar issue, except I'm not sure if it's because of this or my phone getting reset. My phone is also reporting that it is connected to AA, but my car does not.

Halp
 

saves38

New member
Jan 23, 2022
1
0
I bought 2 AAWireless devices, 1 for my car and 1 for my motorcycle.
I have a sony xav-ax7000 head unit which also runs an app called Weblink, which I believe is causing problems for AAWireless to connect properly. Any advice or work around would be great appreciated
 

1qazwsx4

Senior Member
Sep 19, 2011
595
343
New Zealand
Thought it's also worth mentioning that ever since updating from 1.5 to 1.8 I've been unable to use additional AAW settings. Previously I could use DPI settings etc but now I'm forced to use passthrough mode or I'm unable to get a connection regardless of default/direct/mtp etc.
I understand that you guys are pushing to get loads of devices shipped out but each firmware update seems to help some people while breaking functionality for others that had a fully functioning device - can we please please please get a means to downgrade/update our firmware OURSELVES so we can rollback if need be to one that functions best for our device/headunit.
 

matyyyu

Member
Dec 10, 2017
19
1
OnePlus One
OnePlus 3T
I've been having a lot of issues with AAwireless on both my oneplus 6t and my pixel 6 pro. 5ghz simply does not work at all. When on 2.4ghz it will often seem to buffer for about 1-2 seconds randomly, the issue is noticeably increased by switching songs or using other areas in android auto like asking maps to navigate, once the navigation command starts to load. My connection speed is over 300mbps, and normally I'd think using 5ghz would be a solution to this, if it could be used, because I have to assume 2.4 is too slow or something?

Also the AAWireless device has to be removed from bluetooth on the phone and readded about twice a week, or else when getting in the car it will connect and disconnect repeatedly, never loading the entire ride. I tried the troubleshooting steps in the FAQ, I think it was something like, remove contacts from either the car or the aa device's bluetooth. Also have whitelisted aawireless in all areas of the phone like battery optimization.

If there's a more extensive guide for either of these issues than what's in the app faq I can start there if someone has a link, but I couldn't find anything yet.
I have same issue - OnePlus 8T... removed all SMS, removed conntacts, passthru mode - still stuttering... :( For me its completly not usable.. cannot hear music...
 

Top Liked Posts

  • 6
    Ahh, so my start/stop is misbehaving?

    I kind of thought it would do a quick disconnect when BT to the car died, despite there being power to the USB port for a bit after in some cars.
    It should normally indeed. Bassiccly every change we do in the start / stop mechanism it breaks for half of the people and fixes stuff for the other half.
    We have a way now to make it device controlled, so we can finally get rid of this horrible functionality.
    5
    Will the new Start/Stop be compatible with Dongle mode? I find Dongle mode good on its own for Start, but bad for Stop where my Hyundai Elantra 2018 keeps the USB powered ~2 min after turning off the engine and locking the car.
    Yes, that's because the start part (waiting for handsfree) is built into AA itself. Why Google did not built in the stop part as well (kill AA on handsfree loss) is a mystery to me.
    4
    Any ideas why my setup won't project without intervention? So 2.01 is not the 2.1 that was mentioned before?

    Any idea when 2.1 is out?
    Because you have start / stop enabled and for some reason it doesn't work correctly. 2.0.1 is a bug fix release for 2.0. 2.1 will be released end of next week.
    1
    @ZacJ
    Thank you for your information. I think this helps a lot of people to decide.

    Do you feel any difference concerning the battery drain/heating of the phone between AAWireless and Carsifi?
    I didn't notice any difference between the two :)
  • 10
    Small update on firmware 2.0. We fixed the last issue regarding wifi client mode. I'll do a bit of testing tomorrow and then we are ready to go.

    Will also push some more improvements/changes to the app next week.

    We're pushing to people's devices at random over the coming week. If you want to have early access, please fill out: https://forms.gle/NndEexW18UTVVMUn6
    6
    Ahh, so my start/stop is misbehaving?

    I kind of thought it would do a quick disconnect when BT to the car died, despite there being power to the USB port for a bit after in some cars.
    It should normally indeed. Bassiccly every change we do in the start / stop mechanism it breaks for half of the people and fixes stuff for the other half.
    We have a way now to make it device controlled, so we can finally get rid of this horrible functionality.
    6
    So I have some updates on my situation and wanted to share for future refference. I managed to get it working in "dongle mode" and also made "stop/start" work. Actually it seems that the only way for "dongle mode" to work was to also have "stop/start" enabled and functioning. It seems that withtout it my phone will not connect to the WiFi created for wireless connection (which is called "AndroidAuto-xxxx" when in dongle mode, different than "AAwireless-xxxx" when in "standard" mode.

    The issue was the wifi being turned off by the system. Newer Android OS (11 and above I believe) have this WiFi setting option that turns off the WiFi when you leave a "known location" and turns it back on when you get back to those "known locations" so the issue is that the bluetooth beacon that is sent by the dongle is not enough to trigger WiFi to turn on and connect to the WiFi.

    Note that this issue does not manifest itself when I am using a car with proper built-in Wireless AA. I have a Skoda Karoq that has built-in wireless AA and even if my WiFi is turned off, it will turn itself on to connect to AA, just not with this dongle.

    Anyway, long story short, because when "Start/Stop" is active I have a constant notification on my phone from the app indicating the status (connected/not connected/etc.) it showed me "wifi is turned off cannot connect" or something simiar. So when I manually turned it on, everything started working. My phone connects imediately to my car with "dongle mode" ON and "start/stop" ON.

    What remains an issue is that it will not work with "dongle mode" ON but "Start/Stop" OFF. It seems that without the helper app "helping" the phone to connect to the wifi of the dongle, the phone will not do it on its own. This is not a big deal for me, as I want to have "start/stop" enabled anyway.

    So bottom line, everything is working perfectly fine for me now.

    Hope this helps others and helps @Snirpo to figure out if they might want to change some stuff for their app.
    It's probably helpful to explain for everyone how the process works :) So here we go:

    When start / stop is enabled our companion app is in control of starting up AA. So wether dongle mode is enabled or not, it doesn't matter, because the standard bluetooth bootstrap of Android Auto is not used. That's also the reason why wifi is not turned automatically on in start / stop mode. Android Auto, being a system app, can do these things. From the companion app we cannot from Android 10 and above, hence showing the notification to turn on wifi.

    So basically using start / stop completely invalidates the different bootstrap logic in AA regarding dongle mode, because bluetooth (to the device) isn't used to start up the process. It doesn't really matter if you use dongle mode or not.

    "Note that this issue does not manifest itself when I am using a car with proper built-in Wireless AA. I have a Skoda Karoq that has built-in wireless AA and even if my WiFi is turned off, it will turn itself on to connect to AA, just not with this dongle."

    This should also happen with AAWireless, AAWireless == 100% native, except when using start / stop mode like I explained above, when the companion app controls the bootstrap. AA always turns on wifi when using the native bluetooth bootstrap.

    Why dongle mode doesn't work in your case is a bit of a mystery to me though...

    So summary:

    AAWireless + "standard" mode == emulate native Wireless HU, does not need the companion app.

    AAWireless + dongle mode == works as native dongle, like Motorola MA1, does not need companion app.

    AAWireless in dongle or standard mode + start / stop == does not use the native bluetooth bootstrap, but trigger wifi connection based on handsfree connection of the car. Needs the companion app, not native.
    6
    Just sharing this on a few threads in case anyone wants my opinion:

    So I have both Carsifi and AAWireless - just sharing my thoughts here if anyone cares.

    I have a Z Fold 3 and a S20 Ultra. The phones have roughly the same load time on either device in a Hyundai Tuscon. In the Hyundai i30, the AAWireless is about 10 seconds faster than the Carsifi.

    The AAWireless app is nicer and easier to use than the Carsifi app. It's also got a few more options.

    The Carsifi app takes a little longer to update the device when a change is made. There is also an 'experimental' method to boot faster but it made no difference on my phones...

    The only benefit to some people (with Carsifi) may be the 'magic button' - you can set it to do 2 things:
    1) change paired phone (double click)
    2) Play / pause music (triple click) - however on my device, this paused the music but AA froze, and pressing play rebooted the device, so after about 10 seconds it rebooted and started the music again.

    I got the AAWireless many months ago, and the Carsifi yesterday (I purposely got both - one for each car, and so I can test both of them too!)

    At the end of the day, both do the same thing in the same way. In summary, I like the AAWireless better as it seems to just 'work' better, the app is better and I like the developer and their reputation.

    Oh and if anyone has any questions, please let me know and I'll respond.
    6
    Yes, I tried it in my Golf with MIB 2.5 Discover Pro High, a Garmin unit.

    Set to Australia wifi the display shrunk, so I put it back and the display filled the screen again.
    That's weird, I expected the display to be upside down...

    Just kidding of course :) I'll investigate.
  • 35
    This thread is dedicated for AAWireless users.

    AAWireless is a device which allows you to transform your existing wired Android Auto compatible unit into a Wireless Android Auto unit.

    General chat, experience sharing and community support should be expected as well as support from the developers of the product: @Snirpo and myself.
    16
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    15
    We fixed the "VW Headunit crashing on skipping tracks" issue now completely. Confirmed it's a bug on the HU side, latency makes it worse. We will probably push a new firmware by the end of this week.
    I will also submit a bug report to Google, cause they can fix/workaround this issue as well for cabled users.
    14
    Hello. What's new in 1.5?
    A full changelog for each release would really be appreciated :)
    Thanks for all the hard work!
    Yes, I'll write a full changelog next week from 1.0.0 to 1.5.0 and put it on GitHub + add a link in the app.
    14
    I've already waited patiently for delivery 3 months more than expected - I ordered In April and was coming in June but now that's looking like October. Now I read on the indiegogo forum that people in the UK are being charged an additional €27 by the Royal mail as the UK is now not in the EU.

    Hi Emil!
    Just received my AAWireless, and will plug in and test tonight. Love the packaging, looks great! However… Since it was shipped from Hong Kong I was forced to pay a rather substantial import fee and duties on this bad boy. I was under the impression that they would be shipped from within the EU? Is it stands now I’m EUR 27,00 poorer :(
    2 2
    https://www.indiegogo.com/individuals/24534862
    Emil Borconi-Szedressy 2 days ago
    PROJECT OWNER
    Looks like you are in the UK which is outside EU and also there is no way to pre-pay taxes with shipping company any more either....


    This is a crazy. An additional $10 was already taken for delivery and it was meant to ship from the EU. I suspect the units have been shipped by Royal Mail / Dutch post. The Royal Mail rips off people in the UK because they add another £11 in admin fees on top of the 20% VAT even though goods up to £135 should be exempt.
    See https://www.gov.uk/government/publi...s-goods-sold-to-customers-from-1-january-2021

    So not only has VAT been charged coming into the EU from China, it has also been charged coming into the UK ON TOP of the VAT already paid in the EU.

    This is just rubbish. What the guys need to do is either ship it from Hong Kong which can cost £0.20 (there are hundreds of chinese ebay and aliexpress sellers doing this already
    See http://www.vatfraud.org/blog/stop-s...ons-universal-postal-union-upu-terminal-dues/
    The $10 postage already taken should then be refunded.

    The other way round it is send the item from Hong Kong and to mark the item as a gift and providing it is below £39 there is NO VAT to pay and NO Royal mail admin fee. Actually as the original product was $57 - roughly £41.25 This wouldn't be a crime seeing as we have had to wait soo long. This could also mean the $10 delivery could be refunded

    The other way is to ship it via fedex and state the ex-vat cost coming from china and then add 20% vat that the developer should be paying to the UK HMRC.

    Sadly if that doesn't take place, EVERYONE IN THE UK will feel ripped off because of the poor delivery and poor choices made by the developers.

    Cheers
    Disgruntled in the UK

    First of all, your item wasn't shipped yet since in the June batch, so you could have not payed anything for shipping. Secondly, UK is outside the EU, there was a vote about this in 2016, so it doesn't matter if the package comes from EU or from HK or from US, it is treated the same, it's an import. If we import it from HK to EU, we will pay import VAT on the product, then when we send it to UK, we claim back that VAT and we should pay VAT in UK, since there is no more free trading between EU and UK.

    Up till recently there was a nice option, to pay VAT and Import duty up-front, when you ship to the UK, but this has been changed and now they requires business outside UK to register with HMRC and do HMRC feeling even if they are residing outside UK, a lot of red tape. Since crowdfunding is not a sale, we can still ship the units to UK, but not sure if we will be able to after the IndieGoGo campaign.

    We are also a EU registered company so we cannot (and will not take advantage) of any loop-holes in systems to sell at ridiculously / unrealistically cheap prices.

    About the user who paid 27 euros, it turned out that user is living in DK, but provided the address as UK so his package traveled the wrong way, hence the extra duties and surcharges.

    Not aware of other users from UK having to pay anything additional when they received the package.