AAWireless - General discussion and support

Search This thread

festor

Senior Member
Jun 4, 2013
112
50
Are there any MIUI users who switched to another ROM to fix the random disconnections? Did it work and what did you switch to?

I mostly use the phone (POCO F3) for communication and nav so my priority would be a secure and stable alternative that gets regular updates/support.
 
  • Like
Reactions: welshblob

mobileman88

Senior Member
Oct 27, 2008
2,293
427
Are there any MIUI users who switched to another ROM to fix the random disconnections? Did it work and what did you switch to?

I mostly use the phone (POCO F3) for communication and nav so my priority would be a secure and stable alternative that gets regular updates/support.
I am using xiaomi eu for my mi 10 ultra. I am not getting random disconnections but getting the freezing issue. Hopefully this new firmware makes it better
 

festor

Senior Member
Jun 4, 2013
112
50
I am using xiaomi eu for my mi 10 ultra. I am not getting random disconnections but getting the freezing issue. Hopefully this new firmware makes it better
2.1.0 (aka 2.0.1) fixed the freezing for me. They are currently rolling out 2.0.1 in phases. From what I understand, 2.0.0 introduced freezing where a disconnection would have happened previously for MIUI 12.5 and above.

Are you saying you didn't get disconnections with 1.8 and the current (non beta) Xiaomi EU ROM?
 
  • Like
Reactions: osm0sis

valeri_s_k

Member
Aug 24, 2020
48
12
Bourgas
2.1.0 (aka 2.0.1) fixed the freezing for me. They are currently rolling out 2.0.1 in phases. From what I understand, 2.0.0 introduced freezing where a disconnection would have happened previously for MIUI 12.5 and above.

Are you saying you didn't get disconnections with 1.8 and the current (non beta) Xiaomi EU ROM?
Actually I think that freezing in 2.0.0 @mobileman88 mentined is due to random disconnections from MIUI. With 2.0.1 freezing is fixed, but I am afraid disconnections will remain...
AAW firmware/app version have nothing to do with that issue.

For now I am stuck with MIUI beta rom release from Oct 21 (with no disconnections), considering all disadvantages of using an outdated rom. I am already tired of flashing new vesrion, test it and downgrade...

Will also appreciate any info for newer rom release without the issue - does not matter MIUI, AOSP etc.
 
  • Like
Reactions: pacogeno

Gee11

Member
May 10, 2022
21
1
I have not seen one post of yours that gives any information about what settings you have tried or anything you have done to try to solve the problem.
I tried EVERYTING.
- with /without Dongle
- with /without Passtrough
- VAG Crash fix (since update grayed out)
- Start /stop
- every usb mode
- played with timeouts
- several combinations of the above settings
- different android auto versions

no matter what i do, AAW will restart every few minutes (looses BT connection to phone, WiFi stays connected)
Unusable atm

when i connect my phone via USB with Audi A6 4G HU i never have interruptions.

Distance between my phone and AAW is 5cm, its no signal strength problem

My phone is Android 12 Galaxy S20 plus


i want to try new firmware 2.1.0 and older one 1.8
 

festor

Senior Member
Jun 4, 2013
112
50
Actually I think that freezing in 2.0.0 @mobileman88 mentined is due to random disconnections from MIUI. With 2.0.1 freezing is fixed, but I am afraid disconnections will remain...
AAW firmware/app version have nothing to do with that issue.

For now I am stuck with MIUI beta rom release from Oct 21 (with no disconnections), considering all disadvantages of using an outdated rom. I am already tired of flashing new vesrion, test it and downgrade...

Will also appreciate any info for newer rom release without the issue - does not matter MIUI, AOSP etc.
I might have misunderstood the "Actually" part of your post, but that's exactly what I was saying. What was previously a disconnection was turned into a freeze. It's why I asked @mobileman88 about disconnections before 2.0.0 firmware.

As for the beta, it would be interesting to know why it works. Maybe they used an old network stack for some reason?
 

valeri_s_k

Member
Aug 24, 2020
48
12
Bourgas
I might have misunderstood the "Actually" part of your post, but that's exactly what I was saying. What was previously a disconnection was turned into a freeze. It's why I asked @mobileman88 about disconnections before 2.0.0 firmware.

As for the beta, it would be interesting to know why it works. Maybe they used an old network stack for some reason?
Yea, just wanted to reconfirm what you said. IMO some users mix disconnections caused by AAW wifi interferences at some loactions (this seems fixed with 2.0.1) and disconnections caused by MIUI
 

serakar999

New member
May 14, 2018
2
0
Hi to all,

I have received my AAWireless a couple of weeks ago and have been using it with Poco F2 Pro (MIUI 13) and Jeep Renegade MY20 (Europe). I have two main issues:

1. The system freezes at random intervals. It can be after 10 min, it can be after 90 min of operation. Unplugging the device and plugging it back solves the issue.
2. Every time the phone rings and I answer it through android auto, or if I initiate a call through the car android auto screen, the android auto interface disappears from the car screen and the bluetooth connected phone screen appears on the car screen. After 3-5 seconds the android auto interface appears again on the car screen and the call is shown using android auto display. Same thing when I hang up, android auto disappear from the car screen like it is disconnected for 3-5 secs and then reappears and works normally. This of course does not happen when I have the phone connected directly to the car.

I hope the second problem is clear, if not I can post a video.

Firmware version is 2.0.0

Thank you
 

festor

Senior Member
Jun 4, 2013
112
50
Hi to all,

I have received my AAWireless a couple of weeks ago and have been using it with Poco F2 Pro (MIUI 13) and Jeep Renegade MY20 (Europe). I have two main issues:

1. The system freezes at random intervals. It can be after 10 min, it can be after 90 min of operation. Unplugging the device and plugging it back solves the issue.
2. Every time the phone rings and I answer it through android auto, or if I initiate a call through the car android auto screen, the android auto interface disappears from the car screen and the bluetooth connected phone screen appears on the car screen. After 3-5 seconds the android auto interface appears again on the car screen and the call is shown using android auto display. Same thing when I hang up, android auto disappear from the car screen like it is disconnected for 3-5 secs and then reappears and works normally. This of course does not happen when I have the phone connected directly to the car.

I hope the second problem is clear, if not I can post a video.

Firmware version is 2.0.0

Thank you
The freezing issue will probably be fixed with firmware 2.0.1 which will hopefully be made available for everyone over the next day or two.

like me (POCO F3) you will probably still get the disconnections though. A freeze will just change to a 3-5 sec disconnection. It seems the issue started with MIUI 12.5. It happens when the phone drops or lowers the mobile signal which also then affects wifi for some reason.

You can recreate the disconnection by manually switching/forcing a lower network in SIM card settings > Preferred network type.
 

mobileman88

Senior Member
Oct 27, 2008
2,293
427
Actually I think that freezing in 2.0.0 @mobileman88 mentined is due to random disconnections from MIUI. With 2.0.1 freezing is fixed, but I am afraid disconnections will remain...
AAW firmware/app version have nothing to do with that issue.

For now I am stuck with MIUI beta rom release from Oct 21 (with no disconnections), considering all disadvantages of using an outdated rom. I am already tired of flashing new vesrion, test it and downgrade...

Will also appreciate any info for newer rom release without the issue - does not matter MIUI, AOSP etc.
I am using the May 11th eu rom. Disconnections are happening with 2.0.1 now at places with very poor reception not all the time. However the freezing issue is gone. I am using in non transparent mode if it helps.
 
  • Like
Reactions: welshblob

welshblob

Senior Member
Dec 22, 2013
157
32
Fareham (not in Wales)
I am using the May 11th eu rom. Disconnections are happening with 2.0.1 now at places with very poor reception not all the time. However the freezing issue is gone. I am using in non transparent mode if it helps.
That's a shame as I thought the EU rom might have been the fix. I'm on the global rom miui 13.0.4 and still on firmware 1.8.

Wonder what the lineage rom is like?
 

Top Liked Posts

  • 6
    I got bored today, so I thought I make a mock up how the AAWireless app could look like :D When swiping t he car picture could change if you want to connect to annother device/car :D

    View attachment 5645393 View attachment 5645397
    Haha nice! I'll pass it on to our UI/UX designer :) We have some UX changes in the pipeline, but it doesn't have the highest prio right now as you can imagine.
    We made some changes in firmware 2.1.0 which means we don't need these dreaded USB modes anymore. The plan is to ship devices in passthrough + dongle mode, to make it work natively, like the MA1, by default.
    Then we are going to hide away the settings in a sort of advanced settings menu, because all these settings are nice, but people don't read/understand what they do, stuff stops working and then our support has to handle it. Hardly anyone uses these settings, for example, dpi change, the most used feature, is only used on 1 percent of all devices.
    Bassicly we are KISS'ing it, but still keep advanced settings for well... You guys :)
    3
    That is normal when using the dev version of the app. Dev version will always let you reflash actual version if there's no newer one.
    Yes, it's normal, but I'll remove it, because I get a comment about it almost every day :)
    2
    Hi!
    Today, after trying for 20th time, I was able to flash new version (v2.0.2).
    Only odd thing is that now it keeps saying un update is available but actual version 2.0.2 / new version 2.0.2
    Cheers!
    That is normal when using the dev version of the app. Dev version will always let you reflash actual version if there's no newer one.
    2
    Google :( Thanks for the info. I hope this will not be a great storm of Pixel issues again.

    I also noticed it's not possible anymore to be connected to two wifi networks since the latest update. Before you could be connected to home network + AA wifi. But when you did that, AA got all laggy.
    Hey! I find out the culprit, I'm so happy!

    It's the new Google Driving Assistant. You have to disable it and it is smooth as butter with music 😍

    Google App > Settings > Google Assistant > Transports (with car icon) > Car mode > disable everything

    Now it is like before, smoooooooth!

    You can add it to the FAQ.
    2
    I got bored today, so I thought I make a mock up how the AAWireless app could look like :D When swiping t he car picture could change if you want to connect to annother device/car :D

    aawireless_mockup.png
    aawireless_mockup_dark.png
  • 6
    I got bored today, so I thought I make a mock up how the AAWireless app could look like :D When swiping t he car picture could change if you want to connect to annother device/car :D

    View attachment 5645393 View attachment 5645397
    Haha nice! I'll pass it on to our UI/UX designer :) We have some UX changes in the pipeline, but it doesn't have the highest prio right now as you can imagine.
    We made some changes in firmware 2.1.0 which means we don't need these dreaded USB modes anymore. The plan is to ship devices in passthrough + dongle mode, to make it work natively, like the MA1, by default.
    Then we are going to hide away the settings in a sort of advanced settings menu, because all these settings are nice, but people don't read/understand what they do, stuff stops working and then our support has to handle it. Hardly anyone uses these settings, for example, dpi change, the most used feature, is only used on 1 percent of all devices.
    Bassicly we are KISS'ing it, but still keep advanced settings for well... You guys :)
    5
    @everyone

    For feature requests or issues, please use: https://github.com/cpebit/aawireless-issues/issues/new/choose

    I getting really hard to follow this thread. Possibly I already forgot some requests of some people. Need a bit of structure. We will try to fix issues one by one from GitHub.
    4
    Regarding the broken day / nightmode cycle:

    I also have this problem, and I read a few days ago that it was due to a combination of updated Google Maps and Android Auto.

    The combination which should work:

    Android Auto: 7.5.621344
    Google Maps: 11.31.1

    You finde all these old versions on apkmirror.com, or similar sites.

    Didn't have the time to check this out myself.

    I had this same problem. Found out it woud be caused to 11.31.1 and upwards. Found the solution on Google Maps Help.

    I installed Maps 11.35.0 beta (from apk mirror) and all seems to work well again. My AA is level 7.7.622134 (from play store).​

    Tried a lot of different variations, but my conclusion is that Maps from 11.33.1 is the culprit.
    3
    That is normal when using the dev version of the app. Dev version will always let you reflash actual version if there's no newer one.
    Yes, it's normal, but I'll remove it, because I get a comment about it almost every day :)
    3
    I can, but it feels more like a bandaid solution. What kind of problems do you have?
    Yes rebooting is a band-aid solution for sure. But I think it would be a good thing to add in any case. Most devices I own have an option somewhere in the menu for a reboot. Hopefully it's not too difficult to implement.

    As for the issue, here's the description:

    Setup
    Car - Kia Stinger 2019 GT AWD
    AAWireless - Firmware 2.0, factory reset a few weeks ago. Enabled dongle mode and passthrough mode. Everything else is default
    Phone - Pixel 5

    Issue
    Once in a rare while (like every 20-30 trips) the audio from AAWireless connection just stops working. Happened with multiple different apps (Spotify, Pocketcasts, etc.). The app keeps playing the content (I can see the play time advancing) but no sound. There is never an interruption with the AA connection - it's rock solid, stays on my car display and is navigable. it's just the audio that stops working.

    Troubleshooting steps
    Tried factory reset in non-dongle mode (fail)
    Tried factory reset with dongle mode (fail)
    Tried dongle mode + pass through (fail)
    Upgraded to AAWireless firmware 2.0.1 (did that this morning, too early to tell)

    When this happens (again it's rare) the only way that I can resolve this is to leave the car for a few minutes and let the AAWireless unit power down with the car, or power cycle the AAWireless unit by unplugging and plugging back in. If I turn off the car and turn it back on immediately, the problem remains as the AAWIreless device stays powered on. If I switch to radio on the car the sound works fine but when I go back to AAWIreless the sound is still gone.

    In either situation, rebooting the AAWireless seems to fix the issue.

    Hope this helps. Like I said this is fairly rare occurence that can occur at the beginning of a trip or after 30 mins of driving. That's why I'd be happy with a device reboot option in the app as I know the permutations of cars + phones + AAWireless settings makes this hard to diagnose.
  • 40
    This thread is dedicated for AAWireless users.

    AAWireless is a device which allows you to transform your existing wired Android Auto compatible unit into a Wireless Android Auto unit.

    General chat, experience sharing and community support should be expected as well as support from the developers of the product: @Snirpo and myself.
    16
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    15
    We fixed the "VW Headunit crashing on skipping tracks" issue now completely. Confirmed it's a bug on the HU side, latency makes it worse. We will probably push a new firmware by the end of this week.
    I will also submit a bug report to Google, cause they can fix/workaround this issue as well for cabled users.
    14
    Hello. What's new in 1.5?
    A full changelog for each release would really be appreciated :)
    Thanks for all the hard work!
    Yes, I'll write a full changelog next week from 1.0.0 to 1.5.0 and put it on GitHub + add a link in the app.
    14
    I've already waited patiently for delivery 3 months more than expected - I ordered In April and was coming in June but now that's looking like October. Now I read on the indiegogo forum that people in the UK are being charged an additional €27 by the Royal mail as the UK is now not in the EU.

    Hi Emil!
    Just received my AAWireless, and will plug in and test tonight. Love the packaging, looks great! However… Since it was shipped from Hong Kong I was forced to pay a rather substantial import fee and duties on this bad boy. I was under the impression that they would be shipped from within the EU? Is it stands now I’m EUR 27,00 poorer :(
    2 2
    https://www.indiegogo.com/individuals/24534862
    Emil Borconi-Szedressy 2 days ago
    PROJECT OWNER
    Looks like you are in the UK which is outside EU and also there is no way to pre-pay taxes with shipping company any more either....


    This is a crazy. An additional $10 was already taken for delivery and it was meant to ship from the EU. I suspect the units have been shipped by Royal Mail / Dutch post. The Royal Mail rips off people in the UK because they add another £11 in admin fees on top of the 20% VAT even though goods up to £135 should be exempt.
    See https://www.gov.uk/government/publi...s-goods-sold-to-customers-from-1-january-2021

    So not only has VAT been charged coming into the EU from China, it has also been charged coming into the UK ON TOP of the VAT already paid in the EU.

    This is just rubbish. What the guys need to do is either ship it from Hong Kong which can cost £0.20 (there are hundreds of chinese ebay and aliexpress sellers doing this already
    See http://www.vatfraud.org/blog/stop-s...ons-universal-postal-union-upu-terminal-dues/
    The $10 postage already taken should then be refunded.

    The other way round it is send the item from Hong Kong and to mark the item as a gift and providing it is below £39 there is NO VAT to pay and NO Royal mail admin fee. Actually as the original product was $57 - roughly £41.25 This wouldn't be a crime seeing as we have had to wait soo long. This could also mean the $10 delivery could be refunded

    The other way is to ship it via fedex and state the ex-vat cost coming from china and then add 20% vat that the developer should be paying to the UK HMRC.

    Sadly if that doesn't take place, EVERYONE IN THE UK will feel ripped off because of the poor delivery and poor choices made by the developers.

    Cheers
    Disgruntled in the UK

    First of all, your item wasn't shipped yet since in the June batch, so you could have not payed anything for shipping. Secondly, UK is outside the EU, there was a vote about this in 2016, so it doesn't matter if the package comes from EU or from HK or from US, it is treated the same, it's an import. If we import it from HK to EU, we will pay import VAT on the product, then when we send it to UK, we claim back that VAT and we should pay VAT in UK, since there is no more free trading between EU and UK.

    Up till recently there was a nice option, to pay VAT and Import duty up-front, when you ship to the UK, but this has been changed and now they requires business outside UK to register with HMRC and do HMRC feeling even if they are residing outside UK, a lot of red tape. Since crowdfunding is not a sale, we can still ship the units to UK, but not sure if we will be able to after the IndieGoGo campaign.

    We are also a EU registered company so we cannot (and will not take advantage) of any loop-holes in systems to sell at ridiculously / unrealistically cheap prices.

    About the user who paid 27 euros, it turned out that user is living in DK, but provided the address as UK so his package traveled the wrong way, hence the extra duties and surcharges.

    Not aware of other users from UK having to pay anything additional when they received the package.