AAWireless - General discussion and support

Search This thread

DroidShift79

Senior Member
Sep 11, 2012
1,532
618
Frankfurt am Main
OnePlus 9 Pro
I see you're using "direct" usb mode. That should not be used normally, 95% of the cars cannot handle that. Please use default or mtp USB mode. What color is the LED blinking?
When not doing the OFF/ON thing,
And just let it do its thing, LED goes from blinking blue to solid blue, AA icon in the HU goes away, then comes back on LED is going from blinking green to solid green, AA Icon goes away then LED goes to red.

To get it back to live and connection I have to unplug it, turn BT and WLAN OFF, plug it back in, turn BT and WLAN on again, then it finds a connection after some minutes

I sent you 3 logs the second was while the issue was on, the 3rd, after it got connected again.
 

elbubi

Member
May 12, 2013
38
8
Sorry, just to be sure, did I need to make anything else to provide you with the needed debug?
Tried to replicate the issue with bug report activated, but I soon as I hit back arrow to go to update section, bug recording just stops.

Regards!
Hi!
Today, after trying for 20th time, I was able to flash new version (v2.0.2).
Only odd thing is that now it keeps saying un update is available but actual version 2.0.2 / new version 2.0.2
Cheers!
 

Marsou77

Senior Member
Feb 2, 2011
1,469
350
Earth
Hi @Snirpo

It's definitely not an issue with the AA wireless dongle... I drove to Paris ~ 1h with my phone wired to the NAC and there was a huge lag with music... I'm hundred percent sure I never had this issue before. I will test with my Pixel 3 to be sure it's a NAC issue.

Thanks for your help, you can revert my dongle to 2.0.2

Also, do you think I can mess up with AA developers settings to try to fix the issue?
 

Genebaby

Senior Member
Dec 11, 2013
787
107
I went for a drive and got the notice that an upgrade was available. I did it in the garage upon returning home and unlike the previous updtates it was harder to get and apply.

I for some reason had to get it only via wifi, so lucky I was at home. I had to connect to the home wifi even though I had asked (a few times) to download now and not wait for wifi.

It wasn't quite 20 times, but it was the longest update I can remember.

I use direct mode again so I'll change that to Default. It generally runs fine in my car, the 2020 GTI with Mib 2.5, I am just hoping to be able to hear the Assistant on every drive, rather than about 50% of the time. That's mostly what I want in an update.

I'll test 2.02 over the next few sporadic drives. Maybe get 2.1 before that?
 

Snirpo

Senior Member
Jan 23, 2007
489
607
Hi @Snirpo

It's definitely not an issue with the AA wireless dongle... I drove to Paris ~ 1h with my phone wired to the NAC and there was a huge lag with music... I'm hundred percent sure I never had this issue before. I will test with my Pixel 3 to be sure it's a NAC issue.

Thanks for your help, you can revert my dongle to 2.0.2

Also, do you think I can mess up with AA developers settings to try to fix the issue?
Google :( Thanks for the info. I hope this will not be a great storm of Pixel issues again.

I also noticed it's not possible anymore to be connected to two wifi networks since the latest update. Before you could be connected to home network + AA wifi. But when you did that, AA got all laggy.
 
Last edited:

Snirpo

Senior Member
Jan 23, 2007
489
607
My device name is : AAWireless-ezvXL6z3

I should have sent some logs this evening (2x - the first time might have failed because I tried to send them too soon when the device was still rebooting).
Hi!
Today, after trying for 20th time, I was able to flash new version (v2.0.2).
Only odd thing is that now it keeps saying un update is available but actual version 2.0.2 / new version 2.0.2
Cheers!
I'll try to check your logs today, I'm a bit overloaded ATM.
 
  • Like
Reactions: elbubi

DroidShift79

Senior Member
Sep 11, 2012
1,532
618
Frankfurt am Main
OnePlus 9 Pro
Hi!
Today, after trying for 20th time, I was able to flash new version (v2.0.2).
Only odd thing is that now it keeps saying un update is available but actual version 2.0.2 / new version 2.0.2
Cheers!
That is normal when using the dev version of the app. Dev version will always let you reflash actual version if there's no newer one.
 
  • Like
Reactions: elbubi and osm0sis

Snirpo

Senior Member
Jan 23, 2007
489
607
Hi!
Today, after trying for 20th time, I was able to flash new version (v2.0.2).
Only odd thing is that now it keeps saying un update is available but actual version 2.0.2 / new version 2.0.2
Cheers!
Had a look at the logs. Seems it's connected the correct wifi network, but somehow it can't reach the OTA endpoint of the device. I'll have a look into it when I have the time.
 
  • Like
Reactions: elbubi

Marsou77

Senior Member
Feb 2, 2011
1,469
350
Earth
Google :( Thanks for the info. I hope this will not be a great storm of Pixel issues again.

I also noticed it's not possible anymore to be connected to two wifi networks since the latest update. Before you could be connected to home network + AA wifi. But when you did that, AA got all laggy.
Hey! I find out the culprit, I'm so happy!

It's the new Google Driving Assistant. You have to disable it and it is smooth as butter with music 😍

Google App > Settings > Google Assistant > Transports (with car icon) > Car mode > disable everything

Now it is like before, smoooooooth!

You can add it to the FAQ.
 
  • Like
Reactions: osm0sis and wweasel

Snirpo

Senior Member
Jan 23, 2007
489
607
Hey! I find out the culprit, I'm so happy!

It's the new Google Driving Assistant. You have to disable it and it is smooth as butter with music 😍

Google App > Settings > Google Assistant > Transports (with car icon) > Car mode > disable everything

Now it is like before, smoooooooth!

You can add it to the FAQ.
Really?! Wow, that doesn't make any sense. This is crazy... Thanks!

I'm not that happy though because we are bassiccly a sh*tfunnel for every problem in AA itself.
 
Last edited:
  • Like
Reactions: osm0sis

Marsou77

Senior Member
Feb 2, 2011
1,469
350
Earth
Really?! Wow, that doesn't make any sense. This is crazy... Thanks!

I'm not that happy though because we are bassiccly a sh*tfunnel for every problem in AA itself.
Yeah I understand the issue... You should mention it somewhere like an "announcement" or something if it's possible.
At least you can close the issue you sent me earlier and this explains why the Galaxy A7 wasn't laggy!

Could you also revert back the firmware to the latest available for my unit please? The updater keep telling me there is an update to 1.8.0 (it's not trivial but I would like to get the 2.1.0 later lol)

Also how can I clear the "bug report available" pop up? I don't want to sent it anymore 😁

Thank you and have a nice weekend!
 

DroidShift79

Senior Member
Sep 11, 2012
1,532
618
Frankfurt am Main
OnePlus 9 Pro
I got bored today, so I thought I make a mock up how the AAWireless app could look like :D When swiping t he car picture could change if you want to connect to annother device/car :D

aawireless_mockup.png
aawireless_mockup_dark.png
 
  • Like
Reactions: osm0sis and -Loom-

Snirpo

Senior Member
Jan 23, 2007
489
607
I got bored today, so I thought I make a mock up how the AAWireless app could look like :D When swiping t he car picture could change if you want to connect to annother device/car :D

View attachment 5645393 View attachment 5645397
Haha nice! I'll pass it on to our UI/UX designer :) We have some UX changes in the pipeline, but it doesn't have the highest prio right now as you can imagine.
We made some changes in firmware 2.1.0 which means we don't need these dreaded USB modes anymore. The plan is to ship devices in passthrough + dongle mode, to make it work natively, like the MA1, by default.
Then we are going to hide away the settings in a sort of advanced settings menu, because all these settings are nice, but people don't read/understand what they do, stuff stops working and then our support has to handle it. Hardly anyone uses these settings, for example, dpi change, the most used feature, is only used on 1 percent of all devices.
Bassicly we are KISS'ing it, but still keep advanced settings for well... You guys :)
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    I'm afraid you diddn't understand Snirpo answer : so many available features are amost not used, so developping new feature for very few people is not realistic...
    4
    The bug in MIUI is there for around a year. It has same behavior with native (factory) enabled wireless Android auto units. So until you stay with MIUI you can't use wireless AA even if you buy new car.
    To enjoy wireless AA, IMO there are two options only:
    - change the phone
    - unlock bootloader and flash an AOSP rom (this is what I did and all working great on Mi 11 (venus)

    By the way, once you try wireless Android auto (does not matter native or by any dongle on the market), you will never regret for changing the rom or the phone....
    Here's the same problem on an MA1:
    In general I'd advice NOT to buy an Xiaomi phone if you want to use Android Auto Wireless. They have been sh*t since the beginning. Older MIUI had no mobile internet while using AA Wireless. MIUI > 12.5 has these disconnection issues when mobile network reconnects.
    Huawei is also horrible for Android Auto Wireless.
    We decided to only support phones from the official list of Google (https://support.google.com/androida...py=,android-auto-on-your-car-display-wireless), cause it's just not maintainable anymore.
    4
    I'm still using the Ottocast in one of the cars. Now something finally makes sense as it only says Carplay and it's been confusing since the start. There is a great new startup UI that is a big improvement, that I think is in beta. The first was terrible at connections but the second connects up rock solid every time. It does have some audio issues but seems to be getting better each time. I didn't find the FW update process to be difficult.

    I may swap this with the other VW to test the Assistant audio issue I have.
    We're also looking into doing AA via CarPlay protocol. This will definitely help on some cars with horrible Android Auto implementation.
    4
    Yeah I don't know, theoretically (and possibly als practically) we could implement something like Miracast. Personally I'd never use it. I think screen mirroring sucks. But if there's lots of demand for it, I guess we could look into it.
    I guess we can open some kind of poll for features. First need a list of features though.
    3
    I'm afraid I'm going to have to wait before purchasing until the miui bug is sorted out by xiaomi and who knows when this is going to be
    The bug in MIUI is there for around a year. It has same behavior with native (factory) enabled wireless Android auto units. So until you stay with MIUI you can't use wireless AA even if you buy new car.
    To enjoy wireless AA, IMO there are two options only:
    - change the phone
    - unlock bootloader and flash an AOSP rom (this is what I did and all working great on Mi 11 (venus)

    By the way, once you try wireless Android auto (does not matter native or by any dongle on the market), you will never regret for changing the rom or the phone....
  • 42
    This thread is dedicated for AAWireless users.

    AAWireless is a device which allows you to transform your existing wired Android Auto compatible unit into a Wireless Android Auto unit.

    General chat, experience sharing and community support should be expected as well as support from the developers of the product: @Snirpo and myself.
    20
    I used to get the same thing. I believe it is an issue with AA/Google rather than AAW. In any event, I have had to give up on AAW as I can't connect to it/won't update, just sits there with a constant light-blue light. It is a (very expensive) paper weight on my desk now. It is just "too Beta" for my requirements.

    I have now got a Carlink 2022 Android box which works flawlessly for me.
    MG ZS EV 2022
    Galaxy S21 Ultra (not rooted)
    I know I should ignore these posts, but these are the comments why I'm honestly considering completely dropping out any forum / reddit / social media. What's the point? We have support, we have warranty, we have a refund policy. It might be "beta" for you, but we shipped over 100k devices and believe me or not, for most, it just works. It's the same thing for all of these dongles. They will not work perfectly for all, there are just too many variables.
    16
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    15
    Very close to release of 2.1.0 now. We fixed the UConnect issue, except for some cases where you still have to re-plug the device, but this is also the case on the MA1.
    15
    We fixed the "VW Headunit crashing on skipping tracks" issue now completely. Confirmed it's a bug on the HU side, latency makes it worse. We will probably push a new firmware by the end of this week.
    I will also submit a bug report to Google, cause they can fix/workaround this issue as well for cabled users.