• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

AAWireless - General discussion and support

Search This thread

Tikerz

Senior Member
Nov 5, 2005
2,839
654
Mesa, AZ
Wireless iOS CarPlay devices suffered from audio delays during phone calls because CarPlay disconnects the phone bluetooth from the head unit. Does AAWireless/AndroidAuto do the same thing? Any delays in phone calls?
 

fortuneman

Senior Member
Nov 30, 2010
65
2
36
Bratislava
Hi
I also got the box and it works perfectly with my Oneplus 8 Plus and my Kia e-Niro 2021.
Unfortunately, the entire display is not used for Android Auto and there remains a black area on the right that cannot be used.
Is there a way to use the entire screen?

And great device and great Jop!
Most probably there is nothing AAwireless can do about that. It's somewhere among Kia and Google. I have a 2020 Xceed so I too wish there was a fix for the black third of the screen but so far I have found none.
 

cansi22

Member
Nov 10, 2010
9
1
Madrid
I received it on Monday and it works without problems.
It took me a while to find the correct configuration.

I confirm that it works with: :D :D
SONY XAV-AX3005DB (Headunit)
Samsung Galaxy S8

PD I can't change the DPI of the screen :(
 

tallleroy

Senior Member
Nov 20, 2015
78
110
Atlanta, Georgia
Hi
I also got the box and it works perfectly with my Oneplus 8 Plus and my Kia e-Niro 2021.
Unfortunately, the entire display is not used for Android Auto and there remains a black area on the right that cannot be used.
Is there a way to use the entire screen?

And great device and great Jop!
Yes, the Hyundai and Kia 10.25 inch head units confine Android Auto to the left portion of the screen. Head unit software updates allow the right portion of the screen to be something provided by the head unit. But Android Auto has not yet been permitted to fill the whole screen.

There will be another head unit software update coming in April, we can hope they will allow Android Auto to fill the screen. Apple Carplay has had the full screen for a while now.

If you have great vision, set the DPI to 100 with the AAWireless app. You will see what Android Auto will do when it has the full screen. I use DPI 130 daily to show a bit more map on my screen.
 

Scalee

Senior Member
Aug 21, 2009
187
249
Working on SEAT Arona 2021 and a Oneplus 5T. At first the connection would drop out after a few seconds.
But this was due to a 'bad' USB-C to USB-C cable.
 

morback

Senior Member
Mar 9, 2011
488
209
Received, installed, tested, perfect. Thank you!
Don't know about the head unit but I have a OP7T and a RENAULT Megane IV. Works perfectly.
 

andreiav

Senior Member
Jun 4, 2014
222
115
Brasov
Headunit restarting problem happend 2 times in 15 minutes again.
My guess is you have the same issue I have.
You should notice that the music stops playing even if you change songs. Or when you change songs, sometimes there are delays, or the song that is playing doesn't match the song displayed.
I have the same issue and have been contacted by Emil. He will look into it.
Apparently it is something related to MIB2Std. I own a Seat Ateca and have the same problem.
Hopefully a fix is possible.

As a workaround (not the best one though), when you notice the music stops playing, pause it and wait. Then resume playing. If the song resumes, you've just averted another restart. Unfortunately it happens quite often and this doesn't seem like a long term solution.
 
  • Like
Reactions: HofaTheRipper

mmmaxxx

New member
I don't have my unit yet, but I have a question already: Is it possible to use the wifi connection in reverse, i.e. have the phone create a hotspot (I need this for other devices in my car), and have the AAwireless box connect to the phone hotspot for the wifi connection?
 

mesaka

Member
Jul 26, 2006
36
0
Frankfurt
I installed my unit last Saturday and with a very minor issue which I could solve using the faq it just worked out of the box.

Volvo XC40, Pixel 3a (also tried and succeeded with oneplus 6).

I already signed up to be a beta tester for the configuration app but happy to also be a tester if firmware updates are required as well!
 

artgru

New member
Oct 8, 2008
3
0
Hello!
I can confirm a successful connection with AA :)
Huawei Mate 10 Pro
KIA Optima 2019

The default setup didn't work for me. AA started working only after changing USB connection mode and activating pass-through.
 

DevAuto

Member
Mar 9, 2013
43
22
I don't have my unit yet, but I have a question already: Is it possible to use the wifi connection in reverse, i.e. have the phone create a hotspot (I need this for other devices in my car), and have the AAwireless box connect to the phone hotspot for the wifi connection?
I don't know if the AAWireless configuration app allows for this kind of configuration, but I do know that AAGateway (the predecessor/foundation of AAWireless) allows for this. Hopefully @Emil Borconi will be along shortly to answer more directly with how things have been implemented/changed in AAWireless and whether or not it can be done.
 

DevAuto

Member
Mar 9, 2013
43
22
I am still waiting for my unit, but I do have a question.

I have a 2017 Chrysler 300 with Sprint Drive that has a Mobile Hotspot.

Will the AAWireless unit utilize that for internet or does it still need a phone for all that?

I guess I can wait to see how to get it all working, but thought I would ask. :)
IIRC, that is an option that @Emil Borconi is planning for a later release. Right now the focus and emphasis is on getting the basics working and having a solid product in place that just works. Adding routing into it complicates things when troubleshooting issues. I think he said it would be in a future OTA update.
 

-Loom-

Senior Member
Nov 5, 2010
334
66
Düsseldorf
I have my AAWireless for 5 days now.

Phone: OnePlus 8T - Android 11 (rooted)
Car: Volkswagen Golf 7 (Year 2019)
Headunit: Discover Media 8 Inch MIB 2.5 (Manufacturer probably Delphi)

Working smoothly with no hickups, crashs or freezes. Using the provided USB cable, although for me it could be half the lenght.

Had to initially connect manually, as the companion app failed to do a connect at all. Also I had to enable wireless projection, for some mysterious circumstances it was disabled. (Should be enabled as default with Android 11). Also I had to use "DIRECT" mode.

Connection time is very fast. USB gets powered as soon as the door opens, so Android Auto will start almost the same moment as the headunit has booted.

One minor thing that I noted: When I stop the ignition, Android Auto eventually terminates (as it should), but after 10 seconds or so it starts again. Maybe because there is still (or again) a bluetooth connection to the car. Of course the whole process failes as the headunit is already off.

So maybe I'll create a Macrodroid routine that disables bluetooth for about 1 minute. That would be enough time to leave the car and lock the door as locking the door finally disables car bluetooth.

But other then that, I'm extremly happy with this device. Emil has done a perfect job and I'm sure he'll iron out most of the hickups left in the future.
 
Last edited:

crazy-gump

Member
Nov 30, 2016
14
2
Well atm without long investigation it is a 1/3 on this household cars:
phone : Pixel 3
My Mazda3 BM 2016:
Default config work only if connected to USB after head unit start, it will loop [trying to connect AA, connect to car bluetooth, import contact to car, disconnect bluetooth to car]
Passthrough ON: work immediatly as intended. When I start the engine it will cut for 1-2 second and come back (same with AA wired)

My mother Renault Clio V 2020:
Default no Passthrough ON didn't work

My sister Honda Jazz 4 2020:
Default or Passthrough ON didn't work

At least it works in mine so it's perfectly fine for me.
 
  • Like
Reactions: elfeo

Talderon

Senior Member
IIRC, that is an option that @Emil Borconi is planning for a later release. Right now the focus and emphasis is on getting the basics working and having a solid product in place that just works. Adding routing into it complicates things when troubleshooting issues. I think he said it would be in a future OTA update.
Hey, this is great news! I am glad to hear it is on the radar. :)

I'll keep my eyes open for it and maybe I can even Beta Test it. :)
(I'm a Cloud Solutions Architect and am good with testing)
 

Top Liked Posts

  • There are no posts matching your filters.
  • 14
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    6
    Hi,

    are you going to release 1.7.1 this day? Because i have same problems with 1.7 like the others here. Would be great! :) Thank you!
    1.7.1 has just been released :)
    6
    AAWireless-2WuK74t7 here. #7004. Thanks for your efforts and looking into it!
    Boot limit is set to 5 failed boots before reverting to the previous version, so I think you experienced this. I'm glad we built in this failsafe... Didn't think we ever needed it... Thanks for the info guys!
    5
    We 99% percent sure found the issue now. I put your devices on a 1.7-hotfix version.
    4
    @osm0sis @janz25 @dzeidzei

    I put your devices on a version which might fix the boot (no led) issues for 1.7.0+. You can update to this version via the OTA screen. Could you check if this fixes it? I can't reproduce it, so it's a bit hard to verify myself :)

    Thanks!
  • 30
    This thread is dedicated for AAWireless users.

    AAWireless is a device which allows you to transform your existing wired Android Auto compatible unit into a Wireless Android Auto unit.

    General chat, experience sharing and community support should be expected as well as support from the developers of the product: @Snirpo and myself.
    15
    We fixed the "VW Headunit crashing on skipping tracks" issue now completely. Confirmed it's a bug on the HU side, latency makes it worse. We will probably push a new firmware by the end of this week.
    I will also submit a bug report to Google, cause they can fix/workaround this issue as well for cabled users.
    14
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    14
    Hello. What's new in 1.5?
    A full changelog for each release would really be appreciated :)
    Thanks for all the hard work!
    Yes, I'll write a full changelog next week from 1.0.0 to 1.5.0 and put it on GitHub + add a link in the app.
    14
    I've already waited patiently for delivery 3 months more than expected - I ordered In April and was coming in June but now that's looking like October. Now I read on the indiegogo forum that people in the UK are being charged an additional €27 by the Royal mail as the UK is now not in the EU.

    Hi Emil!
    Just received my AAWireless, and will plug in and test tonight. Love the packaging, looks great! However… Since it was shipped from Hong Kong I was forced to pay a rather substantial import fee and duties on this bad boy. I was under the impression that they would be shipped from within the EU? Is it stands now I’m EUR 27,00 poorer :(
    2 2
    https://www.indiegogo.com/individuals/24534862
    Emil Borconi-Szedressy 2 days ago
    PROJECT OWNER
    Looks like you are in the UK which is outside EU and also there is no way to pre-pay taxes with shipping company any more either....


    This is a crazy. An additional $10 was already taken for delivery and it was meant to ship from the EU. I suspect the units have been shipped by Royal Mail / Dutch post. The Royal Mail rips off people in the UK because they add another £11 in admin fees on top of the 20% VAT even though goods up to £135 should be exempt.
    See https://www.gov.uk/government/publi...s-goods-sold-to-customers-from-1-january-2021

    So not only has VAT been charged coming into the EU from China, it has also been charged coming into the UK ON TOP of the VAT already paid in the EU.

    This is just rubbish. What the guys need to do is either ship it from Hong Kong which can cost £0.20 (there are hundreds of chinese ebay and aliexpress sellers doing this already
    See http://www.vatfraud.org/blog/stop-s...ons-universal-postal-union-upu-terminal-dues/
    The $10 postage already taken should then be refunded.

    The other way round it is send the item from Hong Kong and to mark the item as a gift and providing it is below £39 there is NO VAT to pay and NO Royal mail admin fee. Actually as the original product was $57 - roughly £41.25 This wouldn't be a crime seeing as we have had to wait soo long. This could also mean the $10 delivery could be refunded

    The other way is to ship it via fedex and state the ex-vat cost coming from china and then add 20% vat that the developer should be paying to the UK HMRC.

    Sadly if that doesn't take place, EVERYONE IN THE UK will feel ripped off because of the poor delivery and poor choices made by the developers.

    Cheers
    Disgruntled in the UK

    First of all, your item wasn't shipped yet since in the June batch, so you could have not payed anything for shipping. Secondly, UK is outside the EU, there was a vote about this in 2016, so it doesn't matter if the package comes from EU or from HK or from US, it is treated the same, it's an import. If we import it from HK to EU, we will pay import VAT on the product, then when we send it to UK, we claim back that VAT and we should pay VAT in UK, since there is no more free trading between EU and UK.

    Up till recently there was a nice option, to pay VAT and Import duty up-front, when you ship to the UK, but this has been changed and now they requires business outside UK to register with HMRC and do HMRC feeling even if they are residing outside UK, a lot of red tape. Since crowdfunding is not a sale, we can still ship the units to UK, but not sure if we will be able to after the IndieGoGo campaign.

    We are also a EU registered company so we cannot (and will not take advantage) of any loop-holes in systems to sell at ridiculously / unrealistically cheap prices.

    About the user who paid 27 euros, it turned out that user is living in DK, but provided the address as UK so his package traveled the wrong way, hence the extra duties and surcharges.

    Not aware of other users from UK having to pay anything additional when they received the package.