AAWireless - General discussion and support

Search This thread


Senior Member
Jan 28, 2013
I had again the case that my phone connects to AAWireless, but Android Auto does not start.
A couple of pages ago, there was a solution to open the AAWireless app and push the save button in the settings.
Afterwards you explained that in this case the bluetooth connection is disconnected and reconnected to the AAWireless device.

I made a tasker script which does the following thing:
- If Android Auto does not start within 25 seconds after establishing the Wifi connection
- Turn off bluetooth and Wifi
- Wait 20 seconds (important)
- Turn on bluetooth and Wifi

It is important to have a wait time of at least 15 seconds.

I could not get Android Auto to start with a shorter wait time than 15 seconds. I use 20 seconds as this is also the timeout time of AAWireless. I think the timeout time is perhaps the reason why a short wait time does not work.

I had the cases 3 times in the past months. In all 3 cases my tasker script worked well. It was not necessary to replug the AAWireless device.


New member
Dec 3, 2020
Hi, i have some sort of interface box connected to oem head unit that provides cabled android auto which my mercedes c253 lacks. I don't know if it was discussed on this thread but i wonder if aawireless would work this device? I have attached the picture of the interface unit.


  • For-Mercedes-Benz-NGT-5-0-System.jpg
    55.5 KB · Views: 46


Senior Member
Dec 11, 2013
I have a Netplay unit (it gets rebranded) in another car, that has native wireless AA, but it also has a USB input, so it stands to reason that you could put an AAW there instead of plugging in your phone and it should do similar.

In my other car I installed a touchscreen overlay on my factory screen and I can switch over to AA or Carplay. I made sure to get one that was native wireless, but if you can't, then you can give it a go.


Senior Member
Feb 22, 2019
in the development version of the AAWireless app the start/stop settings have experimental settings which are greyed-out and cannot be selected. If I had the firmware 2.1.0 would they then be active?


New member
Sep 23, 2012
Hi, this is more a general question:

I had connected my AAwireless with a short usb a to c cable in my car. I attached my aawireless with tape to the car, so it cannot move when driving. I was driving on a freeway a few days ago. AAwireless was working fine the whole time until all of a sudden it lost connection. after a few seconds it was restored. Music was streamed and Google Maps displayed, but Google Maps stopped updating. I unplugged and replugged AAW once and it wouldn't start again. later I tried AAW again with another cable and it started right away. Now to the real question: is it normal that a cable that has worked for weeks without any problems and is not exposed to any mechanical stress can suddenly fail to work with aaw?


Senior Member
Jun 5, 2012

2.1.0 will also have a firmware based workaround/hack coming up.

This is not a problem in AAWireless, but in Android Auto/HU. MA1 has the same issue, confirmed with @psmedley .

Kinda odd AAGateway works, have to check what's different over there. Did you ever use The AAGateway solution before on this car?

EDIT: Actually think I might know why AAGateway works. Do you by any chance have the "Non ROOT mode" option enabled in AAGateway? When "Non ROOT mode" is enabled, AAGateway does the same "hack" as AAWireless does with firmware 2.1.0.
Works for me now :)
  • Like
Reactions: psmedley


Apr 12, 2016
Is the "Experimental Client Hot Spot" option for running a hot spot on the same phone AAwireless is running on, or just for hot spots on other devices?

I tried it on the same phone, and it did not seem to work (My AAWireless would connect to my hot spot, but my phone could not find the AAWireless).


New member
Aug 16, 2022
Hey @Snirpo @Emil Borconi i want to go back to stable channel. You pushed 2.1.0 on my request to my device. Pls reverse that change and provide me with stable version of the firmware since 2.1.0 has started in stable phase. I want to be on stable for my device name attached in [Screenshot](https://imgur.com/a/R0jFd6L). Thanks u/Snirpoo


Oct 13, 2014
Hello everyone,
Is there someone who has a OnePlus 7T working with AAWireless? If so, can you tell me (PM maybe?) your phone WiFi & network settings plz ?
Mine doesn't work anymore and support says "it is not a AAWireless problem, it is a phone one"; and I need to "allow to use mobile data while you are connected to a Wi-Fi network. Once you enable that it should work."
I doubt it a little (as when my phone tries to connect to the AAWireless WiFi there is connection error before being connected), but I prefer to be sure.

Thanks in advance


Senior Member
Nov 19, 2010
Android Auto Auto version 8.012304 has already been released. Has any one installed this in their phone?Does it have the much talked about Coolwalk features? Anybody please give review of it?


Senior Member
Nov 13, 2009
Google Pixel 4a
Google Pixel 5
Android Auto Auto version 8.012304 has already been released. Has any one installed this in their phone?Does it have the much talked about Coolwalk features? Anybody please give review of i

Android Auto Auto version 8.012304 has already been released. Has any one installed this in their phone?Does it have the much talked about Coolwalk features? Anybody please give review of it?
I already have version 12.123204 and no coolwalk yet. Supposedly it's up to Samsung, since Coolwalk is causing problems there.
  • Haha
Reactions: TheUntouchable


Senior Member
Nov 13, 2009
Google Pixel 4a
Google Pixel 5

Top Liked Posts

  • 1
    My Samsung Fold2 is not rooted and is running on Android 12 OS.It is having Android Auto Version 8.1.626424 and is connected wirelessly with Blaupunkt San Andreas 970 Car head unit.How to add the Sygic Navigation App in my phone to the car screen?
    I have it - just install on your phone . If I remember well, Sygic AA compitability is premium option, so you need to activate/subscribe for premium and it will appear in AA.
    Thank you,valeri.I also had Sygic Installed in my and purchased Premium licence through Google Playstore.Sygic also shows my Premium licence in it's Settings.Also it is worth to mention that Sygic appears in the Car screen when the phone is connected to the Car unit with USB Code.I issue of absence Sygic App occurs only when the phone is connected with the Car Unit WIRELESSLY.Would any one suggest a fruitful solution please?
    Strange, it did appear in wireless connection, but to be honest I haven't used it recently. Going to check that later.
    Sure, what's the name of your device? (AAWireless-xxxx or AndroidAuto-AAWxxx). I'll enable the previous firmware. I don't think this is because of the firmware though, but please provide feedback when it helped.

    So, today I immediately downgraded to 2.0.2.
    Didn't reset anything or make changes to the settings.
    Driving 1h 15m I had not a single issue. Everything worked perfectly fine. I even had 3 stops in between.

    So to me it seems the downgrade really helped.

    Something that came to my mind additionally.
    I use a radar/crash warning app which I start on the phone and it announces warning via audio.
    With the 2.1 it stopped working with car audio pretty fast and then the announcements came from the phone speaker. Now back to 2.0.2 the announcements are comuing from the car speaker again.

    Just hit me up if I can help somehow. I could go back to 2.1 and log stuff if that's possible and then go back to 2.0.2

    Also would you suggest that I upgrade to the next version (maybe 2.1.1) if available. Possibly I'd need to downgrade again if it's as bad as 2.1 and I guess I would have to hit you up to be able to do that?
    Perhaps your WiFi frequency for the AAW dongle changed. Some radar detectors use WiFi frequencies, I think.
    it's just a smartphone app using gps. it's not a detector - only shows map POIs
  • 7
    For everyone who created a translation. We've just pushed app version 2.23.0 to the Play Store which includes all fully completed (100%) translations. Thanks!
    I'm still using the Ottocast in one of the cars. Now something finally makes sense as it only says Carplay and it's been confusing since the start. There is a great new startup UI that is a big improvement, that I think is in beta. The first was terrible at connections but the second connects up rock solid every time. It does have some audio issues but seems to be getting better each time. I didn't find the FW update process to be difficult.

    I may swap this with the other VW to test the Assistant audio issue I have.
    We're also looking into doing AA via CarPlay protocol. This will definitely help on some cars with horrible Android Auto implementation.
    I'm afraid you diddn't understand Snirpo answer : so many available features are amost not used, so developping new feature for very few people is not realistic...
    Yeah I don't know, theoretically (and possibly als practically) we could implement something like Miracast. Personally I'd never use it. I think screen mirroring sucks. But if there's lots of demand for it, I guess we could look into it.
    I guess we can open some kind of poll for features. First need a list of features though.
    The bug in MIUI is there for around a year. It has same behavior with native (factory) enabled wireless Android auto units. So until you stay with MIUI you can't use wireless AA even if you buy new car.
    To enjoy wireless AA, IMO there are two options only:
    - change the phone
    - unlock bootloader and flash an AOSP rom (this is what I did and all working great on Mi 11 (venus)

    By the way, once you try wireless Android auto (does not matter native or by any dongle on the market), you will never regret for changing the rom or the phone....
    Here's the same problem on an MA1:
    In general I'd advice NOT to buy an Xiaomi phone if you want to use Android Auto Wireless. They have been sh*t since the beginning. Older MIUI had no mobile internet while using AA Wireless. MIUI > 12.5 has these disconnection issues when mobile network reconnects.
    Huawei is also horrible for Android Auto Wireless.
    We decided to only support phones from the official list of Google (https://support.google.com/androida...py=,android-auto-on-your-car-display-wireless), cause it's just not maintainable anymore.
  • 42
    This thread is dedicated for AAWireless users.

    AAWireless is a device which allows you to transform your existing wired Android Auto compatible unit into a Wireless Android Auto unit.

    General chat, experience sharing and community support should be expected as well as support from the developers of the product: @Snirpo and myself.
    I used to get the same thing. I believe it is an issue with AA/Google rather than AAW. In any event, I have had to give up on AAW as I can't connect to it/won't update, just sits there with a constant light-blue light. It is a (very expensive) paper weight on my desk now. It is just "too Beta" for my requirements.

    I have now got a Carlink 2022 Android box which works flawlessly for me.
    MG ZS EV 2022
    Galaxy S21 Ultra (not rooted)
    I know I should ignore these posts, but these are the comments why I'm honestly considering completely dropping out any forum / reddit / social media. What's the point? We have support, we have warranty, we have a refund policy. It might be "beta" for you, but we shipped over 100k devices and believe me or not, for most, it just works. It's the same thing for all of these dongles. They will not work perfectly for all, there are just too many variables.
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    Very close to release of 2.1.0 now. We fixed the UConnect issue, except for some cases where you still have to re-plug the device, but this is also the case on the MA1.
    We fixed the "VW Headunit crashing on skipping tracks" issue now completely. Confirmed it's a bug on the HU side, latency makes it worse. We will probably push a new firmware by the end of this week.
    I will also submit a bug report to Google, cause they can fix/workaround this issue as well for cabled users.