AAWireless - General discussion and support

Search This thread

urmanio23

Senior Member
May 30, 2013
81
23
Xiaomi Mi Mix 3 5g
Autostart should stop you having to manually open the app on your phone then reconnect in the mornings. Do you have a YT Music subscription? Google doesn't allow background play without a sub. I noticed the detection is not perfect on Android Auto. A popup stealing focus can be enough to stop play. It also happens if you switch to maps or another app obviously.

If it’s just random audio dropouts then I would make sure you don’t get the same issue with Spotify or another app as it could be an AAWireless setting like using 2.4GHz instead of 5GHz WiFi.

If you mean that Android Auto disconnects completely and it’s not just YT Music then that will be the long standing MIUI issue. For some reason, Xiaomi cut the wireless signal whenever your phone drops the mobile data connection. If you lose signal or even switch from 4g to 3g then WiFi gives up too and AA will disconnect. If you stick with the official ROM then only Xiaomi can fix this issue.
Both situations are true, the AAwireless disconnect from my phone randomly a couple times each time I'm driving, could be the described issue but I'll have to further test this.

The second issue is probably MIUI energy saving options being too aggressive but the auto start option seems to have solved that.
 
  • Like
Reactions: festor

joenforcer

Member
Jan 2, 2013
9
3
Hm that means the pairing on the device side is still there, but it cannot connect because the pairing on the phone side is gone. The only reason I can think of is the phone automatically clearing up the bluetooth pairing when the companion app is not used for a while. Could you possibly delete the AAWireless companion app and pair to the device manually via bluetooth settings of the phone? If it doesn't unpair after a while when pairing manually, this problem is possibly related to the "Companion device" functionality in Android, which we use to pair to the device from the setup in the companion app.
I think this worked, thanks! Seems to connect quicker now but that could be confirmation bias.

Another issue I have is that almost every time I try to use navigation it can't lock on GPS the first time. If I toggle GPS off and on on my phone, it starts to work again and generally works until the next time AAW is turned off and on. Any idea what causes this and a possible fix? From some other comments, it sounds like I may not be the only one.
 

Cryptage

Member
Mar 26, 2010
13
3
@Snirpo : there are a lot of changes on translation these days. :oops:
Sometimes it's not really easy to know in which context the text is used.
It could be great if we could have an AAWireless emulator, if possible ?
 
  • Like
Reactions: Mischell53

Snirpo

Senior Member
Jan 23, 2007
556
652
Good idea!

It's almost impossible to always get down to the car, reset AAW and start over again just to see the new strings.
I've been wanting to do that for quite a while, adding a dummy device. It will come, at some point. Also planning to add "live" translations, that's possible with the translation service we're now using (Crowdin). But yeah... priorities.
 
  • Like
Reactions: osm0sis

-Loom-

Senior Member
Nov 5, 2010
360
74
Düsseldorf
I've been wanting to do that for quite a while, adding a dummy device. It will come, at some point. Also planning to add "live" translations, that's possible with the translation service we're now using (Crowdin). But yeah... priorities.

A dummy device is a brilliant idea! That would make translation work a *lot* easier!
 

Genebaby

Senior Member
Dec 11, 2013
793
108
Nice review. How long have you been using it for now? Some issues show up down the line after it all initially looks good, or a function such as a missed call happens and you realise there is a glitch.
 

tuncan

Senior Member
Dec 30, 2010
382
36
www.kacnje.eu
Tnx.
I've been using it for two months. I agree with you. Many things show issues after a longer period.
There was one minor update to the Carsifi app (not firmware for the adapter). After I set it, it simply works and I didn't have problems with it, except for some disconnections in the same places. I "found" two of them - circle cca 50-100 meters, where it simply disconnects while driving. But it reconnects back very quickly without any intervention.
Conclusion: I'm very happy with Carsifi as you can read in the review.
 

Snirpo

Senior Member
Jan 23, 2007
556
652
Tnx.
I've been using it for two months. I agree with you. Many things show issues after a longer period.
There was one minor update to the Carsifi app (not firmware for the adapter). After I set it, it simply works and I didn't have problems with it, except for some disconnections in the same places. I "found" two of them - circle cca 50-100 meters, where it simply disconnects while driving. But it reconnects back very quickly without any intervention.
Conclusion: I'm very happy with Carsifi as you can read in the review.
Review with affiliate link. Smells funky.... Anyway... Smart move I guess 😂
 

tuncan

Senior Member
Dec 30, 2010
382
36
www.kacnje.eu
Sorry, I apologize. It would be nice to let you know here in the forum. I agree.
I don't have any other connection with them and it is just my honest opinion without trying other adapters. Everybody can use their clean link. I apologize again.
UPDATE: I want to edit my post on the blog with a notification about the affiliate link and I notice that it was already done (in Conclusion).
 

Pipo093

New member
Dec 1, 2022
4
0
hey i received the last days my AAwireless dongle.
Today i wanted to start it in my Hyundai I30 (2019) but i had some problems.
After first pairing i downloaded the latest firmware.
Then the dongle startet flash green and flash blue and then red. So i don't get a connection to my car head unit.
On my second try it only flashed blue and then read.
Smartphone is a Oneplus 8T with Android 12.

Can someone tell me what i make wrong?
 

Jerky_san

Senior Member
Mar 30, 2011
111
40
I received an AAWireless that I have been using for my 2017 Bolt EV. The only thing that is weird about it is literally every time it starts android auto it acts like it's the first time I've used it with a warning notification asking me to hit "continue". Is there a way to stop it from doing this prompt it never did this wired but for some reason using AAWireless it does it literally every single time.
 

Medic97

Senior Member
Jul 9, 2010
423
32
Anyone else using the Wifi feature notice touches don't always work? While using google maps it sometimes wont register a touch.
 

TheFerhatKing

Senior Member
Jul 22, 2012
866
241
Any chances you are launching a Christmas discount or something similar :) ? I didn't catch the 10% discount on time.. I also would buy AAWireless while it was at Indigogo but I don't have a credit card.
 

derek0309

New member
Dec 3, 2022
1
0
I can’t see in my video that it is constantly connected and disconnected. This situation is repeated within a few minutes. I have changed several cables and nothing has worked. I believe that many people have my problem. With the same situation, they also can't find the problem
I am also having this exact same issue, all of a sudden when I start the car, AAWireless just keeps connecting and disconnecting my Android Auto non-stop, it is 100% unusable, no changes / updates were made to the phone or the device.
 

Pipo093

New member
Dec 1, 2022
4
0
I am also having this exact same issue, all of a sudden when I start the car, AAWireless just keeps connecting and disconnecting my Android Auto non-stop, it is 100% unusable, no changes / updates were made to the phone or the device.
also got this problem. smartphone says searching for android auto and AAwireless flashes in green, blue and red :(
 

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    @Snirpo
    Just (perhaps) a stupid question: is it also possible to add another device to AAWireless Wifi?

    For explanation: I ordered a dashcam. I did not receive the dash cam yet.
    The dashcam provides the possibility to get connected to a WiFi router so that I can download the files and live view the dash cam. But it's not possible to be connected to AAWireless Wifi and have another hotspot or Wifi connection at the same time with my phone. Therefore my idea was to connect the dash cam to the same Wifi like my phone (in this case the AAWireless Wifi).
    Yes you can, AAWireless hosts a hotspot. Password of the hotspot is uppercased sha1 of the full SSID. I don't know what performance impact this has though. But I expect none, cause the wifi has more than enough bandwidth.
    7
    I'm a bit confused. I have received the AAwireless yesterday but haven't used it yet since my car is still in the shop.

    I'm reading all these requests about adding device ID's to dev firmware, connection issues etc. Wouldn't I just be able to plug and play and use the device (after updating it) without issues? Or do I need to flash other firmware etc. to get it working properly?

    Sidenote, can I already update this device without having access to my car?
    No, it is plug and play for 90+% of the users. The problem with these kinds of topic is, wherever it's located, reddit, XDA etc, it's mostly about issues.
    So when reading this you might think the device sucks. And for some people, that might be true. Although in alot of cases it's not the device at fault, but Android Auto itself, or the phone or the head unit, or all things combined. And for sure AAWireless is also not perfect, we can still improve and tweak stuff.
    Yes, you can update when powered through any USB port :)
    3
    Tnx for the update, I just saw it in Play Store.
    But the bane of my device changed after resetting. (?!?!)
    It was AAwireless-xxx , now changed to AndroidAuto-AAWxxx?!

    It doesn't supposed to change?! And what's the difference?
    AndroidAuto-AAWxxx means your device is in dongle mode, that's how it's triggered, by the AndroidAuto-xxx. That's what you normally want, and is default on new devices. The reason why we still have "normal" (native wireless HU emulation) mode as well has multiple reasons.

    1. Device priority from AAWireless itself won't work in dongle mode, because how Android Auto is designed to work in dongle mode.
    2. Because dongle mode didn't exist before the MA1 was released, so we kept it as an option to turn it off. This is to avoid potentially breaking people's setups when updating their device. When it's off, it will stay off on firmware update, until you reset the device or switch it off manually.
    3. For some phones / cars, for some reason, in dongle mode it will just never start up AA. We have no idea why, it doesn't make any sense, we have yet to see a pattern. Turn it off and it will work fine. These kinds of issues come and go, so is probably just brokeness in Android Auto itself.
    3
    Snirpo is fully right.
    Of course I only post in this thread when I have an issue. Nevertheless my AAWireless connects perfectly in about 99.5% of my drives.
    It is stable. In my opinion the AAWireless device works more reliable than my phone. Some issues are also phone related and not AAWireless related.
    I normally only post for the 0.5% of my drives.
    3
    @Snirpo I would also appreciate that approach :)

    Just a little site question: Is start/stop still companion app based? Or were your tests on device based start/stop already successful?
    We have two experimental options in the app from Firebase App Distribution (private beta build).

    - Device HFP (to car) controlled. This will not work in 90 percent of the cars, because of the handsfree not being visible / connectable to non-paired device. In theory we could pair the AAW device to the handsfree of the car, but that will cause a whole lot of other issues.
    - Device USB controlled: May work for some cars, AAW tries start up an AA connection to the car every x seconds, if not possible it won't connect to the phone. This might work for cars which keep USB powered, but do shut down the HU (and thus also AA).
    But for example on Kia / Hyundai AA actually keeps running in the background (with screen off) after you turn off ignition. So for these cars this functionality won't help at all, because AA doesn't get killed, it's still running.

    Both these options have been tested, but we found them not really usable. They are either not reliable or cause side effects. So they have never made it to production. They are still in the firmware though.

    So to answer your question. We tried, but did not have success. So right now (in production) start / stop is still companion app controlled.
  • 42
    This thread is dedicated for AAWireless users.

    AAWireless is a device which allows you to transform your existing wired Android Auto compatible unit into a Wireless Android Auto unit.

    General chat, experience sharing and community support should be expected as well as support from the developers of the product: @Snirpo and myself.
    20
    I used to get the same thing. I believe it is an issue with AA/Google rather than AAW. In any event, I have had to give up on AAW as I can't connect to it/won't update, just sits there with a constant light-blue light. It is a (very expensive) paper weight on my desk now. It is just "too Beta" for my requirements.

    I have now got a Carlink 2022 Android box which works flawlessly for me.
    MG ZS EV 2022
    Galaxy S21 Ultra (not rooted)
    I know I should ignore these posts, but these are the comments why I'm honestly considering completely dropping out any forum / reddit / social media. What's the point? We have support, we have warranty, we have a refund policy. It might be "beta" for you, but we shipped over 100k devices and believe me or not, for most, it just works. It's the same thing for all of these dongles. They will not work perfectly for all, there are just too many variables.
    16
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    15
    Very close to release of 2.1.0 now. We fixed the UConnect issue, except for some cases where you still have to re-plug the device, but this is also the case on the MA1.
    15
    We fixed the "VW Headunit crashing on skipping tracks" issue now completely. Confirmed it's a bug on the HU side, latency makes it worse. We will probably push a new firmware by the end of this week.
    I will also submit a bug report to Google, cause they can fix/workaround this issue as well for cabled users.