• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

AAWireless - General discussion and support

Search This thread

Vreel

Member
Feb 19, 2009
6
1
I have received my AAWireless unit a couple of weeks ago. I use the device on a 2015 VW passat B8 with a MIB2 unit and an Oneplus 8T. After the initial setup and some fiddling around I got it up and running but soon came across the random disconnection problems. I had encountered the same problem when I first tried to use my current phone with cable connection. I strongly believe now that the problem with my setup and probably other similar setups is totally cable dependent. The included cable was not working for me neither a couple of new ones I got from ali recently. A cable included with my previous phone charger (or tablet, can't really remember) was the right one. I have tested it for the last five days including a 4 hour journey today and I had so far zero disconnects, slow start ups or any kind of lags.
So check your cables guys!
 
  • Like
Reactions: kgollop

Snirpo

Senior Member
Jan 23, 2007
160
213
I have received my AAWireless unit a couple of weeks ago. I use the device on a 2015 VW passat B8 with a MIB2 unit and an Oneplus 8T. After the initial setup and some fiddling around I got it up and running but soon came across the random disconnection problems. I had encountered the same problem when I first tried to use my current phone with cable connection. I strongly believe now that the problem with my setup and probably other similar setups is totally cable dependent. The included cable was not working for me neither a couple of new ones I got from ali recently. A cable included with my previous phone charger (or tablet, can't really remember) was the right one. I have tested it for the last five days including a 4 hour journey today and I had so far zero disconnects, slow start ups or any kind of lags.
So check your cables guys!
Well we did exchange the cable in the newer batch because we had to. I guess the new cable (with purple connector) could have something to do with the MIB2 issues.
 
  • Like
Reactions: stan79

Snirpo

Senior Member
Jan 23, 2007
160
213
Any recommended cable to use? I did try the cable that came along with the set on my oneplus 7 pro. It works perfectly but not on AAWireless.
There's no recommended cable to use sadly. Some people have issues with the supplied one, others have issues with others and the supplied is the only one that works. For most it doesn't matter which cable they use.

I realize I have to be a bit careful what I'm saying to not blow things up. To clarify: These cases are very specific, for most people there are no issues. There are a lot of different head units, in a lot of different cars with different hardware and software variances. It's extremely hard to pinpoint exact issues because of this.
For sure there are more issues on some head units in general then others, but it's not like the all the devices (or cables) from the newest batch will not work with (in this case) MIB2 head units.
 
Last edited:

stan79

Senior Member
Dec 21, 2005
117
5
Nvidia Shield Tablet
OnePlus 5
There's no recommended cable to use sadly. Some people have issues with the supplied one, others have issues with others and the supplied is the only one that works. For most it doesn't matter which cable they use.

I realize I have to be a bit careful what I'm saying to not blow things up. To clarify: These cases are very specific, for most people there are no issues. There are a lot of different head units, in a lot of different cars with different hardware and software variances. It's extremely hard to pinpoint exact issues because of this.
For sure there are more issues on some head units in general then others, but it's not like the all the devices (or cables) from the newest batch will not work with (in this case) MIB2 head units.
Yes, I do agreed with U. VW MIB2 is cable dependant even using wired connection on AA. I have 2 original OnePlus cables but they don't work well.
 

Vreel

Member
Feb 19, 2009
6
1
There's no recommended cable to use sadly. Some people have issues with the supplied one, others have issues with others and the supplied is the only one that works. For most it doesn't matter which cable they use.

I realize I have to be a bit careful what I'm saying to not blow things up. To clarify: These cases are very specific, for most people there are no issues. There are a lot of different head units, in a lot of different cars with different hardware and software variances. It's extremely hard to pinpoint exact issues because of this.
For sure there are more issues on some head units in general then others, but it's not like the all the devices (or cables) from the newest batch will not work with (in this case) MIB2 head units.
I also agree with you that's why I mentioned my specific car + head-unit + phone setup (MIB2 and oneplus 8T). With my previous phone (pocophone F1) I didn't have any problems using a wired connection to the MIB2 unit. With the 8T I had all sorts of problems from day 1, from connection failures to lagging and random disconnections until I found a suitable working usb cable for my setup. So the solution to my AAwireless & head unit combo was kinda obvious that it was cable dependent.
 

jv.batista

Senior Member
Jan 25, 2011
895
180
33
Faro, Portugal
OnePlus 8T
well, now that you mention cables that reminds me an episode that I had a few weeks ago where my 8T wouldn't connect to my moms Opel Corsa but my previous phone, a Nokia 7+, would connect just fine. I'll swap the cable just in case
 

smurteira

Member
Jan 1, 2010
9
0
Could you pass me your device name (AAWireless-xxxx). I'm curious from which manufacturer the head units in both cars is.

Got it, the 2018 VW has a Delphi HU == good.
2017 VW has a Technisat HU, in general these head units suck (for AA). However the VAG fix should help, you could try to turn it off and see what happens, or try passthrough mode.
I tried those settings and just about every other setting, including changing the DPI and still have disconnects. Unfortunately VW doesn't seem to have fw updates for their USA units, at least not that I could find.
 

smurteira

Member
Jan 1, 2010
9
0
I tried those settings and just about every other setting, including changing the DPI and still have disconnects. Unfortunately VW doesn't seem to have fw updates for their USA units, at least not that I could find.
Spent some more time today and tried 5 different cables, one of them the original cable sent by Samsung and still no luck, tried different settings and still no luck. I'm convinced the issue is between the MIB 2 HU and AAWireless. Hopefully it will get fixed in the next release.
 

stan79

Senior Member
Dec 21, 2005
117
5
Nvidia Shield Tablet
OnePlus 5
Spent some more time today and tried 5 different cables, one of them the original cable sent by Samsung and still no luck, tried different settings and still no luck. I'm convinced the issue is between the MIB 2 HU and AAWireless. Hopefully it will get fixed in the next release.
Not sure but it seems that the shorter the cable the better it is? More electric power to the AAWireless? None of the 1m cables even the original oneplus cable are able to fully boot up AAWireless beyond blinking green or blue light. Only the supplied one which 50cm long is able just that it will disconnect within seconds.

Another question that I had is whether a real USB 3.0 type a to USB 3.1 type c cable vs a USB 2.0 type a to USB 3.1 type c cable makes a difference? Basically a USB 3.0 cable will have a much bigger bandwidth for data vs USB 2.0 cable.
 

Genebaby

Senior Member
Dec 11, 2013
715
89
You also want to make sure it's a cable with a good rating for data. Any old cheap cable is sold for charging, but you want one with good data transmission, the kind you would use if you were doing things like updating the FW on your PC.

I'm still looking at a cable in the 30cm range, I don't need it long at all.
 

kgollop

Member
Jul 24, 2021
8
2
Not sure but it seems that the shorter the cable the better it is? More electric power to the AAWireless? None of the 1m cables even the original oneplus cable are able to fully boot up AAWireless beyond blinking green or blue light. Only the supplied one which 50cm long is able just that it will disconnect within seconds.

Another question that I had is whether a real USB 3.0 type a to USB 3.1 type c cable vs a USB 2.0 type a to USB 3.1 type c cable makes a difference? Basically a USB 3.0 cable will have a much bigger bandwidth for data vs USB 2.0 cable.
I was getting constant disconnects with a 10cm cable that was previously working flawlessly for wired connection. Since switching to the supplied cable I've had no issues
 

stan79

Senior Member
Dec 21, 2005
117
5
Nvidia Shield Tablet
OnePlus 5
You also want to make sure it's a cable with a good rating for data. Any old cheap cable is sold for charging, but you want one with good data transmission, the kind you would use if you were doing things like updating the FW on your PC.

I'm still looking at a cable in the 30cm range, I don't need it long at all.
The question is how do u tell if it is a good cable for data transmission? Look for minimum an USB 3.0 cable?
 

Genebaby

Senior Member
Dec 11, 2013
715
89
Sometimes cables have their throughput specs on sites, other times it's pot luck and looking at reviews.

For me, I had good, then bad luck with my 30cm cables from before and ended up back to the supplied cable, from the very start of production, but it is just too much cable down there for my liking long term.

To save you reading everything, things were fine with my shorter cables, till one drive they weren't and I tested and things worked with the original cable, so I'm still using it.
 

benhur06

New member
Aug 15, 2020
4
1
On many of the devices, the USB port is a bit too far back, or the cover is a bit too thick. It takes a USB cable with a longer reach on the USB-C connector to make a solid connection.

You also want to make sure it's a cable with a good rating for data. Any old cheap cable is sold for charging, but you want one with good data transmission, the kind you would use if you were doing things like updating the FW on your PC.

I'm still looking at a cable in the 30cm range, I don't need it long at all.
I suggest you to read my post here:
 

1qazwsx4

Senior Member
Sep 19, 2011
502
289
New Zealand
For those asking what cables work, I use a short one branded "ugreen" from AliExpress. I actually use their cables for all my tech to be honest because they've always worked great. I'm not affiliated in any way, just wanting to give some advice that may help people... Using aawireless on my late 2018 Holden zb commodore (Buick Regal/Opel Insignia in other countries) zero disconnection issues, connects fast etc.
 

HansWursT619

Senior Member
Jan 11, 2011
106
16
Is there a manual connect/disconnect option other than powering off the device?
Sometimes the connection does not automatically connect.

Could this be an option in the app?


Secondly. Is there a way to disable wired android auto? When connected to charg both options are displayed in my headunit and I am not sure if this is causing any issues. The phone is already set to "charging only", but that does not seem to work.
 

Top Liked Posts

  • 1
    Many people have this problem too, I've personally had this bug since I changed my HU last year even with wired AA (phone is galaxy s10+), now the same with AAwireless, so I think this bug isn't because of AAwireless but AA and/or HU/phone. I already tried many things but still can't fix it because it's intermitten


    I am also experiencing similar issues using Poco F3.
    When I receive a call or make a call it restarts android auto conenction and switched the conversation on my smartwatch.

    If i disable the call option on the smartwatch then when I receive a call/or make a call then AAwirelless will disconect and reconnect and the call will resume on the car's headunit. In the meantime I will have 5-6 secs of dead time while the other party already starts speaking.

    I was not experiencing this a couple of months ago when I started using AAwirelss and the only thing that changed since then was the AA app I guess :/
  • 3
    I wanted provide an update on this to see if anyone has any idea. I ended up downgrading the firmware on my cars head unit to the version that was working perfectly previously. I still have the same situation. Using a cable to my phone AA works perfectly. Using the AAwireless device, my phone connects and prompts me to open AA on my cars head unit however the icon to click on the head unit screen is not there. This behaviour only happens when using the AAWireless device. I am thinking now this is a Android 12 issue and perhaps something updated on my phone around the same time the firmware in my car was updated. Is there anything I should be doing to provide logs on this? There is not really an error I suppose on the AAwireless side but something seems to not communicating correctly. I will be testing on another car to see if the problem persists or not in the coming days.
    We have a support overload since Android 12, it ain't funny... Emil and myself have (almost) zero issues on our Pixel 6s. The only thing I experienced once or twice is Bluetooth cutting out on the Pixel, have to reboot the phone to get it to work again. Stuff is broken for sure... For some it works fine, for others with seemingly exact the same situation it does not. We're trying to find solutions, but we're already pretty overloaded with everything going on.
    2
    Wouldn't recommend downgrading your device (requires @Snirpo or another aawireless dev to do this) because then like me, you'll be stuck on firmware 1.5 with no explanation why someone people are on 1.7.1 and others are stuck on 1.5 and no option to update. I'm also a first gen aawireless AAWireless-eSs19MUQ
    Explanation: some batch 4 devices have been flashed with batch 3 firmware, and at this point we have no way to differentiate them from the backend automatically. So batch 1, 2 and 4 are save to update, batch 3 not, because it could also very well be an batch 4 device. It's causing havoc cause the backend is not really set up for this situation. For now we are only doing manual updates for batch 3 devices.
    2
    Hi !

    I got my AAWireless today. Updated to 1.7.1, and used it with a Pixel 6 Pro on a Hyundai Ioniq 2020 (with the April 2020 head unit SW update).

    It's working fine for ... a few minutes. Then it disconnects. I had about 4 or 5 disconnects on a 15mn trip today while using intermittently maps, spotify or both.

    When it happens, it looks like the LED stays blue, the head unit says the phone disconnected, the phone things AA is still on, and based on feedback from my passenger fiddling with the phone, AAWireless app on the phone still thinks it's connected to the device.

    If you wait long enough (a couple of minutes) it eventually comes back. That or disconnect/reconnect.

    All settings are default.

    Any suggestion ? I couldn't figure out what to do with the "debugging" mode... that said I'm a SW engineer so given instructions I can probably dig out logs etc...
    2
    Some info that may provide some insight to others. I'm using an Xiaomi note 9s (Curtana) and while running MIUI EU 12.5 I have issues with AAW after a call ends it plays through my phone's speakers instead of the headunit speakers. This is a well known bug from MIUI. I tried flashing a few different android 11-12 ROMs and ALL had issues with AAW from aosp ROMs to official lineage os (android 11) and gave up on the idea of a bug free experience.

    However, I flashed a build of MIUI EU 12.6 and I now have a BUG FREE EXPERIENCE of AAW - no dropping out, calls work without disconnecting/sound going through incorrect sources etc.

    My point being: this is XDA - we flash different ROMs some of which are buggy to high hell. If you're having issues with your phone and connections etc please try using a stable ROM or change your ROM to check if you have any luck connecting/resolving bugs. There are plenty of aftermarket ROMs here where android auto via USB functions great but wireless is bugged (looking at you lineage os) just my two cents
    2
    I have a Samsung s21 Ultra on the Android 12 beta. Everything works perfectly for me so far. I haven't seen the change your referring too though.
  • 30
    This thread is dedicated for AAWireless users.

    AAWireless is a device which allows you to transform your existing wired Android Auto compatible unit into a Wireless Android Auto unit.

    General chat, experience sharing and community support should be expected as well as support from the developers of the product: @Snirpo and myself.
    16
    I just want to leave a big THANK YOU for the developers! You invented a great product and do a great job here.

    Anyone who has ordered the product knows that it is a crowdfunding project, which may also have teething problems. I find it cheeky to get upset about problems, even though they are dealt with promptly here. What more should the distributors do than react to the problems here and offer solutions?

    I also have problems with the device, but I was helped quickly. Even if it takes a few days.

    Dear team: Keep up the good work!
    15
    We fixed the "VW Headunit crashing on skipping tracks" issue now completely. Confirmed it's a bug on the HU side, latency makes it worse. We will probably push a new firmware by the end of this week.
    I will also submit a bug report to Google, cause they can fix/workaround this issue as well for cabled users.
    14
    I've already waited patiently for delivery 3 months more than expected - I ordered In April and was coming in June but now that's looking like October. Now I read on the indiegogo forum that people in the UK are being charged an additional €27 by the Royal mail as the UK is now not in the EU.

    Hi Emil!
    Just received my AAWireless, and will plug in and test tonight. Love the packaging, looks great! However… Since it was shipped from Hong Kong I was forced to pay a rather substantial import fee and duties on this bad boy. I was under the impression that they would be shipped from within the EU? Is it stands now I’m EUR 27,00 poorer :(
    2 2
    https://www.indiegogo.com/individuals/24534862
    Emil Borconi-Szedressy 2 days ago
    PROJECT OWNER
    Looks like you are in the UK which is outside EU and also there is no way to pre-pay taxes with shipping company any more either....


    This is a crazy. An additional $10 was already taken for delivery and it was meant to ship from the EU. I suspect the units have been shipped by Royal Mail / Dutch post. The Royal Mail rips off people in the UK because they add another £11 in admin fees on top of the 20% VAT even though goods up to £135 should be exempt.
    See https://www.gov.uk/government/publi...s-goods-sold-to-customers-from-1-january-2021

    So not only has VAT been charged coming into the EU from China, it has also been charged coming into the UK ON TOP of the VAT already paid in the EU.

    This is just rubbish. What the guys need to do is either ship it from Hong Kong which can cost £0.20 (there are hundreds of chinese ebay and aliexpress sellers doing this already
    See http://www.vatfraud.org/blog/stop-s...ons-universal-postal-union-upu-terminal-dues/
    The $10 postage already taken should then be refunded.

    The other way round it is send the item from Hong Kong and to mark the item as a gift and providing it is below £39 there is NO VAT to pay and NO Royal mail admin fee. Actually as the original product was $57 - roughly £41.25 This wouldn't be a crime seeing as we have had to wait soo long. This could also mean the $10 delivery could be refunded

    The other way is to ship it via fedex and state the ex-vat cost coming from china and then add 20% vat that the developer should be paying to the UK HMRC.

    Sadly if that doesn't take place, EVERYONE IN THE UK will feel ripped off because of the poor delivery and poor choices made by the developers.

    Cheers
    Disgruntled in the UK

    First of all, your item wasn't shipped yet since in the June batch, so you could have not payed anything for shipping. Secondly, UK is outside the EU, there was a vote about this in 2016, so it doesn't matter if the package comes from EU or from HK or from US, it is treated the same, it's an import. If we import it from HK to EU, we will pay import VAT on the product, then when we send it to UK, we claim back that VAT and we should pay VAT in UK, since there is no more free trading between EU and UK.

    Up till recently there was a nice option, to pay VAT and Import duty up-front, when you ship to the UK, but this has been changed and now they requires business outside UK to register with HMRC and do HMRC feeling even if they are residing outside UK, a lot of red tape. Since crowdfunding is not a sale, we can still ship the units to UK, but not sure if we will be able to after the IndieGoGo campaign.

    We are also a EU registered company so we cannot (and will not take advantage) of any loop-holes in systems to sell at ridiculously / unrealistically cheap prices.

    About the user who paid 27 euros, it turned out that user is living in DK, but provided the address as UK so his package traveled the wrong way, hence the extra duties and surcharges.

    Not aware of other users from UK having to pay anything additional when they received the package.
    14
    Hello. What's new in 1.5?
    A full changelog for each release would really be appreciated :)
    Thanks for all the hard work!
    Yes, I'll write a full changelog next week from 1.0.0 to 1.5.0 and put it on GitHub + add a link in the app.