[AAWireless] Possible workarounds to get internet connection on MIUI while AA is connected wirelessly

Search This thread

kalhimeo

Inactive Recognized Developer
Jul 3, 2007
264
32
Brussels
It worked for me with my Mi 9 as well, thanks a lot for the tip !

Note that I would not get the "Use mobile data" prompt (only the "switch network") while I was in the range of my home wifi network.
 

Wiesel1985

Member
Sep 29, 2019
9
0
Please let me know if that works for you, too
Hello @usedr ,

it worked. Thank you. But is their any solution to allow the usage of the mobil data automaticly? Now I have to allow it everytime. So the wireless AA is useless, if I have to put the Phone out my pocket everytime.

Xiaomi Mi 9T pro
I use this settings: https://cpeb.freshdesk.com/support/solutions/articles/80000527154-xiaomi-no-internet

Except the Wi-Fi assistant, its off. But traffic mode is active.

Kind regards
 

ericvives

New member
May 20, 2021
2
0
@usedr 's workaround works fine on my Mi 9T pro. But people are right, you seem to nees to allow data everytime your phone connects to AAW wifi...

Man there should be an easy fix to this.. but I can't figure one out 😭
 

saclefr

New member
Oct 2, 2012
4
0
Hello,

At home I have a Poco F3 (Miui 12.0.5, Android 11) and Mi Mix 3 (Miui 11.0.5, Android 10)

No issue with the Poco F3 but I have the no-internet-issue with the Mi Mix 3.
It was expected because I already read a comment about that on aawireless page. The guy changed the ROM.

I will search a few a solution on MIUI, else I will change also the ROM to another one on Miui 12 + Android 11
 

Dehumanizer77

Member
Apr 9, 2011
30
0
Hello guys, I think I has just been able to pin down the problem.
I don't have AAWIRELESS yet (ordered it today :) but when I have read that there is this problem with Xiaomi phones not having internet connection I was thinking about canceling the order, as I have a stock MIUI ROM and I'm not in a mood in changing ROMs (although I might consider it if there was absolutely no other way since wireless Android Auto is really cool).
I came across this thread and read through usedr's workaround and I thought I might try how the wifi connection/mobile data works on MIUI when a phone connects to a wifi without the internet connection.
I have a wifi network at home where an internet connection is not allowed (for home cameras etc. which I don't want to connect to the internet) so I have connected to that wifi. The dialogue with the "switch connection" came up, of course.
Then I completely removed my regular home wifi and only left the non-internet one. I have disconnected and connected back to the wifi without internet and boom, I got the dialogue with "use mobile data".
Next, I have added my regular wifi back and tried it again. "switch connection" again...
So I have disabled auto connect to the regular wifi in the wifi settings (there is "auto connect" switch right at the top when you go to the wifi details), tried it again and that's it! I was once again getting "use mobile data".

So, TLDR: The MIUI won't let you use mobile data if there is another wifi connection available around you which 1. you have properly set up in the phone and 2. it is set to automatically connect.

Thus, there is no elegant solution, but if you disable autoconnect to any wifi connection you might be around when you are connecting to the AAwireless wifi, you will always get "use mobile data" option.
Second option is just to drive away far enough from any wifi you might have access to and connect to the AAwireless just then.

Hope it clears at least something. Those of you who have the AAwireless, please confirm that this is the case, I am almost 100% sure it works as I explain but can't try AAwireless yet since I dont' have it :)
 

ericvives

New member
May 20, 2021
2
0
Regarding Xiaomi, we've conducted multiple tests and tried to come up with a workaround for the "no internet while using wireless Android Auto" issue. Unfortunately, fixing this properly is simply not possible with MIUI. The only solution is an upgrade to Android 11 via the official method or via a custom ROM. Therefore we decided to not support Xiaomi phones with an Android version lower than 11 anymore, except for the Xiaomi Mi A1-A3, because they run Android One and not MIUI and thus work fine. We will update the front page accordingly.
Just posting this update here in case someone didn't get it
cheers
 

cronosmachine

Senior Member
Sep 16, 2010
427
419
Although "use mobile data" option when it prompted it seem to be alternative solution, but it giving me nuts sometimes when about to go off you phone only see "keep" or "switch network" because you have remembered other wifi on your own home and office. Keep deleting and adding other network become pain in the ass. And always need to tap that "use mobile data" before go off or on the way.

There is just be some work out on this, flashing other rom is not option for most people. I was planning to get xiaomi Mi 11 with snapdragon 888 but this turn me down so much.
 

exge

Senior Member
Apr 25, 2010
119
24
i used to be using MIUI on my Poco F1 then gave up and flashed PixelExperience on it. Then it can have both mobile data and wifi at the same time.
 

cronosmachine

Senior Member
Sep 16, 2010
427
419
Can we confirmed only MIUI with Android 11 works with AA wireless by default without need to manually added the wireless hotspot and press "use mobile data".

I will time to time checking on this thread, hoping there is solution on this.

Please anytime report problem on this, xiaomi open report issue in android 10
 
Last edited:

Snc69

Member
Mar 25, 2021
6
0
Xiaomi mi note 10 ( miui 12, android 11) - connects, but a very long time (3-5 minutes)
Xiaomi redmi note 9 pro ( miui 12, android 10) - I was able to connect only by instruction from Usedr.
 
Last edited:

mirrormurr

Member
Sep 11, 2017
5
1
Milovice
This may not work on your rom, but as I've run into this problem on my Galaxy S10+, this might help. Note, I am on the AAWireless beta team. These are general instructions, so forgive the simple details.

*********************
If you are having issues with mobile data not being available when connected to Android Auto, there are a few things and settings to be aware of. The following is on my Galaxy S10+.

Note, to enable Developer Settings (aka Developer Options, Developer Mode) in Android, find the Build Number (Settings => Software Information => Build Number) and tap 10 times to bring up a confirmation.

Settings which could affect Mobile Data availability.
1) In Developer Options > Mobile data always active (Turn On)
2) Settings > Connections > Wi-Fi > 3 Dot Menu > Advanced > Switch to mobile data (Turn On) > Network exceptions (Delete the AAWireless device if accidentally added– see below).

************************
If you get a message pop-up when connecting to AAWireless:
"Internet may not be available - If you stay connected to this Wi-Fi network now, your phone will also stay connected whenever you use this network in the future. You can change this in Settings > Connections > Wi-Fi > ADVANCED > Switch to mobile data > Network exceptions." Then it gives two options: "Allow switch" and "Stay connected".

You must respond by canceling out of the choice – do NOT choose either option.

If you choose to Stay Connected, it will add a listing in "Network exceptions" that needs to be deleted. The label for Network exceptions says "Your phone will remain connected to these networks, even if the connection is unstable."

Google made this very confusing.
This solution worked on my setup with the Samsung galaxy s9+ and OpenAuto pro, lots of tearing ones hair saved, thank you, Spindlewood!
 

1qazwsx4

Senior Member
Sep 19, 2011
612
350
New Zealand
Hi all, thought I would stop in to mention that by following the instructions in the FAQ from aawireless I was able to connect my Xiaomi note 9s while running miui, have data enabled and AA working flawlessly from my pocket without needing to touch the phone or headunit. Screenshot below showing my rom etc. I prefer miui still because the latest ROMs are extremely buggy and lots of issues going on...
 

Attachments

  • Screenshot_2021-06-12-19-39-39-193_com.android.settings.jpg
    Screenshot_2021-06-12-19-39-39-193_com.android.settings.jpg
    196 KB · Views: 168

Snc69

Member
Mar 25, 2021
6
0
Updated Redmi Note 9 pro to Android 11, the wireless connection works, it connects quickly and without problems
 

cronosmachine

Senior Member
Sep 16, 2010
427
419
Today just got official update for Poco X3 NFC to android 11. I'm glad it works!!!

Now no longer need to press "use mobile data". However i still using alternative solution, which is the password saved as remembered password.
Screenshot_2021-06-24-09-37-42-227_com.android.settings.jpg
 

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    Unfortunately none of the above solutions worked for me, but...



    After several failed attempts I documented what i did and analysed it properly, so here is a possible fix that works for me (the "problem" that I have to comfirm to "use mobile data" remains, but at least it works).


    Requirements:
    AAWireless is configured and Android Auto works wirelessly (except for the fact that you have no mobile data of couse)

    ====>

    • turn Wifi Assistant OFF
    • while connected to AAWireless wifi go to wifi settings and click on the wifi connection; in MIUI you should see a QR code to share the wifi connection => take a screenshot
    • open the „scanner“ app from miui which can read QR codes
    • choose the symbol that lets you choose a picture from your images on the phone => choose the screenshot you took
    • now it translates the QR code and gives you SSID and password from your AAWireless wifi connecttion. If you only see strars/symbols instread of the password, tap on the password and it will turn into characters and numbers
    • note the password


    • Open the Android Auto app
    • Go to settings and DEACTIVATE the „Wireless Android Auto“ setting (the one that you had to activate to get AAWireless to work in the first place)
    • Close the App completeley
    • Erase your AAWireless wifi in wifi settings, so that the phone isn’t able to connect to it
    • Shutdown AAWireless by unplugging it
    • Shutdown your car completely
    • Plugin AAWireless again (maybe open and close the door in the car so that the usb plug has power => AAWireless will boot up
    • Connect to the AAWireless wifi manually
    • Maybe you get a prompt that asks you if you want to change wifi connection because it has no internet => ignore it
    • Put your phone into airplane mode, wait 10 seconds
    • Deactivate airplane mode
    • Wifi connects to AAWireless wifi
    • It should now ask you if you want to use mobile data, maybe it takes a few seconds until you get asked
    • ALLOW it to use mobile data
    I had to retry it a few times with switching airplane mode on and off until I got the prompt that it wants to use mobile data.

    If it works until here chances are very high that everything will work in then end!


    • Go to Android Auto app and ACTIVATE „Wireless Android Auto“
    • Shutdown everything again, unplug AAWireless, shutdown your car and wait a few seconds => all connections should be disconnected
    • Start your car, plugin AAWireless
    • AA Wireless and Android Auto should startup as it should and after a few seconds you should get the promt again, that your phone wants to use mobile data => allow it
    • Android Auto should work now with internet connection

    Please let me know if that works for you, too.
    2
    As AAWireless gets shipped and people are getting their device, so I think more people are running into the same problem:

    When using MIUI the chance is pretty high that it is possible to connect wirelessly with Android Auto, but there won't be any internet connection. Which makes AA pretty unusable.

    The problem is that MIUI should switch from Wifi to cellular data if Wifi connection has no internet. But it does not switch.

    As I don't want to unlock my bootloader to change to another ROM (don't know which ROM would work on my Mi Mix3 either) and don't want to wait until some updates from MIUI arrives, I startet this thread and hope it is possible that we find a workaround together.

    Some questions/possibilities I have in mind:

    • Is it possible to combine the connection of cellular data and wifi? Then no switch would be necessary because both are connected at all times
      • maybe speedify will work? => tried it, but i couldn't get cellular data to cennect via speedify
    • is it possible to force some apps to only use cellular data?
      • found the possibility in settings to tell apps that they are not allowed to use SIM1 / SIM2, but I was not able to tell Google Maps that it is not allowed to use Wifi. That setting is not changeable
    • Is it possible to emulate a USB connection so that MIUI thinks that the phone is connected. Because when I connect it via USB cable it switches to cellular data and I can use the internet connection

    Maybe some of you can help with that problem as it is very annoying. AAWireless works at it is intended to, the problem is MIUI in this case.
    2
    I struggled with this too, and found no solution within Miui.

    The only solution that worked for me was to unlock the bootloader of the phone and to replace Miui with Lineage OS.
    1
    I tried switching it on, but it didn't work either.


    BUT I got it to work sometimes!

    Let me explain...

    Some days ago I went to my car, opened it, got my sunglasses and walked away from the car.
    Then I got a notification that told me my wifi connection does not have a internet connection and if i wanted to use mobile data. I don't know what happened there, as I didn't even have the ignition on.

    So I went back to the car later and booted up the system. First I ignored the message, knowing that some people wrote in the forum to ignore the message.
    But as I didn't have working internet connection while connected to AAWireless, I tried to let it use mobile data and it worked!!!!
    I was connected to AAWireless and had a working internet connection for the first time!


    The car wakes up as soon as you open the doors and AAWireless boots up. So something did trigger that my phone went into another mode. So it didn't ask me if i want to stay connected to AAWireless or chosse another, stronger wifi, but if I wanted to use mobile data instead. (Wifi Assistant options were off)

    After that I tried turning the Wifi Assistant options on and thought maybe now it would work. But it didn't.
    So I switched the options back off, tried again to connect to the car, but I was back to having no internet when connected.

    The next day I went to the car, it booted up and it worked again! (After confirming to use mobile data when asked) I have no idea why?!

    I used it a few times in the last days. It worked after I confirmed to use mobile data when asked.
    As soon as I turned Wifi Assistant on it didn't work anymore. Tried that several times.
    But sometimes it did not work the first time I went into the car and started it up. Then I had to turn off the car, open the door (12V will be off), close the door and start it again.

    Today it did not work, even after rebooting it four times.

    So I think it has something to do with timing.

    - when the phone connects to what (Wifi, Bluetooth)
    - media system booting before/after AAWireless
    - ...

    But there is hope that it is fixable!

    P.S.:

    - Xiaomi Mi Mix 3
    - stock MIUI 12.0.2 global stable
    - Android Auto 6.2.610914
    - Wifi was connected to AAWireless
    - Bluetooth was connected to the headunits bluetooth
    1
    This may not work on your rom, but as I've run into this problem on my Galaxy S10+, this might help. Note, I am on the AAWireless beta team. These are general instructions, so forgive the simple details.

    *********************
    If you are having issues with mobile data not being available when connected to Android Auto, there are a few things and settings to be aware of. The following is on my Galaxy S10+.

    Note, to enable Developer Settings (aka Developer Options, Developer Mode) in Android, find the Build Number (Settings => Software Information => Build Number) and tap 10 times to bring up a confirmation.

    Settings which could affect Mobile Data availability.
    1) In Developer Options > Mobile data always active (Turn On)
    2) Settings > Connections > Wi-Fi > 3 Dot Menu > Advanced > Switch to mobile data (Turn On) > Network exceptions (Delete the AAWireless device if accidentally added– see below).

    ************************
    If you get a message pop-up when connecting to AAWireless:
    "Internet may not be available - If you stay connected to this Wi-Fi network now, your phone will also stay connected whenever you use this network in the future. You can change this in Settings > Connections > Wi-Fi > ADVANCED > Switch to mobile data > Network exceptions." Then it gives two options: "Allow switch" and "Stay connected".

    You must respond by canceling out of the choice – do NOT choose either option.

    If you choose to Stay Connected, it will add a listing in "Network exceptions" that needs to be deleted. The label for Network exceptions says "Your phone will remain connected to these networks, even if the connection is unstable."

    Google made this very confusing.