• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[AAWireless] Possible workarounds to get internet connection on MIUI while AA is connected wirelessly

Search This thread

AllBlaxx

Senior Member
May 5, 2011
65
16
This may not be helpful to everyone as some might not want to flash different ROMs but I've been using the xiaomi.eu MIUI ROMs on my Mi 10 and have not had any issues with AA Wireless since I got my unit in late May. Haven't had to change any settings or turn on Wi-Fi assistant, it's just worked
 

Mips81

New member
Apr 15, 2011
4
0
Xiaomi Mi 9
My mi9 android 10 ans miui12 work like a charm When you disable miui optimisation in development options.
After, You can select manualy data mobile.
 

andreaslev

Member
Jun 11, 2016
27
4
It would actually be very easy if the AAWireless would connect to a WLan available in the vehicle where the smartphone is also connected via it. For example, your own hotspot on your smartphone or the WiFi in your own vehicle. Then all devices would have Internet and are still connected to AAwireless via WiFi.

I already mentioned this in the other forum, but unfortunately haven't received an answer yet.
 

TimD88

New member
Aug 27, 2008
2
0
My mi9 android 10 ans miui12 work like a charm When you disable miui optimisation in development options.
After, You can select manualy data mobile.
Hi. Thanks for the hint!
I have the Xiaomi Mi 9 with Android 10 and Miui 12.0.4.0 Global.
When I disable miui optimisation, the handy can connect WiFi and Mobile data at same time. Indeed you habe to confirm the mobile data connection everytime after connecting to AAwireless WiFi.

I am using the following WiFi settings:

Additionally I activated "mobile data always on" in Xiaomi developer settings.

I did not test different setting combination because it is working well. Maybe some of the settings are not required.

After disabling miui optimisation, I did not get any critical issues with the system. Just a few apps lost settings for permissions and you had to confirm it again.

Greetings
Tim
 

ArN0V

Senior Member
Apr 10, 2011
133
13
Mons
Unfortunately none of the above solutions worked for me, but...



After several failed attempts I documented what i did and analysed it properly, so here is a possible fix that works for me (the "problem" that I have to comfirm to "use mobile data" remains, but at least it works).


Requirements:
AAWireless is configured and Android Auto works wirelessly (except for the fact that you have no mobile data of couse)

====>

  • turn Wifi Assistant OFF
  • while connected to AAWireless wifi go to wifi settings and click on the wifi connection; in MIUI you should see a QR code to share the wifi connection => take a screenshot
  • open the „scanner“ app from miui which can read QR codes
  • choose the symbol that lets you choose a picture from your images on the phone => choose the screenshot you took
  • now it translates the QR code and gives you SSID and password from your AAWireless wifi connecttion. If you only see strars/symbols instread of the password, tap on the password and it will turn into characters and numbers
  • note the password


  • Open the Android Auto app
  • Go to settings and DEACTIVATE the „Wireless Android Auto“ setting (the one that you had to activate to get AAWireless to work in the first place)
  • Close the App completeley
  • Erase your AAWireless wifi in wifi settings, so that the phone isn’t able to connect to it
  • Shutdown AAWireless by unplugging it
  • Shutdown your car completely
  • Plugin AAWireless again (maybe open and close the door in the car so that the usb plug has power => AAWireless will boot up
  • Connect to the AAWireless wifi manually
  • Maybe you get a prompt that asks you if you want to change wifi connection because it has no internet => ignore it
  • Put your phone into airplane mode, wait 10 seconds
  • Deactivate airplane mode
  • Wifi connects to AAWireless wifi
  • It should now ask you if you want to use mobile data, maybe it takes a few seconds until you get asked
  • ALLOW it to use mobile data
I had to retry it a few times with switching airplane mode on and off until I got the prompt that it wants to use mobile data.

If it works until here chances are very high that everything will work in then end!


  • Go to Android Auto app and ACTIVATE „Wireless Android Auto“
  • Shutdown everything again, unplug AAWireless, shutdown your car and wait a few seconds => all connections should be disconnected
  • Start your car, plugin AAWireless
  • AA Wireless and Android Auto should startup as it should and after a few seconds you should get the promt again, that your phone wants to use mobile data => allow it
  • Android Auto should work now with internet connection

Please let me know if that works for you, too.
thank you so much my aa unit was in my glove box since 2 months and i was thinking about buy a new phone
 

Sunlight76

Member
Jul 23, 2019
23
0
Huawei P30 Pro
As AAWireless gets shipped and people are getting their device, so I think more people are running into the same problem:

When using MIUI the chance is pretty high that it is possible to connect wirelessly with Android Auto, but there won't be any internet connection. Which makes AA pretty unusable.

The problem is that MIUI should switch from Wifi to cellular data if Wifi connection has no internet. But it does not switch.

As I don't want to unlock my bootloader to change to another ROM (don't know which ROM would work on my Mi Mix3 either) and don't want to wait until some updates from MIUI arrives, I startet this thread and hope it is possible that we find a workaround together.

Some questions/possibilities I have in mind:

  • Is it possible to combine the connection of cellular data and wifi? Then no switch would be necessary because both are connected at all times
    • maybe speedify will work? => tried it, but i couldn't get cellular data to cennect via speedify
  • is it possible to force some apps to only use cellular data?
    • found the possibility in settings to tell apps that they are not allowed to use SIM1 / SIM2, but I was not able to tell Google Maps that it is not allowed to use Wifi. That setting is not changeable
  • Is it possible to emulate a USB connection so that MIUI thinks that the phone is connected. Because when I connect it via USB cable it switches to cellular data and I can use the internet connection

Maybe some of you can help with that problem as it is very annoying. AAWireless works at it is intended to, the problem is MIUI in this case.
I solved the problem simply setting a dummy proxy server in the phone editing car's wifi connection
 

Sunlight76

Member
Jul 23, 2019
23
0
Huawei P30 Pro

Attachments

  • Screenshot_20211017_001227_com.android.settings.jpg
    Screenshot_20211017_001227_com.android.settings.jpg
    344.5 KB · Views: 88
  • Screenshot_20211017_001224_com.android.settings.jpg
    Screenshot_20211017_001224_com.android.settings.jpg
    283.6 KB · Views: 88

Dehumanizer77

Member
Apr 9, 2011
24
0
Ok, so I got the device today and I have been experiencing with this issue on Miui since then.
I have to agree with my previous assumptions from post #27 (https://forum.xda-developers.com/t/...is-connected-wirelessly.4252187/post-85088983)
It works exactly as I have outlined with the aawireless wifi as well.
So, you have either to have no available wifi connection around you to be able to get the "use mobile data" popup, or if there is a wifi near you which you have set up on your phone (like your home wifi), you need to have autoconnect disabled for that wifi. Then you will always get the "use mobile data" popup when you enter the car.

Which means people who are parking the car outside of their home (or work) wifi should be okay :) For others,like myself, unfortunatelly you will have to disable autoconnect on your home wifi and manually connect to it every time you get home.
Or you will have to drive away from your home wifi and then reconnect Aawireless (either by unplugging it and plugging again or by switching the airplane mode on and off).

It might be possible to script the connection to your home wifi using some automation apps like Automate (https://play.google.com/store/apps/details?id=com.llamalab.automate&hl=en&gl=US) and this is what I will be playing with now.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    Unfortunately none of the above solutions worked for me, but...



    After several failed attempts I documented what i did and analysed it properly, so here is a possible fix that works for me (the "problem" that I have to comfirm to "use mobile data" remains, but at least it works).


    Requirements:
    AAWireless is configured and Android Auto works wirelessly (except for the fact that you have no mobile data of couse)

    ====>

    • turn Wifi Assistant OFF
    • while connected to AAWireless wifi go to wifi settings and click on the wifi connection; in MIUI you should see a QR code to share the wifi connection => take a screenshot
    • open the „scanner“ app from miui which can read QR codes
    • choose the symbol that lets you choose a picture from your images on the phone => choose the screenshot you took
    • now it translates the QR code and gives you SSID and password from your AAWireless wifi connecttion. If you only see strars/symbols instread of the password, tap on the password and it will turn into characters and numbers
    • note the password


    • Open the Android Auto app
    • Go to settings and DEACTIVATE the „Wireless Android Auto“ setting (the one that you had to activate to get AAWireless to work in the first place)
    • Close the App completeley
    • Erase your AAWireless wifi in wifi settings, so that the phone isn’t able to connect to it
    • Shutdown AAWireless by unplugging it
    • Shutdown your car completely
    • Plugin AAWireless again (maybe open and close the door in the car so that the usb plug has power => AAWireless will boot up
    • Connect to the AAWireless wifi manually
    • Maybe you get a prompt that asks you if you want to change wifi connection because it has no internet => ignore it
    • Put your phone into airplane mode, wait 10 seconds
    • Deactivate airplane mode
    • Wifi connects to AAWireless wifi
    • It should now ask you if you want to use mobile data, maybe it takes a few seconds until you get asked
    • ALLOW it to use mobile data
    I had to retry it a few times with switching airplane mode on and off until I got the prompt that it wants to use mobile data.

    If it works until here chances are very high that everything will work in then end!


    • Go to Android Auto app and ACTIVATE „Wireless Android Auto“
    • Shutdown everything again, unplug AAWireless, shutdown your car and wait a few seconds => all connections should be disconnected
    • Start your car, plugin AAWireless
    • AA Wireless and Android Auto should startup as it should and after a few seconds you should get the promt again, that your phone wants to use mobile data => allow it
    • Android Auto should work now with internet connection

    Please let me know if that works for you, too.
    2
    As AAWireless gets shipped and people are getting their device, so I think more people are running into the same problem:

    When using MIUI the chance is pretty high that it is possible to connect wirelessly with Android Auto, but there won't be any internet connection. Which makes AA pretty unusable.

    The problem is that MIUI should switch from Wifi to cellular data if Wifi connection has no internet. But it does not switch.

    As I don't want to unlock my bootloader to change to another ROM (don't know which ROM would work on my Mi Mix3 either) and don't want to wait until some updates from MIUI arrives, I startet this thread and hope it is possible that we find a workaround together.

    Some questions/possibilities I have in mind:

    • Is it possible to combine the connection of cellular data and wifi? Then no switch would be necessary because both are connected at all times
      • maybe speedify will work? => tried it, but i couldn't get cellular data to cennect via speedify
    • is it possible to force some apps to only use cellular data?
      • found the possibility in settings to tell apps that they are not allowed to use SIM1 / SIM2, but I was not able to tell Google Maps that it is not allowed to use Wifi. That setting is not changeable
    • Is it possible to emulate a USB connection so that MIUI thinks that the phone is connected. Because when I connect it via USB cable it switches to cellular data and I can use the internet connection

    Maybe some of you can help with that problem as it is very annoying. AAWireless works at it is intended to, the problem is MIUI in this case.
    2
    I struggled with this too, and found no solution within Miui.

    The only solution that worked for me was to unlock the bootloader of the phone and to replace Miui with Lineage OS.
    1
    I tried switching it on, but it didn't work either.


    BUT I got it to work sometimes!

    Let me explain...

    Some days ago I went to my car, opened it, got my sunglasses and walked away from the car.
    Then I got a notification that told me my wifi connection does not have a internet connection and if i wanted to use mobile data. I don't know what happened there, as I didn't even have the ignition on.

    So I went back to the car later and booted up the system. First I ignored the message, knowing that some people wrote in the forum to ignore the message.
    But as I didn't have working internet connection while connected to AAWireless, I tried to let it use mobile data and it worked!!!!
    I was connected to AAWireless and had a working internet connection for the first time!


    The car wakes up as soon as you open the doors and AAWireless boots up. So something did trigger that my phone went into another mode. So it didn't ask me if i want to stay connected to AAWireless or chosse another, stronger wifi, but if I wanted to use mobile data instead. (Wifi Assistant options were off)

    After that I tried turning the Wifi Assistant options on and thought maybe now it would work. But it didn't.
    So I switched the options back off, tried again to connect to the car, but I was back to having no internet when connected.

    The next day I went to the car, it booted up and it worked again! (After confirming to use mobile data when asked) I have no idea why?!

    I used it a few times in the last days. It worked after I confirmed to use mobile data when asked.
    As soon as I turned Wifi Assistant on it didn't work anymore. Tried that several times.
    But sometimes it did not work the first time I went into the car and started it up. Then I had to turn off the car, open the door (12V will be off), close the door and start it again.

    Today it did not work, even after rebooting it four times.

    So I think it has something to do with timing.

    - when the phone connects to what (Wifi, Bluetooth)
    - media system booting before/after AAWireless
    - ...

    But there is hope that it is fixable!

    P.S.:

    - Xiaomi Mi Mix 3
    - stock MIUI 12.0.2 global stable
    - Android Auto 6.2.610914
    - Wifi was connected to AAWireless
    - Bluetooth was connected to the headunits bluetooth
    1
    This may not work on your rom, but as I've run into this problem on my Galaxy S10+, this might help. Note, I am on the AAWireless beta team. These are general instructions, so forgive the simple details.

    *********************
    If you are having issues with mobile data not being available when connected to Android Auto, there are a few things and settings to be aware of. The following is on my Galaxy S10+.

    Note, to enable Developer Settings (aka Developer Options, Developer Mode) in Android, find the Build Number (Settings => Software Information => Build Number) and tap 10 times to bring up a confirmation.

    Settings which could affect Mobile Data availability.
    1) In Developer Options > Mobile data always active (Turn On)
    2) Settings > Connections > Wi-Fi > 3 Dot Menu > Advanced > Switch to mobile data (Turn On) > Network exceptions (Delete the AAWireless device if accidentally added– see below).

    ************************
    If you get a message pop-up when connecting to AAWireless:
    "Internet may not be available - If you stay connected to this Wi-Fi network now, your phone will also stay connected whenever you use this network in the future. You can change this in Settings > Connections > Wi-Fi > ADVANCED > Switch to mobile data > Network exceptions." Then it gives two options: "Allow switch" and "Stay connected".

    You must respond by canceling out of the choice – do NOT choose either option.

    If you choose to Stay Connected, it will add a listing in "Network exceptions" that needs to be deleted. The label for Network exceptions says "Your phone will remain connected to these networks, even if the connection is unstable."

    Google made this very confusing.