AC8257 base unit - new Firmware + MCU update with Android 11 & Android Auto wireless

Search This thread

G3n3R4L

Senior Member
Aug 9, 2011
316
41
Wermelskirchen
Does the unit have a sim card slot? Otherwise maybe its a 4Gb (RAM/Memory) version which you are confusing with 4G internet

that's my unit, Im pretty sure it supports 4G
 

Lelandalexjohnson

New member
Aug 12, 2022
2
0
Hi guys. I bought one of these units (or one very similar, i will post a pic) last year and just had it installed about a week ago. I'm having an issue where it keeps restarting randomly, sometimes 3 times within 5 minutes, sometimes not at all over 45 minutes.
I'm thinking I need to update the software or firmware to fix this issue. But I have no idea how to do that. I just want my carplay to work without the thing restarting. It might be worth noting I have an apple computer and iphone (i tried to look at the dropbox files posted earlier in this thread but my computer wont open them, i'm assuming bc apple)

can anyone here help me? i'm not the most tech forward person, lol

IMG_8616.jpg
IMG_8625.jpg
 

duvshi

Member
Dec 9, 2021
30
9
Hi guys. I bought one of these units (or one very similar, i will post a pic) last year and just had it installed about a week ago. I'm having an issue where it keeps restarting randomly, sometimes 3 times within 5 minutes, sometimes not at all over 45 minutes.
I'm thinking I need to update the software or firmware to fix this issue. But I have no idea how to do that. I just want my carplay to work without the thing restarting. It might be worth noting I have an apple computer and iphone (i tried to look at the dropbox files posted earlier in this thread but my computer wont open them, i'm assuming bc apple)

can anyone here help me? i'm not the most tech forward person, lol

View attachment 5683707View attachment 5683711
From the picture you showed you have a WIFI version. Is that true? If so you should download the version I have uploaded to GDrive (use 2610pro) you should prepare a USB drive with fat32 format and only have in the drive 2 things
'atcupg' folder, and a file called MCU
Look up how to format a USB drive to fat32 using a Mac
 

Lelandalexjohnson

New member
Aug 12, 2022
2
0
From the picture you showed you have a WIFI version. Is that true? If so you should download the version I have uploaded to GDrive (use 2610pro) you should prepare a USB drive with fat32 format and only have in the drive 2 things
'atcupg' folder, and a file called MCU
Look up how to format a USB drive to fat32 using a Mac
I believe it is just the wifi version yes. i will google how to put a usb to a fat32. in the google drive you provided I can see the file that starts with MCU but i cannot see the 'atcupg' folder, all I can see are these.

after I get these files onto the usb, I just plug the usb into the unit and click a "download" button of some sort?

Thank you for your help also

Screen Shot 2022-08-12 at 3.21.04 pm.png
 

vz_commo

Senior Member
Oct 10, 2012
95
11
The firmware update isn't showing up for me, the MCU shows up and updated, any suggestions?
 

Attachments

  • 20220812_175719.jpg
    14 MB · Views: 68

duvshi

Member
Dec 9, 2021
30
9
The firmware update isn't showing up for me, the MCU shows up and updated, any suggestions?
You need to go intro settings , update and restore , and then update , from there go to img, and click upgrade , after the update is complete , go to the same place and loof for 'mcu' then click upgrade

Please note that after the update you should wait like 3 minutes for all the apps to install
 
  • Like
Reactions: carfab

duvshi

Member
Dec 9, 2021
30
9
I believe it is just the wifi version yes. i will google how to put a usb to a fat32. in the google drive you provided I can see the file that starts with MCU but i cannot see the 'atcupg' folder, all I can see are these.

after I get these files onto the usb, I just plug the usb into the unit and click a "download" button of some sort?

Thank you for your help also

View attachment 5683777
You should take the MCU , and there is a zip file with 2610 name on it , extract it till you find the atcupg folder
 

vz_commo

Senior Member
Oct 10, 2012
95
11
did the firmware update, had to change the language from russian to english that was easy enough but ive noticed it doesnt quick boot anymore, it does a cold boot everytime i get in the car.

the setting are set for it appear to be all correct but doesnt seem to want to follow them

any suggestions or could it be a bug in this firmware

also on a plus it is nice to have wireless android auto thanks to the wireless qlink app
 

duvshi

Member
Dec 9, 2021
30
9
did the firmware update, had to change the language from russian to english that was easy enough but ive noticed it doesnt quick boot anymore, it does a cold boot everytime i get in the car.

the setting are set for it appear to be all correct but doesnt seem to want to follow them

any suggestions or could it be a bug in this firmware

also on a plus it is nice to have wireless android auto thanks to the wireless qlink app
Did you update the MCU also?
Try factory restore and give it 3 minutes after ,
If it still cold boot,
Download the config file and it should auto config when you insert the USB
 

duvshi

Member
Dec 9, 2021
30
9
did the firmware update, had to change the language from russian to english that was easy enough but ive noticed it doesnt quick boot anymore, it does a cold boot everytime i get in the car.

the setting are set for it appear to be all correct but doesnt seem to want to follow them

any suggestions or could it be a bug in this firmware

also on a plus it is nice to have wireless android auto thanks to the wireless qlink app
Also, if you did the MCU update, please note, it will reset the Canbus settings, So you should set it up again, some cars have a Canbus Fastboot
 

vz_commo

Senior Member
Oct 10, 2012
95
11
Also, if you did the MCU update, please note, it will reset the Canbus settings, So you should set it up again, some cars have a Canbus Fastboot
thanks, everything seems fine settings wise but it just doesnt fast boot anymore, unless im missing something

is there a way to reinstall the firmware?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    hi I will take screen shots step by step and upload it with description is it ok
    Hi please follow this video for installing MTK drivers and flashtool first thanks
    2
    @carfab and @wanted99

    Just a friendly reminder about XDA Rule #4:

    4. Use the English language.

    We understand that with all the different nationalities, not everyone speaks English well, but please try. If you're really unable to post in English, use an online translator. You're free to include your original message in your own language, below the English translation. (This rule covers your posts, profile entries and signature). You could try :- https://translate.google.com/ or https://www.babelfish.com/ or use one of your choice.

    Thank you: Badger50
    1
    Yes anything should work well connected with android auto/car play as the headunit is using the resources of the phone not the actual head unit so its basically screen mirroring the phone. Does it actually work on the head unit itself with the app? Thanks mate
    Yes. I have tried google maps and igo.
    2
    be careful, I noticed that you could unlock a lot more with passwords. it all depends on what password where... but I never found the password of the orange box... i think is for add UI. because i found many screenshot of UI in system/app/Misc/Misc.apk. Maybe is just garbage file but is suspect.... i know Eonon Ac8257 device have app UI downloader online. but i not found backup of this firmware. Anyway, if someone know this password. ur welcome ;)
  • 3
    Hi,
    After struggling hard to find how to update my unit (what doesn't seems possible with USB key in my case ; only with a MicroSD card), I finaly did it.
    This new system is Android 11 based, and allow to connect to Android Auto wireless, sounds good uh?

    My unit is AC8257 based, and has 8 core, 64 GB ROM, 4 GB LPDDR4 RAM @ 1024x600, but the upload also contains 800x600 & 1280x720px, there is .BAT files that make easyier to pick up the good Android_scatter file.

    Here is where I come from first :

    20220706_180945.jpg


    And here is where I am now :

    20220711_210648.jpg


    Below, a picture of the app/system that detect that my phone is close by and ready to pair with Android Auto. I first had to connect it with wire to show him the way. It now seems automatic.

    20220711_214205.jpg


    You can find this wonderfull new firmware here (dated : 20220513), along with the MCU update : https://www.dropbox.com/sh/k2dotip66u7iekg/AAA69Z_ujnTZQMai5TbPXAbma?dl=0


    8257升级教学(新).MP4
    30/06/2022 09:40

    B200 wifi 1024x600 2022.05.13 ATCUPG.zip
    02/06/2022 10:37

    mcu_202206071001BD2-1559.upd


    I hope this will help :)
    2
    I want to be able to use android auto wireless.
    how can I do it?
    Open Wireless Qlink app and Re-pair your phone to the head unit
    2
    Thank you very much!!

    I want to ask you one more thing.
    how do i download and install zlink?
    the system i bought has PhoneLink installed.
    you cannot install Zlink as they dont have the license for it, you can install it and pay for it if you wish but the phonelink app works well, you can force it ti work by going to settings-general-Carplay
    and if you want android auto wireless you can open wireless Qlink
    2
    hi I will take screen shots step by step and upload it with description is it ok
    Hi please follow this video for installing MTK drivers and flashtool first thanks
    2
    you mean if it has a 4G sim card slot?
    yes, from the version i see it is just WIFI so go ahead and update