AC8257 CPU Based unit's problems & questions - Couldn't find any info about it

Search This thread

Inatrer

Member
Mar 17, 2021
28
7
Thank trou my friend ! Someone have the link for 1.66 in 32bit ? Or It's possible to patch boot.img of 1.68 then flash it on my 1.66 ?

It's same firmware for 32/64bits ? Because I look I have 32bits system

Last question, Do I have to modify boot.img with hex editor I have android 10 32bits on the HU ?

Thank very much @Inatrer
it looks like it is same for 32/64 (or it is only 32bit, it is only one for this model on the developer site)
i am not sure if you should modify, you can try to do it witout modification, if it is needed, you will not have root and you will need to flash modified.
I have same model of device (but 2/32 ver) and most people on 4pda says it is not 10 android, it is fake and we have 9.
anyway, if modify needed it is not danger to flash not modified.
The problem is only if you flash not for your device.


on 4pda another way to have rood with no flashing, but using ADB and supersu, only the problem there, that supersu always asking (at boot, not sure) to modify core or some script, not remembre already. and if you press yes you will have bootloop.
 
  • Like
Reactions: nextgeek

piotrmocko

Senior Member
Dec 14, 2013
67
7
Kraków
@Inatrer can you link some guide how to use SP Flash Tool? I found this one, but I'm not sure if it is correct. Especially I don't know how to put the headunit into download mode without having any phisical buttons.

 

accee

Member
Mar 21, 2021
9
0
If in your original firmware ZLink app was active, then after upgrading to v1.68 it still will be.

But if you previously didn't have active ZLink, then it won't become active after upgrade.
I dont have zlink activated... But i dont know how to do activation.

The QR code and chines Wechat doesent worka for me..

Is for someone this metode works?
 

piotrmocko

Senior Member
Dec 14, 2013
67
7
Kraków
You can't activate ZLink app. Only the manufacturer of the head unit can activate it. The seller can't. The company who sell ZLink doesn't reply to emails.

Instead of ZLink app you can buy and install HeadUnit Reloaded for Android Auto. Version 6.3 of this app works with Android Auto wireless. Tested on my Samsung Galaxy S8 with Android 9.
 

videojo

Senior Member
Apr 21, 2012
110
24
I dont have zlink activated... But i dont know how to do activation.

The QR code and chines Wechat doesent worka for me..

Is for someone this metode works?
download and flash 1.68 firmware without zlink carplay support and activate carplay funktion in secret menu 8888 usb settings menu to carplay on and reboot
 

accee

Member
Mar 21, 2021
9
0
download and flash 1.68 firmware without zlink carplay support and activate carplay funktion in secret menu 8888 usb settings menu to carplay on and reboot
Yes. It works for me.... But with wire... Zlink has wireless carplay support...

Maby any other app can do wireless carplay?
 

accee

Member
Mar 21, 2021
9
0
Hi all.
Y5760b radio.
Canbus 3.1 - in right bottom corner i dont have steringwhele learn button.. in an earlier version I had such a button and I could change the meaning of the steering wheel buttons. Please, let me know what version of CanBus you have and the steering wheel learning is working on?
 

pablo.andrey

New member
Apr 17, 2021
2
0
Hi everyone. I need help !

I tried to update the firmware on my AC8257 using the recovery option. I downloaded the zip version of the XYAUTO link.

It gave an error. Now, it does not boot. It just stays on that screen. Can you help me update with the smart phone flash tool software? Detail: windows does not recognize the drive.
 

Attachments

  • 20210417_130902.jpg
    20210417_130902.jpg
    1.3 MB · Views: 17
  • som.png
    som.png
    6.2 KB · Views: 16
  • 20210416_141000.jpg
    20210416_141000.jpg
    1.7 MB · Views: 17

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    here is systemconfig for xyauto series ac8257/9
    to customize firmware settings on start

    #内置收音机默认地区0 china 1 South Asia 2 japan 3 Europe1 4 Europe2 5 Middle East1 6 Middle East2 7 America1 8 America2
    XYAUTO_FM_CONTRY =DEFAULT_VALUE

    #是否预置电台
    XYAUTO_FM_RELOAD = DEFAULT_VALUE

    # build date
    XYAUTO_PKG_UPGRADE_DATE= DEFAULT_VALUE

    # build version no.
    XYAUTO_PKG_VERSION_NO= DEFAULT_VALUE

    # fm nxp 6851 rds: 0 不开启: 1 :开启
    XYAUTO_FM_RDS= 1

    # fm nxp 默认地区: 0 china 1 Europe 2 Austria 3 Middle East 4 America1 5 South America 6 South Asia 7 JAPAN
    XYAUTO_EXTFM_CONTRY = 1

    #分辨率是否显示 -1隐藏 0 1024*600 1: 800*480 2 :1024 *768 3: 768 *1024 4: 1280 *720 5: 1280 *480 6 1280 x800
    XYAUTO_DISPLAY = DEFAULT_VALUE


    #系统信息 设备接口: -1隐藏 0 显示
    XYAUTO_DEVICE_PORT = DEFAULT_VALUE

    #系统信息 音效设置: -1隐藏 0 显示
    XYAUTO_APS_PAGE = DEFAULT_VALUE

    #系统信息 音效设置AJ: -1隐藏 0 显示
    XYAUTO_APS_MUSIC = DEFAULT_VALUE

    #Android 设置里 :设备名称
    XYAUTO_ANDROID_DEVICENAME = F39L

    # 功放信息自定义:
    XYAUTO_SYSINFO_AMPSTRING = DEFAULT_VALUE

    #分屏开关:
    XYAUTO_SPLIT_SCREEN = DEFAULT_VALUE

    #视频文件夹过滤,多个文件夹,逗号分开
    XYAUTO_VIDEO_FILTER = DEFAULT_VALUE
    1
    Excuse me again. I put the firmware and Xyauto_update.bin on the USB and loaded it, and it was restored to 1.68. thank you for the advice!
  • 1
    The link requires login and password. Can you tell me where to register?

    Username: xyauto
    Password: 123456
    1
    The update you have suggested is Android 10. In your first post you have mentioned that you have Android 9. Have you installed exactly that update and did it update your Android from 9 to 10?

    I have XY Link 1.61 and the new update is 1.65, so hopefully it will fix something.
    Moreover, I have a different radio chip than you.

    Could you please share the screenshot with the full specification of your head unit?
    Screenshot_20201004-120433.png


    Do you have any idea what for are small packages?
    Screenshot 2020-12-24 123238.png
    1
    I was wrong about my radio chipt, it is also NXP6856 (And I'm getting terrible reception).

    About the android version: I wouldn't trust the number that the lovely Chinese fellas give you. I've encountered other posts that say that while the ROM reports Android 10, It's actually 6,7 and so on.

    I can't take a screenshot right now, but it looks very similar, with the only notable differences being:
    1. It shows a CPU of AC8259 (Instead of AC8257)
    2. It says XY LINK: 1.65
    3. Perhaps it also says Android 10, can't remember.

    I'm 99% sure it will work on your system, but I can't promise that.

    About the small packages, I'm guessing that they are small addons you can install. I tried the voice one, expecting to get a working google assistant, but instead I got a very intrusive chinese sepakinng assistant, while also getting most of my settings reset...
    1
    When you will have time, then please confirm what Android version you have in
    Android Settings > System > Advanced > About car
    Screenshot_20201004-120554.png
    1
    I have the same unit.

    1. I don't have this problem.

    2. Mine didn't bring the external mic either.

    3. Ran geekbench and have about the same score as you. Will install DevCheck to confirm the 3 cores situation. Would be nice to have all the cores working tho because the performance is not very good. Can we use DevCheck results to ask for a refund of any kind, since the unit is advertised as an octa-core?
    After reading the Russian forums, using Chrome translate of course, I realised the way they mark the processors as 8 cores could be misleading. Some say it's 4 cores with 4 GPU cores, others say it's 4 big and 4 little cores.

    Using a search on geekbench for posted scores, I see most of them have similar scores. Using my Huawei phone score as comparison, multi core score is about 3x of single core score, which is consistent with the head unit score ratio, so the core being offline might not be the cause of the low score, probably the processor simply sucks given the low single core score.

    Russian forum discussions also mentioned the lousy DSP handling, with attenuated volume when heavy bass kicks in, the Rock DSP mode sounds good but the volume variation is very irritating.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone