• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Access Point Name settings are not available for this user - Poco X3 NFC

Search This thread

Ronan_the_Librarian

New member
May 8, 2021
2
0
Hi everyone,

My Dad is having a problem with a Poco X3 NFC that I hope someone will be able to help us with.

I bought the phone for him as a Christmas present last year from Amazon Germany, as his previous phone was quite old and had been having occasional issues, and poor battery life. We put his SIM from that phone into the new Poco X3 NFC and initially it seemed to be working fine, and he was very happy with it. However, after a while it started having issues where calls would occasionally drop, or he'd be unable to make a call. I took at look at it on one of these occasions, and noticed that the network reception icon at the top was greyed out, and had an x through it:

Network unavailable.png


Each time, a reboot fixed the issue, but it was annoying, and occasionally people couldn't reach him when they phoned him, presumably due to this same issue. At first we suspected the SIM, so we ordered a replacement from the network. Unfortunately the same issue occurred with it installed in the Poco X3 NFC. Then, to test this new SIM, we tried putting it into his old phone, which he then used for about two weeks. The issue did not occur on this phone during this time, but it occurred once again a few days after putting it back into the Poco X3 NFC.

So, we then thought that the problem was with the Poco phone itself. We contacted the retailer and they sent us a replacement (same model), and we set it up again. Unfortunately, after a few days it also exhibited the same problem. While the replacement phone was having one of these occurrences, I looked into it a bit more, and found something unusual in the APN settings. Here is how that screen looks when there is no problem - you can see the entry for our phone network:

APN present.jpg


However, when the problem occurs, I've discovered that the APN entry on this screen is missing, and instead the text 'Access Point Name settings are not available for this user' is present:

APN missing.jpg


I believe the disappearance of the APN settings is causing the phone to lose its connection to the network, but I don't know why this is happening.

I did some Google searches for the above text, but a lot of what I found seems to be related to this being a permanent issue, not an intermittent one like we have. I also spoke to Xiaomi on a live chat on their website about this problem, but I wasn't confident in what they suggested. They first of all suggested that poor network coverage could be causing the issue, until I pointed out that this should not cause the APN settings to disappear.

They then advised trying a factory reset, and said if that didn't work that it could be sent away for repair. I don't think this is a hardware issue, and given that it's intermittent and we don't know how to recreate the problem, and that two models of this phone have both had this problem, I don't think sending it for repair will work. I'm also not keen on trying a factory reset since I'll have to back everything up and reinstall everything afterwards, and again, since both models of the phone had the issue, I'm not confident this will work either.

The representative on the chat also suggested that one of the applications installed by us could be causing the issue, but I'd have thought this to be pretty unlikely. I thought settings like this would be protected from other applications, and Dad only has a handful of applications on the phone, all of which are well known with thousands of users. All of these applications were also installed on his old phone and caused no problems there.

In case they are useful for anyone trying to assist us, below are the software versions on the phone. We've installed all prompted updates, and the problem still occurs with all of these installed.

Software versions 1.jpg

Software versions 2.jpg


Sorry this post got a bit long, but I wanted to include everything we experienced and tried so far. If anyone can help us out with this or suggest anything we can try, we'd be very grateful. Dad is very happy with the phone otherwise, but unfortunately it's not usable to him if its network connection isn't reliable.

Thanks in advance.
 

Alrich

Senior Member
May 3, 2015
202
75
29
Goa
Please replace your SIM card.
I had this issue before too and it drove me nuts. I did all the steps you too undertook including getting a replacement phone. The solutions eventually was to get a new SIM (Of the same number.)

Even if your current SIM works fine in other phones, there is this weird pairing issue that occurs with Poco X3. There is already another user on the forum threads with this same issue who got it fixed by getting a new SIM by my suggestion.
 

Ronan_the_Librarian

New member
May 8, 2021
2
0
Hi Alrich,

Thanks for your response. The thing is, with the first Poco X3 NFC we had, we tried a replacement SIM in it already, and we still got network disconnects and the X in the Network Reception icon. Admittedly, back then I wasn't checking whether the APN settings were going missing, but I suspect that would have been the case if I'd checked. Also, the replacement SIM that's having this problem in the current Poco X3 NFC works fine in Dad's old phone.

Is it likely that the SIM would work fine in a different phone, but still have problems in the Poco X3 NFC? I thought a faulty SIM would cause problems with any phone it was put in.
 

pl1992aw

Senior Member
Apr 5, 2019
1,053
663
Though I don't have x3 NFC but the x3 pro, there's still some way to try.

You see the "Add APN" on your first screen shot?
Did you try manually adding the APN settings on your own?

Note down the APN setting from your dad's phone and manually type in your X3 NFC.

If you don't know the APN settings for your telecom service, you can ask your number carrier.

I guess you're in Ireland, so you can try this APN setting

Also remember some telecom service uses specific 4G bands that some phones don't support. So in this case, your phone can't find any signal, and it has to broadcast and try other bands to check if it works.
 

Nazri786

Senior Member
Jul 18, 2011
560
85
Pulai
Xiaomi Poco X3 NFC
Try using 2g only or 3g only instead of lte/4g..... I am also having this kind of problem if set to 4g as preferred network.... There is problem with this phone 4g reception as I've used different phone at same location and the coverage is good.. Only with this poco x3 the 4g was unstable.