• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Acer Iconia One 7 B1-750 Help needed.

Search This thread


New member
Sep 16, 2021
So I got a friends acer tablet and he asked me to repair it. The problem is the tablet only boots into fastboot which displays "Entering DnX mode. Waiting for fastboot command.. " Usb debugging is not enabled so cant use adb. Fastboot can see the device on fastboot devices command, but seems almost all fastboot commands are locked on the device. Also trying lots of different fast boot commands which give out different errors. Also this is done on windows 7 machine because the tablet is so old drivers only work in older windows. I managed to find the stock rom on some site but no luck so far getting it to install via fastboot. Tablet has a intel bootloader which to my knowledge are always locked and cant be unlocked.

Tablet has no physical factory reset "hole" and none of the usual press volume up/down keys while powering device will go anywhere else than the before mentioned dnx mode. I've tried different usb-cables, different ports (usb2.0). Tried playing around with different TWRP images and and Intel Android FBLR but to no avail. I'm out of ideas, can anyone give me a helping hand?

Edit: Got couple commands run successfully in fastboot. Could run fastboot boot trwp.img/boot.img(from stock) both times table rebooted but back into DnX mode without any change. Fastboot continue gives Okay input but doesn't reboot or do anything.

Second edit: I've had some success with DnX bios flash tool, but don't know how to extract bios from the stock rom, anyone can give me good tool and guide?
Last edited: