Search This thread


Senior Member
Jan 5, 2017
OnePlus 7 Pro
I've never understood if this module is supposed to extend your phone's battery life as in each session it's charged or if it means extending the battery's health over the years so it doesn't degrade.


Senior Member
Dec 2, 2015
Samsung Galaxy S22 Ultra
Hi :)

The 2022.2.22.1 version doesn't work with AccA.
I set it to charge to 80% but it charge to 100%.
The 2022.1.8 works but if I set to 80%, it charge sometimes to 83%, sometimes to 81%, etc.

If you know why...
Have a good day all of you :)


Senior Member
May 23, 2019
Xiaomi Mi 9
Hello, i am using crdroid with my xiaomi mi 9 and wireless charging is overheating my phone. Is it posibile to limit wireless charging only (mah limit)? Which options do i have to set? Looks like the app have many many options :)
Thx for helping!


Senior Member
Sep 11, 2014
LG V10
Xiaomi Poco X3 NFC
Correct battery profile ?
I think I have set all parameters correctly. I don't understand :(
Command line (connected to charger)
acc -t
This will test available battery switches and show wich one works (and have 'battery idle mode).
This is for my phone (X3 NFC).


New member
Dec 13, 2009
Hi, I have an LG G3 phone and ACC worked fine until few weeks ago.
When I try "acc -t", it says "won't work" for all methods.
I have now switched back to version 2021.12.20 and there "acc -t" says "works" for all 5 methods.
Something seems odd with the latest version.


Aug 12, 2010
Hi :)

The 2022.2.22.1 version doesn't work with AccA.
I set it to charge to 80% but it charge to 100%.
The 2022.1.8 works but if I set to 80%, it charge sometimes to 83%, sometimes to 81%, etc.

If you know why...
Have a good day all of you :)
I'm having the same problem. Charges to 100% every time. Did you figure out a fix for this? Thanks.


Senior Member
Aug 8, 2020
Seems to be working ok, as far as I can tell, on a Xiaomi Note 10 pro running MIUI 13.0.4 ( version). I'm using the AccA app, so the version of acc it installs is a little older.

I can see it stop charging when it hits 80%. The max temp is set to 40c with a 90 sec cool down, and I don't see it go over 40c when charging. Whereas before it would sometimes get to 42c or 43c (using the 33w fast charger). However, I haven't noticed any indication that it hits a 90 sec cool down cycle. It still shows as charging. Should there be an indication if charging is paused? Or is it normal not to see it?


Senior Member
Mar 2, 2017
I've never understood if this module is supposed to extend your phone's battery life as in each session it's charged or if it means extending the battery's health over the years so it doesn't degrade.
The module can help with preventing your battery from getting low (depth of discharge is the biggest factor in battery longevity; deeper discharges per session has bigger impact than less deep discharges (20% battery remaining is significantly healthier than 5% remaining). It also can prevent your phone from being topped at 100% for extended durations (keeping at 100% for several hours puts unnecessary strain on battery due to elevated voltage, but also passively drains battery faster. Battery at 90% or lower has significantly less passive energy drain.). Finally another feature is battery idle mode (can work on unsupported device with further steps, but your luck will vary from device to device), which is useful for using your device directly from a power supply without draining nor charging a battery (useful for resource intensive tasks, like gaming).
  • Like
Reactions: duttyend


Senior Member
Mar 2, 2017
Is this normal behavior for pseudo battery idle mode? My oneplus 9 pro stock kernel isn't supported for battery idle mode in the acca app settings, but I've been able to enter some state of battery idle mode whenever I "No limits charge to %value" and reach the target value, which no longer charges/discharges, so long as my charger isn't plugged in and out again. The "current" seems to constantly fluctuate from 10ma to 0 repeatedly (while maintaining same voltage).


  • Screenshot_20220408-134743.jpg
    241 KB · Views: 56


Jun 18, 2019
I have a weird problem.

I installed ACC on a new phone (Poco F3 with Lineage 18.1) and defined voltage and current limits with set --voltage and --set --current. Not using charging switch or capacity limits.

Everything seemed to be working well, the phone was charging within the current limit and up to the voltage limit. However, when I disconnect the phone, IF I disconnect it near the voltage limit, it remains in charging status (both acc -i and lock screen info) until I reboot it. Even connecting and disconnecting the phone repeatedly doesn't solve it, only rebooting does.

How do I solve this?
Even if I can't solve it, is this in any way harmful, to constantly have the charging info while discharging?


Senior Member
Feb 4, 2020

I have Samsung Galaxy S10 (EU version) so with Exynos...
Is it possible to configure module (i.e. in AccA app) so that it really charges in "fast mode"?
I see that 15W (in fact 12-14W) is achievable only with original Samsung charger.
While using any other charger I mean 20W to 35W - max charging current is not more than 1,3 - 1,4A...
As far as I know there are Magisk modules that work, but with Qualcomm processor...
Is it possible to configure module so that on Exynos fast charging was really working?
In the picture there is configuration I made in the app but with no effect...
I configured using tips from ACC help.
Another question is Wireless charging. When I use 15W charger (I know real efficiency is 60-70%) but on average it charges 5-6W, whereas on the screen it shows "fast wireless charging" - is there another separate configuration of ACC for wireless mode?

Please advise, thanks!


  • acca2.jpg
    125.1 KB · Views: 48
  • acca1.jpg
    199.6 KB · Views: 45


Senior Member
Jul 11, 2014
OnePlus Nord
Ok, It works!
I set the the charge limit to 95% and it stops at 95% and shows 100% on the Android Battery Info,

I guess charge mask makes the device think device is 100% but battery charge is at 95% on Acc Settings.

Kudos to the developer.


Senior Member
Dec 23, 2009
Xiaomi Mi 9
Wireless Charging Starts and Stops Repeatedly


I have a strange issue:
When wireless charging and my battery reaches the finish charge level (75%), acc successfully turns the charging off, but a few seconds later the charging starts again. This process repeats endlessly, resulting in my battery very slowly creeping up over 75%.

If I restart acc, it is able to stop the charging properly, but if I remove the phone from the wireless charger and then replace it, the on/off/on/off/... starts again.

I've changed a lot of settings to try and fix the problem, but I'm not getting anywhere.
My device is a new Xiaomi Mi 9 [cepheus] running the latest crDroid ROM, with Magisk.
My charging switch (determined by acc -t) is
dc/input_suspend 0 1
I've also got the (acc recommended)
I've tried setting
resume_capacity = pause_capacity - 1
as well, but I can't make charging completely stop.

I don't see anything that looks like another process is re-starting the charging in my logs, so I don't know what else to try.

Does anyone have any pointers that I could try out next?

Thank you,
Hi, i have the same issue only on Wireless charging on Mi). Have you fixed in the end?


Sep 17, 2021
For you lazy man/woman like me, you can execute idle mode just on pressing a tile in the Quick Setting Tiles

You need Xposed Edge Pro to do this (obviously xposed/lsposed)

I'm using Lsposed

Here's the steps:

Open Xposed Edge Pro

Tap Quick Settings tiles > add tiles and create one tiles + check the box

In Action, select Shell > put command:

acc -d

Check the root box

Allow xposed edge to have root access

Put a label and an icon, then save

You can add this tile to your quick setting tiles so each time you click on it, your phone will go to idle mode without typing command on a terminal


  • Screenshot_20220416-131443_Xposed_edge_pro.png
    23.5 KB · Views: 69
  • Screenshot_20220416-131415_Xposed_edge_pro.png
    17.7 KB · Views: 70

Top Liked Posts

  • There are no posts matching your filters.
  • 77
    Find newer zips here.
    Those who are worried about other projects of mine not being updated for a long time, possibly abandoned...
    Stop worrying.
    After the next stable ACC release, I'll focus more on the other Magisk modules (fbind, Migrator, Systemless GApps, etc.).
    The current ACC framework is the base of all the other projects - meaning, making it rock stable it priority #0.
    A new stable release is up.
    It can be downloaded from Magisk Manager > Downloads as well.
    Refer to the readme for a full list of changes, features and recommendations.
    Now I'll be focusing more on the other projects (migrator, fbind, systemless GApps, daily job scheduler...).
    Until these reach satisfactory status, acc will only get occasional maintenance updates (bugfixes, optimizations, new charging control files...).

    Edit: the installer enforced by Magisk Manager is not playing nice with acc. Until I fix that, use the zip from GitHub (release link above).

    Edit 2: fixed.