[Alexis Rom 3.4_FVG4][23/08/2022][03/2022 Patches][G96xF/FD OneUI3.0 Apps Ported]

Search This thread

AlexisXDA

Recognized Developer
Oct 27, 2014
3,364
11,224
Milan
ALEXIS ROM 3.4 IS ONLINE!
Hope you will enjoy! Clean install is recommended! Dirty flash is allowed!

CHANGELOG:
Updated to latest base with March's security patches (FVG4)
Renamed as 3.4 to match Alexis ROM for Note9

Updated kernel too
Updated CSC as well



HOW TO INSTALL:
Be sure to have latest MODEM & BOOTLOADER installed
Download AlexisRom.zip
Flash it through recovery
Follow aroma installer instructions
Reboot system
Reboot and enjoy

FOLLOW ME ON MY NEW INSTAGRAM's PROFILE: https://www.instagram.com/invites/contact/?i=wehmn6h8vftx&utm_content=ibotzda

IMPORTANT NOTES:
DON'T REPORT BUGS OR FC IF YOU MADE DIRTY FLASH, CLEAN INSTALL IS THE SOLUTION!

IF YOU WANT TO DIRTY FLASH AND ALSO YOU FLASHED MY OneUI 3.0 Apps Port you have to:
1) FLASH THIS: https://www.androidfilehost.com/?fid=10763459528675579373
2)REBOOT SYSTEM
3) DIRTY FLASH THE ROM

If you want to install Bixby Voice or Google App DON'T SELECT TTS Services in aroma!

There are two zips: one for S9 users and one for S9+ users!



DOWNLOAD LINK:
S9 Alexis ROM 3.4: https://www.androidfilehost.com/?fid=15664248565197206816
S9+ Alexis ROM 3.4: https://www.androidfilehost.com/?fid=15664248565197206819
CSC Tweaks not installed FIX: https://www.androidfilehost.com/?fid=15664248565197206818
G960F/FD MODEM AND BOOTLOADER (Extract and flash with odin): https://www.androidfilehost.com/?fid=15664248565197207063
G965F/FD MODEM AND BOOTLOADER (Extract and flash with odin): https://www.androidfilehost.com/?fid=15664248565197207064

TELEGRAM GROUP:
https://t.me/alexisroms9

Thanks for using and supporting my work! You can offer me a coffee donating here:
PayPal: https://www.paypal.me/AlexisXDA

Follow me on Facebook: https://www.facebook.com/AlexisDevXDA/
 

S-bibile

New member
Dec 20, 2020
3
0
Hi coming from the 3'2 version i'm facing some issues :
- Bluetooth headphones (bose qc35) does not reconnect. I have to relaunch the Bose app each time to reconnect
- still have random reboot (no common reasons during the phone use which leads to the reboot)
- faster battery drain 😭 (with the 3.2 version I could use the phone more than one day... Now in the evening I have to charge it).

Anyone who's facing these issues and who has any idea?

Ps I've flashed the flash this first/ reinstall twrp because it disappeared after the first flash / flash the 3.4 version
 

jarton

Member
Oct 26, 2010
10
4
Hi guys, I flashed recently through Odin the latest corresponding firmware before doing a clean install.
Weirdly, none of the debloat option, mods etc that I chose during the aroma installer seemed to work.
Basically, even the build info doesn't show Alexis Rom. Apps selected as debloated are installed, the ported 3.0 apps are not there etc..

I decided to go in TWRP and redo a proper wipe and reinstall completely the 3.4 Rom, but still the same problem.

Anyone has faced this issue before ? Usually it's always a super smooth process for me but this one seems strange.

Should I reflash the stock firmware again and start the entire process ?
Thanks
 

jarton

Member
Oct 26, 2010
10
4
Hi guys, I ended up re-doing the entire process, stock rom, clean install, but still the same. Even tried with another version of TWRP but nothing change.

Always ending up with nothing debloated, no ported apps, nor any sign of AlexisRom despite succesful message in the aroma.

Always been a big fan and user but I'll give up this time. Might come back later if another version shows up. Thanks Alexis for the great work and for the time dedicated to the community
 

akshitmehra

Member
Dec 30, 2017
5
1
New Delhi
Hi guys, I ended up re-doing the entire process, stock rom, clean install, but still the same. Even tried with another version of TWRP but nothing change.

Always ending up with nothing debloated, no ported apps, nor any sign of AlexisRom despite succesful message in the aroma.

Always been a big fan and user but I'll give up this time. Might come back later if another version shows up. Thanks Alexis for the great work and for the time dedicated to the community
The same issue is with me. The Aroma installer showed fine, the script installation was successful. However, after rebooting in to the system, no bloatware apps were removed, the system looked as if it was stock, Samsung Health didn't work. Though the Magisk app was installed, but the root wasn't available.
I flashed this ROM for the first time, so don't know how the previous versions behaved.
I would definitely like to try this ROM. Thanks to the developer for their effort and I hope they will fix the issue, if any, very soon or guide us through an alternative.
 

bilbonotry

Senior Member
Aug 21, 2008
509
164
The same issue is with me. The Aroma installer showed fine, the script installation was successful. However, after rebooting in to the system, no bloatware apps were removed, the system looked as if it was stock, Samsung Health didn't work. Though the Magisk app was installed, but the root wasn't available.
I flashed this ROM for the first time, so don't know how the previous versions behaved.
I would definitely like to try this ROM. Thanks to the developer for their effort and I hope they will fix the issue, if any, very soon or guide us through an alternative.
And @jarton
Have you tried the CSC fix zip?
 

jarton

Member
Oct 26, 2010
10
4
And @jarton
Have you tried the CSC fix zip?
Hi, no I haven't tried, there was no point for me to do it after trying 2 proper full and clean installs, flashing even both times the stock rom before.
I ended up installing the latest ALEXNDR rom which is working perfectly.

I might consider again Alexis Rom if it is fixed because I've been a long time user and really like it !
 

akshitmehra

Member
Dec 30, 2017
5
1
New Delhi
And @jarton
Have you tried the CSC fix zip?
I got some advise on the Telegram group.
Instead of using a newer TWRP version, I falled back to using recovery v3.3.1.1. Then, after a fresh install, the bloatware apps didn't show.
The exact process that worked for me was installing TWRP v3.3.1.1, flash ROM, flash CSC fix (as you advised), flash custom kernel, install Magisk (through recovery only) and then reboot to system. Everything was fine, even Samsung Health also worked. But due to root, I was not able to use banking apps. For that I installed Magisk modules Universal SafetyNet fix and Shamiko. That solved the problem for almost every banking app, except a few.
I was almost there, but because of root, I had to give up. Either, if it is possible to get rid of the root (keeping the custom kernel) or get the Shamiko working for all the banking apps, any of the options will work for me. If you have any further advice, please?
 

bozkurtum

Senior Member
Mar 21, 2011
83
2
Everything is fine in this rom, only magisk is not updated somehow, but when magisk is removed, the phone does not turn on. Is there a solution to this?
 

bilbonotry

Senior Member
Aug 21, 2008
509
164
Hello, how do you update Magisk ? I understood you have to patch boot.img in Magisk app but I cannot find anything about this in the app. Thanks
 

Top Liked Posts