All Pantech Vega Racer II (SKY IM-A830/A840L/S/K)/IM-a800 utilities and works!!

Search This thread

H�ng Hi

New member
Jan 24, 2014
hello i have 1 team xda-A830K Pantech SKY And you can help me in upgrade it to Android 4.4 And I NGI The Box You can have one particular to study this line


Senior Member
Nov 25, 2008
Hi All,

For several months my A830L worked perfectly using a great ROM I got from the site. Recently, I factory reset the phone and gave it to my sister because I just upgraded to a new phone. One thing I forgot is to turn off the auto-firmware update! An official update popped up in which my innocent sister immediately executed. The effect is that after reboot the phone always go to the CWM recovery. To fix it, I just flashed a newer ROM from the same site. Now the PROBLEM is that after reboot the phone always go to the CWM recovery no matter what ROM I flashed! I tried doing all the standard procedures like formatting cache,data, system, dalvik but still it always boot to recovery :(

I need your help guys!


New member
Apr 29, 2014
sky a800s

hi ! I recently bought a sky a800s its auto updated to 4.2.1 smthing like that . I don,t like the korean apps + sms limit kills me plz some one tell me full procedure to root ans install new custom andriod version :/


Senior Member
Nov 19, 2012
came across this one....haven't try yet.

[ROM][A830S/L/K/KE] - VEGA LTE-A style

- Android Jerry Bean 4.1.2, Kernel v4.0 by diszell2008
- Languages: Korean – English – Vietnamese
- SMS over 10000 characters (no more 80 char limit!!!)
- Fix USSD code
- Optimization for 2G/3G.
- UI: combination of LG,SAMSUNG,SKY.
- Pre-rooted and CWM Recovery 6033 installed.
Link for download
Link 1:
Link 2: Racer 2/Hanzoo1504_Choimobile.vn_Vietnamese/
Link 1:
Link 2: Racer 2/Hanzoo1504_Choimobile.vn_Vietnamese/
Link 3:
Link 1:
Link 2:
Link 1:
Link 2: Racer 2/Hanzoo1504_Choimobile.vn_Vietnamese/
How to flash
- Enter recovery mode (Press and hole Volume up + Power while phone is off) and do as follows
|----- install zip from sdcard |--->choose zip from sdcard
| |--->browse for the .zip
| |--->Yes, install zip...
| |--- go back
|------wipe data/factory reset ---> yes
|------wipe cache partition ---> yes
|-------advanced |----> wipe dalvik cache ---> yes
| | go back
|-------reboot system now

The first boot will take 3-5 mins, so don’t panic.

---------- Post added at 11:03 PM ---------- Previous post was at 10:50 PM ----------

Last edited:


New member
May 4, 2014
sky a830s type password to decrypt storage request

my phone show " type password to decrypt storage request" and restart continue. Please help me about this thanks


Senior Member
Jan 6, 2009
hello Please help

when I try to root I get these errors:

1- failed on '/data/local/tmp' - Permission denied
link failed File exists

2- /system/bin/sh: can't create /data/local.prop: Permission denied
uid=2000(shell) gid=2000(shell) groups=1003(graphics),1004(input),1007(log),1009

3- remount failed: Operation not permitted
cannot stat 'su': No such file or directory
Unable to chown /system/bin/su: No such file or directory
Unable to chmod /system/bin/su: No such file or directory
cannot stat 'busybox': No such file or directory
Unable to chown /system/bin/busybox: No such file or directory
Unable to chmod /system/bin/busybox: No such file or directory
cannot stat 'Superuser.apk': No such file or directory
Unable to chown /system/app/Superuser.apk: No such file or directory
Unable to chmod /system/app/Superuser.apk: No such file or directory
cannot stat 'RootExplorer.apk': No such file or directory
Unable to chown /system/app/RootExplorer.apk: No such file or directory
Unable to chmod /system/app/RootExplorer.apk: No such file or directory
Xoa cac thay doi tru ROOT
Dang hoan tat qua trinh
rm failed for /data/local.prop, No such file or directory
rm failed for /data/local/tmp, Permission denied
failed on '/data/local/tmp.bak' - No such file or directory
Khoi dong lai (3/3) - May ban gio da duoc root
May cua ban da duoc Root. Rut cap duoc roi.

Please anybody help me?


Senior Member
Mar 17, 2010
Samsung Galaxy S10e
Nokia 7.2
Links in OP are dead. I ve just bought this device and need info on how to root and install custom recovery. Anyone plz help me with working links. Thanks! And yes the phone is on latest jb firmware.

Update: Never mind I have found the required files but the op must be refined so that new comers may not find any difficulty.
Last edited:


May 28, 2013
Solve sms sent error when sending 80-160 character range.(A830L)

Hi, please let me know can if this sms fix will work with IM-A830ke???
its upgraded to 4.1.2 and please tell me (noobish question) how to know which update version is installed (1.36, 1.46 or whatever).......
Last edited:

Khizar hayyat

Senior Member
Hi Xda Experts,
I Have Vega im-850K And Yesterday I Flashed A Rom In Ma Phone But After Completing The Flashing Procedure My Phones Touch Is Not Working Totally Dead Also Volume Up And Volume Down Buttons Are Not Working In Recovery Or Download Mode Please Help Me I Am Noob.
And Sorry For My Bad English.
Thanks In Advance.


New member
Aug 5, 2014
problem w/ messages background photo...

Hi.. everytime i try to use a photo from my gallery to set as my background photo for my messages..theres always an error message saying "unable to save photo edits"..pls help me..

borin ca

New member
Sep 2, 2014
My Sky Vega A860L Stuck on U+ LTE

FIRM VER - S1234163
rooting - tedected !!!
kemel tempered - not tempered
oen unlock - lock-state
kemel tampered cnt - 0
oem unlock cnt - 0
move item - volume up/down key
select - power key


My Sky Vega A860L stuck on U+ LTE.
Before It's error, I disable “USB Debugging " on my phone.
What should i do?
Please kindly to help me.

Thank for advance.
Last edited:


Mar 28, 2012
I am using stock android 4.1.2 on sky a830l. Using stock music app. Can't able to adjust equalizer settings it gives an error . Pic below

Kindly guide me out of this issue
Thanks in advance


Mar 28, 2012
I have a830l 4.1.2 sw 2.14 stock. The 3g mobile Internet only works when I activate fake roaming using the code. Any one having the same issue. Any solution please share.

Top Liked Posts

  • There are no posts matching your filters.
  • 20
    PM me if u'll like to add anything to OP for others to see ur post.
    Good news Jelly bean(cm10) on 840S here
    Miui also gets to 840s.All by avatartorres!!
    :highfive:thanks mate.:good:

    • IM-A830L/S/K
    Please any one with root,cwm,recovery, and any more info post here please.This is an awesome phone people dont know of.

    FIXED IO issue here
    More roms (Awesome)hereCM10 l/s/k hereIM-a830l 1.38 update and this is how to get it.Best rom for now;Latest software update for the PVR2 a830L here and here for explanation(explanation has a different rom which is my daily driver rom) stock rom for PVR2 A830s here and here for help on a830sCM9 for S here ,k here and for L here(wifi,nfc and other major bugs)
    -Installation bare bones simple just put zip on extsd card wipe data,cache and dalvik cache and install zip from sd card.

    • With thanks for our xda member Borisov we have another rom here.(But be careful as u may run into few bugs like music player,power amp&motion controls are not working).The rom promises u high level of free ram to operate with.So thanks again to Borisov for this contribution.(He found the rom on a chinese thread an decoded the hard language to give us this rom from there)

    -Plug ur device to ur pc with the micro USB cable.
    -Install android sdk.(optional)
    -Download this file, unzip and run Root_RC2.bat (if using Windows 7, please right click and select Run as Administrator).

    -Press any key then ur device reboots and wait before pressing again.When ur device finishes reboot and u can see the lock screen press any key for step 2.Now ur device should reboot and be really slow but wait until u see the lock screen again and press any key for step 3.
    -At boot ur device is rooted and check if super user is installed.

    -For cwm connect ur device and run set up(note that this doesnt install a permanent cwm(5.8.4...) but rather triggers it by sending the necessary files over to ur phone which are deleted at reboot.So this is done every time to enter cwm mode)(Cwm needs SD card >3gb to work or else u'll get mount err.)
    -The new cwm can be optained in fast boot mode.After triggering the first cwm above download this then put ur device in fast boot mode( by holding volup+down+pwr buttons)and selecting fast boot.Connect to pc and install drivers manually by choosing device sky adb drivers in device manager in the android phone section.Run cwm fast boot bat follow instructions and u get cwm.
    -Nandroid backups tend to get stuck at last stage of backing up data.Never tried to restore but if there is a courageous tester u'll be welcome

    credit to cajunflavoredbob

    • Solve sms sent error when sending 80-160 character range.(A830L)(doesn't work with newer 138 update so beware) here

    -Changed links to my account so more reliable for download.(18/07/2012)
    -added sky launcher(31/07/2012)
    -{added launchers link(19/08/2012)}.Removed by xda on 23rd.
    -added google now.(23/08/2012)
    -added new cwm tip and workout.(23/08/2012)
    -Vega racer 2 hands on(29/08/2012)
    -Software upgrade(31/8/2012)
    -added sms fix and changed links to firmwares.(5/9/2012)
    -Borisov rom and my root intructions re-written(8/9/2012)
    -CM9(9/9/2012)CM9 for K(13/9/2012)

    -Added CM9 bug reporter.(12/9/2012)
    _added OTA for IM-a830l(14/10/2012)
    -Real sms fix for a830l(17/9/2012)

    -FIXED IO issue
    -CM10 for both 840&830 :)

    IM-A800L/S:-S Rom here .It's a cwm backup which can be restored to ur device.Download guide follow pictures below.account name is the phone number in picture 2 and password is:besthackever
    more soon....

    You will all be notified as soon as great jelly bean news if found.LOL.:good::good:
    :highfive:Hit thanks below
    Finally....CM10/MIUI/AOKP of A830L/K/S has released...:)


    1. Download A830L's rom (All roms are base on CM10).


    MIUI v4 2.11.9 for Vega Racer2 beta1:

    AOKP for U+ Vega Racer2 beta1:

    2. Put it in sd card. Flash the rom using recovery. Double wipe AFTER flashing rom.

    3. If you are A830S\K user, please download the patch and flash it, then you can use it normally.


    Google service package:

    Use feedback see below thanks.

    Thx the developer& Chinese forums' people who update information.


    Sent from my IM-A830L using Tapatalk 2
    Solve sms sent error when sending 80-160 character range.(A830L)

    This has proven working 100% for ABC alphabet.For others like korean and chinese ur stock on 80.
    What u need
    -Original 135 update(any other rom will give u boot loops)
    -Go sms pro from here
    -Esfile explorer or root explorer
    -This mms package
    -This cwm flashable zip
    -Install this(original 135rom) on top of ur current rom.U don't need to wipe data it will keep everything intact except root.
    -Make sure the rom is booted up on phone and set up as working.
    -Connect to PC and transfer the files external SD card.
    -boot into custom recovery and flash the zip file.
    -Wait dont reboot.Go to advanced and wipe dalvik cache.
    -reboot ur device and wait for it to finish updating.
    -open ur root explorer and gain root privileges.
    -Copy the mms.apk to /system/app and replace the original.Change its permissions to rw-r-r.
    -Get out and install my go sms pro.
    -Now it should be working but u can use only go sms pro.

    Hit thanks below if this helped u or if u learned from this.:highfive:
    OTA updates popping up on IM-A830L

    Download the stock rom and install in cwm recovery.Now reboot and check the sky upgrade app and it should inform u that 1.38 is available.Now download and ur done.
    NB: Don't root or install cwm after installing stock rom or else the update won't work.
    Hit that thanks button if this helped u.Thanks for reading!!:angel:
    The problem of CM10's data&sms bug fixed.:thumbup:

    1. Using root browser, open /system/build.prop

    2. Delete two lines:
    Then save and exit.

    3. Call phone number *#*#4636#*#*(Some rom(s) are *#*#463633#*#*). Set GSM Only(2G)/WDCMA Only(3G).

    4. Reboot, and done!!!

    (About the Wi-Fi problem, make sure your SSID MUST be English or Korean, if not you can't use the Wi-Fi network.)



    Sent from my IM-A830L