Alps FF5000 and other (8227L chipsets) head units - firmwares and other stuff

Search This thread
Dec 6, 2020
5
0
You have at link https://yadi.sk/d/umCvHqCDzHccr folder named resolution fix try with that, only thing is if you can upgrade from system inside android , upgrade button somewhere in settingsa maybe.

Hi, I'm facing the same screen resolution issue. Is there any other way to apply this screen resolution fix?
I don't see any option to upgrade from inside the android unit. Is there any firmware which has 1024x600 resolution by default which I can flash with a USB?
 

Anton TNT

Senior Member
Sep 24, 2020
494
60
Croatia
Android Automotive OS
Hi, I'm facing the same screen resolution issue. Is there any other way to apply this screen resolution fix?
I don't see any option to upgrade from inside the android unit. Is there any firmware which has 1024x600 resolution by default which I can flash with a USB?
Look "screen resolution fix" in search box on this forum and see for further help, I saw a few patches for this on forum a couple of days ago.
 

Anton TNT

Senior Member
Sep 24, 2020
494
60
Croatia
Android Automotive OS
Hi, I have recently bought a Smart EQ fortwo with an after market android head unit. I believe it's by Xonrich but I'm not sure. I am looking for the latest firmware. I've contacted them but they haven't provided me with anything yet. Please see attached images for info. It's running Android 10 security patch 2019-10-05. Alps FF-5000 ac8227L 1024x600 2GB/12GB(?). Any help will be appreciated. Thanks
Search by "XRCH" on forum you will find link for that kind of software
 

dedalos91

Senior Member
Jun 23, 2011
262
53
Hi to all.
After a long time I also saw from Aliexpress an android unit for my car Skoda Octavia MK2 year 2004. in the attached photo you can see its features. Purchased from here https://www.aliexpress.com/item/1005003737664952.html (the model AC8227L with 2/32 ram/rom). System info apps tel me the unit is Alps FF5000 8227L chipsets.
Please if you can help me.
1) Not all the controls on the steering wheel work and I do not have all the car status information, I do not have the indications of the automatic air conditioning ... I changed different options from the canbus type (different car models) but I can not find exactly my own model. Can I enter the correct data of my car model so that everything works properly?
2) it has android 8 (masked android 11), how can I upgrade it and with which rom? is it good to upgrade to android 10 or 11? will this make the unit slower? and if I upgrade everything will work fine? i don't want problems with wrong rom...
I have other additional questions I will remember them in a while and I will add and I am sure you can help me
Thanks for your time
 

Attachments

  • about device-2.jpg
    about device-2.jpg
    1.2 MB · Views: 37
Last edited:

Anton TNT

Senior Member
Sep 24, 2020
494
60
Croatia
Android Automotive OS
Hi to all.
After a long time I also saw from Aliexpress an android unit for my car Skoda Octavia MK2 year 2004. in the attached photo you can see its features. Purchased from here https://www.aliexpress.com/item/1005003737664952.html (the model AC8227L with 2/32 ram/rom). System info apps tel me the unit is Alps FF5000 8227L chipsets.
Please if you can help me.
1) Not all the controls on the steering wheel work and I do not have all the car status information, I do not have the indications of the automatic air conditioning ... I changed different options from the canbus type (different car models) but I can not find exactly my own model. Can I enter the correct data of my car model so that everything works properly?
2) it has android 8 (masked android 11), how can I upgrade it and with which rom? is it good to upgrade to android 10 or 11? will this make the unit slower? and if I upgrade everything will work fine? i don't want problems with wrong rom...
I have other additional questions I will remember them in a while and I will add and I am sure you can help me
Thanks for your time
Hi, sorry for late response I was off for a few days ...

So, as you described problem is canbus decoder and STW write/rewrite based errors.

for Nb. 1 - choose right setings in canbus PSA setting - when you choose correct PSA number other things like STW controls, lcd controls, icons etc. will activate
Problem is in programable PSA setting for specific car, if your car is like let's say PEUGEOT 308 then you will search correct PSA for Peugeot 308 "AND" probably if not working after restart will choose different for Peugeot in a list no matter if it says other model of car like 3008 408 207 307 (and year of production of your car model is also to be considered to use with settings, maybe your year of model is wrongly set like let's say if I choose a PSA setting for wrong model like I have Peugeot 308 year 2011 and in setting says Peugeot 308 - year 2015 - it's not the same model and will not work correctly), try them all and find out which activates all functions.
After choosing the correct PSA settings scroll down a little where this list of car models are and you will see some settings on the left side regarding AC climate control (activate and put it in "ON" mode), rear and front doors, back camera, AVM icon (for ATV/DTV) etc. - there you can choose and activate all options that needs to be sent to main LCD screen, like for doors that are open , various info of state of car etc.

If I am right, you could see the canbus decoder for your self phisically and read PSA settings (if came with radio unit) - it will be written for what car models are settings intended, and so try setting for each model written on canbus.

for Nb. 2 - no need to instal any new firmwares/updates while having stock firmware on unit, correct procedure will be to install theme.apk (look for it on forum on my threads for 8227L) and desired theme for unit. No new installations and updates will correct problems for units
Only choosing the right settings and tweaking "other" menu settings in FACTORY SETTINGS mode will eventually get full operation mode for your unit. I had my unit for two years now and had come across everything and tweaked my unit for best performance.
 
Last edited:
  • Like
Reactions: dedalos91

dedalos91

Senior Member
Jun 23, 2011
262
53
Hi, sorry for late response I was off for a few days ...

So, as you described problem is canbus decoder and STW write/rewrite based errors.

for Nb. 1 - choose right setings in canbus PSA setting - when you choose correct PSA number other things like STW controls, lcd controls, icons etc. will activate
Problem is in programable PSA setting for specific car, if your car is like let's say PEUGEOT 308 then you will search correct PSA for Peugeot 308 "AND" probably if not working after restart will choose different for Peugeot in a list no matter if it says other model of car like 3008 408 207 307 (and year of production of your car model is also to be considered to use with settings, maybe your year of model is wrongly set like let's say if I choose a PSA setting for wrong model like I have Peugeot 308 year 2011 and in setting says Peugeot 308 - year 2015 - it's not the same model and will not work correctly), try them all and find out which activates all functions.
After choosing the correct PSA settings scroll down a little where this list of car models are and you will see some settings on the left side regarding AC climate control (activate and put it in "ON" mode), rear and front doors, back camera, AVM icon (for ATV/DTV) etc. - there you can choose and activate all options that needs to be sent to main LCD screen, like for doors that are open , various info of state of car etc.

If I am right, you could see the canbus decoder for your self phisically and read PSA settings (if came with radio unit) - it will be written for what car models are settings intended, and so try setting for each model written on canbus.

for Nb. 2 - no need to instal any new firmwares/updates while having stock firmware on unit, correct procedure will be to install theme.apk (look for it on forum on my threads for 8227L) and desired theme for unit. No new installations and updates will correct problems for units
Only choosing the right settings and tweaking "other" menu settings in FACTORY SETTINGS mode will eventually get full operation mode for your unit. I had my unit for two years now and had come across everything and tweaked my unit for best performance.
Thanks for your answer.
I am already waiting for a new canbus box from the seller and I will try for STW controls, climate etc.
Please if you can tell me what is the correct procedure that fits my device for root?
for example this procedure without PC (but maybe with files from folder "armv7" instead "arm64" of "SR5-SuperSU-v2.82-SR5-20171001224502.zip" because of android oreo) is ok? https://4pda.to/forum/index.php?showtopic=779092&view=findpost&p=58483264 (google translate) or it only works via wireless like this procedure? https://forum.xda-developers.com/t/root-head-unit-8227l.3855054/post-80550729 and i have find more procedures...
and if you think it necessary what is the correct procedure for custom recovery (twrp etc)?
for example this custom recovery fits to my unit? https://forum.xda-developers.com/t/...7l-android-8-1-2gb-32gb.4192003/post-83951475
I have read many procedures for many HU models that are similar to each other but I do not know which procedure to try so that I do not have problems, I have to look for my "MCU TS907.190518 (H)" ? or depending on the android version? or screen size and the shape of the unit must be the same? or what?
I have also seen so many threads that I was confused, what is the thread for theme.apk?
Thanks in advance
 
Last edited:

Anton TNT

Senior Member
Sep 24, 2020
494
60
Croatia
Android Automotive OS
Thanks for your answer.
I am already waiting for a new canbus box from the seller and I will try for STW controls, climate etc.
Please if you can tell me what is the correct procedure that fits my device for root?
for example this procedure without PC (but maybe with files from folder "armv7" instead "arm64" of "SR5-SuperSU-v2.82-SR5-20171001224502.zip" because of android oreo) is ok? https://4pda.to/forum/index.php?showtopic=779092&view=findpost&p=58483264 (google translate) or it only works via wireless like this procedure? https://forum.xda-developers.com/t/root-head-unit-8227l.3855054/post-80550729 and i have find more procedures...
and if you think it necessary what is the correct procedure for custom recovery (twrp etc)?
I have read many procedures for many HU models that are similar to each other but I do not know which procedure to try so that I do not have problems, I have to look for my "MCU TS907.190518 (H)" ? or depending on the android version? or screen size and the shape of the unit must be the same? or what?
I have also seen so many threads that I was confused, what is the thread for theme.apk?
Thanks in advance
There is no need to root your device in order to put it to work more efficiently, not recommended if you don't know what your doing.

THEME and PACKS (just transfer all to headunit and install thru apk installer):
https://forum.xda-developers.com/t/...rmwares-and-other-stuff.4167669/post-86654407
 

dedalos91

Senior Member
Jun 23, 2011
262
53
There is no need to root your device in order to put it to work more efficiently, not recommended if you don't know what your doing.

THEME and PACKS (just transfer all to headunit and install thru apk installer):
https://forum.xda-developers.com/t/...rmwares-and-other-stuff.4167669/post-86654407
Thanks.... :) I know what root means and I have relevant experience and I always do it with my phones etc just this is stuck in the car and I can not work easily and replace it temporarily if something goes wrong like a phone, so I want to do as much as much confidence as possible. Then I intend to try to make it a little lighter to use if possible ... in general I am a bit of a guy who wants to tease everything .. :D but if you think you do not need maybe to be right as more experienced in such devices...but let me try, i don't know maybe try it and remove some google apps maybe etc
so please guide me
 
Last edited:

beargibson3100

New member
Jun 26, 2022
3
0
Hello Everyone, I'm new to this forum so please bear with me. Last October I purchased a Jeep wrangler. On my list of things to upgrade was the stereo. I found this Android head unit on amazon. Claims to have android 10 etc. I've had it installed since october 2021, but for the past month or so it refuses to remember settings, sometimes it will go days without forgetting. Sometimes it will only forget on apps settings. Torque was the first app it started to affect. Now, it forgets all settings after it has been of for more than a few minutes, even if I tell it to go into stand by for an hour. I have tried resetting it without the gps antenna attatched, something I read in the beginning of this thread. I've factory reset it a few times. I've tried exporting the settings and re loading them. I tried an update file that was listed on a google drive some where in this thread, but it won't update for whatever reason. Do I have a hardware issue, or is it something that can be resolved with software changes. I really like the stereo, but it's getting on my last nerve having to set up the radio every day.

attatched are pictures of the various info screens.

Amazon ling to stereo: https://a.co/d/blIZj1o

Here is a cpu-z export text file:
==========
Device Info
==========
Manufacturer: ALPS
Model: FF-5000 (FF-5000)
Build Number: FF_8227L_10
Baseband Version:
Host ID: ubuntu
Hardware Serial: CUKNY9INDUCUBEAI
Country Locale: en (English)
System Uptime: 0 Days, 0 hours, 6 minutes, 55 seconds
Battery Capacity: 1000 mAh

=======
Display
=======
Screen Size: 4.9 inches
Screen Resolution: 1024 x 600 pixels
Refresh Rate: 60.0 Hz
Density: 240 dpi
Pixels Per Inch:
x: 240.0
y: 240.0
Version: GL version: 2.0

====
CPU
====
Cores: 4
CPU Architeture: ARMv7 Processor rev 3 (v7l)
Board Name: unknown [32-bit]
Chipset: AC8227L
Clock Speed: 598 MHz - 1118 MHz
Instruction Sets: armeabi-v7a, armeabi
Serial: 0000000000000000
Processes Running: 3
Processes Blocked: 0
Features: half thumb fastmult vfp edsp thumbee neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm

=======
OS Info
=======
OS Name: Oreo
OS Version: 10
SDK (API): 27
Bootloader: unknown
Kernel: Linux
Kernel Version: 3.18.79
Dalvik VM Version: 2.1.0
Build ID: O11019
Build Fingerprint: alps/full_8227L_demo/8227L_demo:8.1.0/O11019/1571038753:userdebug/test-keys
Build Time: 2019 10 14 02:37:50
Latest Security Patch: 2019-10-05

=======
Storage
=======
RAM:
Total: 1957 MB
Free: 1178 MB
Internal Storage:
Total: 26.0 GB
Free: 25.0 GB
SD Card:
Total: 14.4 GB
Free: 12.5 GB

=========================
CPU-Z Hardware Info Pro
Created by Binita Apps
Jun 26, 2022 10:42:33 AM

www.binitaapps.com
© 2021 All Rights Reserved.

=========================
 

Attachments

  • KIMG3140.JPG
    KIMG3140.JPG
    2.6 MB · Views: 30
  • KIMG3163.JPG
    KIMG3163.JPG
    4.1 MB · Views: 32
  • KIMG3165.JPG
    KIMG3165.JPG
    3.2 MB · Views: 24
  • KIMG3166.JPG
    KIMG3166.JPG
    3.1 MB · Views: 33

Anton TNT

Senior Member
Sep 24, 2020
494
60
Croatia
Android Automotive OS
@beargibson3100
Try to remove sd card and usb stick and restart the unit, after that choose your settings and restart again and see if your settings is stored ok.
It is something like that, your settings stored on usb or sd card, you can search about that
Or if you have music and files in SD card and SD card is always in headunit go to FACTORY SETTINGS and to menu MP MODE and choose save to SD card (factory settings and system image). After that, after any restart of unit, the image will be restored from SD card.
 

beargibson3100

New member
Jun 26, 2022
3
0
Or if you have music and files in SD card and SD card is always in headunit go to FACTORY SETTINGS and to menu MP MODE and choose save to SD card (factory settings and system image). After that, after any restart of unit, the image will be restored from SD card.
I will try this, I have 2 sd cards atm, one for music and one for maps
 

dedalos91

Senior Member
Jun 23, 2011
262
53
Thanks for your answer.
I am already waiting for a new canbus box from the seller and I will try for STW controls, climate etc.
Please if you can tell me what is the correct procedure that fits my device for root?
for example this procedure without PC (but maybe with files from folder "armv7" instead "arm64" of "SR5-SuperSU-v2.82-SR5-20171001224502.zip" because of android oreo) is ok? https://4pda.to/forum/index.php?showtopic=779092&view=findpost&p=58483264 (google translate) or it only works via wireless like this procedure? https://forum.xda-developers.com/t/root-head-unit-8227l.3855054/post-80550729 and i have find more procedures...
and if you think it necessary what is the correct procedure for custom recovery (twrp etc)?
for example this custom recovery fits to my unit? https://forum.xda-developers.com/t/...7l-android-8-1-2gb-32gb.4192003/post-83951475
I have read many procedures for many HU models that are similar to each other but I do not know which procedure to try so that I do not have problems, I have to look for my "MCU TS907.190518 (H)" ? or depending on the android version? or screen size and the shape of the unit must be the same? or what?
I have also seen so many threads that I was confused, what is the thread for theme.apk?
Thanks in advance
Anton TNT
And what about my questions?
:)... please tell me if you know...
 
Last edited:

beargibson3100

New member
Jun 26, 2022
3
0
Or if you have music and files in SD card and SD card is always in headunit go to FACTORY SETTINGS and to menu MP MODE and choose save to SD card (factory settings and system image). After that, after any restart of unit, the image will be restored from SD card.
*****FIXED*****🤞

I had at one time tried to change the settings in the menus to fix the issue, but it didn't help. So, like you said I just transferred my music to internal drive, removed the SD cards, and reset the HU. I set it all back up, and let it set for a while powered off. It seemed to be remembering the settings. So I again let it set a few hours this afternoon, It's still remembering this evening. Fingers crossed this fixed the issue, although I am curious as to why using SD cards causes this issue. Another annoying thing about the SD cards was that the system always had a notification in the tool bar asking if I wanted to eject or setup the SD cards. I tried setting them up which would have included formatting them. However, when I pressed the format button it was as if I just clicked off of the tool bar and it all went away. It never tried to format the cards.


Thank you for taking time out of your day to help me sort this thing out.
 

dedalos91

Senior Member
Jun 23, 2011
262
53
Hi, sorry for late response I was off for a few days ...

So, as you described problem is canbus decoder and STW write/rewrite based errors.

for Nb. 1 - choose right setings in canbus PSA setting - when you choose correct PSA number other things like STW controls, lcd controls, icons etc. will activate
Problem is in programable PSA setting for specific car, if your car is like let's say PEUGEOT 308 then you will search correct PSA for Peugeot 308 "AND" probably if not working after restart will choose different for Peugeot in a list no matter if it says other model of car like 3008 408 207 307 (and year of production of your car model is also to be considered to use with settings, maybe your year of model is wrongly set like let's say if I choose a PSA setting for wrong model like I have Peugeot 308 year 2011 and in setting says Peugeot 308 - year 2015 - it's not the same model and will not work correctly), try them all and find out which activates all functions.
After choosing the correct PSA settings scroll down a little where this list of car models are and you will see some settings on the left side regarding AC climate control (activate and put it in "ON" mode), rear and front doors, back camera, AVM icon (for ATV/DTV) etc. - there you can choose and activate all options that needs to be sent to main LCD screen, like for doors that are open , various info of state of car etc.

If I am right, you could see the canbus decoder for your self phisically and read PSA settings (if came with radio unit) - it will be written for what car models are settings intended, and so try setting for each model written on canbus.

for Nb. 2 - no need to instal any new firmwares/updates while having stock firmware on unit, correct procedure will be to install theme.apk (look for it on forum on my threads for 8227L) and desired theme for unit. No new installations and updates will correct problems for units
Only choosing the right settings and tweaking "other" menu settings in FACTORY SETTINGS mode will eventually get full operation mode for your unit. I had my unit for two years now and had come across everything and tweaked my unit for best performance.
for Nb. 1
I have already tried everything you say (I asked the seller and I have read various posts etc), but unfortunately I had no result. So I expect a new canbus box from the seller.
for Nb. 2
I understand exactly what you are saying but I have read and searched so much that I have been stubborn to find answers, but I did not find answers either because I was in the wrong thread or because it was an old thread or something else. Thank you very much for answering me. Later I will think if I will try for root etc. So if you can please tell me your opinion because I understand that you have the necessary knowledge.
I apologize for my persistence.
Thanks
 
Last edited:

dedalos91

Senior Member
Jun 23, 2011
262
53
for Nb. 1
I have already tried everything you say (I asked the seller and I have read various posts etc), but unfortunately I had no result. So I expect a new canbus box from the seller.
for Nb. 2
I understand exactly what you are saying but I have read and searched so much that I have been stubborn to find answers, but I did not find answers either because I was in the wrong thread or because it was an old thread or something else. Thank you very much for answering me. Later I will think if I will try for root etc. So if you can please tell me your opinion because I understand that you have the necessary knowledge.
I apologize for my persistence.
Thanks
I find something and i will try.
and
and
and more
Thanks any way.
 

Eraser5

Member
Mar 12, 2016
6
1
Firmware : CHS_UI04_8227L_v4_ANDROID 11_20210705 (in some cases will be "activation not valid" or "license not activated")
https://drive.google.com/file/d/1tHaHhgbTnnBRM7Ex4EY3rknjUrW6fRna/view?usp=sharing

Old firmwares with 8.1 OREO - with nicer UI - for older devices: CHS_UI04_8227L_v3_ANDROID 8.1_20210707
https://drive.google.com/file/d/1Iphu0mS2u-flKB7nx6ogaSFLRhSdrkXO/view?usp=sharing
Hi,
Is that good for this unit?
Xtrons TS708L - 2/16G - Droid 8.1
Thanks
 

Attachments

  • IMG_20190827_180600.jpg
    IMG_20190827_180600.jpg
    659.5 KB · Views: 26

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    STEP1 OPEN SP FLASH TOOL . FROM DOWNLOAD TAPE CHOOSE SCATTER AND PRELOADER It is necessary to choose the PRELOADER as in the picture No. 2
    STEP2 FROM DOWNLOAD TAPE CHOOSE Download Only PRESS Download
    STEP3 CONNECT USB CABLE (4PIN) WITH PC
    STEP4 SHORT THE TWO TEST POINTS
    STEP5 CONNECT THE POWER 12V TO BOARD DON'T move the short when the process starts
    STEP6 AFTER Download THE The device will work again
    1
    Which test points do you think are? 1 or 2?
    I can't say what the test points are, only someone who knows for sure can tell us,
    but caution
    if you're not sure where the test points are, then you have to put a 150-300 ohm resistor on the cable you're going to use to connect them to no damage to the motherboard ...and try until you find them
    that's what they told me too, but in the end I didn't need it because there was someone with a similar unit to mine, who was sure where the test points were
    on my motherboard the two test points have a very small hole in the middle (they look more like your No1 I think)
    but as we said, test it safely using a resistor
    1
    Thank you very much for the helpful advice from you. I keep trying, although I'm already a bit resigned. Regards.
    you can see the above post from mohamed taher elbstani , i think is for you
  • 4

    LAUNCHERS FOR MTK AC8227L_8 (Alps FF5000 , JUNSUN V1)​

    Theme 1.0 apk to change between the launchers​

    ( DO NOT WORK WITH alps ac8227L_demo XYAUTO )
    3
    ALL USERS - NOTE !!!!

    Due to high demand of firmware and problems that came with it I'm officially making a new website just for HEADUNITS with 8227L based firmware and support. (for easy Google tracking and finding all in one place)

    STAY TUNED , will paste link here.

    (this thread IS to be opened for future problems and will be opened for help each other)

    SO... READ THIS...

    - new website will be for all devices with 8227L, AC8227L based chipset devices
    - there will be all files and updates inculding help & support that I collected (and future updates also) in these two years of having and testing my car multimedia device ALPS FF5000 (also includes units MEKEDE,JUNSUN,HIZPO, etc. - with 8227L based chips inside)
    - on this website will be a E-mail form or teamviewer or TEAMS connections directly to users that needs help with device (requiring a user to connect their device to active internet connection - on laptop, PC even in a car and with active connection and teamviever apk installed in units, etc.)
    - MODS installing, flashing and brick recovery is not an option yet as I haven't tried that yet, but will in future (must do root for my device for some settings to enter like travel computer and test more)
    - all people with similar problems of their head units will be more than welcome to participate and help each other in this website

    Cheers to anyone who want to be a part of this and participate and greetings to all...
    2
    well that's great! that app HeadUnit Reloaded is a paid app right? or did you get it from somewhere else?
    do you have to install on both phone and unit? or only on unit?
    well update firmware i simply reached xtron by facebook sent them my headunit model and they reply with firmware link...
    next step is to root device and get rid of several apps!
    2
    You don't need one it will generate automatically when installed software that matches your device and mcu.
    Look for software on links that I pinned here in posts, or try find and install the correct one here :
    https://yadi.sk/d/umCvHqCDzHccr

    NOTE: if your device is not ALPS 5500 then you must follow posts for links that matcgh your device !
    I found license.dat from 4pda and with fw you provided all my problems are solved. Thank you. :)
    2
    I can't find my mcu either :confused:
    MCU: TS907.190518 (H)

    Hi, try not to be obsessed with searching by that number of MCU it is most probably wrong. Search for model like ALPS 5000 (which brand is 8227L-demo etc.). On forum there is a collection of software for 8227L devices, you will find them direct on headunits/android.

    IF YOU HAVE MINE ALPS 5000 8227L demo device:

    Download and install with usb/SD card : https://yadi.sk/d/umCvHqCDzHccr

    IF THIS LINK IS NOT HELPING YOU....
    MY SOFTWARE FOR AC8227L DEVICE THAT MY SELLER PROVIDED ME :
    https://drive.google.com/file/d/1Ta2vL7Fc8tWmzmRxaJ-JMYGmlYYnRmud/view?usp=sharing