Alps FF5000 and other (8227L chipsets) head units - firmwares and other stuff

Search This thread

WojtekWWW

Member
Jul 27, 2022
25
1
I was in your position too, but the situation is being corrected. what I did as I described above. they helped me in the above link on 4pda, see the posts there. give a picture of the motherboard and if it's the same as mine you can see where the test points are.
also you can see the tool that i make for the test point method
But you must have the correct files for flashing
Thank you, I'll take photos in the evening and send it. Really thank you for wanting to help.
 

dedalos91

Senior Member
Jun 23, 2011
266
54
Thank you, I'll take photos in the evening and send it. Really thank you for wanting to help.
please you can see the latest post again? (i make an edit)

in my case I flashed the wrong preloader file and my unit became dead (I wanted to put twrp through sp flash tool)
then I fixed it with the test point method and the correct proloader file
you can ask the seller to give you the correct files for your device if you haven't found them already
in the attched file is the files from my case, files for my own device

please do not use them unless you are sure they are the right ones for your device and please do whatever you do at your own risk


2022-08-03_125623.jpg
 

Attachments

  • spflashtool.zip
    13.8 MB · Views: 13
Last edited:

WojtekWWW

Member
Jul 27, 2022
25
1
I was in your position too, but the situation is being corrected. what I did as I described above. they helped me in the above link on 4pda, see the posts there. give a picture of the motherboard and if it's the same as mine you can see where the test points are.
also you can see the tool that i make for the test point method
But you must have the correct files for flashing

1 - prepare the the power source and the cables (from the car or at your table from a 12V charger) and prepare the motherboard (remove the screen etc)
2 - turn power off the radio (no power on mobo)
3 - connect the radio to the computer via usb cable
4 - prepare SpFlashtool and click download
5 - close the test point with a special tool
6 - turn on the radio (give 12V power)
7 - disable the test point after the SpFlashtool red line
 

WojtekWWW

Member
Jul 27, 2022
25
1
I was in your position too, but the situation is being corrected. what I did as I described above. they helped me in the above link on 4pda, see the posts there. give a picture of the motherboard and if it's the same as mine you can see where the test points are.
also you can see the tool that i make for the test point method
But you must have the correct files for flashing

1 - prepare the the power source and the cables (from the car or at your table from a 12V charger) and prepare the motherboard (remove the screen etc)
2 - turn power off the radio (no power on mobo)
3 - connect the radio to the computer via usb cable
4 - prepare SpFlashtool and click download
5 - close the test point with a special tool
6 - turn on the radio (give 12V power)
7 - disable the test point after the SpFlashtool red line
I was able to take pictures earlier. This is my motherboard and unit.
20220803_133846.jpg

20220803_134028.jpg

20220803_134036.jpg

20220803_134049.jpg
 

dedalos91

Senior Member
Jun 23, 2011
266
54
it is a total deferent device (motherboard) from mine but i don't know about software, maybe it is compatible...
I hope you find the solution, don't be disappointed
 

WojtekWWW

Member
Jul 27, 2022
25
1
I was in your position too, but the situation is being corrected. what I did as I described above. they helped me in the above link on 4pda, see the posts there. give a picture of the motherboard and if it's the same as mine you can see where the test points are.
also you can see the tool that i make for the test point method
But you must have the correct files for flashing

1 - prepare the the power source and the cables (from the car or at your table from a 12V charger) and prepare the motherboard (remove the screen etc)
2 - turn power off the radio (no power on mobo)
3 - connect the radio to the computer via usb cable
4 - prepare SpFlashtool and click download
5 - close the test point with a special tool
6 - turn on the radio (give 12V power)
7 - disable the test point after the SpFlashtool red line
Hello. Thank you for the files :). I tried according to your method but unfortunately it failed. Somewhere there is a problem. It seems to me that with the drivers, although another motherboard using the test point method from XYAuto I flash without any problems and the whole process is successful.
 

WojtekWWW

Member
Jul 27, 2022
25
1
I was in your position too, but the situation is being corrected. what I did as I described above. they helped me in the above link on 4pda, see the posts there. give a picture of the motherboard and if it's the same as mine you can see where the test points are.
also you can see the tool that i make for the test point method
But you must have the correct files for flashing

1 - prepare the the power source and the cables (from the car or at your table from a 12V charger) and prepare the motherboard (remove the screen etc)
2 - turn power off the radio (no power on mobo)
3 - connect the radio to the computer via usb cable
4 - prepare SpFlashtool and click download
5 - close the test point with a special tool
6 - turn on the radio (give 12V power)
7 - disable the test point after the SpFlashtool red line
Which test points do you think are? 1 or 2?
 

Attachments

  • 20220803_134028.jpg
    20220803_134028.jpg
    148.2 KB · Views: 16

dedalos91

Senior Member
Jun 23, 2011
266
54
Which test points do you think are? 1 or 2?
I can't say what the test points are, only someone who knows for sure can tell us,
but caution
if you're not sure where the test points are, then you have to put a 150-300 ohm resistor on the cable you're going to use to connect them to no damage to the motherboard ...and try until you find them
that's what they told me too, but in the end I didn't need it because there was someone with a similar unit to mine, who was sure where the test points were
on my motherboard the two test points have a very small hole in the middle (they look more like your No1 I think)
but as we said, test it safely using a resistor
 
Last edited:
  • Like
Reactions: WojtekWWW

WojtekWWW

Member
Jul 27, 2022
25
1
I can't say what the test points are, only someone who knows for sure can tell us,
but caution
if you're not sure where the test points are, then you have to put a 150-300 ohm resistor on the cable you're going to use to connect them to no damage to the motherboard ...and try until you find them
that's what they told me too, but in the end I didn't need it because there was someone with a similar unit to mine, who was sure where the test points were
on my motherboard the two test points have a very small hole in the middle (they look more like your No1 I think)
but as we said, test it safely using a resistor
Thank you very much for the helpful advice from you. I keep trying, although I'm already a bit resigned. Regards.
 
Nov 2, 2021
30
19
STEP1 OPEN SP FLASH TOOL . FROM DOWNLOAD TAPE CHOOSE SCATTER AND PRELOADER It is necessary to choose the PRELOADER as in the picture No. 2
STEP2 FROM DOWNLOAD TAPE CHOOSE Download Only PRESS Download
STEP3 CONNECT USB CABLE (4PIN) WITH PC
STEP4 SHORT THE TWO TEST POINTS
STEP5 CONNECT THE POWER 12V TO BOARD DON'T move the short when the process starts
STEP6 AFTER Download THE The device will work again
 

Attachments

  • SCATTER AND PRELOADER.rar
    109.7 KB · Views: 13
  • NO.2.png
    NO.2.png
    147.8 KB · Views: 33
  • index.png
    index.png
    1.3 MB · Views: 36

WojtekWWW

Member
Jul 27, 2022
25
1
STEP1 OPEN SP FLASH TOOL . FROM DOWNLOAD TAPE CHOOSE SCATTER AND PRELOADER It is necessary to choose the PRELOADER as in the picture No. 2
STEP2 FROM DOWNLOAD TAPE CHOOSE Download Only PRESS Download
STEP3 CONNECT USB CABLE (4PIN) WITH PC
STEP4 SHORT THE TWO TEST POINTS
STEP5 CONNECT THE POWER 12V TO BOARD DON'T move the short when the process starts
STEP6 AFTER Download THE The device will work again
I tried as in the post you recommended to me, but unfortunately it failed. I don't know if it's not a problem with the motherboard. All usb that are available windows recognizes as "one of the usb devices has a failure, the system cannot recognize it".
 

dedalos91

Senior Member
Jun 23, 2011
266
54
I tried as in the post you recommended to me, but unfortunately it failed. I don't know if it's not a problem with the motherboard. All usb that are available windows recognizes as "one of the usb devices has a failure, the system cannot recognize it".
This is a drivers problem maybe
 
Nov 2, 2021
30
19
I tried as in the post you recommended to me, but unfortunately it failed. I don't know if it's not a problem with the motherboard. All usb that are available windows recognizes as "one of the usb devices has a failure, the system cannot recognize it".
When doing the test point, did you see this picture NO.1?
 

Attachments

  • NO.1.png
    NO.1.png
    128.4 KB · Views: 24

WojtekWWW

Member
Jul 27, 2022
25
1
This is a drivers problem maybe
I thought that the problem is the drivers. But I have a motherboard for XYAuto testing and I do flash software without problems. It detects it in the device manager and there is no message about a usb device failure, but in the one with which I have a problem after connecting to the laptop the device manager sees usb , and talks about the failure.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hi,
    Have you launched your website?

    Regards,
    Askar
    No I haven't got the time to put it up together and finish , slow process... But will in future...
    Have work in shifts and so little time. Sorry that all of you are waiting for website but must prolonge it till end of this year. Also have a new family member so...
    1
    No I haven't got the time to put it up together and finish , slow process... But will in future...
    Have work in shifts and so little time. Sorry that all of you are waiting for website but must prolonge it till end of this year. Also have a new family member so...
    Thanks for your update & Good Luck.
  • 5

    LAUNCHERS FOR MTK AC8227L_8 (Alps FF5000 , JUNSUN V1)​

    Theme 1.0 apk to change between the launchers​

    ( DO NOT WORK WITH alps ac8227L_demo XYAUTO )
    3
    ALL USERS - NOTE !!!!

    Due to high demand of firmware and problems that came with it I'm officially making a new website just for HEADUNITS with 8227L based firmware and support. (for easy Google tracking and finding all in one place)

    STAY TUNED , will paste link here.

    (this thread IS to be opened for future problems and will be opened for help each other)

    SO... READ THIS...

    - new website will be for all devices with 8227L, AC8227L based chipset devices
    - there will be all files and updates inculding help & support that I collected (and future updates also) in these two years of having and testing my car multimedia device ALPS FF5000 (also includes units MEKEDE,JUNSUN,HIZPO, etc. - with 8227L based chips inside)
    - on this website will be a E-mail form or teamviewer or TEAMS connections directly to users that needs help with device (requiring a user to connect their device to active internet connection - on laptop, PC even in a car and with active connection and teamviever apk installed in units, etc.)
    - MODS installing, flashing and brick recovery is not an option yet as I haven't tried that yet, but will in future (must do root for my device for some settings to enter like travel computer and test more)
    - all people with similar problems of their head units will be more than welcome to participate and help each other in this website

    Cheers to anyone who want to be a part of this and participate and greetings to all...
    2
    well that's great! that app HeadUnit Reloaded is a paid app right? or did you get it from somewhere else?
    do you have to install on both phone and unit? or only on unit?
    well update firmware i simply reached xtron by facebook sent them my headunit model and they reply with firmware link...
    next step is to root device and get rid of several apps!
    2
    You don't need one it will generate automatically when installed software that matches your device and mcu.
    Look for software on links that I pinned here in posts, or try find and install the correct one here :
    https://yadi.sk/d/umCvHqCDzHccr

    NOTE: if your device is not ALPS 5500 then you must follow posts for links that matcgh your device !
    I found license.dat from 4pda and with fw you provided all my problems are solved. Thank you. :)
    2
    I can't find my mcu either :confused:
    MCU: TS907.190518 (H)

    Hi, try not to be obsessed with searching by that number of MCU it is most probably wrong. Search for model like ALPS 5000 (which brand is 8227L-demo etc.). On forum there is a collection of software for 8227L devices, you will find them direct on headunits/android.

    IF YOU HAVE MINE ALPS 5000 8227L demo device:

    Download and install with usb/SD card : https://yadi.sk/d/umCvHqCDzHccr

    IF THIS LINK IS NOT HELPING YOU....
    MY SOFTWARE FOR AC8227L DEVICE THAT MY SELLER PROVIDED ME :
    https://drive.google.com/file/d/1Ta2vL7Fc8tWmzmRxaJ-JMYGmlYYnRmud/view?usp=sharing