• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Alps FF5000 head car unit help with firmware

Search This thread

Anton TNT

Senior Member
Sep 24, 2020
102
11
here is a picture of my motherboard. all the cables connect to the top right side. There is an open 4 pin connector. Could that be for the USB that would be able to read flash? there is also another similar connector. What about test pads. can anyone spot them? What is the name for that 4 pin connector?
Yes this junction J14 (free 4 pin port on upper right side) might be entrance but you need a cable for it (4 pin to usb female in/out), and question is will it recognize cable. For some machines including computers (desktop) J14 is a input/output or gateway for usb connections in front exterior. Maybe I'm wrong but it is a good lead following that there is no active connection present from usb.
Take picture of you back end of device where cables and inputs are and please upload here.

I found some cable for that entrance at
https://www.aliexpress.com/item/329...2d645eec-0&pdp_ext_f={"sku_id":"66671220244"}
 
Last edited:

Anton TNT

Senior Member
Sep 24, 2020
102
11
I have a little problem. I tried to do a firmware update (with no time in my bag). I started the update by putting my SD in the SD slot and a start up of the HU. In the upper left corner there was the typically "detected" shown with no red failure message. So I thought it was updating. During this process i needed shut down down the ignition of the car due to lack of time.

Now, if i start the HU i see glowing Buttons and a Black screen (with backlight on)

My question - is the HU irretrievable dead or is there a possibility to reanimtate the SW by a hard reset or a boot into the recovery mode?

Thanks in advance
Hi, no it is not dead repeat the process again and wait till device finishes update DO NOT UNPLUG/CUT POWER / CONTACT by any means neccesary it will FAIL . Best thing is to insert usb with update, start car and wait for whole install to end (JUST WAIT), it will enter it self in android when finished.
 

ramunsa

Member
Dec 15, 2010
21
2
From what I was able to find about that connector, it looks more like "mini molex blade" type connector. However there are no usb cables with this connector. So maybe it's not for USB.

Here is the picture of the back of my radio
IMG_20200314_155826236.jpg
IMG_20200314_155806646.jpg
 

Anton TNT

Senior Member
Sep 24, 2020
102
11
From what I was able to find about that connector, it looks more like "mini molex blade" type connector. However there are no usb cables with this connector. So maybe it's not for USB.

Here is the picture of the back of my radioView attachment 5431683View attachment 5431685
Far I can see in that pic , usb here has cinch connections aswell , it might be possible to use that for usb connection, there is a converter usb to AV/CVBS (digital not analog) also to buy https://www.aliexpress.com/item/400...xp_id=253195d0-282f-4e40-a5b3-a95ebe5a23c1-36
if not maybe you have defected usb cable , I see that usb connector going from connector to outside is separate connector and can be replaced with better one or with one that suits this device (on computer maybe it is old usb 1.1 or usb 2 connector on computer that is not recognizable , maybe it works with usb 3 I don't know). Also , I notice this yellow jack what is that for ? Camera ?
Please take a picture of whole cable harness the one with usb connector please. It is vital to see endpoints of this cable harness.

PREVOIUS POST : Connector on prevoius link is for usb connections thru various junctions (pin like interface on devices) - one point is 4 pin entrance in device and at far point of cable is usb male standard usb connector.
If you can find that gateway with this cable your computer must recognize this as uart cable or RS232 (standard port apropriate for any external devices), description of cable in sale says it all :

PL2303 PL2303HX USB to UART TTL Cable Module 4p 4 pin RS232 Converter
Feature:
USB TO RS232 TTL PL2303HX AUTO CONVERTER MODULE ADAPTER 5V OUTPUT, PROVIDES THE BEST AND CONVENIENT WAY TO CONNECT YOUR RS232 TTL DEVICES OR DEMO BRD. TO YOUR COMPUTER, VIA THE USB PORT.
Driver link:
https://www.adrive.com/public/kRPsVm/k000306 driver

Built-in TTL COM PC-PL2303HX Chip
Standard USB type A male and TTL 4 pin connector
Cable length: 1000mm (39 3/8 in)
Simple and Easy way to give USB support to your designs
Available for Linux, Mac, WinCE and Windows (XP, 2003), Vista, Win 7
Black cable-----GND
Green cable----TXD
White cable----RXD
Red cable -----VCC(5V)

1 x PL2303 PL2303HX USB to UART TTL Cable Module
 
Last edited:

ramunsa

Member
Dec 15, 2010
21
2
Radio does have a dedicated USB A connector that comes out with all of those cables. I am not sure what version it is ,1, 2, or 3. But it works just fine when I plug in USV flash drive. I am able to read/write files to it.

Yellow RCA jack with cable is backup camera connected. Radio is mounted in the car so it would be a while before I can take it out. But there is nothing uncommon just a bunch of RCA connectors and USB A cable that i have routed in the glove compartment.

regarding your comment about "PL2303 PL2303HX USB to UART TTL Cable Module 4p 4 pin RS232 Converter"
I do have those converter adapters. I use the all the time with arduino projects and other serial communication. Even if that J14 connector is serial port, it would be no good to me. To do a full backup i will need to copy 16GB of flash. Over serial it would be days of data copy.

The thing I am thinking, a lot of vidoes online that were showing to do a full backup over USB had to either press "Vol -" button or in my case with no physical buttons to shorten some pins on motherboard for a radio to be in recovery mode.

Does your radio has physical buttons? Have you ever tried to see if you can see it with laptop and flash tool? Or yours is a bit newer model where the whole radio is a bit smaller and on the back of the radio there is connections to attach the cables (not like mine where the cables connect inside the radio)?
 

Anton TNT

Senior Member
Sep 24, 2020
102
11
Radio does have a dedicated USB A connector that comes out with all of those cables. I am not sure what version it is ,1, 2, or 3. But it works just fine when I plug in USV flash drive. I am able to read/write files to it.

Yellow RCA jack with cable is backup camera connected. Radio is mounted in the car so it would be a while before I can take it out. But there is nothing uncommon just a bunch of RCA connectors and USB A cable that i have routed in the glove compartment.

regarding your comment about "PL2303 PL2303HX USB to UART TTL Cable Module 4p 4 pin RS232 Converter"
I do have those converter adapters. I use the all the time with arduino projects and other serial communication. Even if that J14 connector is serial port, it would be no good to me. To do a full backup i will need to copy 16GB of flash. Over serial it would be days of data copy.

The thing I am thinking, a lot of vidoes online that were showing to do a full backup over USB had to either press "Vol -" button or in my case with no physical buttons to shorten some pins on motherboard for a radio to be in recovery mode.

Does your radio has physical buttons? Have you ever tried to see if you can see it with laptop and flash tool? Or yours is a bit newer model where the whole radio is a bit smaller and on the back of the radio there is connections to attach the cables (not like mine where the cables connect inside the radio)?
Well, friend I only provided solutions for you, I tought that you cannot transfer files from device using usb connection.
Yes, my radio has phisical buttons/knobs. It is 7 inch screen DSP android 10 (chinese) machine - ALPS FF5000 - 8227L demo software.
I have direct USB ports in cable harness - 3 usb v2, 1 usb v3 and 1 usb 5V for fast charging devices like mobiles etc.
Also have wifi antenna/connection which means I do not need a cable connection to other computers. I connect thru gateway in home network router and is visible in network. If in some occasion if connection fails I have 3 standard usb ports to connect to other computer. Only thing I don't have is pin code for master settings (not 8888) and device is not rooted which means I cannot do much to change advanced settings of device, only those in hidden menu (8888), and cannot update MCU at all (that is odd). Travel computer also has pin code which I tried to find but nothing so far.
About backup and flash, did your machine have SD card slots ? If do use that to transfer files, speeds are better thatn usb port speed.
Just to mention did you asked you vendor for some help ? If do , what have they told you?

P.S. I noticed on pictures that you have wifi ready device (place on board and hole at back of device for wifi antenna, you can buy wifi card for your machine), but question remains if your software has wifi connections, if not upgrade is avilable.
 
Last edited:

ramunsa

Member
Dec 15, 2010
21
2
My stereo does have SD card slot, USB, and external wifi antenna for wifi connection. I am not worried about transferring files since don't do that too often.
My main issue is when I start the car, it takes a long time for a music player to start playing MP3 files stored either on internal memory or SD card. Android starts reasonably quickly, but then Music player starts screen loading spins for at lest 30-50 seconds (looking for songs I guess). I was hoping that by doing software upgrade I will reduce the time on the amount of time it takes to start playing music from the car start.

I did reached out to the vendor and they provided the update file, but that update needs to be performed over computer with flash tool, and since my laptop can't see the stereo I can't do it.

I could try updating it via the files that you provided but I am scared that something will go wrong and the streo will not work at all. Without having a good backup I rather not do it. So I am just rying to figure out the way to make a good backup first
 

Anton TNT

Senior Member
Sep 24, 2020
102
11
My stereo does have SD card slot, USB, and external wifi antenna for wifi connection. I am not worried about transferring files since don't do that too often.
My main issue is when I start the car, it takes a long time for a music player to start playing MP3 files stored either on internal memory or SD card. Android starts reasonably quickly, but then Music player starts screen loading spins for at lest 30-50 seconds (looking for songs I guess). I was hoping that by doing software upgrade I will reduce the time on the amount of time it takes to start playing music from the car start.

I did reached out to the vendor and they provided the update file, but that update needs to be performed over computer with flash tool, and since my laptop can't see the stereo I can't do it.

I could try updating it via the files that you provided but I am scared that something will go wrong and the streo will not work at all. Without having a good backup I rather not do it. So I am just rying to figure out the way to make a good backup first
Just a little help with that loading of files of yours ...

Which format is music ? MP3 or WAV or something else?
For MP3 format : lesser the MB's , quicker is to reading of file - DO NOT put music with high bands (kBits) as they are loading to slowly. I tried that on mine. Just normally compressed MP3 files with 192 kBts transfer rates
WAV and other file formats avoid as they are enormous MB files and so on with Apple or Microsoft file formats (aac, mov, mpeg etc.).

Odd thing on my device is that also loading of files in music player is a bit slow but I think that main culprit for this is slow reading/writing in memory banks and also internal memory of device is better than play music files from SD cad or USB stick, cause transfer rates are slow. SO, copy/paste music files, ussually in MP3 format and put them in internal memory of device in MUSIC folder and load from there and see if this helps.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    You don't need one it will generate automatically when installed software that matches your device and mcu.
    Look for software on links that I pinned here in posts, or try find and install the correct one here :
    https://yadi.sk/d/umCvHqCDzHccr

    NOTE: if your device is not ALPS 5500 then you must follow posts for links that matcgh your device !
    I found license.dat from 4pda and with fw you provided all my problems are solved. Thank you. :)
    2
    I can't find my mcu either :confused:
    MCU: TS907.190518 (H)

    Hi, try not to be obsessed with searching by that number of MCU it is most probably wrong. Search for model like ALPS 5000 (which brand is 8227L-demo etc.). On forum there is a collection of software for 8227L devices, you will find them direct on headunits/android.

    IF YOU HAVE MINE ALPS 5000 8227L demo device:

    Download and install with usb/SD card : https://yadi.sk/d/umCvHqCDzHccr

    IF THIS LINK IS NOT HELPING YOU....
    MY SOFTWARE FOR AC8227L DEVICE THAT MY SELLER PROVIDED ME :
    https://drive.google.com/file/d/1Ta2vL7Fc8tWmzmRxaJ-JMYGmlYYnRmud/view?usp=sharing
    1
    I have a full backup of boot_1 boot_2 and emmc_user partitions. It’s for 2g-32g model 8227l
    It’s fake android 10 with api27 which is 8.1 Oreo if that helps
    Includes SU binary that’s not hampered from factory. Eonon had SU binary but was not functional per se.
    1
    Turn your usb stick or SD card with software back in port... Then when boots up just click on update. If window not removed after update, go to main menu with password 8888 and find others menu or the one in which to set all settings for device and declick one for updates/software/firmware.

    Or maybe usb or SD card with software in it is just stuck in memory and android detects update and wishes to install. If this is the case, unplug usb /SD card clicking on usb icon on lcd and then press eject and then safely remove stick.

    Keep me updated will help you out.
    I already found the problem, it had the .BIN files copied to the root of the internal memory of the radio, and every time it is turned on it detects them and restarts in USB reading mode. I deleted them and the problem is over
    1
    here is the link for settings backup