• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Amazfit GTS in bootloop, HELP¡¡¡¡¡¡

Search This thread

farazhasan

Member
Mar 30, 2021
8
3
I have gone to repair shop and what he has done is he opened the board and noticed that ic and the board is not attached properly do check one more thing.. power off your device when it is turned off heat the watch with hairdryer once it is heated properly like an iron press,, try to open it and it see if it works.. I have tried this because amazfit customer service told me that this issue occurs because you took a bath while wearing the watch so I tried this and it works..

whenever you heat the watch it will work and when it cools down it gets stuck on the logo. so it isn't related to the water issue, this happens to every 1 watch out of 3 watches ..
 

arringorri

New member
Oct 2, 2008
1
0
When the watch can´t connect with the phone, disassembly the battery, conect the charger to the backcase, and connect the battery again. For me works fine
 

FasihArshad

New member
Sep 12, 2021
1
0
hi
I have same issue my watch stuck on Amazfit logo, And now Iam not able to use my watch because its stuck in Amazfit logo.
What can i do Can anyone help?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    its fixed. for fix it, put to charge. go to amazfit app and change the watchface for one of the app and it fixed itself. use this if someone have this problem
    1
    hi, i habe the same Problem with the boot loop. but how can you connect to the watch while charging? thx
    1
    i too have experienced same problem. amazefit logo is not going from the screen even on after putting it on charge the amazefit logo is not disappearing from the screen. please someone help me out
    1
    When the watch is stuck on amazfit logo, how should I connect the watch with the application, watch is still showing logo and application is stuck on connecting.