• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

An issue with Arabic subtitles.

Search This thread

Hamad ALtaleb

New member
Jul 19, 2020
2
0
Hello,
I noticed an issue with Arabic subtitles,
When go to (subtitle) then (settings) then (text) I prefer my subtitles to be (border) but when I choose my Arabic subtitles to be (border) it seems like there’s something wrong!
English subtitles work perfectly with (border) choice but with Arabic subtitles there’s an issue and it looks strange!
I took some screenshots down below to make you understand my issue perfectly.
I also wrote my message in English and Arabic language.
Thank you and keep up the good work.

حين أذهب للاعدادات الخاصة بالنص وأقوم بتفعيل خيار (الحواف) مع الترجمة العربية الخط يظهر بشكل غريب نوعاً ما،
ياليت يتم حل هذا الخلل،
مع العلم أني قمت بتجربة الخيار مع الترجمة الإنجليزية وكانت تعمل بشكل صحيح تماماً،
المشكلة فقط مع الترجمة العربية،
هل من الممكن العمل على حل هذه المشكلة مع الترجمة العربية لأن الحواف مهمة جداً وتعمل على تسهيل قراءة الترجمة دون إزعاج.

[IMG="screenshots"]https://ibb.co/HXVPq2R
https://ibb.co/nccvJhp[/IMG]

NLBpr4m
 

MXPlayer

Senior Member
Nov 3, 2015
418
113
mx.j2inter.com
Hello,
I noticed an issue with Arabic subtitles,
When go to (subtitle) then (settings) then (text) I prefer my subtitles to be (border) but when I choose my Arabic subtitles to be (border) it seems like there’s something wrong!
English subtitles work perfectly with (border) choice but with Arabic subtitles there’s an issue and it looks strange!
I took some screenshots down below to make you understand my issue perfectly.
I also wrote my message in English and Arabic language.
Thank you and keep up the good work.

حين أذهب للاعدادات الخاصة بالنص وأقوم بتفعيل خيار (الحواف) مع الترجمة العربية الخط يظهر بشكل غريب نوعاً ما،
ياليت يتم حل هذا الخلل،
مع العلم أني قمت بتجربة الخيار مع الترجمة الإنجليزية وكانت تعمل بشكل صحيح تماماً،
المشكلة فقط مع الترجمة العربية،
هل من الممكن العمل على حل هذه المشكلة مع الترجمة العربية لأن الحواف مهمة جداً وتعمل على تسهيل قراءة الترجمة دون إزعاج.

[IMG="screenshots"]https://ibb.co/HXVPq2R
https://ibb.co/nccvJhp[/IMG]

NLBpr4m

Hi Hamad,

Based on your report and the samples we received over email, we investigated this further and found that this seems to be specific to the Arabic font used in the android system. Request you to try the latest version of the font (NotoNaskhArabicUI) we attached here or a different Arabic font and report back if it fixes your issues.

In case if you are not familiar about using the custom subtitle fonts, please try the following
1. Open Settings » Subtitle » Font Folder
2. Select the folder with your font files.
3. Open the Text option and select the font.
 

Attachments

  • NotoNaskhArabicUI-VF.ttf.zip
    114.8 KB · Views: 79
Last edited:

Mohd93

Member
Jul 24, 2020
12
0
Same problem with me it only show on my xiaomi box s, on my phone there is no problem, I connect the support over email and yes they send me the same font (NotoNaskhArabicUI-VF.ttf), I've try it and still same problem happening!! this really annoying ?

20200724-124603.jpg
 

MXPlayer

Senior Member
Nov 3, 2015
418
113
mx.j2inter.com
Same problem with me it only show on my xiaomi box s, on my phone there is no problem, I connect the support over email and yes they send me the same font (NotoNaskhArabicUI-VF.ttf), I've try it and still same problem happening!! this really annoying

20200724-124603.jpg

Please share a sample video or subtitle file and timestamp of a dialogue that has the issue. It will help us to investigate this further and get a workaround for you.
 

Mohd93

Member
Jul 24, 2020
12
0
I uninstall the app then reinstall it, used the font you send it and everything work perfectly, like I'm so happy right now :eek:
 
Last edited: