Android 10 on Moto g6 play

Search This thread

Wid_w

Member
Aug 11, 2016
5
2
Ok my friends, it's true that family moto g6 (specifically g6 play) will receive android 10? if it's possitive... When will we have news about this?

Also ... does anyone know if there is any rom in development with android 10 for this model (lineage, RR, etc.)?

If anyone knows about this, I think several would appreciate this valuable information. :D
 

ninjakira

Senior Member
Nov 6, 2016
541
245
30
batavia, ohio
Answer 1, just wait for Moto to announce it, usually they announce when there gonna do a soak test of a new Android version so whenever Moto does that will be some sort of answer however soak test usually go on for a few months basically it's prolly gonna be almost another year before we hear anything I mean we just got official pie about 2 months ago now after they did soak test for months.

Answer 2, there is not even a custom rom like rr or anything for this device for Oreo or pie so doubtable. Best you can do is try out gsi A only builds, custom rom means it's made specifically for this device where as gsi is compatible with any phone that shipped with Android 8. There is a gsi thread you can out
 

PimpMy5Ton

Senior Member
Jul 23, 2015
750
394
Answer 3: Motorola has already confirmed that the Moto G6 Play will only get one major OS upgrade, and being that we got Pie now that's all it will get unless a DEV figures out how to make a custom rom for Android 10.
 
  • Like
Reactions: busattovini

Spaceminer

Senior Member
Sep 9, 2016
1,232
599
Olympus Mons
Moto E (2020)
Answer 3: Motorola has already confirmed that the Moto G6 Play will only get one major OS upgrade, and being that we got Pie now that's all it will get unless a DEV figures out how to make a custom rom for Android 10.

I have no WiFi right now or I'd already be trying to build for us. They finally fixed the sources for our phone. Phh has Android 10 GSIs out. They'll boot if you flash the Oreo vendor, oem, and boot images first but it's very alpha at the moment. You also need to flash phh's modified magisk from his first Android 10 release. LTE is broken (3G works), and it has some graphics glitches. Most everything else is working fine though. It's not a daily driver yet but it's getting there fast. It will break LTE on stock. To fix that just flash your firmware and let it setup until it reactivates, then you can restore a backup like normal.
 

PimpMy5Ton

Senior Member
Jul 23, 2015
750
394
I have no WiFi right now or I'd already be trying to build for us. They finally fixed the sources for our phone. Phh has Android 10 GSIs out. They'll boot if you flash the Oreo vendor, oem, and boot images first but it's very alpha at the moment. You also need to flash phh's modified magisk from his first Android 10 release. LTE is broken (3G works), and it has some graphics glitches. Most everything else is working fine though. It's not a daily driver yet but it's getting there fast. It will break LTE on stock. To fix that just flash your firmware and let it setup until it reactivates, then you can restore a backup like normal.

That's cool, I was just adding to the answer as to the number of os upgrades that Moto phones get, as far as Phh's android 10 you should be fine as long as you include vendor partition with your stock backup.

---------- Post added at 08:59 PM ---------- Previous post was at 08:54 PM ----------

@Spaceminer Could you link to the sources for the Moto G6 Play?? I have the XT1922-7 Boost Mobile variant.
 
Last edited:

madbat99

Senior Member
Mar 1, 2014
5,538
3,286
That's cool, I was just adding to the answer as to the number of os upgrades that Moto phones get, as far as Phh's android 10 you should be fine as long as you include vendor partition with your stock backup.

---------- Post added at 08:59 PM ---------- Previous post was at 08:54 PM ----------

@Spaceminer Could you link to the sources for the Moto G6 Play?? I have the XT1922-7 Boost Mobile variant.
https://github.com/MotorolaMobilityLLC/kernel-msm/releases/tag/MMI-PCP29.118-41
 
  • Like
Reactions: Spaceminer

ry755

Member
Oct 12, 2016
30
22
Temecula, California

Attachments

  • Screenshot_20191024-210220.jpg
    Screenshot_20191024-210220.jpg
    44.1 KB · Views: 1,024
  • Screenshot_20191024-210018.png
    Screenshot_20191024-210018.png
    67.2 KB · Views: 1,032
  • Screenshot_20191024-205912.png
    Screenshot_20191024-205912.png
    49.3 KB · Views: 1,021
  • Screenshot_20191024-205854.png
    Screenshot_20191024-205854.png
    69.3 KB · Views: 974
  • Screenshot_20191024-210109.jpg
    Screenshot_20191024-210109.jpg
    85.3 KB · Views: 939

ry755

Member
Oct 12, 2016
30
22
Temecula, California
Can you guide us? I install the test img but cant boot on pie vendor

First flash the latest stock boot.img to remove any leftover traces of Magisk, which is now incompatible with phh's AOSP 10 builds.
After that you'll need to disable encryption and dm-verity, if you haven't already done that:

- Download the dm-verity + forced encryption disabler zip here

- Boot into TWRP, go to Wipe, and press Format Data. This will wipe everything from the internal storage! Make sure you have backups stored somewhere else.
- Reboot > Reboot Recovery
- Copy the disabler zip to your phone and flash it

Now the test image should be able to boot on Pie vendor.

(There might be other/better ways of doing this, but those are the steps that worked for me)
 

Grom9A

Member
Nov 2, 2017
47
22
First flash the latest stock boot.img to remove any leftover traces of Magisk, which is now incompatible with phh's AOSP 10 builds.
After that you'll need to disable encryption and dm-verity, if you haven't already done that:

- Download the dm-verity + forced encryption disabler zip here

- Boot into TWRP, go to Wipe, and press Format Data. This will wipe everything from the internal storage! Make sure you have backups stored somewhere else.
- Reboot > Reboot Recovery
- Copy the disabler zip to your phone and flash it

Now the test image should be able to boot on Pie vendor.

(There might be other/better ways of doing this, but those are the steps that worked for me)
Thanks, it works. We need to find a way to restore the sound. I try a few zips they send on the telegram group but nothing.
 
  • Like
Reactions: ry755

Spaceminer

Senior Member
Sep 9, 2016
1,232
599
Olympus Mons
Moto E (2020)
Thanks, it works. We need to find a way to restore the sound. I try a few zips they send on the telegram group but nothing.

Did you format using the "yes" option? I tried those steps but couldn't get it to boot, but formatting with "yes" was the only thing that I didn't do. I didn't think it would be necessary because my encryption was already disabled.

Have you tried flashing Viper4android? It might make the sound work since it uses it's own drivers and has to gain root access. I'd try the one by zackptg5, the same guy who makes the disabler.
 

ry755

Member
Oct 12, 2016
30
22
Temecula, California
Did you format using the "yes" option? I tried those steps but couldn't get it to boot, but formatting with "yes" was the only thing that I didn't do. I didn't think it would be necessary because my encryption was already disabled.

Have you tried flashing Viper4android? It might make the sound work since it uses it's own drivers and has to gain root access. I'd try the one by zackptg5, the same guy who makes the disabler.

Did you flash the stock boot.img? That's all I had to do to make it work, I didn't have to format data since I already have it decrypted.
 

Grom9A

Member
Nov 2, 2017
47
22
Did you format using the "yes" option? I tried those steps but couldn't get it to boot, but formatting with "yes" was the only thing that I didn't do. I didn't think it would be necessary because my encryption was already disabled.

Have you tried flashing Viper4android? It might make the sound work since it uses it's own drivers and has to gain root access. I'd try the one by zackptg5, the same guy who makes the disabler.
I want to try but can't root this rom
 

Spaceminer

Senior Member
Sep 9, 2016
1,232
599
Olympus Mons
Moto E (2020)
I want to try but can't root this rom

Under phh's v200 build there's a special magisk he made for his Android 10 GSI.

---------- Post added at 08:11 PM ---------- Previous post was at 08:07 PM ----------

Did you flash the stock boot.img? That's all I had to do to make it work, I didn't have to format data since I already have it decrypted.

Maybe I flashed the wrong boot.img... I might've mixed up Oreo and Pie boot images. I have both firmwares sitting right next to each other.
 
  • Like
Reactions: ry755

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    I found a much easier SU fix. This won't work on LOS 17 just yet but I'm working on that. For AOSP, open the superuser app that's included in the GSI, then open it's settings in the top right corner. Select superuser access, then reselect apps & adb. You'll see a toast that says something like, "superuser was granted to superuser". After this most root apps should work. To get all root apps working though you'll need to take one more extra step. Using a rootexplorer navigate to /system/bin/ select phh-su and create symlink to it in the same folder named su and reboot.

    Update: I have acquired root on LOS 17. See this post. Flash in twrp. Enjoy!
    3
    Can you guide us? I install the test img but cant boot on pie vendor

    First flash the latest stock boot.img to remove any leftover traces of Magisk, which is now incompatible with phh's AOSP 10 builds.
    After that you'll need to disable encryption and dm-verity, if you haven't already done that:

    - Download the dm-verity + forced encryption disabler zip here

    - Boot into TWRP, go to Wipe, and press Format Data. This will wipe everything from the internal storage! Make sure you have backups stored somewhere else.
    - Reboot > Reboot Recovery
    - Copy the disabler zip to your phone and flash it

    Now the test image should be able to boot on Pie vendor.

    (There might be other/better ways of doing this, but those are the steps that worked for me)
    3
    phh built an AOSP 10 test image for us which fixes the bootloop on Pie vendor. I tried it last night and everything seemed to work except sound. LTE works after adding the APN settings.

    https://github.com/phhusson/treble_experimentations/issues/792#issuecomment-546130091
    3
    phh built an AOSP 10 test image for us which fixes the bootloop on Pie vendor. I tried it last night and everything seemed to work except sound. LTE works after adding the APN settings.

    https://github.com/phhusson/treble_experimentations/issues/792#issuecomment-546130091
    Glad to have it running with Pie and more stable, those are great news
    2
    Answer 3: Motorola has already confirmed that the Moto G6 Play will only get one major OS upgrade, and being that we got Pie now that's all it will get unless a DEV figures out how to make a custom rom for Android 10.

    I have no WiFi right now or I'd already be trying to build for us. They finally fixed the sources for our phone. Phh has Android 10 GSIs out. They'll boot if you flash the Oreo vendor, oem, and boot images first but it's very alpha at the moment. You also need to flash phh's modified magisk from his first Android 10 release. LTE is broken (3G works), and it has some graphics glitches. Most everything else is working fine though. It's not a daily driver yet but it's getting there fast. It will break LTE on stock. To fix that just flash your firmware and let it setup until it reactivates, then you can restore a backup like normal.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone