• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Android 12 Beta 2 Root Question

Search This thread

Machuda

Member
Jun 7, 2021
8
0
Hello.

I had root in beta 1 by flashing a modified boot image patched by magisk (after wiping my device and disabling verification on vbmeta with fastboot). I was able to boot into the system no problem and root was achieved.

Now that I have flashed Beta 2, I'm not able to root. I tried flashing disable verification with vbmeta but it won't go past the Google logo. It says the data is (damaged). I tried flashing just the modified boot image of Beta 2 (from magisk) and it says it's not able to verify the boot image. I also tried booting into the boot image, flashing magisk directly through the app, but when it reboots, it gives the same error.

The only thing I haven't tried is factory reset my data.

Any help would be appreciated, thanks.
 

Sh0X31

Senior Member
Mar 27, 2010
1,394
645
Frankfurt am Main
To root Android 12 you have to flash the beta image and than do this:

fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img

And I think when you do a update, its broke the disabled verity & verification.
I find this and you can to update with this command

fastboot update --disable-verity --disable-verification image-redfin.zip

but I don't know I its work.