Android 12 Developer Preview

Search This thread

DoobyDroid

Senior Member
Mar 17, 2013
1,714
380
tenbury wells
Samsung Galaxy S21 Ultra
Side loaded OTA via ADB all works fine no issues so far no FC can't say much difference
 

Attachments

  • Screenshot_20210220-171221.png
    Screenshot_20210220-171221.png
    113.9 KB · Views: 196
  • Screenshot_20210220-171137.png
    Screenshot_20210220-171137.png
    191.4 KB · Views: 197
  • Screenshot_20210220-171126.png
    Screenshot_20210220-171126.png
    198.6 KB · Views: 191
  • Like
Reactions: alek889

Totone56

Senior Member
Mar 26, 2013
664
332
Vannes
Side loaded OTA via ADB all works fine no issues so far no FC can't say much difference

Seems like for now, most UI and user facing changes in general are hidden behind flags, this one is meant for the devs, so it's to be expected. The beta, on the other end, will be aimed at users, and then we will see what changes :)
 
  • Like
Reactions: DoobyDroid

sanjsrik

Senior Member
Apr 15, 2006
2,108
220
54
Brooklyn
I upgraded last night. Had to reboot twice after restart. Then everything was stable. First time it rebooted after install, nothing seemed to want to work and kept FCing. Second reboot, everything is fine now. Sometimes, Nova needs to be indicated when I press the home button that it's default, otherwise, everything is working fine.

Is it me or does the Android version still say 11 but the build is "S"?
 

bubbyj

Senior Member
Dec 31, 2015
109
81
I downloaded the 12 DP1... and it just isn't ready yet (understandably so) for the daily driver use I need.f

Rooting it requires disable verity and verification. You'll need magisk 23 or canary to patch boot.img as well. Not disabling verity/verification, it will only boot back into fastboot and list the reason as something like, "unable to load boot image".

Once rooted, I moved on to installing edxposed --- using riru, riru edxposed, and edxposed manager. Everything installs without problems. Final reboot, and reboots as normal. But then about 90 seconds later, you'll start getting FC after FC after FC. All apps too, and background apps, and systemui, etc.

Removing the riru components and edxposed manager, doesn't correct this problem.

Did fresh format and reinstall of the DP1... rooted again... and then tried Viper4Android. I use a very simple version. You just flash it, and its done (no manual driver install either). Rather than the 3 reboot, AML, driver install, etc.

V4A installs with good logs. Reboots without a hitch. But I noticed the v4a icon in the status bar is missing. I open it up manually, and start getting freezes and fc's. Within 5 minutes, I get kernel panic reboots -- and non-bootloop freezes on the working G screen.

Reboot manually with long press power, get it loaded back up and immediately remove V4A. Reboot and now I'm back to stock.

Get FC's every hour or two. Random reboots too. Battery life is struggling.

I decided to wait until a better version drops, perhaps the beta or at least a DP2.5 or 3.0. As of right now, having Android S is mostly just a status thing -- to show people how cool we are to have access to it as such an early stage. But unless you are dedicated to helping improve the ROM through daily use and reporting... I highly recommend that you stick with Android R.
 

gee2012

Recognized Contributor
Jul 13, 2010
11,140
4,166
Heerlen
Just flashed the 1st public android 12 beta bramble-ota-spb1.210331.013-3c294b13.zip with adb sideload. Listed as android S atm, surprised 5G was enabled as this wasn`t the case with android 11 in the Netherlands. All apps working fine so far and still finding out the new stuff.
 

ggrip

Senior Member
Dec 21, 2010
80
17
yep i also like to know..tried twice but ended up in fastboot mode and cant get it to boot.i used the old magisk patched method but i probebly missing something
Clean wipe and follow the OP instructions in this Pixel 5 thread. Make sure you use the images for 4a5g where needed
 
  • Like
Reactions: J0kker

Top Liked Posts